Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] 10 sec boot and shutdown delays with AMDGPU device
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
Goverp
l33t
l33t


Joined: 07 Mar 2007
Posts: 804

PostPosted: Wed Jun 26, 2019 3:02 pm    Post subject: [SOLVED] 10 sec boot and shutdown delays with AMDGPU device Reply with quote

Since I installed a Radeon RX570 graphics card and got the AMDGPU driver working, I've had annoying 10 sec delays, when booting and shutdown, and when switching sessions between tty7 and tty 8. Dmesg shows the driver trying to send a series of amdgpu powerplay commands and failing, along the following lines:
Code:
[13842.569209] amdgpu: [powerplay]
                failed to send message 171 ret is 0

I found the hangs and messages disappear set the amdgpu module parameter dpm=0, either with a /etc/modprobe.d entry along the lines:
Code:
options amdgpu dpm=0
or the command line parameter
Code:
amdgpu.dpm=0


I don't know if it's disabling something important or not. Xorg.0.log shows
Code:
[    22.232] (II) AMDGPU(0): DPMS capabilities: Off
[    22.535] (==) AMDGPU(0): DPMS enabled
[    22.547] (II) Initializing extension DPMS

but I'm not sure if DPMS (Energy Star power saving) is the same thing as dpm.

I found an intriguing reference that said on old cards and kernels dpm=1 enabled the new dpm; then when AMD power play came out, they swapped its definition and dpm=0 would select power play and dpm=1 would still select the old power management, which might explain the problem.
_________________
Greybeard
Back to top
View user's profile Send private message
TigerJr
Guru
Guru


Joined: 19 Jun 2007
Posts: 540

PostPosted: Wed Jun 26, 2019 11:07 pm    Post subject: Reply with quote

What kernel are you use?
_________________
Do not use gentoo, it die
Back to top
View user's profile Send private message
Goverp
l33t
l33t


Joined: 07 Mar 2007
Posts: 804

PostPosted: Thu Jun 27, 2019 9:14 am    Post subject: Reply with quote

AFAIR kernel 5.1.12 (I'm on a different box just now)
_________________
Greybeard
Back to top
View user's profile Send private message
TigerJr
Guru
Guru


Joined: 19 Jun 2007
Posts: 540

PostPosted: Thu Jun 27, 2019 3:02 pm    Post subject: Reply with quote

im using 5.0.18 and amdgpu drivers, but those message in kernel log doesn't appear
_________________
Do not use gentoo, it die
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum