Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Solved] Screen frozen in kernel 4.19.x, but 4.14.x works
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
solamour
l33t
l33t


Joined: 21 Dec 2004
Posts: 645
Location: San Diego, CA

PostPosted: Mon Jul 08, 2019 2:16 am    Post subject: [Solved] Screen frozen in kernel 4.19.x, but 4.14.x works Reply with quote

After upgrading the kernel from 4.14.127 to 4.19.52, the system crashes with the following error message during booting.

Code:
ACPI BIOS Error (bug): Could not resolve [^^^PB2.VGA.AFN7], AE_NOT_FOUND (20180810/psargs-330)
ACPI Error: Method parse/execution failed \_SB.PCI0.VGA.LCD._BCM, AE_NOT_FOUND (20180810/psparse-516)
ACPI Error: Evaluating _BCM failed (20180810/video-364)
input: Video Bus as /devices/LNXSYSTM:00/LNXSYBUS:00/PNP0A08:00/LNXVIDEO:00/input/input2
[drm] amdgpu kernel modesetting enabled.
fb: switching to amdgpudrmfb from EFI VGA


How do I resolve this problem?
__
sol


Last edited by solamour on Tue Jul 09, 2019 6:31 am; edited 2 times in total
Back to top
View user's profile Send private message
Ant P.
Watchman
Watchman


Joined: 18 Apr 2009
Posts: 6351

PostPosted: Mon Jul 08, 2019 4:11 am    Post subject: Reply with quote

Include the correct firmware for your GPU, which should appear in dmesg after it times out trying to load it a minute later.
Back to top
View user's profile Send private message
solamour
l33t
l33t


Joined: 21 Dec 2004
Posts: 645
Location: San Diego, CA

PostPosted: Mon Jul 08, 2019 6:46 pm    Post subject: Reply with quote

Ant P. wrote:
Include the correct firmware for your GPU, which should appear in dmesg after it times out trying to load it a minute later.


Could this have something to do with the following error message?
dmesg: https://pastebin.com/Un25PJTL
Code:
[    1.957673] amdgpu 0000:00:01.0: Direct firmware load for amdgpu/kabini_pfp.bin failed with error -2
[    1.957687] gfx7: Failed to load firmware "amdgpu/kabini_pfp.bin"
[    1.957704] [drm:gfx_v7_0_sw_init] *ERROR* Failed to load gfx firmware!
[    1.957719] [drm:amdgpu_device_init.cold.31] *ERROR* sw_init of IP block <gfx_v7_0> failed -2
[    1.957732] amdgpu 0000:00:01.0: amdgpu_device_ip_init failed
[    1.957743] amdgpu 0000:00:01.0: Fatal error during GPU init

Something I noticed is that although the system looks frozen, it does boot correctly; it's just that the screen is not responsive.

The last message shown on the screen before it stops scrolling is the following.
Code:
[    1.952531] ACPI BIOS Error (bug): Could not resolve [^^^PB2.VGA.AFN7], AE_NOT_FOUND (20180810/psargs-330)
[    1.952696] ACPI Error: Method parse/execution failed \_SB.PCI0.VGA.LCD._BCM, AE_NOT_FOUND (20180810/psparse-516)
[    1.952870] ACPI Error: Evaluating _BCM failed (20180810/video-364)
[    1.953130] input: Video Bus as /devices/LNXSYSTM:00/LNXSYBUS:00/PNP0A08:00/LNXVIDEO:00/input/input2
[    1.954687] [drm] amdgpu kernel modesetting enabled.
[    1.954799] checking generic (c0000000 7f0000) vs hw (c0000000 10000000)
[    1.954801] fb: switching to amdgpudrmfb from EFI VGA

__
sol
Back to top
View user's profile Send private message
solamour
l33t
l33t


Joined: 21 Dec 2004
Posts: 645
Location: San Diego, CA

PostPosted: Tue Jul 09, 2019 6:30 am    Post subject: Reply with quote

I noticed something odd in dmesg when the screen looks frozen even though the system boots up correctly.
Code:
[    1.957673] amdgpu 0000:00:01.0: Direct firmware load for amdgpu/kabini_pfp.bin failed with error -2

The kernel is trying to load "amdgpu/kabini_pfp.bin" but failed.

I have the following config, based on Radeon guide (https://wiki.gentoo.org/wiki/Radeon).
Code:
CONFIG_EXTRA_FIRMWARE="radeon/kabini_ce.bin radeon/kabini_me.bin radeon/kabini_mec.bin radeon/kabini_pfp.bin radeon/kabini_rlc.bin radeon/kabini_sdma1.bin radeon/kabini_sdma.bin radeon/kabini_uvd.bin radeon/kabini_vce.bin"


After changing all "radeon" to "amdgpu", everything worked.
Code:
CONFIG_EXTRA_FIRMWARE="amdgpu/kabini_ce.bin amdgpu/kabini_me.bin amdgpu/kabini_mec.bin amdgpu/kabini_pfp.bin amdgpu/kabini_rlc.bin amdgpu/kabini_sdma1.bin amdgpu/kabini_sdma.bin amdgpu/kabini_uvd.bin amdgpu/kabini_vce.bin"

Thanks everyone for taking time to share your suggestions.
__
sol
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum