Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[solved] Kein normales Update möglich
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
l3u
Advocate
Advocate


Joined: 26 Jan 2005
Posts: 2399
Location: Konradsreuth (Germany)

PostPosted: Mon Jul 08, 2019 5:38 pm    Post subject: [solved] Kein normales Update möglich Reply with quote

Hallo allerseits!

Ich bekomm mal wieder eines meiner Stable-Only(!)-Systeme nicht normal upgedatet. Und vielleicht kann mir einer von euch unter die Arme greifen? Es hängt scheinbar an libreoffice-bin bzw. dessen Abhängigkeiten. Was ging, hab ich manuell per emerge -1 upgedatet. libreoffice-bin ist das letzte world-Paket, was upgedatet werden wollen würde. emerge -uavD @world will das auch Paket machen, aber u. a. media-libs/harfbuzz-9999 ziehen (das kann ja eigentlich nicht sein, oder?!) und mein halbes System neu bauen (von wegen Update von icu).

Ich hab's ein bisschen eingrenzen können. dev-libs/libixion mag nicht:
Code:
# emerge -1av dev-libs/libixion

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     U *] dev-libs/libixion-9999:0/0.15::gentoo [0.13.0:0/0.13::gentoo] USE="threads -debug -python -static-libs" PYTHON_SINGLE_TARGET="python3_6 -python3_5 -python3_7%" PYTHON_TARGETS="python3_6 -python3_5 -python3_7%" 0 KiB

Total: 1 package (1 upgrade), Size of downloads: 0 KiB

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-libs/libixion:0

  (dev-libs/libixion-9999:0/0.15::gentoo, ebuild scheduled for merge) pulled in by
    dev-libs/libixion (Argument)

  (dev-libs/libixion-0.13.0:0/0.13::gentoo, installed) pulled in by
    =dev-libs/libixion-0.13*:= required by (dev-libs/liborcus-0.13.4:0/0.13::gentoo, installed)
    ^                  ^^^^^                                                                                                                                             
    (and 1 more with the same problem)

Und als passendes Gegenstück auch dev-libs/liborcus:
Code:
# emerge -1av dev-libs/liborcus

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     U  ] dev-libs/libixion-0.14.1:0/0.14::gentoo [0.13.0:0/0.13::gentoo] USE="threads -debug -python -static-libs" PYTHON_SINGLE_TARGET="python3_6 -python3_5 (-python3_7)" PYTHON_TARGETS="python3_6 -python3_5 (-python3_7)" 353 KiB
[ebuild     U *] dev-libs/liborcus-9999:0/0.14::gentoo [0.13.4:0/0.13::gentoo] USE="spreadsheet-model -python -static-libs -tools" PYTHON_SINGLE_TARGET="python3_6 -python3_5 -python3_7%" PYTHON_TARGETS="python3_6 -python3_5 -python3_7%" 0 KiB

Total: 2 packages (2 upgrades), Size of downloads: 353 KiB

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-libs/liborcus:0

  (dev-libs/liborcus-9999:0/0.14::gentoo, ebuild scheduled for merge) pulled in by
    dev-libs/liborcus (Argument)

  (dev-libs/liborcus-0.13.4:0/0.13::gentoo, installed) pulled in by
    =dev-libs/liborcus-0.13* required by (app-office/libreoffice-bin-6.1.5.2:0/0::gentoo, installed)
    ^                  ^^^^^                                                                                                                               

dev-libs/libixion:0

  (dev-libs/libixion-0.14.1:0/0.14::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-libs/libixion-0.14.0:= required by (dev-libs/liborcus-9999:0/0.14::gentoo, ebuild scheduled for merge)
    ^^                  ^^^^^^                                                                                                                                                           

  (dev-libs/libixion-0.13.0:0/0.13::gentoo, installed) pulled in by
    =dev-libs/libixion-0.13*:0/0.13= required by (dev-libs/liborcus-0.13.4:0/0.13::gentoo, installed)
    ^                  ^^^^^^^^^^^^^                                                                                                                                           
    (and 1 more with the same problem)

Passt da was mit der Abhängigkeitenberechnung nicht?! Wieso wollen die jeweils gegenseitig eine Live-Version ziehen? Wie gesagt, ich hab das System voll auf stable, nicht ein testing-Paket ist installiert.


Last edited by l3u on Mon Jul 08, 2019 7:06 pm; edited 1 time in total
Back to top
View user's profile Send private message
mike155
Advocate
Advocate


Joined: 17 Sep 2010
Posts: 2126
Location: Frankfurt, Germany

PostPosted: Mon Jul 08, 2019 5:58 pm    Post subject: Reply with quote

Ich bin mir sicher, dass es einen eleganteren Weg gibt. Aber in diesem Fall würde ich libixion und liborcus löschen und danach 'emerge --update --deep --newuse -avt @world' aufrufen. Libreoffice-bin wird die richtigen Versionen dann schon reinziehen... :-)
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 7741
Location: Austria

PostPosted: Mon Jul 08, 2019 6:07 pm    Post subject: Reply with quote

libreoffice-bin-6.1.5.2 ist alt und benötigt alte Abhängigkeiten. Wieso kein Update?
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
l3u
Advocate
Advocate


Joined: 26 Jan 2005
Posts: 2399
Location: Konradsreuth (Germany)

PostPosted: Mon Jul 08, 2019 6:18 pm    Post subject: Reply with quote

Ich würde ja gern auf 6.2.4.2 updaten … was halt eben stable ist …
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 7741
Location: Austria

PostPosted: Mon Jul 08, 2019 6:27 pm    Post subject: Reply with quote

Einzelne Pakete wie libixion/liborcus updaten bringt jedenfalls keinerlei Erkenntnisgewinn wenn installierte Programme mit direkter Versionsabhängigkeit [wie libreoffice-bin-6.1.5.2] nicht zur selben Zeit zum Update einbezogen werden. Also musst du schon den ursprünglichen Fehler zeigen.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
l3u
Advocate
Advocate


Joined: 26 Jan 2005
Posts: 2399
Location: Konradsreuth (Germany)

PostPosted: Mon Jul 08, 2019 6:31 pm    Post subject: Reply with quote

Code:
# emerge -av =app-office/libreoffice-bin-6.2.4.2

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N     ] media-libs/libuninameslist-20091231-r1::gentoo  0 KiB
[ebuild     U  ] dev-libs/libixion-0.14.1:0/0.14::gentoo [0.13.0:0/0.13::gentoo] USE="threads -debug -python -static-libs" PYTHON_SINGLE_TARGET="python3_6 -python3_5 (-python3_7)" PYTHON_TARGETS="python3_6 -python3_5 (-python3_7)" 353 KiB
[ebuild     U  ] dev-libs/liborcus-0.14.1:0/0.14::gentoo [0.13.4:0/0.13::gentoo] USE="spreadsheet-model -python -static-libs -tools" PYTHON_SINGLE_TARGET="python3_6 -python3_5 (-python3_7)" PYTHON_TARGETS="python3_6 -python3_5 (-python3_7)" 1.851 KiB
[ebuild     U  ] app-office/libreoffice-l10n-6.2.4.2::gentoo [6.1.5.2::gentoo] USE="-offlinehelp" L10N="de -af -am -ar -as -ast -be -bg -bn -bn-IN -bo -br -brx -bs -ca -ca-valencia -cs -cy -da -dgo -dz -el -en -en-GB -en-ZA -eo -es -et -eu -fa -fi -fr -ga -gd -gl -gu -gug -he -hi -hr -hu -id -is -it -ja -ka -kk -km -kmr-Latn -kn -ko -kok -ks -lb -lo -lt -lv -mai -mk -ml -mn -mni -mr -my -nb -ne -nl -nn -nr -nso -oc -om -or -pa -pl -pt -pt-BR -ro -ru -rw -sa -sat -sd -si -sid -sk -sl -sq -sr -sr-Latn -ss -st -sv -sw-TZ -ta -te -tg -th -tn -tr -ts -tt -ug -uk -uz -ve -vi -xh -zh-CN -zh-TW -zu" 21.247 KiB
[ebuild     U  ] dev-libs/icu-64.2:0/64.2::gentoo [63.1-r1:0/63.1::gentoo] USE="-debug -doc -examples -static-libs" ABI_X86="(64) -32 (-x32)" 0 KiB
[ebuild  N     ] dev-db/mariadb-connector-c-3.0.6-r1:0/3::gentoo  USE="curl ssl -gnutls -kerberos -libressl (-mysqlcompat) -static-libs -test" ABI_X86="(64) -32 (-x32)" 652 KiB
[ebuild  N     ] media-gfx/fontforge-20170731-r4::gentoo  USE="X cairo gif gtk jpeg png python readline svg tiff unicode -test -truetype-debugger" PYTHON_SINGLE_TARGET="python3_6 -python2_7 -python3_5" PYTHON_TARGETS="python2_7 python3_6 -python3_5" 13.658 KiB
[ebuild     U  ] app-office/libreoffice-bin-6.2.4.2::gentoo [6.1.5.2::gentoo] USE="kde -gnome -java" PYTHON_TARGETS="python3_6" 120.660 KiB

Total: 8 packages (5 upgrades, 3 new), Size of downloads: 158.417 KiB

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-libs/icu:0

  (dev-libs/icu-64.2:0/64.2::gentoo, ebuild scheduled for merge) pulled in by
    dev-libs/icu:0/64.2 required by (app-office/libreoffice-bin-6.2.4.2:0/0::gentoo, ebuild scheduled for merge)
                ^^^^^^^                                                                                                                             

  (dev-libs/icu-63.1-r1:0/63.1::gentoo, installed) pulled in by
    dev-libs/icu:0/63.1= required by (dev-libs/libical-3.0.4:0/3::gentoo, installed)
                ^^^^^^^^                                                                                               
    (and 14 more with the same problem)

Wenn ich einfach das "normale"(?) emerge -uavD @world starte, dann ist die Liste noch viel länger …
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 7741
Location: Austria

PostPosted: Mon Jul 08, 2019 6:33 pm    Post subject: Reply with quote

Code:
dev-libs/icu:0

  (dev-libs/icu-64.2:0/64.2::gentoo, ebuild scheduled for merge) pulled in by
    dev-libs/icu:0/64.2 required by (app-office/libreoffice-bin-6.2.4.2:0/0::gentoo, ebuild scheduled for merge)
                ^^^^^^^                                                                                                                             

  (dev-libs/icu-63.1-r1:0/63.1::gentoo, installed) pulled in by
    dev-libs/icu:0/63.1= required by (dev-libs/libical-3.0.4:0/3::gentoo, installed)
                ^^^^^^^^                                                                                               
    (and 14 more with the same problem)

Andere Pakete selbes Problem wie zuvor, libreoffice-bin-6.2.4.2 wurde gegen icu-64.2 gebaut, aber das icu update enthaltest du Portage vor.

=> Komplettes world update oder gar nichts.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
l3u
Advocate
Advocate


Joined: 26 Jan 2005
Posts: 2399
Location: Konradsreuth (Germany)

PostPosted: Mon Jul 08, 2019 6:47 pm    Post subject: Reply with quote

Das würde ich ja liebend gerne tun (siehe auch meinen 1. Post), ich will ja einfach nur ein stable-System normal updaten. Es sind weder Pakete maskiert, noch demaskiert. Alles einfach nur stable. Und emerge -uavD @world sagt:
Code:
These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N     ] media-libs/libuninameslist-20091231-r1::gentoo  0 KiB
[ebuild     U  ] dev-libs/libixion-0.14.1:0/0.14::gentoo [0.13.0:0/0.13::gentoo] USE="threads -debug -python -static-libs" PYTHON_SINGLE_TARGET="python3_6 -python3_5 (-python3_7)" PYTHON_TARGETS="python3_6 -python3_5 (-python3_7)" 353 KiB
[ebuild     U  ] dev-libs/liborcus-0.14.1:0/0.14::gentoo [0.13.4:0/0.13::gentoo] USE="spreadsheet-model -python -static-libs -tools" PYTHON_SINGLE_TARGET="python3_6 -python3_5 (-python3_7)" PYTHON_TARGETS="python3_6 -python3_5 (-python3_7)" 1.851 KiB
[ebuild     U  ] app-office/libreoffice-l10n-6.2.4.2::gentoo [6.1.5.2::gentoo] USE="-offlinehelp" L10N="de -af -am -ar -as -ast -be -bg -bn -bn-IN -bo -br -brx -bs -ca -ca-valencia -cs -cy -da -dgo -dz -el -en -en-GB -en-ZA -eo -es -et -eu -fa -fi -fr -ga -gd -gl -gu -gug -he -hi -hr -hu -id -is -it -ja -ka -kk -km -kmr-Latn -kn -ko -kok -ks -lb -lo -lt -lv -mai -mk -ml -mn -mni -mr -my -nb -ne -nl -nn -nr -nso -oc -om -or -pa -pl -pt -pt-BR -ro -ru -rw -sa -sat -sd -si -sid -sk -sl -sq -sr -sr-Latn -ss -st -sv -sw-TZ -ta -te -tg -th -tn -tr -ts -tt -ug -uk -uz -ve -vi -xh -zh-CN -zh-TW -zu" 21.247 KiB
[ebuild  r  U  ] dev-libs/icu-64.2:0/64.2::gentoo [63.1-r1:0/63.1::gentoo] USE="-debug -doc -examples -static-libs" ABI_X86="(64) -32 (-x32)" 0 KiB
[ebuild  rR    ] dev-qt/qtcore-5.12.3:5/5.12::gentoo  USE="icu -debug -systemd -test" 0 KiB
[ebuild  rR    ] dev-libs/libxml2-2.9.9-r1:2::gentoo  USE="icu ipv6 python readline -debug -examples -lzma -static-libs -test" ABI_X86="(64) -32 (-x32)" PYTHON_TARGETS="python2_7 python3_6 -python3_5 (-python3_7)" 0 KiB
[ebuild  rR    ] dev-lang/spidermonkey-60.5.2_p0-r2:60::gentoo  USE="jit system-icu -custom-cflags -custom-optimization -debug -minimal -test" 0 KiB
[ebuild  rR    ] app-text/libmspub-0.1.4::gentoo  USE="-doc -static-libs" 0 KiB
[ebuild  rR    ] media-libs/libzmf-0.0.2::gentoo  USE="-debug -doc -test -tools" 0 KiB
[ebuild  rR    ] media-libs/libcdr-0.1.5::gentoo  USE="-doc -static-libs -test" 0 KiB
[ebuild  rR    ] app-text/libqxp-0.0.2::gentoo  USE="-debug -doc -test -tools" 0 KiB
[ebuild  rR    ] dev-tex/bibtexu-3.71_p20170524::gentoo  USE="-doc -source" 0 KiB
[ebuild  rR    ] media-libs/libvisio-0.1.6::gentoo  USE="-doc -static-libs -test -tools" 0 KiB
[ebuild  rR    ] app-text/libebook-0.1.2-r1::gentoo  USE="-doc -test -tools" 0 KiB
[ebuild  NS    ] sys-devel/binutils-2.32-r1:2.32::gentoo [2.31.1-r6:2.31::gentoo] USE="cxx gold nls plugins -default-gold -doc -multitarget -static-libs -test" 0 KiB
[ebuild  rR    ] media-libs/raptor-2.0.15-r2:2::gentoo  USE="curl unicode -debug -json -static-libs" 0 KiB
[ebuild     U  ] dev-libs/libical-3.0.5:0/3::gentoo [3.0.4:0/3::gentoo] USE="berkdb -doc -examples -static-libs -test" 862 KiB
[ebuild  N     ] dev-db/mariadb-connector-c-3.0.6-r1:0/3::gentoo  USE="curl ssl -gnutls -kerberos -libressl (-mysqlcompat) -static-libs -test" ABI_X86="(64) -32 (-x32)" 652 KiB
[ebuild  rR    ] media-libs/harfbuzz-2.3.1:0/0.9.18::gentoo  USE="cairo glib graphite introspection truetype -debug -icu* -static-libs -test" ABI_X86="(64) -32 (-x32)" 0 KiB
[ebuild  rR    ] dev-qt/qtwebkit-5.212.0_pre20180120:5/5.212::gentoo  USE="X gstreamer hyphen jit opengl printsupport qml -geolocation (-gles2) -multimedia -nsplugin -orientation -webp" 0 KiB
[ebuild  rR    ] dev-qt/qtwebengine-5.12.3:5/5.12::gentoo  USE="alsa system-ffmpeg system-icu widgets -bindist -debug -designer -geolocation -jumbo-build -pax_kernel -pulseaudio -test" 0 KiB
[ebuild  N     ] media-gfx/fontforge-20170731-r4::gentoo  USE="X cairo gif gtk jpeg png python readline svg tiff unicode -test -truetype-debugger" PYTHON_SINGLE_TARGET="python3_6 -python2_7 -python3_5" PYTHON_TARGETS="python2_7 python3_6 -python3_5" 13.658 KiB
[ebuild  r  U *] media-libs/harfbuzz-9999:0/0.9.18::gentoo [2.3.1:0/0.9.18::gentoo] USE="cairo glib graphite icu introspection truetype -debug -static-libs -test" ABI_X86="(64) -32 (-x32)" 0 KiB
[ebuild     U  ] app-office/libreoffice-bin-6.2.4.2::gentoo [6.1.5.2::gentoo] USE="kde -gnome -java" PYTHON_TARGETS="python3_6" 120.660 KiB

Total: 26 packages (7 upgrades, 1 downgrade, 3 new, 1 in new slot, 14 reinstalls), Size of downloads: 159.279 KiB

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

media-libs/harfbuzz:0

  (media-libs/harfbuzz-2.3.1:0/0.9.18::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (media-libs/harfbuzz-9999:0/0.9.18::gentoo, ebuild scheduled for merge) pulled in by
    media-libs/harfbuzz:0/0.9.18[icu] required by (app-office/libreoffice-bin-6.2.4.2:0/0::gentoo, ebuild scheduled for merge)
                                 ^^^                                                                                                                             
    >=media-libs/harfbuzz-0.9.42:=[graphite,icu] required by (app-office/libreoffice-bin-6.2.4.2:0/0::gentoo, ebuild scheduled for merge)
                                            ^^^                                                                                                                             


!!! Enabling --newuse and --update might solve this conflict.
!!! If not, it might help emerge to give a more specific suggestion.


The following packages are causing rebuilds:

  (dev-libs/icu-64.2:0/64.2::gentoo, ebuild scheduled for merge) causes rebuilds for:
    (dev-tex/bibtexu-3.71_p20170524:0/0::gentoo, ebuild scheduled for merge)
    (dev-qt/qtcore-5.12.3:5/5.12::gentoo, ebuild scheduled for merge)
    (dev-lang/spidermonkey-60.5.2_p0-r2:60/60::gentoo, ebuild scheduled for merge)
    (dev-libs/libxml2-2.9.9-r1:2/2::gentoo, ebuild scheduled for merge)
    (app-text/libqxp-0.0.2:0/0::gentoo, ebuild scheduled for merge)
    (media-libs/libcdr-0.1.5:0/0::gentoo, ebuild scheduled for merge)
    (media-libs/libvisio-0.1.6:0/0::gentoo, ebuild scheduled for merge)
    (dev-qt/qtwebengine-5.12.3:5/5.12::gentoo, ebuild scheduled for merge)
    (app-text/libmspub-0.1.4:0/0::gentoo, ebuild scheduled for merge)
    (app-text/libebook-0.1.2-r1:0/0::gentoo, ebuild scheduled for merge)
    (media-libs/libzmf-0.0.2:0/0::gentoo, ebuild scheduled for merge)
    (media-libs/raptor-2.0.15-r2:2/2::gentoo, ebuild scheduled for merge)
    (dev-qt/qtwebkit-5.212.0_pre20180120:5/5.212::gentoo, ebuild scheduled for merge)

The following keyword changes are necessary to proceed:
 (see "package.accept_keywords" in the portage(5) man page for more details)
# required by @__auto_slot_operator_replace_installed__ (argument)
=media-libs/harfbuzz-9999 **

The following USE changes are necessary to proceed:
 (see "package.use" in the portage(5) man page for more details)
# required by app-office/libreoffice-bin-6.2.4.2::gentoo
# required by @selected
# required by @world (argument)
>=media-libs/harfbuzz-9999 icu

NOTE: The --autounmask-keep-masks option will prevent emerge
      from creating package.unmask or ** keyword changes.

Would you like to add these changes to your config files? [Yes/No]

Was hat das media-libs/harfbuzz-9999 da drin verloren?!
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 7741
Location: Austria

PostPosted: Mon Jul 08, 2019 6:53 pm    Post subject: Reply with quote

Code:
[ebuild  rR    ] media-libs/harfbuzz-2.3.1:0/0.9.18::gentoo  USE="cairo glib graphite introspection truetype -debug -icu* -static-libs -test" ABI_X86="(64) -32 (-x32)" 0 KiB

^ hier sehen wir einen 'icu' USE flag switch zum Negativen. Wieso?

Code:
media-libs/harfbuzz:0

  (media-libs/harfbuzz-2.3.1:0/0.9.18::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (media-libs/harfbuzz-9999:0/0.9.18::gentoo, ebuild scheduled for merge) pulled in by
    media-libs/harfbuzz:0/0.9.18[icu] required by (app-office/libreoffice-bin-6.2.4.2:0/0::gentoo, ebuild scheduled for merge)
                                 ^^^                                                                                                                             
    >=media-libs/harfbuzz-0.9.42:=[graphite,icu] required by (app-office/libreoffice-bin-6.2.4.2:0/0::gentoo, ebuild scheduled for merge)
                                            ^^^                                                                                                                             


!!! Enabling --newuse and --update might solve this conflict.
!!! If not, it might help emerge to give a more specific suggestion.

Hier sehen wir den daraus resultierenden unerfüllbaren Wunsch von libreoffice-bin, media-libs/harfbuzz möge doch bitte mit USE=icu gebaut worden sein.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
l3u
Advocate
Advocate


Joined: 26 Jan 2005
Posts: 2399
Location: Konradsreuth (Germany)

PostPosted: Mon Jul 08, 2019 7:05 pm    Post subject: Reply with quote

asturm wrote:
Code:
[ebuild  rR    ] media-libs/harfbuzz-2.3.1:0/0.9.18::gentoo  USE="cairo glib graphite introspection truetype -debug -icu* -static-libs -test" ABI_X86="(64) -32 (-x32)" 0 KiB

^ hier sehen wir einen 'icu' USE flag switch zum Negativen. Wieso?

Das ist eine berechtigte Frage! Scheinbar ist da was verschütt gegangen?! Ich ha jetzt "=media-libs/harfbuzz-2.3.1 icu" in /etc/portage/package.use geschrieben, und jetzt macht emerge brav ein Update.

Vielen Dank, das hab ich nicht gesehen :-)

Aber warum will emerge dann eine Live-Version ziehen, anstatt mir zu sagen, dass dieses Use-Flag fehlt?
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 7741
Location: Austria

PostPosted: Mon Jul 08, 2019 7:10 pm    Post subject: Reply with quote

Das war jetzt eigentlich halb so wild; jede Konfliktmeldung hat auf harfbuzz hingedeutet. Portage kennt sich dann gar nicht mehr aus bei solchen Konflikten und tendiert dazu gleich zur allerletzten Version zu gehen, selbst wenn das noch immer keine Konfliktlösung ist.

l3u wrote:
anstatt mir zu sagen, dass dieses Use-Flag fehlt?

Aber das hat es ja.

Allerdings ist mir neu dass das ein standardmäßig inaktives USE flag ist, das offenbar jeden LibreOffice User zu einem package.use Eintrag zwingt. Das sollte besser eher auf harfbuzz- oder desktop-profile Ebene gelöst werden.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
l3u
Advocate
Advocate


Joined: 26 Jan 2005
Posts: 2399
Location: Konradsreuth (Germany)

PostPosted: Mon Jul 08, 2019 7:25 pm    Post subject: Reply with quote

Da wär ich stark dafür ;-)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum