Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
UTF charactes in kernel cmdline
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
brundage
Tux's lil' helper
Tux's lil' helper


Joined: 02 Dec 2004
Posts: 116

PostPosted: Tue Aug 13, 2019 6:13 pm    Post subject: UTF charactes in kernel cmdline Reply with quote

I'm running 4.19.57-gentoo on a UEFI system without grub and am trying to get the bootloder to pass options to the kernel. I'm getting Asian characters in /proc/cmdline when I do.

Right now I have a kernel with a built in commandline.

Code:
0 blaze:0.0 /home/brundage % zgrep CMDLINE /proc/config.gz
CONFIG_CMDLINE_BOOL=y
CONFIG_CMDLINE="root=/dev/sda2 pci=noaer intel_iommu=on nvidia-drm.modeset=1"
# CONFIG_CMDLINE_OVERRIDE is not set
# CONFIG_BLK_CMDLINE_PARSER is not set
# CONFIG_CMDLINE_PARTITION is not set
CONFIG_FB_CMDLINE=y


I've booted with this UEFI entry

Code:
Boot0002* gentoo-4.19.75 xtra   HD(2,GPT,366809d6-3983-4be3-be3e-852e902a962c,0xe1800,0x63fff)/File(\EFI\GENTOO\BZIMAGE-4.19.57.EFI)root=/dev/sda2 pci=noaer intel_iommu=on vfio-pci.ids=8086:1912


This is currently the contents of /proc/cmdline

Code:
1 blaze:0.0 /home/brundage % cat /proc/cmdline 
root=/dev/sda2 pci=noaer intel_iommu=on nvidia-drm.modeset=1 潲瑯⼽敤⽶摳㉡瀠楣渽慯牥椠瑮汥楟浯畭漽晶潩瀭楣椮獤㠽㠰㨶㤱㈱


It appears that the vfio-pci parameters are not passed

Code:
0 blaze:0.0 /root # for F in /sys/module/vfio_pci/parameters/*; do
  echo $F
  cat $F
  echo
done
/sys/module/vfio_pci/parameters/disable_idle_d3
N

/sys/module/vfio_pci/parameters/disable_vga
N

/sys/module/vfio_pci/parameters/nointxmask
N


What's going on here? Thanks.
Back to top
View user's profile Send private message
bunder
Bodhisattva
Bodhisattva


Joined: 10 Apr 2004
Posts: 5908

PostPosted: Tue Aug 13, 2019 6:38 pm    Post subject: Reply with quote

Quote:
It appears that the vfio-pci parameters are not passed


where did nvidia-drm.modeset come from as well... :?

one thing we could try though for the boxes, is to use the -u flag with efibootmgr when making a new entry to force the cmdline to be unicode.

cheers
_________________
Neddyseagoon wrote:
The problem with leaving is that you can only do it once and it reduces your influence.

banned from #gentoo since sept 2017
Back to top
View user's profile Send private message
mike155
Veteran
Veteran


Joined: 17 Sep 2010
Posts: 1982
Location: Frankfurt, Germany

PostPosted: Tue Aug 13, 2019 7:12 pm    Post subject: Reply with quote

Looks like this one: https://forums.gentoo.org/viewtopic-t-1094526.html
Back to top
View user's profile Send private message
brundage
Tux's lil' helper
Tux's lil' helper


Joined: 02 Dec 2004
Posts: 116

PostPosted: Tue Aug 13, 2019 7:53 pm    Post subject: Reply with quote

Yep, adding -u to efibootmgr got rid of the characters. Looks like the UEFI parameters are additive to the built-in command line.

Are these periods going to be a problem?

Code:
Boot0001* gentoo-4.19.57   HD(2,GPT,366809d6-3983-4be3-be3e-852e902a962c,0xe1800,0x63fff)/File(\EFI\GENTOO\BZIMAGE-4.19.57.EFI)r.o.o.t.=./.d.e.v./.s.d.a.2. .i.n.t.e.l._.i.o.m.m.u.=.o.n.


/proc/cmdline looks okay

Code:
1 blaze /home/brundage % cat /proc/cmdline
root=/dev/sda2 root=/dev/sda2 intel_iommu=on
Back to top
View user's profile Send private message
bunder
Bodhisattva
Bodhisattva


Joined: 10 Apr 2004
Posts: 5908

PostPosted: Tue Aug 13, 2019 8:42 pm    Post subject: Reply with quote

the periods are fine, my systems do the same thing, i think its because unicode is represented differently or something.

i forgot about that thread too. i thought this sounded familiar :lol:
_________________
Neddyseagoon wrote:
The problem with leaving is that you can only do it once and it reduces your influence.

banned from #gentoo since sept 2017
Back to top
View user's profile Send private message
Hu
Moderator
Moderator


Joined: 06 Mar 2007
Posts: 14957

PostPosted: Wed Aug 14, 2019 1:21 am    Post subject: Reply with quote

For completeness: the non-English characters shown, when dumped as hex, byte-swapped, and reloaded as individual 8-bit characters rather than as 16-bit characters, match the expected command line set by efibootmgr.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum