Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] Minimal ISO: no video after GRUB
View unanswered posts
View posts from last 24 hours

Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message

Joined: 17 Jun 2019
Posts: 21
Location: Gensokyo

PostPosted: Mon Aug 19, 2019 7:06 pm    Post subject: [SOLVED] Minimal ISO: no video after GRUB Reply with quote


UPDATE: This is a GRUB problem, using another grub executable than the one in the iso and loading gentoo from it worked. Seems related to this bug. More details at the end.

I am trying to install Gentoo on a PC and I can't get video.
I boot the minimal iso and grub menu loads, I execute Gentoo then nothing. On the screen the grub menu is still there, when I boot with kernel parameters (nomodeset), I get the "Booting a command list" and nothing.
I can confirm that Gentoo boot because I started it with the "dosshd" parameter and I could ssh to it from another PC and everithing is working, except the video.

For hardware info:
- GPU: NVIDIA 1080
- CPU: AMD Threadripper 1950x

What I tried:
Using some kernel parameters: nomodeset, vga=792
Changing the cable from displayport to HDMI, and the monitor
Debian live iso works well, but it uses the nouveau driver. I tried to boot it while blacklisting the nouveau driver and TTY1-6 were still working (but no X since no video driver). I used "nosplash modprobe.blacklist=nouveau video=efifb noquiet" kernel parameters. It doesn't work for gentoo iso.

No efifb or vga available:

livecd ~ # dmesg | grep -i efifb
[    3.490028] efifb: invalid framebuffer address
livecd ~ # dmesg | grep -i vga
[    2.918539] pci 0000:01:00.0: vgaarb: VGA device added: decodes=io+mem,owns=none,locks=none
[    2.918539] pci 0000:01:00.0: vgaarb: bridge control possible
[    2.918539] pci 0000:01:00.0: vgaarb: setting as boot device (VGA legacy resources not available)
[    2.918539] vgaarb: loaded

I think I will do the install from SSH but I don't understand why it doesn't load any video.
Does anyone knows why it can't load any video ?

P.S. Using the latest Gentoo minimal ISO "install-amd64-minimal-20190818T214502Z.iso".

I tried to boot an archiso to see if it had the same problem, after blacklisting the nouveau driver it started without problem.
Howerver, I saw that efifb was working correctly, while on gentoo it throw an invalid framebuffer address error.
# dmesg | grep -i fb
[    7.219339] efifb: probing for efifb
[    7.219448] efifb: framebuffer at 0x1000000000, using 2400k, total 2400k
[    7.219449] efifb: mode is 800x600x32, linelength=4096, pages=1
[    7.219449] efifb: scrolling: redraw
[    7.219450] efifb: Truecolor: size=8:8:8:8, shift=24:16:8:0
[    7.219607] fbcon: Deferring console take-over
[    7.219608] fb0: EFI VGA frame buffer device
[    7.643646] fbcon: Taking over console

So there is actually a valid framebuffer, but Gentoo doesn't find it.

After some research, I found that it could be a problem from GRUB. I found this bug and the problem is the same for me.
So, to try this, I copied the BOOTX64.EFI and the grubx64.efi from the debian iso to the gentoo iso, overwriting the existing ones.
After doing this, I booted and got a grub prompt, I loaded the gentoo config with "configfile (cd0)/grub/grub.cfg" and got the gentoo grub config.
I then needed to change the root with "set root=(cd0)" and boot the Gentoo entry.
Gentoo started and video worked, "dmesg | grep -i efifb" is the same output as live debian or archiso.

So this problem can be qualified as solved.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum