Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
No integrated video card found, quitting
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
hedmo
Veteran
Veteran


Joined: 29 Aug 2009
Posts: 1040
Location: halmstad

PostPosted: Sun Sep 01, 2019 5:47 am    Post subject: No integrated video card found, quitting Reply with quote

hi all

i wanted to get my integrated video card up running when i am on battery with my laptop but ran in to this problem:

Code:

mya51 /home/hedmo # lspci | grep  Display   
00:02.0 Display controller: Intel Corporation UHD Graphics 630 (Desktop 9 Series) (rev 02)
mya51 /home/hedmo # lspci | grep  VGA
01:00.0 VGA compatible controller: NVIDIA Corporation TU106M [GeForce RTX 2060 Mobile] (rev a1)
mya51 /home/hedmo #

Code:

mya51 /home/hedmo # lspci -k
00:02.0 Display controller: Intel Corporation UHD Graphics 630 (Desktop 9 Series) (rev 02)
   DeviceName: Onboard - Video
   Subsystem: Dell UHD Graphics 630 (Desktop 9 Series)
   Kernel driver in use: i915
   Kernel modules: i915
01:00.0 VGA compatible controller: NVIDIA Corporation TU106M [GeForce RTX 2060 Mobile] (rev a1)
   Subsystem: Dell TU106M [GeForce RTX 2060 Mobile]
   Kernel driver in use: nvidia
   Kernel modules: nvidia_drm, nvidia
mya51 /home/hedmo #


i have switched to

Code:
hedmo@mya51 ~ $ eselect opengl list
Available OpenGL implementations:
  [1]   nvidia
  [2]   xorg-x11 *
hedmo@mya51 ~ $


and getting :
Code:


hedmo@mya51 ~ $ glxinfo | grep -E 'OpenGL (vendor|renderer)'
libGL error: No matching fbConfigs or visuals found
libGL error: failed to load driver: swrast
X Error of failed request:  GLXBadContext
  Major opcode of failed request:  151 (GLX)
  Minor opcode of failed request:  6 (X_GLXIsDirect)
  Serial number of failed request:  60
  Current serial number in output stream:  59
hedmo@mya51 ~ $




here is my Xorg.0.log=http://dpaste.com/1J1GHJ1

regards hedmo
Back to top
View user's profile Send private message
Dominique_71
Veteran
Veteran


Joined: 17 Aug 2005
Posts: 1708
Location: Switzerland (Romandie)

PostPosted: Tue Sep 17, 2019 11:35 pm    Post subject: Reply with quote

Your dpaste is expired.
Back to top
View user's profile Send private message
Prof. Frink
Apprentice
Apprentice


Joined: 07 Jan 2017
Posts: 176

PostPosted: Fri Sep 20, 2019 9:15 am    Post subject: Reply with quote

Maybe it is a problem of the BIos/Uefi configuration. But I don't know.
Back to top
View user's profile Send private message
Phoenix591
Apprentice
Apprentice


Joined: 17 Sep 2007
Posts: 271

PostPosted: Sun Sep 22, 2019 3:05 am    Post subject: Reply with quote

You'll probably want to checkout bumblebee if you havn't already , basically it uses your integrated graphics most of the time, but you can switch back and forth, it gives use flags you'll want to enable and disable
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum