Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
genkernel 3.5.3.3 wants util-linux w/ static-libs?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
Hund
Tux's lil' helper
Tux's lil' helper


Joined: 18 Jul 2016
Posts: 89
Location: Sweden

PostPosted: Mon Oct 07, 2019 8:13 pm    Post subject: genkernel 3.5.3.3 wants util-linux w/ static-libs? Reply with quote

Why does genkernel 3.5.3.3 want the package `util-linux` with the USE-flag `static-libs`?

Code:
These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R    ] sys-apps/util-linux-2.33.2::gentoo  USE="cramfs ncurses nls pam readline (split-usr) static-libs* suid unicode -build -caps -fdformat -kill -python (-selinux) -slang -systemd -test -tty-helpers -udev" PYTHON_TARGETS="python2_7 python3_6 -python3_5 (-python3_7)" 0 KiB
[ebuild  N     ] sys-kernel/genkernel-3.5.3.3::gentoo  USE="firmware -cryptsetup (-ibm) (-selinux)" 0 KiB

Total: 2 packages (1 new, 1 reinstall), Size of downloads: 0 KiB

The following USE changes are necessary to proceed:
 (see "package.use" in the portage(5) man page for more details)
# required by sys-kernel/genkernel-3.5.3.3::gentoo
# required by genkernel (argument)
>=sys-apps/util-linux-2.33.2 static-libs

Would you like to add these changes to your config files? [Yes/No]

_________________
$ Linuxkompis.se
Back to top
View user's profile Send private message
eccerr0r
Watchman
Watchman


Joined: 01 Jul 2004
Posts: 7414
Location: almost Mile High in the USA

PostPosted: Mon Oct 07, 2019 9:32 pm    Post subject: Reply with quote

Probably uses the binaries built inside the initramfs.
_________________
Intel Core i7 2700K@ 4.1GHz/HD3000 graphics/8GB DDR3/180GB SSD
What am I supposed watching?
Back to top
View user's profile Send private message
Whissi
Developer
Developer


Joined: 12 Jan 2011
Posts: 78

PostPosted: Mon Oct 07, 2019 10:28 pm    Post subject: Reply with quote

Reason is https://bugs.gentoo.org/658256#c6

tl;dr
Switch to genkernel-4. Version is still beta but already production ready.
_________________
Regards,
Whissi
Back to top
View user's profile Send private message
Hund
Tux's lil' helper
Tux's lil' helper


Joined: 18 Jul 2016
Posts: 89
Location: Sweden

PostPosted: Tue Oct 08, 2019 2:53 pm    Post subject: Reply with quote

Whissi wrote:
Reason is https://bugs.gentoo.org/658256#c6

tl;dr
Switch to genkernel-4. Version is still beta but already production ready.


Thank you! I guess my search-foo failed me. I didn't see that ticket. :)
_________________
$ Linuxkompis.se
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum