Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] ASM1142 USB 3.1Gen2 only 5Gbps instead of 10Gbps
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
manwe_
l33t
l33t


Joined: 01 Feb 2006
Posts: 629
Location: Kraków/Cracow, Poland

PostPosted: Thu Oct 17, 2019 7:25 am    Post subject: [SOLVED] ASM1142 USB 3.1Gen2 only 5Gbps instead of 10Gbps Reply with quote

Hi *.

I bought ASM1142 USB 3.1Gen2 (10Gbps) card for PCI-E. It's i-tec PCE2U31AC. Pluged in, card shows up, but unfortunately only as 5Gbps (USB3.1Gen1).

Code:

# lspci -s 06:00.0 -nnv
06:00.0 USB controller [0c03]: ASMedia Technology Inc. ASM1142 USB 3.1 Host Controller [1b21:1242] (prog-if 30 [XHCI])
        Subsystem: ASMedia Technology Inc. ASM1142 USB 3.1 Host Controller [1b21:1242]
        Flags: bus master, fast devsel, latency 0, IRQ 16
        Memory at dfa00000 (64-bit, non-prefetchable) [size=32K]
        Capabilities: [50] MSI: Enable- Count=1/8 Maskable- 64bit+
        Capabilities: [68] MSI-X: Enable+ Count=8 Masked-
        Capabilities: [78] Power Management version 3
        Capabilities: [80] Express Endpoint, MSI 00
        Capabilities: [100] Virtual Channel
        Capabilities: [200] Advanced Error Reporting
        Capabilities: [280] Secondary PCI Express <?>
        Capabilities: [300] Latency Tolerance Reporting
        Kernel driver in use: xhci_hcd

# lsusb -t
/:  Bus 06.Port 1: Dev 1, Class=root_hub, Driver=xhci_hcd/2p, 5000M
    |__ Port 2: Dev 2, If 0, Class=Mass Storage, Driver=usb-storage, 5000M
....

# dmesg | grep 0000:06:00.0
[    0.479106] pci 0000:06:00.0: [1b21:1242] type 00 class 0x0c0330
[    0.479136] pci 0000:06:00.0: reg 0x10: [mem 0xdfa00000-0xdfa07fff 64bit]
[    0.479188] pci 0000:06:00.0: enabling Extended Tags
[    0.479261] pci 0000:06:00.0: PME# supported from D3hot D3cold
[    0.716992] pci 0000:06:00.0: Adding to iommu group 20
[    1.267093] xhci_hcd 0000:06:00.0: xHCI Host Controller
[    1.267117] xhci_hcd 0000:06:00.0: new USB bus registered, assigned bus number 5
[    1.328188] xhci_hcd 0000:06:00.0: hcc params 0x0200eec1 hci version 0x110 quirks 0x0000000000000010
[    1.328341] usb usb5: SerialNumber: 0000:06:00.0
[    1.328442] xhci_hcd 0000:06:00.0: xHCI Host Controller
[    1.328457] xhci_hcd 0000:06:00.0: new USB bus registered, assigned bus number 6
[    1.328458] xhci_hcd 0000:06:00.0: Host supports USB 3.0 SuperSpeed
[    1.328494] usb usb6: SerialNumber: 0000:06:00.0



Any ideas how to enable 10Gbps support?


Last edited by manwe_ on Fri Oct 18, 2019 9:01 am; edited 1 time in total
Back to top
View user's profile Send private message
Anon-E-moose
Advocate
Advocate


Joined: 23 May 2008
Posts: 4402
Location: Dallas area

PostPosted: Thu Oct 17, 2019 9:51 am    Post subject: Reply with quote

If I'm not mistaken you will only see gen2 speed with a gen2 device plugged in.

If a gen1 device is plugged in then it runs at 5g speed.
_________________
Asus m5a99fx, FX 8320 - nouveau, oss4, rx550 for qemu passthrough
Acer laptop E5-575, i3-7100u - i965, alsa
---both---
5.0.13 zen kernel, profile 17.1 (no-pie & modified) amd64-no-multilib
gcc 8.2.0, eudev, openrc, openbox, palemoon
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 44945
Location: 56N 3W

PostPosted: Thu Oct 17, 2019 4:56 pm    Post subject: Reply with quote

manwe_

To add to what Anon-E-moose said, you need 10Gbit support end to end.

Quote:
Supports 4-line PCI Express v2.0


You will need 2 PCIe rev 2 lanes to get 10GBit.
PCIe rev 2 is 5GBit/lane.

How many lanes are wired in the slot you are using?
What PCIe revision are they?

PCIe Rev 3 is about 10Gbit/Lane but that card may not be PCIe Rev 3, even if your motherboard is.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
manwe_
l33t
l33t


Joined: 01 Feb 2006
Posts: 629
Location: Kraków/Cracow, Poland

PostPosted: Fri Oct 18, 2019 9:00 am    Post subject: Reply with quote

Quote:
How many lanes are wired in the slot you are using?
What PCIe revision are they?
PCIe Rev 3 is about 10Gbit/Lane but that card may not be PCIe Rev 3, even if your motherboard is.


Card is not v3, but has 4 lines of v2 (16Gbps in total). Unfortunately (for me) looks like you are right. I have 16x v2 slot in my Asus Z97-AR, but just found in manual that only 2 lines of that port are actually connected :x So looks like I'm stuck with 5Gbps for now. Thank you.
Back to top
View user's profile Send private message
Anon-E-moose
Advocate
Advocate


Joined: 23 May 2008
Posts: 4402
Location: Dallas area

PostPosted: Fri Oct 18, 2019 11:13 am    Post subject: Reply with quote

manwe_ wrote:
Quote:
How many lanes are wired in the slot you are using?
What PCIe revision are they?
PCIe Rev 3 is about 10Gbit/Lane but that card may not be PCIe Rev 3, even if your motherboard is.


Card is not v3, but has 4 lines of v2 (16Gbps in total). Unfortunately (for me) looks like you are right. I have 16x v2 slot in my Asus Z97-AR, but just found in manual that only 2 lines of that port are actually connected :x So looks like I'm stuck with 5Gbps for now. Thank you.


Are you using both 16x slots (1 and 2), slot 3 indeed only runs at x2 speed.
If you're not using the 16x slot 2 then move the card there and see what it does.
_________________
Asus m5a99fx, FX 8320 - nouveau, oss4, rx550 for qemu passthrough
Acer laptop E5-575, i3-7100u - i965, alsa
---both---
5.0.13 zen kernel, profile 17.1 (no-pie & modified) amd64-no-multilib
gcc 8.2.0, eudev, openrc, openbox, palemoon
Back to top
View user's profile Send private message
manwe_
l33t
l33t


Joined: 01 Feb 2006
Posts: 629
Location: Kraków/Cracow, Poland

PostPosted: Wed Oct 23, 2019 10:41 am    Post subject: Reply with quote

I'm using all 16x slots - GPU, NVMe M.2+adapter and now USB-C. Well, time to think about upgrading MoBo/CPU.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum