Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ glsa 201910-01 ] php
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index News & Announcements
View previous topic :: View next topic  
Author Message
GLSA
Advocate
Advocate


Joined: 12 May 2004
Posts: 2308

PostPosted: Fri Oct 25, 2019 11:26 am    Post subject: [ glsa 201910-01 ] php Reply with quote

Gentoo Linux Security Advisory

Title: PHP: Arbitrary code execution (GLSA 201910-01)
Severity: high
Exploitable: remote
Date: 2019-10-25
Bug(s): #698452
ID: 201910-01

Synopsis

A vulnerability in PHP might allow an attacker to execute arbitrary
code.


Background

PHP is an open source general-purpose scripting language that is
especially suited for web development.


Affected Packages

Package: dev-lang/php
Vulnerable: < 7.1.33
Vulnerable: < 7.2.24
Vulnerable: < 7.3.11
Vulnerable: < 5.6.40-r7
Unaffected: >= 7.1.33
Unaffected: >= 7.2.24
Unaffected: >= 7.3.11
Unaffected: >= 5.6.40-r7
Architectures: All supported architectures


Description

A underflow in env_path_info in PHP-FPM under certain configurations can
be exploited to gain remote code execution.


Impact

A remote attacker, by sending special crafted HTTP requests, could
possibly execute arbitrary code with the privileges of the process, or
cause a Denial of Service condition.


Workaround

If patching is not feasible, the suggested workaround is to include
checks to verify whether or not a file exists before passing to PHP.


Resolution

All PHP 5.6 users should upgrade to the latest version:
Code:
# emerge --sync
      # emerge --ask --oneshot --verbose ">=dev-lang/php-5.6.40-r7"
   
All PHP 7.1 users should upgrade to the latest version:
Code:
# emerge --sync
      # emerge --ask --oneshot --verbose ">=dev-lang/php-7.1.33"
   
All PHP 7.2 users should upgrade to the latest version:
Code:
# emerge --sync
      # emerge --ask --oneshot --verbose ">=dev-lang/php-7.2.24"
   
All PHP 7.3 users should upgrade to the latest version:
Code:
# emerge --sync
      # emerge --ask --oneshot --verbose ">=dev-lang/php-7.3.11"
   


References

CVE-2019-11043


Last edited by GLSA on Wed Nov 20, 2019 4:17 am; edited 1 time in total
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index News & Announcements All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum