Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Not solved - reinstalled] update system to 17.1 and openrc
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2  
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
Waterdevil
Apprentice
Apprentice


Joined: 15 Aug 2017
Posts: 151
Location: LaniakeaHypercluster VirgoSupercluster MilkomedaGroup OrionArm Sector001 GouldBelt SolSystem Austria

PostPosted: Sun Nov 24, 2019 12:16 am    Post subject: Reply with quote

Quote:
It's probably easier at this point.

This would be not too bad...

Code:
ls -alR /lib64/security
/lib64/security:
insgesamt 1,5M
drwxr-xr-x 3 root root   53 21. Nov 00:45 .
drwxr-xr-x 8 root root  180 21. Nov 00:45 ..
-rwxr-xr-x 1 root root  18K 20. Nov 23:28 pam_access.so
-rwxr-xr-x 1 root root  14K 11. Nov 16:17 pam_cap.so
-rwxr-xr-x 1 root root  18K 13. Nov 03:04 pam_cifscreds.so
-rwxr-xr-x 1 root root  14K 12. Nov 13:08 pam_ck_connector.so
-rwxr-xr-x 1 root root  18K 20. Nov 23:28 pam_cracklib.so
-rwxr-xr-x 1 root root  14K 20. Nov 23:28 pam_debug.so
-rwxr-xr-x 1 root root  14K 20. Nov 23:28 pam_deny.so
-rwxr-xr-x 1 root root  14K 20. Nov 23:28 pam_echo.so
-rwxr-xr-x 1 root root 331K 11. Nov 21:11 pam_elogind.so
-rwxr-xr-x 1 root root  18K 20. Nov 23:28 pam_env.so
-rwxr-xr-x 1 root root  19K 20. Nov 23:28 pam_exec.so
-rwxr-xr-x 1 root root  14K 20. Nov 23:28 pam_faildelay.so
drwxr-xr-x 2 root root    3 21. Nov 00:45 pam_filter
-rwxr-xr-x 1 root root  18K 20. Nov 23:28 pam_filter.so
-rwxr-xr-x 1 root root  27K 12. Nov 15:05 pam_fprintd.so
-rwxr-xr-x 1 root root  14K 20. Nov 23:28 pam_ftp.so
-rwxr-xr-x 1 root root  14K 14. Nov 23:27 pam_gdm.so
-rwxr-xr-x 1 root root  47K 11. Nov 22:15 pam_gnome_keyring.so
-rwxr-xr-x 1 root root  18K 20. Nov 23:28 pam_group.so
-rwxr-xr-x 1 root root  14K 20. Nov 23:28 pam_issue.so
-rwxr-xr-x 1 root root  14K 20. Nov 23:28 pam_keyinit.so
-rwxr-xr-x 1 root root  18K 20. Nov 23:28 pam_lastlog.so
-rwxr-xr-x 1 root root  27K 20. Nov 23:28 pam_limits.so
-rwxr-xr-x 1 root root  14K 20. Nov 23:28 pam_listfile.so
-rwxr-xr-x 1 root root  14K 20. Nov 23:28 pam_localuser.so
-rwxr-xr-x 1 root root  14K 20. Nov 23:28 pam_loginuid.so
-rwxr-xr-x 1 root root  14K 20. Nov 23:28 pam_mail.so
-rwxr-xr-x 1 root root  14K 20. Nov 23:28 pam_mkhomedir.so
-rwxr-xr-x 1 root root  14K 20. Nov 23:28 pam_motd.so
-rwxr-xr-x 1 root root  39K 20. Nov 23:28 pam_namespace.so
-rwxr-xr-x 1 root root  14K 20. Nov 23:28 pam_nologin.so
-rwxr-xr-x 1 root root  14K 20. Nov 23:28 pam_permit.so
-rwxr-xr-x 1 root root  19K 20. Nov 23:28 pam_pwhistory.so
-rwxr-xr-x 1 root root  14K 12. Nov 08:13 pam_pwquality.so
-rwxr-xr-x 1 root root  14K 20. Nov 23:28 pam_rhosts.so
-rwxr-xr-x 1 root root  14K 20. Nov 23:28 pam_rootok.so
-rwxr-xr-x 1 root root  14K 20. Nov 23:28 pam_securetty.so
-rwxr-xr-x 1 root root  14K 20. Nov 23:28 pam_shells.so
-rwxr-xr-x 1 root root  18K 20. Nov 23:28 pam_stress.so
-rwxr-xr-x 1 root root  18K 20. Nov 23:28 pam_succeed_if.so
-rwxr-xr-x 1 root root  18K 20. Nov 23:28 pam_tally.so
-rwxr-xr-x 1 root root  18K 20. Nov 23:28 pam_tally2.so
-rwxr-xr-x 1 root root  18K 20. Nov 23:28 pam_time.so
-rwxr-xr-x 1 root root  23K 20. Nov 23:28 pam_timestamp.so
-rwxr-xr-x 1 root root  14K 20. Nov 23:28 pam_umask.so
-rwxr-xr-x 1 root root  55K 20. Nov 23:28 pam_unix.so
-rwxr-xr-x 1 root root  14K 20. Nov 23:28 pam_userdb.so
-rwxr-xr-x 1 root root  14K 20. Nov 23:28 pam_warn.so
-rwxr-xr-x 1 root root  14K 20. Nov 23:28 pam_wheel.so
-rwxr-xr-x 1 root root  50K 17. Nov 01:17 pam_winbind.so
-rwxr-xr-x 1 root root  23K 20. Nov 23:28 pam_xauth.so

/lib64/security/pam_filter:
insgesamt 26K
drwxr-xr-x 2 root root   3 21. Nov 00:45 .
drwxr-xr-x 3 root root  53 21. Nov 00:45 ..
-rwxr-xr-x 1 root root 14K 20. Nov 23:28 upperLOWER


Code:
egrep -Rv '^($|account|auth|password|session|#%PAM-1.0)' /etc/pam.d/
/etc/pam.d/mate-screensaver:# Fedora Core
/etc/pam.d/mate-screensaver:# SuSE/Novell
/etc/pam.d/mate-screensaver:#auth       include      common-auth
/etc/pam.d/mate-screensaver:#auth       optional     pam_gnome_keyring.so
/etc/pam.d/mate-screensaver:#account    include      common-account
/etc/pam.d/mate-screensaver:#password   include      common-password
/etc/pam.d/mate-screensaver:#session    include      common-session
/etc/pam.d/lightdm-greeter:# File autogenerated by pamd_mimic in pam eclass
/etc/pam.d/cups:# File autogenerated by pamd_mimic in pam eclass
/etc/pam.d/gdm-smartcard:# mirrors system-auth / system(-local)-login
/etc/pam.d/gdm-smartcard:# except for the authentication method, which is:
/etc/pam.d/gdm-smartcard:# smartcard login
/etc/pam.d/gdm-smartcard:-auth       optional    pam_gnome_keyring.so
/etc/pam.d/gdm-smartcard:-session    optional    pam_gnome_keyring.so auto_start
/etc/pam.d/xdm:# File autogenerated by pamd_mimic in pam eclass
/etc/pam.d/screen:# File autogenerated by pamd_mimic in pam eclass
/etc/pam.d/sudo:# File autogenerated by pamd_mimic in pam eclass
/etc/pam.d/passwd:-password   optional   pam_gnome_keyring.so use_authtok
/etc/pam.d/ppp:# File autogenerated by pamd_mimic in pam eclass
/etc/pam.d/elogind-user:# This file is part of systemd.
/etc/pam.d/elogind-user:#
/etc/pam.d/elogind-user:# Used by systemd --user instances.
/etc/pam.d/gdm-autologin:# mirrors system-auth / system(-local)-login
/etc/pam.d/gdm-autologin:# except for the authentication method, which is:
/etc/pam.d/gdm-autologin:# always permit login
/etc/pam.d/gdm-autologin:-auth       optional    pam_gnome_keyring.so
/etc/pam.d/gdm-autologin:-session    optional    pam_gnome_keyring.so auto_start
/etc/pam.d/lightdm:# File autogenerated by pamd_mimic in pam eclass
/etc/pam.d/gdm-launch-environment:-session    optional    pam_elogind.so
/etc/pam.d/gdm-launch-environment:-session    optional    pam_systemd.so
/etc/pam.d/system-auth:-session        optional        pam_elogind.so
/etc/pam.d/crond:#
/etc/pam.d/crond:# The PAM configuration file for the cron daemon
/etc/pam.d/crond:#
/etc/pam.d/crond:#


Code:
eix elfutils
[I] dev-libs/elfutils
     Verfügbare Versionen:   0.176-r1^t{tbz2} ~0.177^t {bzip2 lzma nls static-libs test +threads +utils ABI_MIPS="n32 n64 o32" ABI_RISCV="lp64 lp64d" ABI_S390="32 64" ABI_X86="32 64 x32"}
     Installierte Versionen: 0.176-r1^t{tbz2}(23:30:38 17.11.2019)(bzip2 nls utils -lzma -static-libs -test -threads ABI_MIPS="-n32 -n64 -o32" ABI_RISCV="-lp64 -lp64d" ABI_S390="-32 -64" ABI_X86="64 -32 -x32")
     Startseite:             http://elfutils.org/
     Beschreibung:           Libraries/utilities to handle ELF objects (drop in replacement for libelf)

_________________
_____________________
Aut semper aut numquam

Main-Sys: LianLi modded Big Cube 8000,X11DPG-QT,MEM:64G,LSI 9305,HDD:102TB(16x3T,8x6T,4x1T,1x0,5Tm.2,4x0,5TSSD),nVidia GTX1060,NIC:2x10GbSFP+,Fans:20,PSU:1200W+500W,UPS:APC1500VA,FibreChannel,Tandberg LTO-6
Back to top
View user's profile Send private message
pjp
Administrator
Administrator


Joined: 16 Apr 2002
Posts: 18434

PostPosted: Sun Nov 24, 2019 3:58 am    Post subject: Reply with quote

If it were my system this far along into a problem with no meaningful leads, I start to simplify by uninstalling anything unnecessary (most GUI stuff, then very carefully anything else) and then running emerge -e @system. With the big stuff removed, you'd spend less time waiting for extranous stuff to compile that may not help with a solution.

Oh. I didn't notice that you mentioned having run 'emerge --depclean --pretend', have you?
_________________
The media sells it and you live the role.
Back to top
View user's profile Send private message
Waterdevil
Apprentice
Apprentice


Joined: 15 Aug 2017
Posts: 151
Location: LaniakeaHypercluster VirgoSupercluster MilkomedaGroup OrionArm Sector001 GouldBelt SolSystem Austria

PostPosted: Sun Nov 24, 2019 9:16 am    Post subject: Reply with quote

I pressed e during grub boot, added single at the end of kernel line with one space separated, continued with F10, runlevel 3 appears, reboot, s, F10, runlevel 3, reboot, S, F10, runlevel 3 reboot, 1, F10, runlevel 3.
I had no success to get into single mode.

Edit:
I changed runlevel selection:
Code:
/etc/inittabDefault
id:1:initdefault:

Get login, type password - Login incorrect - nothing changed.
/Edit

I'll start to uninstall xdm gnome gdm gtk X.

unmerged 449 packages.

Get login, type password - Login incorrect - nothing changed.

What would you recommend now to unmerge?

Many thanks
_________________
_____________________
Aut semper aut numquam

Main-Sys: LianLi modded Big Cube 8000,X11DPG-QT,MEM:64G,LSI 9305,HDD:102TB(16x3T,8x6T,4x1T,1x0,5Tm.2,4x0,5TSSD),nVidia GTX1060,NIC:2x10GbSFP+,Fans:20,PSU:1200W+500W,UPS:APC1500VA,FibreChannel,Tandberg LTO-6


Last edited by Waterdevil on Sun Nov 24, 2019 7:20 pm; edited 2 times in total
Back to top
View user's profile Send private message
pjp
Administrator
Administrator


Joined: 16 Apr 2002
Posts: 18434

PostPosted: Sun Nov 24, 2019 6:19 pm    Post subject: Reply with quote

Waterdevil wrote:
I pressed e during grub boot, added single at the end of kernel line with one space separated, continued with F10, runlevel 3 appears, reboot, s, F10, runlevel 3, reboot, S, F10, runlevel 3 reboot, 1, F10, runlevel 3.
I had no success to get into single mode.
Interesting. A post from June of this year suggests that 'S' should work. My understanding is that the kernel just passes that info to the init, so mayb somehting has changed there.
post wrote:
I always use upper case "S" instead of single, works for me.

Edit to add: from linux/Documentation/admin-guide/kernel-parameters.txt

Code:

rw [KNL] Mount root device read-write on boot

S [KNL] Run init in single mode


Waterdevil wrote:
Ok I'll start to uninstall xdm gnome gdm gtk X.

unmerged 449 packages.

Get login, type password - Login incorrect - nothing changed.

What would you now recommend to unmerge?
Uninstalling alone won't solve the problem, it will just reduce what is on the system that could be getting in the way of a solution.

What is the output of 'emerge --depclean --pretend'? What I would look for are large unnecessary packages. Maybe rust? One possible solution for rust would be to use rust-bin at least temporarily. But absolutely ONLY uninstall packages that you understandd the implication of their removal. Don't uninstall any part of the toolchain or python, obviously. Probably nothing part of @system. The key is large unnecessary stuff. Some random 1k package isn't worth the effort as it would recompile quickly.

After depclean, then revdep-rebuild to see if it wants to reinstall anything other than binary packages (drivers, openoffice-bin, etc.) Once the output of depclean and revdep-rebuild are in a "good state," then I'd move any packages in PKGDIR aside so they are not used. Then I'd run 'emerge -e @system'.

The depclean / revdep-rebuild / emerge --pretend -e @system is a process to come to a reasonably "clean" state before running the final emerge -e @system.

After that, if the issue isn't resolved or there aren't any news clues, then I'd to a complete rebuild.
_________________
The media sells it and you live the role.
Back to top
View user's profile Send private message
Waterdevil
Apprentice
Apprentice


Joined: 15 Aug 2017
Posts: 151
Location: LaniakeaHypercluster VirgoSupercluster MilkomedaGroup OrionArm Sector001 GouldBelt SolSystem Austria

PostPosted: Sun Nov 24, 2019 7:16 pm    Post subject: Reply with quote

Quote:
What is the output of 'emerge --depclean --pretend'?


I copied my world file then removed all X-related packages. Then I did:
Code:
emerge --depclean

A second time:
Code:
emerge --depclean -p

 * Always study the list of packages to be cleaned for any obvious
 * mistakes. Packages that are part of the world set will always
 * be kept.  They can be manually added to this set with
 * `emerge --noreplace <atom>`.  Packages that are listed in
 * package.provided (see portage(5)) will be removed by
 * depclean, even if they are part of the world set.
 *
 * As a safety measure, depclean will not remove any packages
 * unless *all* required dependencies have been resolved.  As a
 * consequence of this, it often becomes necessary to run
 * `emerge --update --newuse --deep @world` prior to depclean.

Calculating dependencies... done!
>>> No packages selected for removal by depclean
>>> To see reverse dependencies, use --verbose
Packages installed:   1050
Packages in world:    109
Packages in system:   43
Required packages:    1050
Number to remove:     0


So there was nothing more to do.

Info:
Code:

EMERGE_DEFAULT_OPTS="-j --load-average 7 --keep-going \
                     --quiet-build --quiet-fail -b --verbose-conflicts \
                     --autounmask-keep-masks \
                     --buildpkg --usepkg \
                     --usepkg-exclude 'sys-kernel/gentoo-sources virtual/*'"


So an unmerge and merge again is fast and after 55 days some 'emerge --usepkg n blabla' aren't counting very much.

Quote:
After depclean, then revdep-rebuild to see if it wants to reinstall anything other than binary packages (drivers, openoffice-bin, etc.)

Code:
revdep-rebuild
 * This is the new python coded version
 * Please report any bugs found using it.
 * The original revdep-rebuild script is installed as revdep-rebuild.sh
 * Please file bugs at: https://bugs.gentoo.org/
 * Collecting system binaries and libraries
 * Checking dynamic linking consistency
 * Assign files to packages

emerge  --oneshot --complete-graph=y x11-drivers/nvidia-drivers:0/440
Calculating dependencies... done!
>>> Running pre-merge checks for x11-drivers/nvidia-drivers-440.31
 * nvidia-drivers-440.31.tbz2 MD5 SHA1 size ;-) ...                      [ ok ]
 * Checking for suitable kernel configuration options...                      [ ok ]
>>> Emerging binary (1 of 1) x11-drivers/nvidia-drivers-440.31::gentoo
>>> Installing (1 of 1) x11-drivers/nvidia-drivers-440.31::gentoo
>>> Jobs: 1 of 1 complete                           Load avg: 1.68, 0.81, 0.34
>>> Auto-cleaning packages...

>>> No outdated packages were found on your system.

 * GNU info directory index is up-to-date.
19:36:34 allengen ~ # revdep-rebuild
 * This is the new python coded version
 * Please report any bugs found using it.
 * The original revdep-rebuild script is installed as revdep-rebuild.sh
 * Please file bugs at: https://bugs.gentoo.org/
 * Checking dynamic linking consistency
 * Assign files to packages

emerge  --oneshot --complete-graph=y x11-drivers/nvidia-drivers:0/440
Calculating dependencies... done!
>>> Running pre-merge checks for x11-drivers/nvidia-drivers-440.31
 * nvidia-drivers-440.31.tbz2 MD5 SHA1 size ;-) ...                      [ ok ]
 * Checking for suitable kernel configuration options...                      [ ok ]
>>> Emerging binary (1 of 1) x11-drivers/nvidia-drivers-440.31::gentoo
>>> Installing (1 of 1) x11-drivers/nvidia-drivers-440.31::gentoo
>>> Jobs: 1 of 1 complete                           Load avg: 1.57, 0.90, 0.40
>>> Auto-cleaning packages...

>>> No outdated packages were found on your system.

 * GNU info directory index is up-to-date.

x11-drivers/nvidia-drivers doesn't disappear.

Quote:
then I'd move any packages in PKGDIR aside so they are not used.

Really move "ALL" packages to a save directory?

Output without remove of all packages:
Code:
emerge -e @system -p

These are the packages that would be merged, in order:

Calculating dependencies... done!
[binary   R    ] sys-libs/zlib-1.2.11-r2
[binary   R    ] dev-lang/python-exec-2.4.6-r1
[ebuild   R    ] virtual/libintl-0-r2
[ebuild   R    ] sys-libs/ncurses-6.1_p20181020  USE="-gpm* -threads*"
[binary   R    ] app-arch/bzip2-1.0.6-r11
[ebuild   R    ] virtual/libiconv-0-r2
[binary   R    ] x11-base/xorg-proto-2019.2
[binary   R    ] app-arch/xz-utils-5.2.4-r2
[binary   R    ] sys-apps/attr-2.4.48-r3
[binary   R    ] dev-libs/libbsd-0.9.1
[binary   R    ] dev-libs/gmp-6.1.2-r1
[binary   R    ] sys-apps/gentoo-functions-0.12
[binary   R    ] sys-kernel/linux-headers-4.19
[binary   R    ] dev-libs/libtasn1-4.13
[binary   R    ] sys-devel/gnuconfig-20180101
[binary   R    ] sys-libs/libseccomp-2.4.0
[binary   R    ] dev-libs/libunistring-0.9.10
[binary   R    ] dev-libs/nspr-4.22
[binary   R    ] x11-libs/xtrans-1.4.0
[binary   R    ] app-misc/c_rehash-1.7-r1
[binary   R    ] dev-libs/gobject-introspection-common-1.60.2
[binary   R    ] app-misc/mime-types-9
[binary   R    ] sys-libs/e2fsprogs-libs-1.45.4
[binary   R    ] dev-libs/fribidi-1.0.5
[binary   R    ] x11-libs/libxshmfence-1.3-r1
[binary   R    ] app-text/libpaper-1.1.24-r2
[binary   R    ] x11-libs/pixman-0.38.4
[binary   R    ] app-arch/gzip-1.9
[binary   R    ] sys-apps/net-tools-1.60_p20180626073013
[ebuild   R    ] net-libs/libmnl-1.0.4  USE="-examples*"
[binary   R    ] net-firewall/iptables-1.6.1-r3
[binary   R    ] sys-apps/debianutils-4.8.3
[binary   R    ] acct-group/messagebus-0
[binary   R    ] dev-libs/libpthread-stubs-0.4-r1
[binary   R    ] app-misc/editor-wrapper-4-r1
[binary   R    ] dev-libs/libpipeline-1.4.2
[binary   R    ] app-text/manpager-1
[binary   R    ] sys-apps/sysvinit-2.93
[binary   R    ] sys-apps/opentmpfiles-0.2
[binary   R    ] app-crypt/openpgp-keys-gentoo-release-20190427
[binary   R    ] sys-apps/sandbox-2.13
[binary   R    ] sys-apps/install-xattr-0.5
[binary   R    ] dev-libs/npth-1.3
[binary   R    ] x11-themes/hicolor-icon-theme-0.17
[binary   R    ] sys-devel/llvm-common-8.0.1
[binary   R    ] acct-group/lp-0
[binary   R    ] app-text/poppler-data-0.4.9
[ebuild   R    ] dev-libs/lzo-2.10  USE="-examples*"
[ebuild   R    ] media-fonts/liberation-fonts-2.00.1-r3  USE="-X*"
[binary   R    ] media-libs/libjpeg-turbo-2.0.3
[binary   R    ] acct-group/input-0
[binary   R    ] acct-group/kvm-0
[binary   R    ] acct-group/render-0
[binary   R    ] dev-libs/libffi-3.3_rc0
[binary   R    ] sys-apps/baselayout-2.6-r1
[binary   R    ] sys-apps/which-2.21
[binary   R    ] sys-apps/diffutils-3.6-r1
[binary   R    ] dev-libs/libltdl-2.4.6
[binary   R    ] dev-util/ninja-1.8.2
[binary   R    ] sys-devel/automake-wrapper-11
[binary   R    ] sys-devel/autoconf-wrapper-13-r1
[binary   R    ] app-text/sgml-common-0.6.3-r7
[binary   R    ] dev-libs/libuv-1.33.1
[binary   R    ] app-arch/cpio-2.12-r1
[binary   R    ] dev-util/gperf-3.1
[binary   R   ~] sys-libs/readline-8.0_p1-r1
[ebuild   R    ] virtual/jpeg-0-r3
[binary   R    ] dev-libs/libgpg-error-1.36
[binary   R    ] x11-libs/libICE-1.0.10
[ebuild   R    ] virtual/libffi-3.3_rc0
[binary   R    ] app-misc/ca-certificates-20190110.3.43
[binary   R    ] sys-apps/acl-2.2.53
[binary   R    ] x11-libs/libXau-1.0.9
[ebuild   R    ] virtual/os-headers-0
[binary   R    ] sys-libs/timezone-data-2019c
[binary   R    ] dev-libs/popt-1.16-r2
[binary   R    ] net-dns/libidn2-2.1.1a-r1
[binary   R    ] x11-libs/libXdmcp-1.1.3
[ebuild   R    ] virtual/ttf-fonts-1-r1
[ebuild   R    ] sys-devel/binutils-config-5.1-r1
[binary   R    ] dev-libs/mpfr-4.0.2
[binary   R    ] net-dns/libidn-1.35
[binary   R    ] sys-devel/make-4.2.1-r4
[ebuild   R    ] sys-apps/busybox-1.30.1  USE="-syslog*"
[binary   R    ] sys-apps/iproute2-5.2.0-r1
[binary   R    ] acct-user/messagebus-0
[binary   R    ] sys-devel/gcc-config-2.1
[ebuild   R    ] virtual/tmpfiles-0
[binary   R    ] dev-libs/nettle-3.4.1
[binary   R    ] dev-libs/elfutils-0.176-r1
[binary   R    ] sys-devel/patch-2.7.6-r4
[binary   R    ] sys-apps/findutils-4.6.0-r1
[binary   R    ] app-portage/elt-patches-20170815
[ebuild   R    ] sys-devel/m4-1.4.18-r1  USE="-examples*"
[binary   R    ] app-arch/rpm2targz-9.0.0.5g
[binary   R    ] dev-libs/openssl-1.1.1d-r2
[ebuild   R    ] media-libs/libpng-1.6.37  USE="-apng*"
[binary   R    ] dev-libs/libgcrypt-1.8.5
[ebuild   R    ] media-libs/lcms-2.9  USE="-jpeg* -tiff*"
[ebuild   R    ] virtual/acl-0-r2
[binary   R    ] sys-libs/gdbm-1.13-r2
[binary   R    ] sys-apps/coreutils-8.30
[ebuild   R    ] sys-libs/cracklib-2.9.6-r2  USE="-python*"
[binary   R    ] dev-libs/libassuan-2.5.3
[ebuild   R    ] sys-apps/file-5.37-r1  USE="-python*"
[ebuild   R    ] app-shells/bash-4.4_p23-r1  USE="-examples*"
[ebuild   R    ] virtual/libelf-3
[binary   R    ] sys-devel/binutils-2.32-r1
[binary   R    ] dev-libs/mpc-1.1.0-r1
[binary   R    ] dev-libs/libksba-1.3.5-r1
[binary   R    ] app-crypt/p11-kit-0.23.12-r1
[ebuild   R    ] app-text/qpdf-9.0.2  USE="-examples* -perl*"
[binary   R    ] sys-devel/bc-1.06.95-r2
[ebuild   R    ] media-fonts/urw-fonts-2.4.9  USE="-X*"
[binary   R    ] sys-libs/binutils-libs-2.32-r1
[binary   R    ] sys-apps/gawk-4.2.1-r1
[ebuild   R    ] virtual/dev-manager-0-r2
[binary   R    ] sys-devel/flex-2.6.4-r1
[binary   R    ] x11-libs/libX11-1.6.9
[binary   R    ] media-libs/openjpeg-2.3.1
[binary   R    ] sys-apps/sed-4.5
[binary   R    ] app-arch/tar-1.32
[binary   R    ] net-misc/iputils-20180629
[binary   R    ] app-editors/nano-4.2
[binary   R    ] net-misc/wget-1.20.3-r1
[binary   R   ~] app-crypt/rhash-1.3.8
[binary   R    ] www-client/lynx-2.8.9_p1
[binary   R    ] x11-libs/libXext-1.3.4
[binary   R    ] x11-libs/libXfixes-5.0.3-r1
[binary   R    ] x11-libs/libXrender-0.9.10-r1
[binary   R    ] app-admin/eselect-1.4.15
[ebuild   R    ] virtual/editor-0-r2
[binary   R    ] x11-libs/libXi-1.7.10
[binary   R    ] x11-libs/libXrandr-1.5.2
[binary   R    ] x11-libs/libXcomposite-0.4.5
[binary   R    ] x11-libs/libXdamage-1.1.5
[binary   R    ] x11-libs/libXinerama-1.1.4
[binary   R    ] x11-libs/libXcursor-1.2.0
[binary   R    ] x11-libs/libXxf86vm-1.1.4-r1
[binary   R    ] app-eselect/eselect-opengl-1.3.1-r4
[binary   R    ] app-eselect/eselect-lib-bin-symlink-0.1.1
[binary   R    ] app-eselect/eselect-python-20171204
[binary   R    ] app-eselect/eselect-pinentry-0.7
[binary   R    ] dev-lang/perl-5.28.2-r1
[ebuild   R    ] virtual/perl-Data-Dumper-2.170.0
[ebuild   R    ] sys-apps/groff-1.22.3  USE="-X* -examples*"
[ebuild   R    ] virtual/perl-Test-Harness-3.420.0-r1
[binary   R    ] perl-core/File-Temp-0.230.400-r1
[binary   R    ] sys-devel/autoconf-2.69-r4
[binary   R    ] dev-util/gtk-doc-am-1.25-r1
[binary   R    ] sys-apps/man-db-2.7.6.1-r2
[ebuild   R    ] virtual/perl-File-Temp-0.230.400-r5
[binary   R    ] sys-devel/automake-1.16.1-r1
[ebuild   R    ] virtual/man-0-r2
[binary   R    ] sys-devel/libtool-2.4.6-r3
[ebuild   R    ] dev-libs/expat-2.2.8  USE="-examples*"
[ebuild   R    ] dev-db/sqlite-3.29.0  USE="-icu*"
[ebuild   R    ] sys-libs/libcap-ng-0.7.8  USE="-python*"
[ebuild   R    ] dev-libs/iniparser-3.1-r1  USE="-examples*"
[binary   R    ] app-i18n/man-pages-de-2.12
[binary   R    ] sys-apps/man-pages-posix-2013a
[ebuild   R    ] media-libs/jbig2dec-0.17-r1  USE="-png*"
[ebuild   R    ] sys-apps/man-pages-5.01  L10N="-ru*"
[binary   R    ] dev-perl/XML-Parser-2.440.0
[binary   R    ] sys-libs/pam-1.3.0-r2
[binary   R    ] sys-libs/libcap-2.26-r2
[binary   R    ] sys-apps/kbd-2.0.4
[binary   R    ] sys-devel/gcc-8.3.0-r1
[binary   R    ] app-crypt/libb2-0.98.1-r2
[binary   R    ] dev-libs/glib-2.60.6
[binary   R    ] dev-util/pkgconfig-0.29.2
[binary   R    ] dev-util/desktop-file-utils-0.23
[ebuild   R    ] virtual/pkgconfig-1
[ebuild   R    ] dev-lang/python-2.7.16  USE="-bluetooth* -examples*"
[ebuild   R    ] dev-libs/libxml2-2.9.9-r1  USE="-examples* -icu* -python*"
[ebuild   R    ] media-libs/freetype-2.9.1-r3  USE="-X* -png*"
[ebuild   R    ] dev-libs/icu-64.2  USE="-examples*"
[ebuild   R    ] dev-libs/libpcre-8.42  USE="-pcre16*"
[ebuild   R    ] app-misc/pax-utils-1.2.3  USE="-python*"
[ebuild   R    ] net-misc/curl-7.66.0  USE="-samba* -threads*"
[ebuild   R    ] sys-apps/kmod-26-r3  USE="-python*"
[ebuild   R    ] net-misc/rsync-3.1.3  USE="-examples*"
[ebuild   R    ] sys-devel/gettext-0.19.8.1  USE="-git*"
[binary   R    ] x11-misc/shared-mime-info-1.10
[binary   R    ] dev-python/certifi-2019.6.16
[binary   R    ] dev-lang/spidermonkey-60.5.2_p0-r2
[binary   R    ] dev-python/pyblake2-1.1.2
[binary   R    ] dev-libs/libcroco-0.6.13
[binary   R    ] sys-apps/less-531
[ebuild   R    ] virtual/modutils-0
[binary   R    ] dev-python/pyxattr-0.6.0-r1
[binary   R    ] dev-python/bz2file-0.98
[binary   R    ] sys-apps/grep-3.1-r1
[ebuild   R    ] dev-libs/libxslt-1.1.33-r1  USE="-examples* -python*"
[binary   R    ] app-arch/libarchive-3.4.0
[ebuild   R    ] sys-apps/util-linux-2.33.2  USE="-python* -udev*"
[binary   R    ] dev-python/setuptools-40.6.3
[ebuild   R    ] net-libs/gnutls-3.6.7  USE="-examples*"
[ebuild   R    ] sys-process/psmisc-23.1-r1  USE="-X*"
[ebuild   R    ] virtual/pager-0
[ebuild   R    ] sys-devel/bison-3.1  USE="-examples*"
[binary   R    ] dev-util/intltool-0.51.0-r2
[binary   R    ] dev-util/cmake-3.14.6
[ebuild   R    ] dev-libs/gobject-introspection-1.60.2  USE="-cairo*"
[binary   R    ] x11-libs/libSM-1.2.3
[ebuild   R    ] sys-libs/glibc-2.29-r2  USE="-suid*"
[ebuild   R    ] sys-devel/llvm-8.0.1  USE="-xml*"
[ebuild   R    ] media-gfx/graphite2-1.3.13  USE="-perl*"
[binary   R    ] sys-fs/e2fsprogs-1.45.4
[binary   R    ] app-text/build-docbook-catalog-1.21
[binary   R    ] dev-util/meson-0.51.2
[binary   R    ] dev-libs/atk-2.30.0
[binary   R    ] x11-libs/libXt-1.2.0
[ebuild   R    ] virtual/libc-1
[binary   R    ] app-text/docbook-xsl-stylesheets-1.79.1-r2
[binary   R    ] dev-util/gtk-update-icon-cache-3.24.8
[ebuild   R    ] dev-util/glib-utils-2.60.6
[binary   R    ] app-text/docbook-xml-dtd-4.1.2-r7
[ebuild   R    ] dev-util/gdbus-codegen-2.60.6
[binary   R    ] media-libs/fontconfig-2.13.0-r4
[binary   R    ] app-eselect/eselect-fontconfig-1.1-r1
[binary   R    ] app-crypt/libsecret-0.18.8
[ebuild   R    ] sys-fs/eudev-3.2.9  USE="-introspection*"
[ebuild   R    ] virtual/libudev-232-r3
[ebuild   R    ] virtual/udev-217
[binary   R    ] sys-apps/hwids-20190316
[binary   R    ] sys-fs/udev-init-scripts-33
[binary   R    ] x11-libs/libpciaccess-0.16
[binary   R    ] x11-libs/libdrm-2.4.100
[binary   R    ] gnome-base/librsvg-2.40.20
[binary   R    ] sys-auth/elogind-241.3
[binary   R    ] sys-process/procps-3.3.15-r1
[binary   R    ] gnome-base/dconf-0.30.1
[ebuild   R    ] app-accessibility/at-spi2-core-2.30.1  USE="-X*"
[ebuild   R    ] sys-auth/consolekit-1.2.1  USE="-policykit* -udev*"
[binary   R    ] sys-auth/pambase-20150213-r2
[binary   R    ] app-accessibility/at-spi2-atk-2.30.1
[ebuild   R    ] sys-auth/polkit-0.115-r4  USE="-examples* -gtk*"
[binary   R    ] sys-apps/shadow-4.6
[ebuild   R    ] virtual/shadow-0
[ebuild   R    ] net-misc/openssh-8.0_p1-r4  USE="-X*"
[ebuild   R    ] virtual/ssh-0
[ebuild   R    ] net-print/cups-2.2.12  USE="-X* -python* -usb*"
[ebuild   R    ] x11-themes/adwaita-icon-theme-3.30.1  USE="-branding*"
[ebuild   R    ] app-crypt/pinentry-1.1.0-r2  USE="-gtk*"
[ebuild   R    ] net-print/cups-filters-1.25.11  USE="-jpeg* -pdf* -perl* -png* -tiff*"
[ebuild   R    ] app-crypt/gnupg-2.2.17  USE="-usb*"
[binary   R    ] app-portage/gemato-14.1
[binary   R    ] gnome-base/gnome-keyring-3.28.2
[ebuild   R    ] app-crypt/gpgme-1.13.0-r1  USE="-python*"
[binary   R    ] sys-apps/portage-2.3.76-r1
[binary   R    ] app-portage/portage-utils-0.80
[binary   R    ] app-admin/perl-cleaner-2.27
[ebuild   R    ] virtual/package-manager-1
[binary   R    ] sys-apps/openrc-0.41.2
[binary   R    ] net-misc/netifrc-0.5.1
[ebuild   R    ] virtual/service-manager-0

WARNING: One or more updates/rebuilds have been skipped due to a dependency conflict:

dev-lang/python:3.6

  (dev-lang/python-3.6.9:3.6/3.6m::gentoo, ebuild scheduled for merge) conflicts with
    dev-lang/python:3.6[xml(+),sqlite] required by (app-portage/layman-2.4.2-r1:0/0::gentoo, installed)
                               ^^^^^^

app-crypt/gcr:0

  (app-crypt/gcr-3.28.1:0/1::gentoo, ebuild scheduled for merge) conflicts with
    >=app-crypt/gcr-3.14:=[gtk] required by (gnome-extra/nm-applet-1.8.22:0/0::gentoo, installed)
                           ^^^
    >=app-crypt/gcr-3.27.90:0/1=[gtk] required by (gnome-base/gnome-keyring-3.28.2:0/0::gentoo, binary scheduled for merge)
                                 ^^^
    >=app-crypt/gcr-3.14:0/1=[gtk] required by (gnome-extra/nm-applet-1.8.22:0/0::gentoo, installed)
                              ^^^
    >=app-crypt/gcr-3.4[gtk] required by (gnome-extra/evolution-data-server-3.30.5-r1:0/62::gentoo, installed)
                        ^^^

media-libs/mesa:0

  (media-libs/mesa-19.1.8:0/0::gentoo, ebuild scheduled for merge) conflicts with
    >=media-libs/mesa-9.1.6[opencl,X(+),abi_x86_64(-)] required by (virtual/opencl-2:0/0::gentoo, installed)
                            ^^^^^^                   

sys-apps/dbus:0

  (sys-apps/dbus-1.12.16:0/0::gentoo, ebuild scheduled for merge) conflicts with
    sys-apps/dbus[X] required by (app-i18n/ibus-1.5.20:0/0::gentoo, installed)
                  ^
    sys-apps/dbus[X] required by (gnome-base/gnome-session-3.30.1-r1:0/0::gentoo, installed)
                  ^

media-libs/harfbuzz:0

  (media-libs/harfbuzz-2.6.4:0/0.9.18::gentoo, ebuild scheduled for merge) conflicts with
    >=media-libs/harfbuzz-1.4.2:0/0.9.18=[icu(+)] required by (net-libs/webkit-gtk-2.24.4:4/37::gentoo, installed)
                                                 
    >=media-libs/harfbuzz-1.4.2:=[icu(+)] required by (net-libs/webkit-gtk-2.24.4:4/37::gentoo, installed)
                                         

x11-libs/gdk-pixbuf:2

  (x11-libs/gdk-pixbuf-2.38.1-r1:2/2::gentoo, ebuild scheduled for merge) conflicts with
    >=x11-libs/gdk-pixbuf-2.30:2[introspection,jpeg,tiff] required by (media-gfx/eom-1.22.0:0/0::gentoo, installed)
                                               ^^^^ ^^^^
    x11-libs/gdk-pixbuf:2[X] required by (media-libs/libwmf-0.2.8.4-r7:0/0::gentoo, installed)
                          ^
    x11-libs/gdk-pixbuf:2[jpeg,introspection] required by (media-video/cheese-3.30.0:0/8::gentoo, installed)
                          ^^^^               
    x11-libs/gdk-pixbuf[X] required by (x11-drivers/nvidia-drivers-440.31:0/440::gentoo, installed)
                        ^

app-text/poppler:0

  (app-text/poppler-0.79.0-r1:0/89::gentoo, ebuild scheduled for merge) conflicts with
    >=app-text/poppler-0.71.0[cairo] required by (media-libs/gegl-0.4.14:0.4/0.4::gentoo, installed)
                              ^^^^^
    >=app-text/poppler-0.44[cairo] required by (media-gfx/gimp-2.10.8-r1:2/2::gentoo, installed)
                            ^^^^^

x11-libs/pango:0

  (x11-libs/pango-1.42.4-r2:0/0::gentoo, ebuild scheduled for merge) conflicts with
    x11-libs/pango[X] required by (x11-drivers/nvidia-drivers-440.31:0/440::gentoo, installed)
                   ^
    x11-libs/pango[X] required by (dev-python/wxpython-3.0.2.0:3.0/3.0::gentoo, installed)
                   ^

media-libs/tiff:0

  (media-libs/tiff-4.1.0:0/0::gentoo, ebuild scheduled for merge) conflicts with
    media-libs/tiff:0/0=[jpeg,zlib] required by (dev-python/pillow-6.0.0:0/0::gentoo, installed)
                         ^^^^     
    media-libs/tiff:0=[jpeg,zlib] required by (dev-python/pillow-6.0.0:0/0::gentoo, installed)
                       ^^^^     

dev-libs/libpcre2:0

  (dev-libs/libpcre2-10.33-r1:0/0::gentoo, ebuild scheduled for merge) conflicts with
    dev-libs/libpcre2[pcre16,unicode] required by (dev-qt/qtcore-5.12.5-r1:5/5.12::gentoo, installed)
                      ^^^^^^         

x11-libs/libxcb:0

  (x11-libs/libxcb-1.13.1:0/1.12::gentoo, ebuild scheduled for merge) conflicts with
    >=x11-libs/libxcb-1.12:=[xkb] required by (dev-qt/qtgui-5.12.5:5/5.12::gentoo, installed)
                             ^^^
    >=x11-libs/libxcb-1.12:0/1.12=[xkb] required by (dev-qt/qtgui-5.12.5:5/5.12::gentoo, installed)
                                   ^^^
    >=x11-libs/libxcb-1.10:0/1.12=[abi_x86_64(-),xkb] required by (x11-libs/libxkbcommon-0.9.1:0/0::gentoo, installed)
                                                 ^^^
    >=x11-libs/libxcb-1.10:=[abi_x86_64(-),xkb] required by (x11-libs/libxkbcommon-0.9.1:0/0::gentoo, installed)
                                           ^^^


!!! The following binary packages have been ignored due to non matching USE:

    =sys-apps/man-pages-5.01 l10n_ru
    =net-misc/rsync-3.1.3 examples
    =sys-apps/file-5.37-r1 python
    =sys-process/psmisc-23.1-r1 X
    =sys-apps/util-linux-2.33.2 python udev
    =sys-apps/busybox-1.30.1 syslog
    =app-shells/bash-4.4_p23-r1 examples
    =net-libs/libmnl-1.0.4 examples
    =sys-libs/glibc-2.29-r2 suid
    =app-misc/pax-utils-1.2.3 python
    =sys-devel/bison-3.1 examples
    =sys-devel/m4-1.4.18-r1 examples
    =sys-devel/gettext-0.19.8.1 git
    =dev-libs/libxml2-2.9.9-r1 examples icu python
    =dev-libs/expat-2.2.8 examples
    =sys-libs/ncurses-6.1_p20181020 gpm threads
    =sys-libs/cracklib-2.9.6-r2 python
    =sys-auth/consolekit-1.2.1 policykit udev
    =sys-auth/polkit-0.115-r4 examples gtk
    =dev-libs/libxslt-1.1.33-r1 examples python
    =dev-libs/gobject-introspection-1.60.2 cairo
    =dev-libs/libpcre-8.42 pcre16
    =dev-libs/icu-64.2 examples
    =sys-apps/groff-1.22.3 X examples
    =sys-fs/eudev-3.2.9 introspection
    =app-crypt/gnupg-2.2.17 usb
    =dev-lang/python-2.7.16 bluetooth examples
    =dev-db/sqlite-3.29.0 icu
    =net-misc/curl-7.66.0 samba threads
    =net-libs/gnutls-3.6.7 examples
    =app-crypt/pinentry-1.1.0-r2 gtk
    =sys-libs/libcap-ng-0.7.8 python
    =net-misc/openssh-8.0_p1-r4 X
    =net-print/cups-2.2.12 X python usb
    =x11-themes/adwaita-icon-theme-3.30.1 branding
    =sys-devel/llvm-8.0.1 xml
    =app-accessibility/at-spi2-core-2.30.1 X
    =net-print/cups-filters-1.25.11 jpeg pdf perl png tiff
    =app-text/qpdf-9.0.2 examples perl
    =media-libs/freetype-2.9.1-r3 X png
    =media-libs/lcms-2.9 jpeg tiff
    =media-libs/jbig2dec-0.17-r1 png
    =media-libs/libpng-1.6.37 apng
    =media-fonts/urw-fonts-2.4.9 X
    =media-gfx/graphite2-1.3.13 perl
    =dev-libs/lzo-2.10 examples
    =media-fonts/liberation-fonts-2.00.1-r3 X
    =media-fonts/dejavu-2.37 X
    =sys-apps/kmod-26-r3 python
    =app-editors/xemacs-21.4.24-r1 X gif gpm jpeg png tiff
    =dev-libs/iniparser-3.1-r1 examples
    =app-crypt/gpgme-1.13.0-r1 python

NOTE: The --binpkg-respect-use=n option will prevent emerge
      from ignoring these binary packages if possible.
      Using --binpkg-respect-use=y will silence this warning.

!!! The following binary packages have been ignored due to changed dependencies:

     sys-devel/binutils-config-5.1-r1::gentoo
     dev-util/glib-utils-2.60.6::gentoo
     dev-util/gdbus-codegen-2.60.6::gentoo

NOTE: The --binpkg-changed-deps=n option will prevent emerge
      from ignoring these binary packages if possible.
      Using --binpkg-changed-deps=y will silence this warning.


I edited my previous answer with successful single mode and unsuccessful login.

I reduced my USE flags:
Code:
USE="-X -wayland -gtk -gnome -xorg -systemd -qt4 -qt5 -kde -abi_x86_32 -consolekit \
    dbus efi eudev elogind initramfs -libav -libressl -oss"


I've moved the packages and now @system is emerging...
Code:
emerge -e @system -a

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R    ] dev-lang/python-exec-2.4.6-r1
[ebuild   R    ] virtual/libintl-0-r2
[ebuild   R    ] sys-libs/ncurses-6.1_p20181020  USE="-gpm* -threads*"
[ebuild   R    ] app-arch/bzip2-1.0.6-r11
[ebuild   R    ] virtual/libiconv-0-r2
[ebuild   R    ] sys-devel/gnuconfig-20180101
[ebuild   R    ] sys-apps/gentoo-functions-0.12
[ebuild   R    ] app-misc/mime-types-9
[ebuild   R    ] app-misc/c_rehash-1.7-r1
[ebuild   R    ] app-arch/gzip-1.9
[ebuild   R    ] acct-group/messagebus-0
[ebuild   R    ] sys-apps/debianutils-4.8.3
[ebuild   R    ] dev-libs/libpthread-stubs-0.4-r1
[ebuild   R    ] sys-devel/llvm-common-8.0.1
[ebuild   R    ] acct-group/lp-0
[ebuild   R    ] app-text/poppler-data-0.4.9
[ebuild   R    ] dev-libs/lzo-2.10  USE="-examples*"
[ebuild   R    ] net-libs/libmnl-1.0.4  USE="-examples*"
[ebuild   R    ] app-misc/editor-wrapper-4-r1
[ebuild   R    ] app-text/manpager-1
[ebuild   R    ] sys-apps/opentmpfiles-0.2
[ebuild   R    ] app-crypt/openpgp-keys-gentoo-release-20190427
[ebuild   R    ] sys-apps/install-xattr-0.5
[ebuild   R    ] acct-group/input-0
[ebuild   R    ] acct-group/kvm-0
[ebuild   R    ] acct-group/render-0
[ebuild   R    ] dev-libs/libffi-3.3_rc0
[ebuild   R    ] media-fonts/liberation-fonts-2.00.1-r3  USE="-X*"
[ebuild   R    ] sys-apps/which-2.21
[ebuild   R    ] sys-apps/baselayout-2.6-r1
[ebuild   R    ] app-text/sgml-common-0.6.3-r7
[ebuild   R    ] sys-devel/autoconf-wrapper-13-r1
[ebuild   R    ] dev-util/gperf-3.1
[ebuild   R    ] sys-devel/automake-wrapper-11
[ebuild   R    ] dev-util/re2c-1.1.1
[ebuild   R    ] app-arch/cpio-2.12-r1
[ebuild   R    ] virtual/libffi-3.3_rc0
[ebuild   R    ] sys-libs/timezone-data-2019c
[ebuild   R    ] virtual/ttf-fonts-1-r1
[ebuild   R    ] sys-devel/binutils-config-5.1-r1
[ebuild   R    ] acct-user/messagebus-0
[ebuild   R    ] sys-devel/gcc-config-2.1
[ebuild   R    ] virtual/tmpfiles-0
[ebuild   R    ] app-arch/unzip-6.0_p25  USE="-natspec*"
[ebuild   R    ] virtual/pkgconfig-1
[ebuild   R   ~] sys-libs/readline-8.0_p1-r1
[ebuild   R    ] dev-libs/fribidi-1.0.5
[ebuild   R    ] sys-libs/e2fsprogs-libs-1.45.4
[ebuild   R    ] app-shells/bash-4.4_p23-r1  USE="-examples*"
[ebuild   R    ] app-misc/ca-certificates-20190110.3.43
[ebuild   R    ] dev-util/ninja-1.8.2
[ebuild   R    ] virtual/jpeg-0-r3
[ebuild   R    ] virtual/libudev-232-r3
[ebuild   R    ] virtual/udev-217
[ebuild   R    ] sys-apps/hwids-20190316
[ebuild   R    ] sys-fs/udev-init-scripts-33
[ebuild   R    ] virtual/os-headers-0
[ebuild   R    ] sys-apps/sysvinit-2.93
[ebuild   R    ] virtual/acl-0-r2
[ebuild   R    ] virtual/man-0-r2
[ebuild   R    ] sys-apps/man-pages-posix-2013a
[ebuild   R    ] sys-apps/man-pages-5.01  L10N="-ru*"
[ebuild   R    ] virtual/perl-Data-Dumper-2.170.0
[ebuild   R    ] app-eselect/eselect-pinentry-0.7
[ebuild   R    ] app-eselect/eselect-python-20171204
[ebuild   R    ] virtual/perl-File-Temp-0.230.400-r5
[ebuild   R    ] virtual/perl-Test-Harness-3.420.0-r1
[ebuild   R    ] virtual/libelf-3
[ebuild   R    ] virtual/modutils-0
[ebuild   R    ] virtual/libc-1
[ebuild   R    ] virtual/shadow-0
[ebuild   R    ] app-admin/perl-cleaner-2.27
[ebuild   R    ] app-eselect/eselect-fontconfig-1.1-r1
[ebuild   R    ] net-misc/netifrc-0.5.1
[ebuild   R    ] app-text/docbook-xsl-stylesheets-1.79.1-r2
[ebuild   R    ] virtual/perl-Carp-1.500.0-r1
[ebuild   R    ] virtual/perl-ExtUtils-MakeMaker-7.340.0-r1
[ebuild   R    ] virtual/perl-File-Spec-3.740.0
[ebuild   R    ] virtual/perl-Exporter-5.730.0-r1
[ebuild   R    ] app-text/build-docbook-catalog-1.21
[ebuild   R    ] app-text/docbook-xml-dtd-4.2-r3
[ebuild   R    ] app-text/docbook-xml-dtd-4.3-r2
[ebuild   R    ] app-text/docbook-xml-dtd-4.1.2-r7
[ebuild   R    ] app-text/docbook-xml-dtd-4.5-r2
[ebuild   R    ] virtual/yacc-0
[ebuild   R    ] virtual/perl-IO-1.390.0
[ebuild   R    ] virtual/perl-Parse-CPAN-Meta-2.150.10-r2
[ebuild   R    ] virtual/perl-CPAN-Meta-YAML-0.18.0-r4
[ebuild   R    ] virtual/perl-version-0.992.300
[ebuild   R    ] virtual/perl-podlators-4.100.0
[ebuild   R    ] virtual/perl-Text-ParseWords-3.300.0-r5
[ebuild   R    ] virtual/perl-Perl-OSType-1.10.0-r2
[ebuild   R    ] virtual/perl-Module-Metadata-1.0.33-r1
[ebuild   R    ] virtual/perl-Getopt-Long-2.500.0-r1
[ebuild   R    ] virtual/perl-ExtUtils-ParseXS-3.390.0
[ebuild   R    ] virtual/perl-ExtUtils-Manifest-1.700.0-r5
[ebuild   R    ] virtual/perl-ExtUtils-Install-2.140.0-r1
[ebuild   R    ] virtual/perl-ExtUtils-CBuilder-0.280.230
[ebuild   R    ] virtual/perl-CPAN-Meta-2.150.10-r2
[ebuild   R    ] dev-libs/glib-2.60.6
[ebuild   R    ] x11-libs/libX11-1.6.9
[ebuild   R    ] sys-libs/zlib-1.2.11-r2
[ebuild   R    ] app-text/qpdf-9.0.2  USE="-examples* -perl*"
[ebuild   R    ] dev-libs/gobject-introspection-1.60.2  USE="-cairo*"
[ebuild   R    ] app-arch/xz-utils-5.2.4-r2
[ebuild   R    ] dev-libs/gobject-introspection-common-1.60.2
[ebuild   R    ] sys-apps/net-tools-1.60_p20180626073013
[ebuild   R    ] x11-themes/hicolor-icon-theme-0.17
[ebuild   R    ] app-portage/elt-patches-20170815
[ebuild   R    ] dev-util/desktop-file-utils-0.23
[ebuild   R    ] sys-devel/m4-1.4.18-r1  USE="-examples*"
[ebuild   R    ] dev-libs/libltdl-2.4.6
[ebuild   R    ] dev-libs/vala-common-0.42.7
[ebuild   R    ] app-arch/rpm2targz-9.0.0.5g
[ebuild   R    ] media-libs/freetype-2.9.1-r3  USE="-X* -png*"
[ebuild   R    ] media-libs/libpng-1.6.37  USE="-apng*"
[ebuild   R    ] media-libs/lcms-2.9  USE="-jpeg* -tiff*"
[ebuild   R    ] dev-libs/gmp-6.1.2-r1
[ebuild   R    ] dev-libs/libpcre-8.42  USE="-pcre16*"
[ebuild   R    ] sys-libs/cracklib-2.9.6-r2  USE="-python*"
[ebuild   R    ] dev-libs/libunistring-0.9.10
[ebuild   R    ] sys-apps/file-5.37-r1  USE="-python*"
[ebuild   R    ] sys-apps/kmod-26-r3  USE="-python*"
[ebuild   R    ] dev-libs/npth-1.3
[ebuild   R    ] media-fonts/urw-fonts-2.4.9  USE="-X*"
[ebuild   R    ] dev-util/pkgconfig-0.29.2
[ebuild   R    ] dev-libs/libpipeline-1.4.2
[ebuild   R    ] dev-libs/mpfr-4.0.2
[ebuild   R    ] sys-apps/less-531
[ebuild   R    ] dev-libs/mpc-1.1.0-r1
[ebuild   R    ] virtual/pager-0
[ebuild   R    ] app-eselect/eselect-lib-bin-symlink-0.1.1
[ebuild   R    ] x11-libs/libXext-1.3.4
[ebuild   R    ] dev-libs/openssl-1.1.1d-r2
[ebuild   R    ] dev-libs/libxml2-2.9.9-r1  USE="-examples* -icu* -python*"
[ebuild   R    ] sys-devel/gettext-0.19.8.1  USE="-git*"
[ebuild   R    ] sys-apps/attr-2.4.48-r3
[ebuild   R    ] dev-libs/popt-1.16-r2
[ebuild   R    ] sys-apps/sed-4.5
[ebuild   R    ] sys-devel/make-4.2.1-r4
[ebuild   R    ] net-dns/libidn-1.35
[ebuild   R    ] sys-libs/binutils-libs-2.32-r1
[ebuild   R    ] app-editors/nano-4.2
[ebuild   R    ] net-misc/wget-1.20.3-r1
[ebuild   R    ] sys-apps/gawk-4.2.1-r1
[ebuild   R    ] sys-apps/grep-3.1-r1
[ebuild   R    ] sys-apps/diffutils-3.6-r1
[ebuild   R    ] sys-apps/findutils-4.6.0-r1
[ebuild   R    ] sys-devel/flex-2.6.4-r1
[ebuild   R   ~] app-crypt/rhash-1.3.8
[ebuild   R    ] www-client/lynx-2.8.9_p1
[ebuild   R    ] sys-apps/acl-2.2.53
[ebuild   R    ] sys-devel/binutils-2.32-r1
[ebuild   R    ] net-misc/rsync-3.1.3  USE="-examples*"
[ebuild   R    ] app-arch/tar-1.32
[ebuild   R    ] sys-devel/patch-2.7.6-r4
[ebuild   R    ] sys-devel/bc-1.06.95-r2
[ebuild   R    ] dev-libs/elfutils-0.176-r1
[ebuild   R    ] virtual/editor-0-r2
[ebuild   R    ] sys-devel/bison-3.1  USE="-examples*"
[ebuild   R    ] sys-apps/coreutils-8.30
[ebuild   R    ] app-admin/eselect-1.4.15
[ebuild   R    ] app-eselect/eselect-opengl-1.3.1-r4
[ebuild   R    ] media-libs/fontconfig-2.13.0-r4
[ebuild   R    ] x11-base/xorg-proto-2019.2
[ebuild   R    ] x11-misc/shared-mime-info-1.10
[ebuild   R    ] sys-auth/elogind-241.3
[ebuild   R    ] sys-process/procps-3.3.15-r1
[ebuild   R    ] x11-libs/libXi-1.7.10
[ebuild   R    ] dev-libs/expat-2.2.8  USE="-examples*"
[ebuild   R    ] x11-libs/libXfixes-5.0.3-r1
[ebuild   R    ] sys-auth/polkit-0.115-r4  USE="-examples* -gtk*"
[ebuild   R    ] dev-libs/libgcrypt-1.8.5
[ebuild   R    ] dev-python/setuptools-40.6.3
[ebuild   R    ] dev-util/meson-0.51.2
[ebuild   R    ] x11-libs/pixman-0.38.4
[ebuild   R    ] sys-apps/util-linux-2.33.2  USE="-python* -udev*"
[ebuild   R    ] sys-kernel/linux-headers-4.19
[ebuild   R    ] dev-libs/libbsd-0.9.1
[ebuild   R    ] sys-libs/libseccomp-2.4.0
[ebuild   R    ] sys-apps/busybox-1.30.1  USE="-syslog*"
[ebuild   R    ] net-firewall/iptables-1.6.1-r3
[ebuild   R    ] app-misc/pax-utils-1.2.3  USE="-python*"
[ebuild   R    ] virtual/dev-manager-0-r2
[ebuild   R    ] sys-apps/sandbox-2.13
[ebuild   R    ] dev-libs/libgpg-error-1.36
[ebuild   R    ] dev-libs/libassuan-2.5.3
[ebuild   R    ] dev-libs/libksba-1.3.5-r1
[ebuild   R    ] x11-libs/libXrandr-1.5.2
[ebuild   R    ] x11-libs/libXrender-0.9.10-r1
[ebuild   R    ] x11-libs/libICE-1.0.10
[ebuild   R    ] sys-libs/libcap-2.26-r2
[ebuild   R    ] net-misc/iputils-20180629
[ebuild   R    ] dev-db/sqlite-3.29.0  USE="-icu*"
[ebuild   R    ] dev-libs/atk-2.30.0
[ebuild   R    ] gnome-base/librsvg-2.40.20
[ebuild   R    ] x11-themes/adwaita-icon-theme-3.30.1  USE="-branding*"
[ebuild   R    ] sys-auth/pambase-20150213-r2
[ebuild   R    ] x11-libs/libXcomposite-0.4.5
[ebuild   R    ] x11-libs/libXdamage-1.1.5
[ebuild   R    ] x11-libs/libSM-1.2.3
[ebuild   R    ] app-crypt/libsecret-0.18.8
[ebuild   R    ] x11-libs/libXinerama-1.1.4
[ebuild   R    ] x11-libs/libXt-1.2.0
[ebuild   R    ] dev-libs/icu-64.2  USE="-examples*"
[ebuild   R    ] sys-devel/gcc-8.3.0-r1
[ebuild   R    ] sys-libs/gdbm-1.13-r2
[ebuild   R    ] dev-lang/python-2.7.16  USE="-bluetooth* -examples*"
[ebuild   R    ] dev-python/certifi-2019.6.16
[ebuild   R    ] dev-python/pyblake2-1.1.2
[ebuild   R    ] dev-python/pyxattr-0.6.0-r1
[ebuild   R    ] dev-python/bz2file-0.98
[ebuild   R    ] sys-apps/portage-2.3.76-r1
[ebuild   R    ] virtual/package-manager-1
[ebuild   R    ] gnome-base/dconf-0.30.1
[ebuild   R    ] x11-libs/libXau-1.0.9
[ebuild   R    ] sys-libs/db-5.3.28-r2  USE="-examples*"
[ebuild   R    ] dev-lang/perl-5.28.2-r1
[ebuild   R    ] sys-apps/iproute2-5.2.0-r1
[ebuild   R    ] perl-core/File-Temp-0.230.400-r1
[ebuild   R    ] sys-apps/groff-1.22.3  USE="-X* -examples*"
[ebuild   R    ] sys-devel/autoconf-2.69-r4
[ebuild   R    ] dev-util/gtk-doc-am-1.25-r1
[ebuild   R    ] dev-perl/XML-Parser-2.440.0
[ebuild   R    ] dev-perl/Locale-gettext-1.70.0
[ebuild   R    ] dev-perl/TermReadKey-2.370.0  USE="-examples*"
[ebuild   R    ] dev-perl/Module-Build-0.422.400
[ebuild   R    ] dev-perl/Unicode-EastAsianWidth-1.330.0-r1
[ebuild   R    ] dev-perl/Text-Unidecode-1.300.0
[ebuild   R    ] dev-perl/Class-Inspector-1.320.0
[ebuild   R    ] dev-perl/File-ShareDir-Install-0.110.0
[ebuild   R    ] dev-perl/Text-CharWidth-0.40.0-r1
[ebuild   R    ] virtual/perl-JSON-PP-2.970.10
[ebuild   R    ] dev-lang/nasm-2.14.02
[ebuild   R    ] dev-libs/libcroco-0.6.13
[ebuild   R    ] dev-util/intltool-0.51.0-r2
[ebuild   R    ] sys-apps/help2man-1.47.10
[ebuild   R    ] dev-perl/File-ShareDir-1.104.0
[ebuild   R    ] dev-perl/SGMLSpm-1.1-r1
[ebuild   R    ] dev-perl/Text-WrapI18N-0.60.0-r1
[ebuild   R    ] dev-libs/libtasn1-4.13
[ebuild   R    ] net-dns/libidn2-2.1.1a-r1
[ebuild   R    ] sys-devel/automake-1.16.1-r1
[ebuild   R    ] dev-perl/libintl-perl-1.310.0  USE="-examples*"
[ebuild   R    ] sys-libs/glibc-2.29-r2  USE="-suid*"
[ebuild   R    ] app-crypt/p11-kit-0.23.12-r1
[ebuild   R    ] sys-devel/libtool-2.4.6-r3
[ebuild   R    ] sys-apps/texinfo-6.6-r1
[ebuild   R    ] sys-libs/pam-1.3.0-r2
[ebuild   R    ] x11-libs/libXcursor-1.2.0
[ebuild   R    ] x11-libs/xtrans-1.4.0
[ebuild   R    ] x11-libs/libXxf86vm-1.1.4-r1
[ebuild   R    ] net-misc/curl-7.66.0  USE="-samba* -threads*"
[ebuild   R    ] x11-libs/libXdmcp-1.1.3
[ebuild   R    ] dev-libs/nspr-4.22
[ebuild   R    ] dev-libs/iniparser-3.1-r1  USE="-examples*"
[ebuild   R    ] app-crypt/pinentry-1.1.0-r2  USE="-gtk*"
[ebuild   R    ] sys-libs/libcap-ng-0.7.8  USE="-python*"
[ebuild   R    ] x11-libs/libxshmfence-1.3-r1
[ebuild   R    ] x11-libs/libpciaccess-0.16
[ebuild   R    ] app-text/libpaper-1.1.24-r2
[ebuild   R    ] sys-fs/eudev-3.2.9  USE="-introspection*"
[ebuild   R    ] sys-process/psmisc-23.1-r1  USE="-X*"
[ebuild   R    ] sys-fs/e2fsprogs-1.45.4
[ebuild   R    ] app-crypt/libb2-0.98.1-r2
[ebuild   R    ] media-libs/jbig2dec-0.17-r1  USE="-png*"
[ebuild   R    ] dev-libs/nettle-3.4.1
[ebuild   R    ] dev-libs/libxslt-1.1.33-r1  USE="-examples* -python*"
[ebuild   R    ] dev-libs/libuv-1.33.1
[ebuild   R    ] sys-devel/autoconf-2.13-r1
[ebuild   R    ] net-libs/libtirpc-1.1.4
[ebuild   R    ] net-libs/gnutls-3.6.7  USE="-examples*"
[ebuild   R    ] x11-libs/libdrm-2.4.100
[ebuild   R    ] dev-util/gtk-update-icon-cache-3.24.8
[ebuild   R    ] sys-apps/openrc-0.41.2
[ebuild   R    ] net-misc/openssh-8.0_p1-r4  USE="-X*"
[ebuild   R    ] dev-lang/spidermonkey-60.5.2_p0-r2
[ebuild   R    ] sys-auth/consolekit-1.2.1  USE="-policykit* -udev*"
[ebuild   R    ] sys-apps/shadow-4.6
[ebuild   R    ] sys-apps/kbd-2.0.4
[ebuild   R    ] dev-util/glib-utils-2.60.6
[ebuild   R    ] dev-util/gdbus-codegen-2.60.6
[ebuild   R    ] dev-lang/vala-0.42.7
[ebuild   R    ] app-arch/libarchive-3.4.0
[ebuild   R    ] net-libs/libnsl-1.2.0
[ebuild   R    ] app-crypt/gnupg-2.2.17  USE="-usb*"
[ebuild   R    ] app-accessibility/at-spi2-core-2.30.1  USE="-X*"
[ebuild   R    ] virtual/service-manager-0
[ebuild   R    ] virtual/ssh-0
[ebuild   R    ] dev-util/cmake-3.14.6
[ebuild   R    ] app-text/opensp-1.5.2-r3
[ebuild   R    ] media-libs/openjpeg-2.3.1
[ebuild   R    ] app-accessibility/at-spi2-atk-2.30.1
[ebuild   R    ] app-crypt/gpgme-1.13.0-r1  USE="-python*"
[ebuild   R    ] gnome-base/gnome-keyring-3.28.2
[ebuild   R    ] sys-devel/llvm-8.0.1  USE="-xml*"
[ebuild   R    ] media-gfx/graphite2-1.3.13  USE="-perl*"
[ebuild   R    ] app-portage/gemato-14.1
[ebuild   R    ] media-libs/libjpeg-turbo-2.0.3
[ebuild   R    ] app-text/openjade-1.3.2-r9
[ebuild   R    ] app-portage/portage-utils-0.80
[ebuild   R    ] app-text/po4a-0.47-r1
[ebuild   R    ] app-i18n/man-pages-de-2.12
[ebuild   R    ] sys-apps/man-db-2.7.6.1-r2
[ebuild   R    ] net-print/cups-2.2.12  USE="-X* -python* -usb*"
[ebuild   R    ] net-print/cups-filters-1.25.11  USE="-jpeg* -pdf* -perl* -png* -tiff*"

WARNING: One or more updates/rebuilds have been skipped due to a dependency conflict:

dev-lang/python:3.6

  (dev-lang/python-3.6.9:3.6/3.6m::gentoo, ebuild scheduled for merge) conflicts with
    dev-lang/python:3.6[xml(+),sqlite] required by (app-portage/layman-2.4.2-r1:0/0::gentoo, installed)
                               ^^^^^^

app-crypt/gcr:0

  (app-crypt/gcr-3.28.1:0/1::gentoo, ebuild scheduled for merge) conflicts with
    >=app-crypt/gcr-3.14:0/1=[gtk] required by (gnome-extra/nm-applet-1.8.22:0/0::gentoo, installed)
                              ^^^
    >=app-crypt/gcr-3.27.90:=[gtk] required by (gnome-base/gnome-keyring-3.28.2:0/0::gentoo, ebuild scheduled for merge)
                              ^^^
    >=app-crypt/gcr-3.14:=[gtk] required by (gnome-extra/nm-applet-1.8.22:0/0::gentoo, installed)
                           ^^^
    >=app-crypt/gcr-3.4[gtk] required by (gnome-extra/evolution-data-server-3.30.5-r1:0/62::gentoo, installed)
                        ^^^

sys-apps/dbus:0

  (sys-apps/dbus-1.12.16:0/0::gentoo, ebuild scheduled for merge) conflicts with
    sys-apps/dbus[X] required by (gnome-base/gnome-session-3.30.1-r1:0/0::gentoo, installed)
                  ^
    sys-apps/dbus[X] required by (app-i18n/ibus-1.5.20:0/0::gentoo, installed)
                  ^

media-libs/harfbuzz:0

  (media-libs/harfbuzz-2.6.4:0/0.9.18::gentoo, ebuild scheduled for merge) conflicts with
    >=media-libs/harfbuzz-1.4.2:=[icu(+)] required by (net-libs/webkit-gtk-2.24.4:4/37::gentoo, installed)
                                         
    >=media-libs/harfbuzz-1.4.2:0/0.9.18=[icu(+)] required by (net-libs/webkit-gtk-2.24.4:4/37::gentoo, installed)
                                                 

x11-libs/gdk-pixbuf:2

  (x11-libs/gdk-pixbuf-2.38.1-r1:2/2::gentoo, ebuild scheduled for merge) conflicts with
    x11-libs/gdk-pixbuf:2[jpeg,introspection] required by (media-video/cheese-3.30.0:0/8::gentoo, installed)
                          ^^^^               
    x11-libs/gdk-pixbuf:2[X] required by (media-libs/libwmf-0.2.8.4-r7:0/0::gentoo, installed)
                          ^
    x11-libs/gdk-pixbuf[X] required by (x11-drivers/nvidia-drivers-440.31:0/440::gentoo, installed)
                        ^
    >=x11-libs/gdk-pixbuf-2.30:2[introspection,jpeg,tiff] required by (media-gfx/eom-1.22.0:0/0::gentoo, installed)
                                               ^^^^ ^^^^

media-libs/mesa:0

  (media-libs/mesa-19.1.8:0/0::gentoo, ebuild scheduled for merge) conflicts with
    >=media-libs/mesa-9.1.6[opencl,X(+),abi_x86_64(-)] required by (virtual/opencl-2:0/0::gentoo, installed)
                            ^^^^^^                   

app-text/poppler:0

  (app-text/poppler-0.79.0-r1:0/89::gentoo, ebuild scheduled for merge) conflicts with
    >=app-text/poppler-0.71.0[cairo] required by (media-libs/gegl-0.4.14:0.4/0.4::gentoo, installed)
                              ^^^^^
    >=app-text/poppler-0.44[cairo] required by (media-gfx/gimp-2.10.8-r1:2/2::gentoo, installed)
                            ^^^^^

x11-libs/pango:0

  (x11-libs/pango-1.42.4-r2:0/0::gentoo, ebuild scheduled for merge) conflicts with
    x11-libs/pango[X] required by (dev-python/wxpython-3.0.2.0:3.0/3.0::gentoo, installed)
                   ^
    x11-libs/pango[X] required by (x11-drivers/nvidia-drivers-440.31:0/440::gentoo, installed)
                   ^

media-libs/tiff:0

  (media-libs/tiff-4.1.0:0/0::gentoo, ebuild scheduled for merge) conflicts with
    media-libs/tiff:0/0=[jpeg,zlib] required by (dev-python/pillow-6.0.0:0/0::gentoo, installed)
                         ^^^^     
    media-libs/tiff:0=[jpeg,zlib] required by (dev-python/pillow-6.0.0:0/0::gentoo, installed)
                       ^^^^     

dev-libs/libpcre2:0

  (dev-libs/libpcre2-10.33-r1:0/0::gentoo, ebuild scheduled for merge) conflicts with
    dev-libs/libpcre2[pcre16,unicode] required by (dev-qt/qtcore-5.12.5-r1:5/5.12::gentoo, installed)
                      ^^^^^^         

x11-libs/libxcb:0

  (x11-libs/libxcb-1.13.1:0/1.12::gentoo, ebuild scheduled for merge) conflicts with
    >=x11-libs/libxcb-1.12:=[xkb] required by (dev-qt/qtgui-5.12.5:5/5.12::gentoo, installed)
                             ^^^
    >=x11-libs/libxcb-1.12:0/1.12=[xkb] required by (dev-qt/qtgui-5.12.5:5/5.12::gentoo, installed)
                                   ^^^
    >=x11-libs/libxcb-1.10:=[abi_x86_64(-),xkb] required by (x11-libs/libxkbcommon-0.9.1:0/0::gentoo, installed)
                                           ^^^
    >=x11-libs/libxcb-1.10:0/1.12=[abi_x86_64(-),xkb] required by (x11-libs/libxkbcommon-0.9.1:0/0::gentoo, installed)
                                                 ^^^


Would you like to merge these packages? [Yes/No]
>>> Verifying ebuild manifests
>>> Running pre-merge checks for acct-group/messagebus-0
>>> Running pre-merge checks for acct-group/lp-0
>>> Running pre-merge checks for acct-group/input-0
>>> Running pre-merge checks for acct-group/kvm-0
>>> Running pre-merge checks for acct-group/render-0
>>> Running pre-merge checks for acct-user/messagebus-0
>>> Running pre-merge checks for sys-devel/gcc-8.3.0-r1
>>> Running pre-merge checks for sys-apps/portage-2.3.76-r1
 * Determining the location of the kernel source code
 * Found kernel source directory:
 *     /usr/src/linux
 * Found sources for kernel version:
 *     5.3.11-gentoo
 * Checking for suitable kernel configuration options...                      [ ok ]
>>> Running pre-merge checks for sys-libs/glibc-2.29-r2
 * Checking general environment sanity.
make -j -l7 -s glibc-test
 * Checking that IA32 emulation is enabled in the running kernel ...          [ ok ]
 * Checking gcc for __thread support ...                                      [ ok ]
 * Checking running kernel version (5.3.8-gentoo >= 3.2.0) ...                [ ok ]
 * Checking linux-headers version (4.19.0 >= 3.2.0) ...                       [ ok ]
>>> Running pre-merge checks for sys-libs/pam-1.3.0-r2
>>> Running pre-merge checks for sys-fs/eudev-3.2.9
 *
 * As of 2013-01-29, eudev-3.2.9 provides the new interface renaming functionality,
 * as described in the URL below:
 * https://www.freedesktop.org/wiki/Software/systemd/PredictableNetworkInterfaceNames
 *
 * This functionality is enabled BY DEFAULT because eudev has no means of synchronizing
 * between the default or user-modified choice of sys-fs/udev.  If you wish to disable
 * this new iface naming, please be sure that /etc/udev/rules.d/80-net-name-slot.rules
 * exists: touch /etc/udev/rules.d/80-net-name-slot.rules
 *
>>> Running pre-merge checks for net-misc/openssh-8.0_p1-r4
>>> Running pre-merge checks for dev-lang/spidermonkey-60.5.2_p0-r2
 * Checking for at least 2 GiB disk space at "/tpool/rpool/var/tmp/portage/dev-lang/spidermonkey-60.5.2_p0-r2/temp" ...                                            [ ok ]
>>> Emerging (1 of 306) dev-lang/python-exec-2.4.6-r1::gentoo

_________________
_____________________
Aut semper aut numquam

Main-Sys: LianLi modded Big Cube 8000,X11DPG-QT,MEM:64G,LSI 9305,HDD:102TB(16x3T,8x6T,4x1T,1x0,5Tm.2,4x0,5TSSD),nVidia GTX1060,NIC:2x10GbSFP+,Fans:20,PSU:1200W+500W,UPS:APC1500VA,FibreChannel,Tandberg LTO-6
Back to top
View user's profile Send private message
pjp
Administrator
Administrator


Joined: 16 Apr 2002
Posts: 18434

PostPosted: Sun Nov 24, 2019 9:46 pm    Post subject: Reply with quote

Waterdevil wrote:
Info:
Code:

EMERGE_DEFAULT_OPTS="-j --load-average 7 --keep-going \
                     --quiet-build --quiet-fail -b --verbose-conflicts \
                     --autounmask-keep-masks \
                     --buildpkg --usepkg \
                     --usepkg-exclude 'sys-kernel/gentoo-sources virtual/*'"
man emerge wrote:
--usepkg option if you want to install a tbz2.


Waterdevil wrote:
Quote:
then I'd move any packages in PKGDIR aside so they are not used.

Really move "ALL" packages to a save directory?
The point is to make sure no packages are installed based on previously compiled binary pacakges. I'd just remove them myself, but having them temporarily may be useful. If the probem were to be solved, you could move the X / big stuff back and not recompile those, unless something else required it.

Waterdevil wrote:
x11-drivers/nvidia-drivers doesn't disappear.
Using --pretend is helpful to skip reinstalling. I forget which scenarios require video drivers to be reinstalled.

Waterdevil wrote:
Output without remove of all packages:
Code:
WARNING: One or more updates/rebuilds have been skipped due to a dependency conflict:
Avoiding some of those issues is part of the point to get a "cleaner" look at what is going on. I find it easier to work through when there are fewer needless errors to resolve.

Waterdevil wrote:
I edited my previous answer with successful single mode and unsuccessful login.

Waterdevil wrote:
Get login, type password - Login incorrect - nothing changed.
What I think this helps demonstrate is that the problem is at a low level. Before it wasn't clear (to me) if there was a problem with virtual terminals not functioning and another problem with the GUI login process. ssh using publickey to log in uses its own / different processes, so that was helpful. It seemed possible that something may have broken PAM related authentication. The files in pam.d seem like they should be generically fine (barring some sort of intentional user changes that could break authentication).

I beiieve single user login bypasses PAM, but I could be mistaken, or it may no longer be true. In my inittab, the "new-style" single user login is listed with "su1:S:wait:/sbin/sulogin". The man page for agetty indicates that /bin/login is called. On one of my systems, /bin/login is linked against PAM, but /sbin/sulogin (for single user mode) is not. That seems to suggest the problem is at a lower level than PAM:
Code:
$ ldd /sbin/sulogin
        linux-vdso.so.1 (0x00007ffe9670e000)
        libcrypt.so.1 => /lib64/libcrypt.so.1 (0x00007fe3561d6000)
        libc.so.6 => /lib64/libc.so.6 (0x00007fe355e0a000)
        /lib64/ld-linux-x86-64.so.2 (0x00007fe356621000)
$ ldd /bin/login
        linux-vdso.so.1 (0x00007fff2efe0000)
        libpam.so.0 => /lib64/libpam.so.0 (0x00007f28225bc000)
        libpam_misc.so.0 => /lib64/libpam_misc.so.0 (0x00007f28223b8000)
        libc.so.6 => /lib64/libc.so.6 (0x00007f2821fec000)
        libdl.so.2 => /lib64/libdl.so.2 (0x00007f2821de8000)
        /lib64/ld-linux-x86-64.so.2 (0x00007f28229d6000)


With the login screen present, we've at least established a working terminal (I may be remebering incorrectly, but I thought that wasn't working at some point). That would be notable if it stops working again,

Waterdevil wrote:
I've moved the packages and now @system is emerging...
Code:
>>> Emerging (1 of 306) dev-lang/python-exec-2.4.6-r1::gentoo
I would have tried to resolve the python / layman issue and then I would have tried to determine why it was trying to pull in a bunch of X / GUI related stuff. As long as the console continues to work, that probably doesn't matter, other than time.

If in fact /sbin/sulogin was being used and without PAM, then aside from a corrupted file, libraries are the only thing I can think of. Which I believe emerge -e @system should resolve.
_________________
The media sells it and you live the role.
Back to top
View user's profile Send private message
Waterdevil
Apprentice
Apprentice


Joined: 15 Aug 2017
Posts: 151
Location: LaniakeaHypercluster VirgoSupercluster MilkomedaGroup OrionArm Sector001 GouldBelt SolSystem Austria

PostPosted: Mon Nov 25, 2019 9:50 am    Post subject: Reply with quote

Code:
WARNING: One or more updates/rebuilds have been skipped due to a dependency conflict:
Very interesting. I thought the output of the emerge command with all packages not removed would be unnecessary ballast, but you saw, that this could have caused additional problems...

Code:
emerge -e @system

Finished without errors.

I tried to login with my kernel/config 5.3.8, but:
Get login, type password - Login incorrect - nothing changed.

I tried to login with my kernel/config 5.3.11 and - surprise - I get login - this is new, but:
Get login, type password - Login incorrect - nothing changed.

I copied the last known functional config to ensure, that the problems are not kernel-related:
Code:
cp /usr/src/kernel.config.bak/.config--2018-07-17--16-27-35.bak /usr/src/linux/.config
emerge -1 gentoo-sources-5.3.13
eselect kernel set linux-5.3.13-gentoo
cd /usr/src/linux
make olddefconfig
make -j41 modules_prepare
make -j41

There are a lot of "warning: this statement may fall through [-Werror=implicit-fallthrough=]"
and this warnings too:
-Waddress-of-packed-member
-Wmissing-attributes

Code:
make -j41 modules_install
make -j41 install
emerge @module-rebuild
emerge -1 zfs-kmod
genkernel --zfs --no-mrproper --no-clean initramfs
grub-mkconfig -o /boot/grub/grub.cfg

I don't know, why zfs-kmod is not remerged automatically...

Reboot
Get login, type password - Login incorrect - nothing changed.

Code:
dmesg --level=err,warn
[    0.188500] MDS CPU bug present and SMT on, data leak possible. See https://www.kernel.org/doc/html/latest/admin-guide/hw-vuln/mds.html for more details.
[    0.188500]  #5 #6 #7
[    0.258910] platform MSFT0101:00: failed to claim resource 1: [mem 0xfed40000-0xfed40fff]
[    0.258914] acpi MSFT0101:00: platform device creation failed: -16
[    8.299921] r8169 0000:04:00.0: can't disable ASPM; OS doesn't have ASPM control
[    8.323062] usb: port power management may be unreliable
[    8.387761] hdaudio hdaudioC0D0: Unable to bind the codec
[    8.388432] hdaudio hdaudioC0D2: Unable to bind the codec
[    9.295734] psmouse serio1: synaptics: The touchpad can support a better bus than the too old PS/2 protocol. Make sure MOUSE_PS2_SYNAPTICS_SMBUS and RMI4_SMB are enabled to get a better touchpad experience.
[    9.318644] usb 1-11: config 1 interface 1 altsetting 0 endpoint 0x3 has wMaxPacketSize 0, skipping
[    9.319538] usb 1-11: config 1 interface 1 altsetting 0 endpoint 0x83 has wMaxPacketSize 0, skipping
[   10.167441] spl: loading out-of-tree module taints kernel.
[   10.169389] znvpair: module license 'CDDL' taints kernel.
[   10.170132] Disabling lock debugging due to kernel taint
[   52.625046] wmi_bus wmi_bus-PNP0C14:00: WQ data block query control method not found
[   52.625050] wmi_bus wmi_bus-PNP0C14:00: WQ data block query control method not found
[   52.625054] wmi_bus wmi_bus-PNP0C14:00: WQ data block query control method not found
[   52.625057] wmi_bus wmi_bus-PNP0C14:00: WQ data block query control method not found
[   52.627942] acpi PNP0C14:02: duplicate WMI GUID 05901221-D566-11D1-B2F0-00A0C9062910 (first instance was on PNP0C14:01)
[   52.753547] [Firmware Bug]: ACPI(PEGP) defines _DOD but not _DOS
[   52.995994] NVRM: loading NVIDIA UNIX x86_64 Kernel Module  440.31  Sun Oct 27 02:19:35 UTC 2019
[   53.018159] ACPI Warning: \_SB.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20190703/nsarguments-66)


Code:
cat /var/log/messages
Nov 25 10:52:35 allengen syslog-ng[14695]: syslog-ng starting up; version='3.22.1'
Nov 25 10:52:35 allengen acpid[14725]: starting up with netlink and the input layer
Nov 25 10:52:35 allengen acpid[14725]: skipping incomplete file /etc/acpi/events/lm_lid
Nov 25 10:52:35 allengen acpid[14725]: 4 rules loaded
Nov 25 10:52:35 allengen acpid[14725]: waiting for events: event logging is off
Nov 25 10:52:35 allengen bluetoothd[14753]: Bluetooth daemon 5.51
Nov 25 10:52:35 allengen bluetoothd[14753]: Starting SDP server
Nov 25 10:52:35 allengen bluetoothd[14753]: kernel lacks bnep-protocol support
Nov 25 10:52:35 allengen bluetoothd[14753]: System does not support network plugin
Nov 25 10:52:35 allengen bluetoothd[14753]: Bluetooth management interface 1.14 initialized
Nov 25 10:52:35 allengen NetworkManager[14511]: <info>  [1574675555.9024] bluez: use BlueZ version 5
Nov 25 10:52:36 allengen NetworkManager[14511]: <info>  [1574675556.2907] keyfile: add connection /run/NetworkManager/system-connections/enp4s0.nmconnection (1a46e025-4816-4913-b6da-e743c24f9821,"enp4s0")
Nov 25 10:52:36 allengen NetworkManager[14511]: <info>  [1574675556.2913] device (enp4s0): state change: unavailable -> disconnected (reason 'connection-assumed', sys-iface-state: 'external')
Nov 25 10:52:36 allengen NetworkManager[14511]: <info>  [1574675556.2921] device (enp4s0): Activation: starting connection 'enp4s0' (1a46e025-4816-4913-b6da-e743c24f9821)
Nov 25 10:52:36 allengen NetworkManager[14511]: <info>  [1574675556.2922] device (enp4s0): state change: disconnected -> prepare (reason 'none', sys-iface-state: 'external')
Nov 25 10:52:36 allengen NetworkManager[14511]: <info>  [1574675556.2925] device (enp4s0): state change: prepare -> config (reason 'none', sys-iface-state: 'external')
Nov 25 10:52:36 allengen NetworkManager[14511]: <info>  [1574675556.2927] device (enp4s0): state change: config -> ip-config (reason 'none', sys-iface-state: 'external')
Nov 25 10:52:36 allengen NetworkManager[14511]: <info>  [1574675556.2930] device (enp4s0): state change: ip-config -> ip-check (reason 'none', sys-iface-state: 'external')
Nov 25 10:52:36 allengen NetworkManager[14511]: <info>  [1574675556.2934] device (enp4s0): state change: ip-check -> secondaries (reason 'none', sys-iface-state: 'external')
Nov 25 10:52:36 allengen NetworkManager[14511]: <info>  [1574675556.2936] device (enp4s0): state change: secondaries -> activated (reason 'none', sys-iface-state: 'external')
Nov 25 10:52:36 allengen NetworkManager[14511]: <info>  [1574675556.2938] manager: NetworkManager state is now CONNECTED_LOCAL
Nov 25 10:52:36 allengen NetworkManager[14511]: <info>  [1574675556.4453] device (enp4s0): Activation: successful, device activated.
Nov 25 10:52:36 allengen nm-dispatcher[14531]: req:3 'up' [enp4s0]: new request (1 scripts)
Nov 25 10:52:36 allengen nm-dispatcher[14531]: req:3 'up' [enp4s0]: start running ordered scripts...
Nov 25 10:52:36 allengen /etc/init.d/NetworkManager[15336]: status: inactive
Nov 25 10:52:36 allengen /etc/init.d/NetworkManager[15354]: status: inactive
Nov 25 10:52:38 allengen bluetoothd[14753]: Loading LTKs timed out for hci0
Nov 25 10:52:38 allengen NetworkManager[14511]: <info>  [1574675558.1497] keyfile: add connection /run/NetworkManager/system-connections/iPhone von andy-Netzwerk.nmconnection (c6ab4d8d-e076-49d6-9adf-b54d4ea33e35,"iPhone von andy-Netzwerk")
Nov 25 10:52:38 allengen NetworkManager[14511]: <info>  [1574675558.1505] bluez: BT device iPhone von andy (04:F1:3E:AB:30:F3) added (NAP)
Nov 25 10:52:38 allengen NetworkManager[14511]: <info>  [1574675558.1507] manager: (04:F1:3E:AB:30:F3): new Bluetooth device (/org/freedesktop/NetworkManager/Devices/4)
Nov 25 10:52:38 allengen NetworkManager[14511]: <info>  [1574675558.1510] device (04:F1:3E:AB:30:F3): state change: unmanaged -> unavailable (reason 'managed', sys-iface-state: 'external')
Nov 25 10:52:38 allengen NetworkManager[14511]: <info>  [1574675558.1524] keyfile: add connection /run/NetworkManager/system-connections/iPad von Andy-Netzwerk.nmconnection (b519c76d-a312-4dd9-b9a7-329964a3d0a9,"iPad von Andy-Netzwerk")
Nov 25 10:52:38 allengen NetworkManager[14511]: <info>  [1574675558.1532] bluez: BT device iPad von Andy (8C:FA:BA:85:D2:13) added (NAP)
Nov 25 10:52:38 allengen NetworkManager[14511]: <info>  [1574675558.1533] manager: (8C:FA:BA:85:D2:13): new Bluetooth device (/org/freedesktop/NetworkManager/Devices/5)
Nov 25 10:52:38 allengen NetworkManager[14511]: <info>  [1574675558.1536] device (8C:FA:BA:85:D2:13): state change: unmanaged -> unavailable (reason 'managed', sys-iface-state: 'external')
Nov 25 10:52:38 allengen NetworkManager[14511]: <info>  [1574675558.1548] device (04:F1:3E:AB:30:F3): state change: unavailable -> disconnected (reason 'none', sys-iface-state: 'managed')
Nov 25 10:52:38 allengen NetworkManager[14511]: <info>  [1574675558.1551] device (8C:FA:BA:85:D2:13): state change: unavailable -> disconnected (reason 'none', sys-iface-state: 'managed')
Nov 25 10:52:38 allengen NetworkManager[14511]: <info>  [1574675558.1555] manager: startup complete
Nov 25 10:52:44 allengen kernel: r8169 0000:04:00.0 enp4s0: Link is Up - 100Mbps/Full - flow control rx/tx
Nov 25 10:52:44 allengen kernel: IPv6: ADDRCONF(NETDEV_CHANGE): enp4s0: link becomes ready
Nov 25 10:52:44 allengen kernel[14622]: [   79.513594] r8169 0000:04:00.0 enp4s0: Link is Up - 100Mbps/Full - flow control rx/tx
Nov 25 10:52:44 allengen kernel[14622]: [   79.513608] IPv6: ADDRCONF(NETDEV_CHANGE): enp4s0: link becomes ready
Nov 25 10:52:44 allengen NetworkManager[14511]: <info>  [1574675564.2779] device (enp4s0): carrier: link connected
Nov 25 10:52:50 allengen NetworkManager[14511]: <info>  [1574675570.9445] manager: NetworkManager state is now CONNECTED_GLOBAL
Nov 25 10:52:50 allengen dbus-daemon[14029]: [system] Activating service name='org.freedesktop.nm_dispatcher' requested by ':1.1' (uid=0 pid=14511 comm="/usr/sbin/NetworkManager --pid-file /run/NetworkMa" label="kernel") (using servicehelper)
Nov 25 10:52:50 allengen dbus-daemon[14029]: [system] Successfully activated service 'org.freedesktop.nm_dispatcher'
Nov 25 10:52:50 allengen nm-dispatcher[15581]: req:1 'connectivity-change': new request (1 scripts)
Nov 25 10:52:50 allengen nm-dispatcher[15581]: req:1 'connectivity-change': start running ordered scripts...
Nov 25 10:52:57 allengen ntpdate[15321]: step time server 193.171.23.163 offset 0.050358 sec
Nov 25 10:52:57 allengen crond[15651]: (CRON) STARTUP (1.5.4)
Nov 25 10:52:57 allengen crond[15651]: (CRON) INFO (RANDOM_DELAY will be scaled with factor 0% if used.)
Nov 25 10:52:57 allengen crond[15651]: (CRON) INFO (running with inotify support)
Nov 25 10:52:58 allengen laptop-mode[15750]: enabled, not active
Nov 25 10:52:59 allengen dbus-daemon[14029]: [system] Activating service name='org.freedesktop.ColorManager' requested by ':1.10' (uid=0 pid=15683 comm="/usr/sbin/cupsd -f -c /etc/cups/cupsd.conf -s /etc" label="kernel") (using servicehelper)
Nov 25 10:52:59 allengen dbus-daemon[14029]: [system] Successfully activated service 'org.freedesktop.ColorManager'
Nov 25 10:53:00 allengen nmbd[17717]: [2019/11/25 10:53:00.050140,  0] ../lib/util/become_daemon.c:137(daemon_ready)
Nov 25 10:53:00 allengen nmbd[17717]:   daemon_ready: STATUS=daemon 'nmbd' finished starting up and ready to serve connections
Nov 25 10:53:00 allengen sshd[17750]: Server listening on 0.0.0.0 port 22.
Nov 25 10:53:00 allengen sshd[17750]: Server listening on :: port 22.
Nov 25 10:53:00 allengen smbd[17709]: [2019/11/25 10:53:00.103795,  0] ../lib/util/become_daemon.c:137(daemon_ready)
Nov 25 10:53:00 allengen smbd[17709]:   daemon_ready: STATUS=daemon 'smbd' finished starting up and ready to serve connections
Nov 25 10:53:01 allengen thermald[17800]: [WARN]22 CPUID levels; family:model:stepping 0x6:9e:9 (6:158:9)
Nov 25 10:53:01 allengen thermald[17800]: [WARN]Polling mode is enabled: 4
Nov 25 10:53:01 allengen thermald[17800]: [WARN]Thermal DTS: No coretemp sysfs found
Nov 25 10:53:01 allengen thermald[17800]: [WARN]sensor id 2 : No temp sysfs for reading raw temp
Nov 25 10:53:01 allengen thermald[17800]: [WARN]sensor id 2 : No temp sysfs for reading raw temp
Nov 25 10:53:01 allengen thermald[17800]: [WARN]sensor id 2 : No temp sysfs for reading raw temp
Nov 25 10:53:01 allengen thermald[17800]: [WARN]error: could not parse file /etc/thermald/thermal-conf.xml
Nov 25 10:53:01 allengen thermald[17800]: [WARN]sysfs open failed
Nov 25 10:53:01 allengen thermald[17800]: [WARN]error: could not parse file /etc/thermald/thermal-conf.xml
Nov 25 10:53:01 allengen thermald[17800]: [ERR]Thermal DTS or hwmon: No Zones present Need to configure manually
Nov 25 10:53:01 allengen thermald[17800]: [WARN]error: could not parse file /etc/thermald/thermal-conf.xml
Nov 25 10:53:01 allengen zed[17834]: ZFS Event Daemon 0.8.2-r1-gentoo (PID 17834)
Nov 25 10:53:01 allengen zed[17834]: Add Agent: init
Nov 25 10:53:01 allengen zed[17834]: Diagnosis Engine: register module
Nov 25 10:53:01 allengen zed[17834]: Retire Agent: register module
Nov 25 10:53:01 allengen zed[17834]: zfs_unavail_pool: examining 'lpool' (state 7)
Nov 25 10:53:01 allengen zed[17834]: zed_disk_event_init
Nov 25 10:53:01 allengen zed[17834]: Processing events since eid=0
Nov 25 10:53:01 allengen zed[17834]: Waiting for new udev disk events...
Nov 25 10:53:01 allengen zed[17834]: Invoking "all-syslog.sh" eid=1 pid=17841
Nov 25 10:53:01 allengen zed[17834]: zfs_unavail_pool: examining 'tpool' (state 7)
Nov 25 10:53:01 allengen zed[17847]: eid=1 class=history_event pool_guid=0x8E355C6D44193D20 
Nov 25 10:53:01 allengen zed[17834]: Finished "all-syslog.sh" eid=1 pid=17841 exit=0
Nov 25 10:53:01 allengen zed[17834]: Invoking "all-syslog.sh" eid=2 pid=17849
Nov 25 10:53:01 allengen zed[17853]: eid=2 class=config_sync pool_guid=0x8E355C6D44193D20 
Nov 25 10:53:01 allengen zed[17834]: Finished "all-syslog.sh" eid=2 pid=17849 exit=0
Nov 25 10:53:01 allengen zed[17834]: Invoking "all-syslog.sh" eid=3 pid=17856
Nov 25 10:53:01 allengen zed[17863]: eid=3 class=pool_import pool_guid=0x8E355C6D44193D20 
Nov 25 10:53:01 allengen zed[17834]: Finished "all-syslog.sh" eid=3 pid=17856 exit=0
Nov 25 10:53:01 allengen zed[17834]: Invoking "pool_import-led.sh" eid=3 pid=17875
Nov 25 10:53:01 allengen zed[17834]: Finished "pool_import-led.sh" eid=3 pid=17875 exit=1
Nov 25 10:53:01 allengen zed[17834]: Invoking "all-syslog.sh" eid=4 pid=17887
Nov 25 10:53:01 allengen zed[17888]: eid=4 class=history_event pool_guid=0x8E355C6D44193D20 
Nov 25 10:53:01 allengen zed[17834]: Finished "all-syslog.sh" eid=4 pid=17887 exit=0
Nov 25 10:53:01 allengen zed[17834]: Invoking "all-syslog.sh" eid=5 pid=17889
Nov 25 10:53:01 allengen zed[17890]: eid=5 class=config_sync pool_guid=0x8E355C6D44193D20 
Nov 25 10:53:01 allengen zed[17834]: Finished "all-syslog.sh" eid=5 pid=17889 exit=0
Nov 25 10:53:01 allengen zed[17834]: Invoking "all-syslog.sh" eid=6 pid=17895
Nov 25 10:53:01 allengen zed[17896]: eid=6 class=history_event pool_guid=0x22BC311C9F49AF18 
Nov 25 10:53:01 allengen zed[17834]: Finished "all-syslog.sh" eid=6 pid=17895 exit=0
Nov 25 10:53:01 allengen zed[17834]: Invoking "all-syslog.sh" eid=7 pid=17909
Nov 25 10:53:01 allengen zed[17917]: eid=7 class=config_sync pool_guid=0x22BC311C9F49AF18 
Nov 25 10:53:01 allengen zed[17834]: Finished "all-syslog.sh" eid=7 pid=17909 exit=0
Nov 25 10:53:01 allengen zed[17834]: Invoking "all-syslog.sh" eid=8 pid=17927
Nov 25 10:53:01 allengen zed[17935]: eid=8 class=pool_import pool_guid=0x22BC311C9F49AF18 
Nov 25 10:53:01 allengen zed[17834]: Finished "all-syslog.sh" eid=8 pid=17927 exit=0
Nov 25 10:53:01 allengen zed[17834]: Invoking "pool_import-led.sh" eid=8 pid=17936
Nov 25 10:53:01 allengen zed[17834]: Finished "pool_import-led.sh" eid=8 pid=17936 exit=1
Nov 25 10:53:01 allengen zed[17834]: Invoking "all-syslog.sh" eid=9 pid=17937
Nov 25 10:53:01 allengen zed[17938]: eid=9 class=history_event pool_guid=0x22BC311C9F49AF18 
Nov 25 10:53:01 allengen zed[17834]: Finished "all-syslog.sh" eid=9 pid=17937 exit=0
Nov 25 10:53:01 allengen zed[17834]: Invoking "all-syslog.sh" eid=10 pid=17939
Nov 25 10:53:01 allengen zed[17940]: eid=10 class=config_sync pool_guid=0x22BC311C9F49AF18 
Nov 25 10:53:01 allengen zed[17834]: Finished "all-syslog.sh" eid=10 pid=17939 exit=0
Nov 25 10:53:11 allengen login[17928]: FAILED LOGIN (1) on '/dev/tty1' FOR 'root', Authentication failure
Nov 25 10:53:19 allengen sshd[18166]: Accepted publickey for root from 192.168.0.21 port 43448 ssh2: RSA SHA256:2J4SwzMnW57fiJr9c4SM03Lv+/HBt6X4oQ0QivSWliQ
Nov 25 10:53:19 allengen sshd[18166]: pam_unix(sshd:session): session opened for user root by (uid=0)
Nov 25 10:53:19 allengen kernel: elogind-daemon[14059]: New session 2 of user root.
Nov 25 10:53:19 allengen kernel[14622]: <38>[  114.736870] elogind-daemon[14059]: New session 2 of user root.
Nov 25 10:53:19 allengen dbus-daemon[14029]: [system] Activating service name='org.freedesktop.ConsoleKit' requested by ':1.16' (uid=0 pid=18166 comm="sshd: root [priv]                                 " label="kernel") (using servicehelper)
Nov 25 10:53:19 allengen dbus-daemon[14029]: [system] Successfully activated service 'org.freedesktop.ConsoleKit'
Nov 25 10:53:23 allengen nmbd[17717]: [2019/11/25 10:53:23.366755,  0] ../source3/nmbd/nmbd_become_lmb.c:397(become_local_master_stage2)
Nov 25 10:53:23 allengen nmbd[17717]:   *****
Nov 25 10:53:23 allengen nmbd[17717]:   
Nov 25 10:53:23 allengen nmbd[17717]:   Samba name server ALLENGEN is now a local master browser for workgroup LCI.AT on subnet 192.168.0.31
Nov 25 10:53:23 allengen nmbd[17717]:   
Nov 25 10:53:23 allengen nmbd[17717]:   *****
Nov 25 10:54:14 allengen passwd[18398]: pam_unix(passwd:chauthtok): password changed for root
Nov 25 10:54:14 allengen passwd[18398]: gkr-pam: couldn't update the login keyring password: no old password was entered


ssh continues to work
I tried to change the password for root - i entered an easy one with message bad password, but changed.
Then I changed the password again with a strong:
Code:
Nov 25 11:00:46 allengen passwd[18782]: pam_unix(passwd:chauthtok): password changed for root
Nov 25 11:00:46 allengen passwd[18782]: gkr-pam: couldn't update the login keyring password: no old password was entered


I've seen, that a new stable pambase-version has appeared, so:
Code:
emerge -1u pambase

Reboot
Get login, type password - Login incorrect - nothing changed.
Code:
tail /var/log/messages
Nov 25 11:13:26 allengen passwd[10567]: pam_unix(passwd:chauthtok): password changed for andreas
Nov 25 11:13:26 allengen passwd[10567]: gkr-pam: couldn't update the login keyring password: no old password was entered
Nov 25 11:17:29 allengen passwd[10852]: pam_unix(passwd:chauthtok): password changed for root
Nov 25 11:17:29 allengen passwd[10852]: gkr-pam: couldn't update the login keyring password: no old password was entered

eix pambase
[I] sys-auth/pambase
     Verfügbare Versionen:   20190402^b{tbz2} {consolekit +cracklib debug elogind minimal mktemp +nullok pam_krb5 pam_ssh passwdqc securetty selinux +sha512 systemd}
     Installierte Versionen: 20190402^b{tbz2}(11:05:26 25.11.2019)(cracklib elogind nullok sha512 -consolekit -debug -minimal -mktemp -pam_krb5 -pam_ssh -passwdqc -securetty -selinux -systemd)
     Startseite:             https://github.com/gentoo/pambase
     Beschreibung:           PAM base configuration files


May I get rid of this horrible pam?
How can I delete all passwd-, group-, shadow-, pam-, authentication-related files and structures and renew them?

The bug https://bugs.gentoo.org/show_bug.cgi?id=671132 looks very similar to my problems, what I have when using gnome.
_________________
_____________________
Aut semper aut numquam

Main-Sys: LianLi modded Big Cube 8000,X11DPG-QT,MEM:64G,LSI 9305,HDD:102TB(16x3T,8x6T,4x1T,1x0,5Tm.2,4x0,5TSSD),nVidia GTX1060,NIC:2x10GbSFP+,Fans:20,PSU:1200W+500W,UPS:APC1500VA,FibreChannel,Tandberg LTO-6
Back to top
View user's profile Send private message
pjp
Administrator
Administrator


Joined: 16 Apr 2002
Posts: 18434

PostPosted: Mon Nov 25, 2019 10:38 pm    Post subject: Reply with quote

All of that X, Gnome and related stuff is why I remove it and all dependencies. As for the bug, that reinforces that approach. The system without that stuff should function. And at best, the X / GUI related stuff isn't the problem but can be noise.

Waterdevil wrote:
Code:
emerge -e @system

Finished without errors.

I tried to login with my kernel/config 5.3.8, but:
Get login, type password - Login incorrect - nothing changed.

I tried to login with my kernel/config 5.3.11 and - surprise - I get login - this is new, but:
Get login, type password - Login incorrect - nothing changed.
5.3.8 was used prior to the profile update? If you have it, I'd test with the version used prior to 5.3.8. Then I'd look to see what differences existed among them. Might not matter, but that different behavior happens is notable.

Waterdevil wrote:
I don't know, why zfs-kmod is not remerged automatically...
Are binary blob video drivers such as Nvidia's automatically reinstalled now? I haven't used them in a very long time, so I haen't kept up with how that functions. Maybe something similar with components such as zfs.

Waterdevil wrote:
May I get rid of this horrible pam?
How can I delete all passwd-, group-, shadow-, pam-, authentication-related files and structures and renew them?
If you're working from a live CD or some variation and not the system itself, then sure. Use equery to identify installed files owned by the package, uninstall, then see what files are left behind. As for going without PAM entirely, I'm not sure.
PAM and Gentoo wrote:
Although it is possible to run Gentoo systems without PAM (by setting USE="-pam"), but the default is to run with PAM support enabled.
There are probably some relevant threads on the forums, but i've not tried it (though it is tempting).

The bug references pambase-20150213-r2. I have that installed without problems. I'm not using ZFS, Gnome or a login manager (xdm, lightdm, etc.). Nor am I using elogin or udev (I do have eudev). None of that may be related.

So if I were going to continue to try and fix it, I'd try downgrading pambase. The version in question, -r2, references a bug that I read to be what resulted in -r1. So maybe older than 20150213 is required? Or not using lightdm and gnome-keyring (as a test).
Code:
$ diff pambase-20150213-r1.ebuild pambase-20150213-r2.ebuild
4c4
< EAPI=6
---
> EAPI=7
12,13c12,13
< KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 -x86-fbsd ~amd64-linux ~x86-linux"
< IUSE="consolekit +cracklib debug elogind gnome-keyring minimal mktemp +nullok pam_krb5 pam_ssh passwdqc securetty selinux +sha512 systemd"
---
> KEYWORDS="alpha amd64 arm arm64 ~hppa ia64 ~m68k ~mips ~ppc ppc64 s390 ~sh ~sparc x86 -x86-fbsd ~amd64-linux ~x86-linux"
> IUSE="consolekit +cracklib debug elogind minimal mktemp +nullok pam_krb5 pam_ssh passwdqc securetty selinux +sha512 systemd"
27d26
<       gnome-keyring? ( gnome-base/gnome-keyring[pam] )
46a46
>       "${FILESDIR}"/${P}-gnome-keyring.patch #652194
90d89
<               $(use_var GNOME_KEYRING gnome-keyring) \
After that, it would depend on what you do with the system. Can you take the time to work with the developer on the bug? Otherwise reinstalling seems appealing. Especially if you can install in different partitions and keep the old one around. Only install the absolute minium required to get a base system (no X, GUI etc., add them once login works. Then avoid lightdm and gnome-keyring. If the new system still works, then add lightdm and gnome-keyring.
_________________
The media sells it and you live the role.
Back to top
View user's profile Send private message
Waterdevil
Apprentice
Apprentice


Joined: 15 Aug 2017
Posts: 151
Location: LaniakeaHypercluster VirgoSupercluster MilkomedaGroup OrionArm Sector001 GouldBelt SolSystem Austria

PostPosted: Fri Nov 29, 2019 4:27 pm    Post subject: Reply with quote

So I see I have to install from stage3. Which files should I save to have all preferences?

My idea:
/boot
/etc
/home
/root
/var/lib/portage/world

Any more suggestions?

And which files from /etc I sholdn't play back after installation?

Thanks
_________________
_____________________
Aut semper aut numquam

Main-Sys: LianLi modded Big Cube 8000,X11DPG-QT,MEM:64G,LSI 9305,HDD:102TB(16x3T,8x6T,4x1T,1x0,5Tm.2,4x0,5TSSD),nVidia GTX1060,NIC:2x10GbSFP+,Fans:20,PSU:1200W+500W,UPS:APC1500VA,FibreChannel,Tandberg LTO-6
Back to top
View user's profile Send private message
pjp
Administrator
Administrator


Joined: 16 Apr 2002
Posts: 18434

PostPosted: Fri Nov 29, 2019 10:18 pm    Post subject: Reply with quote

If there is a list of files you know need to be restored, I'd use that. Then I'd probably use checksums to see what differed between the backup and new instlal. I would not automatically restore files, especially not knowing the cause of your current predicament.

distfiles would reduce the need to download a bunch of sources. Depending on your usage, /usr/local, /opt, other directories under /var.
_________________
The media sells it and you live the role.
Back to top
View user's profile Send private message
Waterdevil
Apprentice
Apprentice


Joined: 15 Aug 2017
Posts: 151
Location: LaniakeaHypercluster VirgoSupercluster MilkomedaGroup OrionArm Sector001 GouldBelt SolSystem Austria

PostPosted: Tue Dec 03, 2019 9:20 am    Post subject: Reply with quote

Hi,
Status:
I made a backup of my root-partition.
Then I erased it and began new from stage3.
I can boot the fresh system and login with root...

My question was about what to save/restore and not to work through the handbook to get all of the following:

Code:

booting like before (root on zfs with custom initramfs)                                        [ok]
timezone, localization as before                                                          [failure]
all services running like before                                                               [??]
all applications installed as before                                                      [working]
all preferences of gnome, kde, lxce (desktop, autostart, sizes, ...)                           [no]
all codecs in firefox, vlc, handbrake, kino, mplayer, smplayer working as before               [??]
all X configuration to have working with intel gpu and optimus prime nvidia for 3D            [yes]


I have to do additional tasks (restore ethereum mining, reinstall apps from git).
And maybe some things which I currently don't think of...

Sorry to write, that this case is not satisfying, because of unreliability of gentoo and this forum.

There is no knowledge database or handbook, where all cases of issues can be found. It's random luck if one finds here a solution. And duration till solved ist random too...

But I will stay with Gentoo, because I love it and all the people who try to help here.

Many thanks - it's not your fault and I know that you are great experts and spend much of your time here for answers - I was out of luck.
_________________
_____________________
Aut semper aut numquam

Main-Sys: LianLi modded Big Cube 8000,X11DPG-QT,MEM:64G,LSI 9305,HDD:102TB(16x3T,8x6T,4x1T,1x0,5Tm.2,4x0,5TSSD),nVidia GTX1060,NIC:2x10GbSFP+,Fans:20,PSU:1200W+500W,UPS:APC1500VA,FibreChannel,Tandberg LTO-6
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Goto page Previous  1, 2
Page 2 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum