Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Krita from 'bloody' overlay error (EAPI=6 is not supported)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
Chrjs
n00b
n00b


Joined: 27 Aug 2019
Posts: 16

PostPosted: Mon Nov 04, 2019 11:49 am    Post subject: Krita from 'bloody' overlay error (EAPI=6 is not supported) Reply with quote

I am trying to install the newest version of Krita (4.2.7.1) from their 'bloody' overlay, but I am getting errors when I do an emerge search for the krita package.

Here is the "emerge --info '=media-gfx/krita-4.2.7.1::bloody'" pastebin
Here is the "emerge -pqv '=media-gfx/krita-4.2.7.1::bloody'" pastebin

Not sure what to do about it.
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 7453
Location: Austria

PostPosted: Mon Nov 04, 2019 11:56 am    Post subject: Reply with quote

Why don't you use the krita version from Gentoo ebuild repo?
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
Chrjs
n00b
n00b


Joined: 27 Aug 2019
Posts: 16

PostPosted: Mon Nov 04, 2019 11:59 am    Post subject: Reply with quote

asturm wrote:
Why don't you use the krita version from Gentoo ebuild repo?


I saw that 4.2 had some performance optimizations over 4.1, and although I haven't used Krita in many months, I remember it being really slow back then.

Although I was still on Windows at that time. :D

But you're right. I guess I could just try the one from the official repo first.
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 7453
Location: Austria

PostPosted: Mon Nov 04, 2019 12:03 pm    Post subject: Reply with quote

But why the overlay? We have 4.2 in tree, and stable keywords the overlay version has neither.

Code:
$ eshowkw krita
Keywords for media-gfx/krita:
              |                               |   u   | 
              | a a   a     p           s r   |   n   | 
              | l m   r i   p   h m s   p i m | e u s | r
              | p d a m a p c x p 6 3   a s i | a s l | e
              | h 6 r 6 6 p 6 8 p 8 9 s r c p | p e o | p
              | a 4 m 4 4 c 4 6 a k 0 h c v s | i d t | o
--------------+-------------------------------+-------+-------
     4.1.8-r1 | o + o o o o o ~ o o o o o o o | 7 o 5 | gentoo
[I]4.2.7.1    | o ~ o o o o o ~ o o o o o o o | 7 o   | gentoo


Regarding bloody overlay issues: https://bugs.gentoo.org/698336
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
Chrjs
n00b
n00b


Joined: 27 Aug 2019
Posts: 16

PostPosted: Mon Nov 04, 2019 12:22 pm    Post subject: Reply with quote

:oops:

I'm real sorry. I forgot to look if there was something in the testing branch.
Had to install blender from overlay today, so my mind was already in that track.
Back to top
View user's profile Send private message
Ionen
Guru
Guru


Joined: 06 Dec 2018
Posts: 533

PostPosted: Mon Nov 04, 2019 12:24 pm    Post subject: Reply with quote

If curious for the actual cause, it was from this commit:
https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=6e81cf122526cf466ae853c041c8bc00e4d651d3
kde5 eclass doesn't support EAPI=6 anymore, so those ebuilds need updates. But yeah, enjoy gentoo's own up-to-date testing ebuilds.

Blender seems to be a nightmare to keep updated on the other end.
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 7453
Location: Austria

PostPosted: Mon Nov 04, 2019 12:30 pm    Post subject: Reply with quote

Chrjs wrote:
I'm real sorry.

No need to, I was just curious. ;)

But now I'm curious why the bloody overlay maintainer does not choose to simply contribute to kde overlay instead, we don't bite and it's much easier to stay on track with overall changes. ;)
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum