Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Paket installieren mit neuer Portage Version 2.3.79
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
alexander_ro
Apprentice
Apprentice


Joined: 22 Nov 2014
Posts: 207

PostPosted: Sun Dec 01, 2019 10:21 am    Post subject: Paket installieren mit neuer Portage Version 2.3.79 Reply with quote

Hi

ich versuche gerade von Letsencrypt den certbot zu installieren (ARM-System) das ging bisher immer ganz Problemlos. Mit einem "emerge --ask certbot". Der fragte dann ob man die Änderungen in die Konfigurationsdatei haben will. Dann hat man die Änderung aus der versteckten Datei in die echte Konfig kopiert und gut war es. Jetzt bekomme ich nur noch die Meldung das die Pakete alle Maskiert sind was auch richtig ist.

Code:

emerge --ask certbot

These are the packages that would be merged, in order:

Calculating dependencies... done!

!!! All ebuilds that could satisfy "certbot" have been masked.
!!! One of the following masked packages is required to complete your request:
- app-crypt/certbot-9999::gentoo (masked by: missing keyword)
- app-crypt/certbot-0.40.1::gentoo (masked by: ~arm keyword)
- app-crypt/certbot-0.39.0::gentoo (masked by: ~arm keyword)
- app-crypt/certbot-0.38.0::gentoo (masked by: ~arm keyword)

For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.


Der Versuch das zu entmaskieren bringt nur weitere Pakete die Maskiert sind.
Code:

cat /etc/portage/package.accept_keywords

# Letsencrypt Tool
=app-crypt/certbot-0.40.1 ~arm


Code:

emerge --ask app-crypt/certbot

 * IMPORTANT: 7 news items need reading for repository 'gentoo'.
 * Use eselect news read to view new items.


These are the packages that would be merged, in order:

Calculating dependencies... done!

!!! All ebuilds that could satisfy ">=app-crypt/acme-0.40.0[python_targets_python2_7(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,python_targets_python3_7(-)?,-python_single_target_python2_7(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-),-python_single_target_python3_7(-)]" have been masked.
!!! One of the following masked packages is required to complete your request:
- app-crypt/acme-9999::gentoo (masked by: missing keyword)
- app-crypt/acme-0.40.1::gentoo (masked by: ~arm keyword)

(dependency required by "app-crypt/certbot-0.40.1::gentoo" [ebuild])
(dependency required by "app-crypt/certbot" [argument])
For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.


Ein "emerge --ask --autounmask-write app-crypt/certbot" hat da auch nichts gebracht. Ich dachte das vielleicht mit der Option dann wieder die versteckte Beispiel Konfig generriert wird.

Muss man jetzt in der neuen Version wirklich manuell jede einzelne Abhängigkeit manuell in die Konfig eintragen damit man es installieren kann oder mach ich da was falsch?

Grüße
Alexander
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3809
Location: Germany

PostPosted: Sun Dec 01, 2019 3:40 pm    Post subject: Reply with quote

Hi,
die meisten Teile von autounmask sind nun nicht mehr per default enabled (und das ist auch gut so),
siehe zb im https://bugs.gentoo.org/658648

Gebe --autounmask=y mal im emerge Kommando mit an, dann sollte das freischalten vermutlich wie gewünscht funktionieren:
Code:
emerge -av =app-crypt/certbot-0.40.1 --autounmask=y
Back to top
View user's profile Send private message
alexander_ro
Apprentice
Apprentice


Joined: 22 Nov 2014
Posts: 207

PostPosted: Sun Dec 01, 2019 4:14 pm    Post subject: Reply with quote

Es war ja nicht wirklich ein autounmask. Es wurde einem nur netter weiße die dazu nötige Konfiguration in einer Datei zur Verfügung gestellt. Also ich finde das immer sehr praktisch.
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3809
Location: Germany

PostPosted: Sun Dec 01, 2019 4:39 pm    Post subject: Reply with quote

Ja sorry, aber die Funktion nennt sich nun mal autounmask :)
Woran scheitert es denn jetzt noch?
Back to top
View user's profile Send private message
alexander_ro
Apprentice
Apprentice


Joined: 22 Nov 2014
Posts: 207

PostPosted: Sun Dec 01, 2019 4:47 pm    Post subject: Reply with quote

Es scheiterte am lesen ... das brauchte mehr Zeit :)
Ich habe mich gerade noch durch den Bugreport gewühlt ist immer Mühsam wegen der Merkwürdigen Sprache ... ;)
Ich habe das halt nicht als auto... verstanden danke für die Info.
Toll das geht so wie Du geschrieben hast der Parameter mehr ist jetzt auch kein Problem ... danke ... :)

Nur weil ich immer Neugierig wozu braucht man denn --autounmask-write?
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3809
Location: Germany

PostPosted: Sun Dec 01, 2019 10:57 pm    Post subject: Reply with quote

alexander_ro wrote:
Nur weil ich immer Neugierig wozu braucht man denn --autounmask-write?

Hm, gute Frage,
laut `man emerge` ist --autounmask-write default enabled wenn man emerge mit --autounmask=y zusammen mit --ask verwendet, sprich das muss man dann nicht mehr zusätzlich mit angeben.

Ansonsten muss ich hier leider passen, hab --autounmask bisher kaum verwendet.
Back to top
View user's profile Send private message
alexander_ro
Apprentice
Apprentice


Joined: 22 Nov 2014
Posts: 207

PostPosted: Mon Dec 02, 2019 9:26 am    Post subject: Reply with quote

Was ich brauche geht ja nun wieder einfach zu lösen also kein Problem.

Ich brauche autounmask öfter mal. Entweder weil irgendwas noch nicht als stabile Version verfügbar ist oder weil es für die CPU Archtektur nicht vorhanden ist. Man sollte zwar immer nochmal schauen was der dann machen will aber meistens ist richtig was er vorschlägt.
Back to top
View user's profile Send private message
platinumviper
l33t
l33t


Joined: 12 Feb 2004
Posts: 629
Location: Munich, Germany

PostPosted: Wed Dec 18, 2019 11:21 am    Post subject: Reply with quote

Mir war das Verhalten der früheren Versionen auch lieber. Man kann das alte Verhalten mit der Zeile
Code:
EMERGE_DEFAULT_OPTS="--autounmask-keep-masks --autounmask"
in der make.conf wieder herstellen.
_________________
No money back garantee. In case of problems, don't call us, we call you.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum