Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Boot hangs up - Exec format error
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
gol70
n00b
n00b


Joined: 15 Oct 2014
Posts: 11

PostPosted: Sat Dec 07, 2019 6:49 pm    Post subject: Boot hangs up - Exec format error Reply with quote

I'm totally stuck on boot analysis - please help !
The last thing reported in dmesg is:
Code:

Dec 07 18:13:01 X1 kernel: sd 0:0:0:0: [sda] Attached SCSI removable disk
Dec 07 18:13:01 X1 kernel:  sdb: sdb1

at this lines boot stopped but for sure the problem is more early in process.
I also noticed:
Code:

Failed to execute /lib/systemd/system-generators/gentoo-local-generator: Exec format error

This is the clear stage 3 Systemd installation based on:
http://distfiles.gentoo.org/releases/amd64/autobuilds/current-stage3-amd64-systemd/

Full journalctl here: https://pastebin.com/nqGs1Y0S
Kernel config here (only options marked as M or Y): https://pastebin.com/Nj3yEJJh

The installation booting without problems as a systemd container (spawned from ArchLinux systemd based LiveCD) so the problem is for sure in kernel configuration.

I will be very grateful for any help.
_________________
best regards
Gregory
Back to top
View user's profile Send private message
fturco
Veteran
Veteran


Joined: 08 Dec 2010
Posts: 1038
Location: Italy

PostPosted: Sat Dec 07, 2019 7:04 pm    Post subject: Reply with quote

Try setting the CONFIG_IA32_EMULATION=y kernel option.
Back to top
View user's profile Send private message
Ionen
l33t
l33t


Joined: 06 Dec 2018
Posts: 691

PostPosted: Sat Dec 07, 2019 7:05 pm    Post subject: Reply with quote

I don't use systemd so I'm not sure what that file is, but I don't see a CONFIG_BINFMT_SCRIPT=y in those kernel config which is essential.
Edit: This is what let scripts files with "#!/path/..." work, can be found under Executable File Formats in kernel configs

Edit2: That aside, you probably want the above IA32_EMULATION as well (under Binary Emulation) unless you're 100% sure you have no 32bit applications (things like Wine32, many games, some emulators, some/old binary-only packages, etc... need this).
Back to top
View user's profile Send private message
jburns
Veteran
Veteran


Joined: 18 Jan 2007
Posts: 1079
Location: Massachusetts USA

PostPosted: Sun Dec 08, 2019 3:06 am    Post subject: Reply with quote

Code:
Dec 07 18:12:58 X1 systemd[68]: Failed to execute /lib/systemd/system-generators/gentoo-local-generator: Exec format error
Dec 07 18:12:58 X1 systemd[67]: /lib/systemd/system-generators/gentoo-local-generator failed with exit status 1.
Dec 07 18:12:58 X1 systemd[1]: local-fs.target: Found ordering cycle on var-tmp-portage.mount/start
Dec 07 18:12:58 X1 systemd[1]: local-fs.target: Found dependency on zram.service/start
Dec 07 18:12:58 X1 systemd[1]: local-fs.target: Found dependency on basic.target/start
Dec 07 18:12:58 X1 systemd[1]: local-fs.target: Found dependency on sockets.target/start
Dec 07 18:12:58 X1 systemd[1]: local-fs.target: Found dependency on dbus.socket/start
Try disabling zram services and see if error changes

The following will not cause a boot failure.
Code:
Dec 07 18:12:59 X1 mount[118]: mount: /boot: wrong fs type, bad option, bad superblock on /dev/nvme0n1p1, missing codepage or helper program, or other error.
Dec 07 18:12:59 X1 systemd[1]: boot.mount: Mount process exited, code=exited, status=32/n/a
Dec 07 18:12:59 X1 systemd[1]: boot.mount: Failed with result 'exit-code'.
Dec 07 18:12:59 X1 systemd[1]: Failed to mount efi partition.
Could be error if fstab.

Code:

Dec 07 18:12:59 X1 kernel: platform regulatory.0: Direct firmware load for regulatory.db failed with error -2
Dec 07 18:12:59 X1 kernel: cfg80211: failed to load regulatory.db
emerge wireless-regdb
Back to top
View user's profile Send private message
gol70
n00b
n00b


Joined: 15 Oct 2014
Posts: 11

PostPosted: Sat Jan 04, 2020 12:48 am    Post subject: Reply with quote

Sorry for late response.
CONFIG_BINFMT_SCRIPT=y
do the job!
_________________
best regards
Gregory
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum