Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
AMD Kaveri - which firmware?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
depontius
Advocate
Advocate


Joined: 05 May 2004
Posts: 3423

PostPosted: Sun Dec 22, 2019 3:40 pm    Post subject: AMD Kaveri - which firmware? Reply with quote

Way back when, when I first installed Gentoo on my Kaveri-based system, I added the firmware line to the kernel build per suggestions I've found somewhere. (source forgotten) It's always worked. Since then I've moved from "radeon" to "amdgpu" and things have kept working.

However in the past few days I had problems building the 5.4.5 kernel, which I traced to having upgraded to the 17.1 profile. The firmware path in my kernel config was "/lib64/firmware", which no longer exists. Changing it to "/lib/firmware" fixed it. In the meantime, I noted multiple copies of the Kaveri firmware, and they're not the same.
Code:
~ $ ls -l /lib/firmware/radeon/*_ce.bin | grep -i kaveri
-rw-r--r-- 1 root root 8832 Dec 20 16:30 /lib/firmware/radeon/kaveri_ce.bin
-rw-r--r-- 1 root root 8576 Dec 20 16:30 /lib/firmware/radeon/KAVERI_ce.bin
~ $ ls -l /lib/firmware/amdgpu/*_ce.bin | grep -i kaveri
-rw-r--r-- 1 root root   8832 Dec 20 16:30 /lib/firmware/amdgpu/kaveri_ce.bin
~ $ md5sum /lib/firmware/radeon/kaveri_ce.bin
0154fad3c4b7afe3eeb0ad7259c17767  /lib/firmware/radeon/kaveri_ce.bin
~ $ md5sum /lib/firmware/radeon/KAVERI_ce.bin
631b133b5a0a16d46531e47dd7f0c5f4  /lib/firmware/radeon/KAVERI_ce.bin
~ $ md5sum /lib/firmware/amdgpu/kaveri_ce.bin
fc4605bdebc5fa90f4f2b42ac173fa3d  /lib/firmware/amdgpu/kaveri_ce.bin
~ $

So I'm not sure which I should be using. At the moment I'm using "...../radeon/KAVERI_ce.bin", which dates back to installation day. However I'm now using amdgpu, so maybe I should be using "...../amdgpu/kaveri_ce.bin". I can always try it and see what happens, but it would be nice to find some explanation of what the heck is going on, here.
_________________
.sigs waste space and bandwidth
Back to top
View user's profile Send private message
Banana
Guru
Guru


Joined: 21 May 2004
Posts: 334
Location: Germany

PostPosted: Wed Dec 25, 2019 3:48 pm    Post subject: Reply with quote

Well, I would reinstall the firmware and have a look at https://wiki.gentoo.org/wiki/AMDGPU
Particular this here: https://wiki.gentoo.org/wiki/AMDGPU#Incorporating_firmware
_________________
My personal space
Back to top
View user's profile Send private message
Tony0945
Advocate
Advocate


Joined: 25 Jul 2006
Posts: 3546
Location: Illinois, USA

PostPosted: Wed Dec 25, 2019 4:09 pm    Post subject: Reply with quote

Over time capitalization has changed on some of these firmware packages. I was bitten by this on my standalone card.
Run "locate <fullpathname of firmware>" and "locate -t <shortfile name of firmware>" just to be sure you have capitalization right.
Back to top
View user's profile Send private message
depontius
Advocate
Advocate


Joined: 05 May 2004
Posts: 3423

PostPosted: Wed Dec 25, 2019 5:39 pm    Post subject: Reply with quote

Thank you for the pointer, and in the meantime I decided to just try the stuff in amdgpu and see. I could always go back to a previous kernel. Anyway, it's working, and I've done no benchmarking, and at the moment don't particularly care, as long as it is working. I have mandelbulber installed, and that's probably more where the rubber meets the road. I might have written down somewhere it's results with and without GPU, so can compare with that.
_________________
.sigs waste space and bandwidth
Back to top
View user's profile Send private message
Tony0945
Advocate
Advocate


Joined: 25 Jul 2006
Posts: 3546
Location: Illinois, USA

PostPosted: Wed Dec 25, 2019 10:10 pm    Post subject: Reply with quote

depontius wrote:
and at the moment don't particularly care, as long as it is working.

Merry Christmas!

And that should have be -i instead of -t in my post.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum