Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
NVIDIA GeForce 6600GT: black screen, cannot return to tty
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
vitaly-zdanevich
n00b
n00b


Joined: 01 Dec 2019
Posts: 29
Location: Belarus

PostPosted: Mon Dec 23, 2019 4:53 am    Post subject: NVIDIA GeForce 6600GT: black screen, cannot return to tty Reply with quote

Good day, my GPU is old GeForce 6600GT.

According to Nvidia website I found that the latest supported version is 304. As I understand I cannot mask it to so old version, so I downloaded official one, extracted, patched against error during install, installed, to `/etc/X11/xorg.conf` added:
Code:
Section "ServerFlags"
    Option "IgnoreABI" "1"
EndSection

because
Quote:
[ 37.151] ================ WARNING WARNING WARNING WARNING ================
[ 37.151] This server has a video driver ABI version of 15.0 that is not
supported by this NVIDIA driver. Please check
http://www.nvidia.com/ for driver updates or downgrade to an X
server with a supported driver ABI.
[ 37.151] =================================================================
[ 37.151] (EE) NVIDIA: Use the -ignoreABI option to override this check.


`startx`: and I see black nothing on my two screens.

I tried this on kernel without nouveau.

Motherboard is GA-MA785GM-US2H

I want official drivers for less noise (I remember almost silent RPM), to play Portal, maybe faster Google Maps.

Please, help. I can share some other system information if you want.
Back to top
View user's profile Send private message
Ionen
l33t
l33t


Joined: 06 Dec 2018
Posts: 691

PostPosted: Mon Dec 23, 2019 6:32 am    Post subject: Reply with quote

As far as I know It's simply not compatible with modern Xorg anymore, nvidia updated their drivers to work with xorg 1.20.x starting 340+ but 304 didn't get that service and appears abandoned.

Looking at Debian it seems to install an older xorg version (1.19.xx it looks like) to make 304 work. But older xorg will also break other things and makes it hard to maintain (which is why 304 has been removed from "most" distros including gentoo unfortunately). You could try to downgrade (older xorg isn't in ::gentoo repos either), but it'll likely be a pain.

That aside, for the noise, it maaaay be possible to manipulate nouveau to either run at lower performance levels and/or control fan manually (at your own risks), it does seem to support few things for nv40/curie but all those "mostly" are a bit unclear. I'm not knowledgeable enough about nouveau to advise you on this anyhow (I've used it before but my own card was always forced in low power mode, couldn't be reclocked, and way too weak to be usable for a lot of things -- not that I use this card anymore).

Edit: If you _really_ want to use official drivers, it'll be simpler to use a distro that actually supports it (may be other required fixes/patches I'm not aware of), although hard to say when they'll suddenly decide to drop it (security reasons often come into play). Shame nvidia didn't update 304 given xorg development is pretty slow and we'll likely be on the 1.20.x series for a long time.
Back to top
View user's profile Send private message
vitaly-zdanevich
n00b
n00b


Joined: 01 Dec 2019
Posts: 29
Location: Belarus

PostPosted: Mon Dec 23, 2019 1:58 pm    Post subject: Reply with quote

@Ionen, thank you for detailed answer.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum