Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[solved] No sound with HDMI (Intel)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
embeddedmz
n00b
n00b


Joined: 04 Jan 2020
Posts: 8
Location: Pau, France

PostPosted: Sat Jan 04, 2020 9:15 pm    Post subject: [solved] No sound with HDMI (Intel) Reply with quote

Hi,

There's no sound output to HDMI (when I switch the output in KDE).

I recompiled the kernel with all ALSA modules/codecs

aplay --list-devices shows the HDMI device :

Code:
$ aplay --list-devices
**** Liste des P�riph�riques Mat�riels PLAYBACK ****
carte 0: PCH [HDA Intel PCH], p�riph�rique 0: ALC269VC Analog [ALC269VC Analog]
  Sous-p�riph�riques: 1/1
  Sous-p�riph�rique #0: subdevice #0
carte 0: PCH [HDA Intel PCH], p�riph�rique 3: Generic Digital [Generic Digital]
  Sous-p�riph�riques: 1/1
  Sous-p�riph�rique #0: subdevice #0


but /proc/asound/cards doesn't ?

Code:
$ cat /proc/asound/cards
 0 [PCH            ]: HDA-Intel - HDA Intel PCH
                      HDA Intel PCH at 0xf0600000 irq 27


Code:
$ lspci   
00:00.0 Host bridge: Intel Corporation 2nd Generation Core Processor Family DRAM Controller (rev 09)
00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)
00:16.0 Communication controller: Intel Corporation 7 Series/C216 Chipset Family MEI Controller #1 (rev 04)
00:1a.0 USB controller: Intel Corporation 7 Series/C216 Chipset Family USB Enhanced Host Controller #2 (rev 04)
00:1b.0 Audio device: Intel Corporation 7 Series/C216 Chipset Family High Definition Audio Controller (rev 04)
00:1c.0 PCI bridge: Intel Corporation 7 Series/C216 Chipset Family PCI Express Root Port 1 (rev c4)
00:1c.3 PCI bridge: Intel Corporation 7 Series/C216 Chipset Family PCI Express Root Port 4 (rev c4)
00:1d.0 USB controller: Intel Corporation 7 Series/C216 Chipset Family USB Enhanced Host Controller #1 (rev 04)
00:1f.0 ISA bridge: Intel Corporation HM70 Express Chipset LPC Controller (rev 04)
00:1f.2 SATA controller: Intel Corporation 7 Series Chipset Family 6-port SATA Controller [AHCI mode] (rev 04)
00:1f.3 SMBus: Intel Corporation 7 Series/C216 Chipset Family SMBus Controller (rev 04)
01:00.0 Network controller: Qualcomm Atheros AR9485 Wireless Network Adapter (rev 01)
02:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 06)


Thank you.

[Moderator edit: changed [quote] tags to [code] tags to preserve output layout. -Hu]


Last edited by embeddedmz on Sun Jan 05, 2020 1:07 am; edited 1 time in total
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 44945
Location: 56N 3W

PostPosted: Sat Jan 04, 2020 10:40 pm    Post subject: Reply with quote

embeddedmz,

Welcome to Gentoo.

My French isn't really ou to reading your messages.

However, Alsa uses card 0 device 0 by default.
It looks like you want to use card 0 device 3.
Code:
carte 0: PCH [HDA Intel PCH], p�riph�rique 3: Generic Digital [Generic Digital]


Do you have CONFIG_SND_HDA_CODEC_HDMI in your kernel?

The content of /proc/asound/devices is useful.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
embeddedmz
n00b
n00b


Joined: 04 Jan 2020
Posts: 8
Location: Pau, France

PostPosted: Sun Jan 05, 2020 12:49 am    Post subject: Reply with quote

Thank you.

Quote:
Do you have CONFIG_SND_HDA_CODEC_HDMI in your kernel?

Yes (my .config file https://pastebin.com/7fHrRnUP)

UPDATE : I forgot to "make install" the kernel :( So there's no problem ! (I was looking at the .config in in /usr/src/linux/ and not the one under /boot)

Code:
$ cat /proc/asound/devices
  0: [ 0]   : control
  1:        : sequencer
  4: [ 0- 0]: hardware dependent
  7: [ 0- 3]: hardware dependent
 16: [ 0- 0]: digital audio playback
 19: [ 0- 3]: digital audio playback
 24: [ 0- 0]: digital audio capture
 33:        : timer


I'm using KDE stuff to switch sound output from laptop speakers to the TV, but it isn't working for HDMI (no sound when testing).
Back to top
View user's profile Send private message
Hu
Moderator
Moderator


Joined: 06 Mar 2007
Posts: 14971

PostPosted: Sun Jan 05, 2020 1:37 am    Post subject: Reply with quote

embeddedmz wrote:
UPDATE : I forgot to "make install" the kernel :( So there's no problem !
For what it is worth, you are not alone. I have lost count of the number of users who followed a similar pattern: report problem, try a fix, report the fix does not work, come back later and report that the wrong kernel was used, so the retry was an invalid test.
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 44945
Location: 56N 3W

PostPosted: Sun Jan 05, 2020 10:46 am    Post subject: Reply with quote

embeddedmz,

After a kernel update, run uname -a
Code:
$ uname -a
Linux NeddySeagoon_Static 5.4.1-gentoo #1 SMP PREEMPT Mon Dec 2 19:28:45 GMT 2019 x86_64 AMD Phenom(tm) II X6 1090T Processor AuthenticAMD GNU/Linux


The date and time (Mon Dec 2 19:28:45 GMT 2019) is the build time of the running kernel. If you have just rebooted into a new kernel, the date/time should be very recent.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
embeddedmz
n00b
n00b


Joined: 04 Jan 2020
Posts: 8
Location: Pau, France

PostPosted: Sun Jan 05, 2020 3:27 pm    Post subject: Reply with quote

Thank you NeddySeagoon, I'll think about it next time.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum