Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Booting fails on loading kernel
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
V5r29JrRjC576nAY5jQi
n00b
n00b


Joined: 06 Jan 2020
Posts: 19

PostPosted: Mon Jan 06, 2020 12:35 pm    Post subject: Booting fails on loading kernel Reply with quote

Hello, I for the first time installing Gentoo on efi compatible motherboard and felt in trouble.
I have 2 partitions: one for efi and other for /boot. When I was installing grub I mentioned that efi dir is /boot/efi. And finally I have custom initamfs (which I embed into kernel (as I think)). Root partition is encrypted.

When I boot, I pick efi partition and it is just blinked for a moment and returned me back to the boot media selection menu. Then I pick partition that carry grub, and It is stuck on loading Linux <version> message.

Pretty obviously that I did something wrong with grub or efi installation. Please help me. :D

P.S. feel free to asking me any cmd output.
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 45451
Location: 56N 3W

PostPosted: Mon Jan 06, 2020 12:45 pm    Post subject: Reply with quote

V5r29JrRjC576nAY5jQi,

Welcome to Gentoo.

There is nothing like jumping in at the deep end with an encryted root on your first install.
Getting debug information will be tricky.

The initrd is key to booting with an encrypted root but the kernel should have generated console output before it panicked.

Check that your kernel has both EFI Framebuffer and Simple Framebuffer support set to yes.
The kernel will use one of them for your console.

You could use genkernel to build a working kernel. That would avoid this issue for the time being and build your own kernel knowing that you have a working kernel to boot into when your own kernel won't boot.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
V5r29JrRjC576nAY5jQi
n00b
n00b


Joined: 06 Jan 2020
Posts: 19

PostPosted: Mon Jan 06, 2020 2:51 pm    Post subject: Reply with quote

NeddySeagoon wrote:
V5r29JrRjC576nAY5jQi,

Welcome to Gentoo.

There is nothing like jumping in at the deep end with an encryted root on your first install.
Getting debug information will be tricky.

The initrd is key to booting with an encrypted root but the kernel should have generated console output before it panicked.

Check that your kernel has both EFI Framebuffer and Simple Framebuffer support set to yes.
The kernel will use one of them for your console.

You could use genkernel to build a working kernel. That would avoid this issue for the time being and build your own kernel knowing that you have a working kernel to boot into when your own kernel won't boot.


Actually it is not my first install with encrypted root. It is my first EFI install, custom initramfs

EFI Framebuffer and Simple Framebuffer. Can you mention concrete kernel options?
I checked options from Sakaki's EFI guide

genkernel is useless because it still need some tune to actually boot my system.

After I
Code:
cp /boot/efi/efi/gentoo/grubx64.efi /boot/efi/efi/boot/bootx64.efi

Efi seems to work fine. (passes me to grub prompt).
But I still stucked with message "Loading linux 4.19.86-gentoo ..."
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 45451
Location: 56N 3W

PostPosted: Mon Jan 06, 2020 4:28 pm    Post subject: Reply with quote

V5r29JrRjC576nAY5jQi,

The kernel symbol name for Simple Framebuffer is CONFIG_FB_SIMPLE.
As I don't have an EFI capable system the EFI framebuffer is hidden for me.

In menuconfig, press /
Enter FB_SIMPLE (lowercase works too)
The search resuls have a single didgit to the left. Prees that key to go to the option.

Simple Framebuffer is at the bottom of the Framebuffer menu.
EFI is near the top, unless you have kernel EFI support disabled.
Press z to toggle the display of hidden options.

I suspect that the kernel is starting, just not drawing on the console.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
V5r29JrRjC576nAY5jQi
n00b
n00b


Joined: 06 Jan 2020
Posts: 19

PostPosted: Mon Jan 06, 2020 6:25 pm    Post subject: Reply with quote

NeddySeagoon wrote:
V5r29JrRjC576nAY5jQi,

The kernel symbol name for Simple Framebuffer is CONFIG_FB_SIMPLE.
As I don't have an EFI capable system the EFI framebuffer is hidden for me.

In menuconfig, press /
Enter FB_SIMPLE (lowercase works too)
The search resuls have a single didgit to the left. Prees that key to go to the option.

Simple Framebuffer is at the bottom of the Framebuffer menu.
EFI is near the top, unless you have kernel EFI support disabled.
Press z to toggle the display of hidden options.

I suspect that the kernel is starting, just not drawing on the console.


FB was turned off but turning it on didt help me. Still same message.
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 45451
Location: 56N 3W

PostPosted: Mon Jan 06, 2020 7:02 pm    Post subject: Reply with quote

V5r29JrRjC576nAY5jQi,

What about EFI framebuffer?
Are you sure its your new kernel being loaded?

Make friends with wgetpaste and put your entire kernel.config onto a pastebin site - post the link.
Post your
Code:
lspci -nnk

Describe how your block devices are connected. NVME, SATA, real SCSI, PATA ... Shugart ST506/ST412 whatever.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
V5r29JrRjC576nAY5jQi
n00b
n00b


Joined: 06 Jan 2020
Posts: 19

PostPosted: Tue Jan 07, 2020 10:25 am    Post subject: Reply with quote

NeddySeagoon wrote:
V5r29JrRjC576nAY5jQi,

What about EFI framebuffer?
Are you sure its your new kernel being loaded?

Make friends with wgetpaste and put your entire kernel.config onto a pastebin site - post the link.
Post your
Code:
lspci -nnk

Describe how your block devices are connected. NVME, SATA, real SCSI, PATA ... Shugart ST506/ST412 whatever.



EFI buffer is on.
Yes, I "make && make install" just before checking and grub-mkconfig -o.
Strange, but menuconfig runs in x86 instead of x86_64, so I additionally specified ARCH to ensure that all will be OK.
/boot and /boot/efi partiotions are located on usb-stick. I use SATA. :D

lspci -nnk output here: https://pastebin.com/A0nDuw2v
kernel config: https://pastebin.com/08gYnYCF
Hope it will be helpful.
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 45451
Location: 56N 3W

PostPosted: Tue Jan 07, 2020 11:31 am    Post subject: Reply with quote

V5r29JrRjC576nAY5jQi,

If you want to use an NVME block device, fix
Code:
# CONFIG_BLK_DEV_NVME is not set

Grub will read it and load the kernel but the kernel won't see it.

As you have a
Code:
0a:00.0 VGA compatible controller [0300]: NVIDIA Corporation TU104 [GeForce RTX 2070 SUPER] [10de:1e84] (rev a1)
   Subsystem: NVIDIA Corporation TU104 [GeForce RTX 2070 SUPER] [10de:1e84]
nVidia GPU, how you get a framebuffer console depends on the grapics driver you want to use in Xorg. The evil binary blob requires that its the only thing trying to configure the hardware and it does not prove a console at all.
That leaves you with Simple or EFI or without a framebuffer console at all.

If you turn off CONFIG_FRAMEBUFFER_CONSOLE, you should get the old 80x25 text mode display.

If you don't want to use nvidia-drivers, in Xorg, get the testing gentoo-sources and turn on CONFIG_DRM_NOUVEAU.
Your current 4.19.86-gentoo is too old for the nouveau driver to support your GeForce RTX 2070 SUPER GPU.

The kernel detects your arch correctly. The 32 bit and 64 bit kernel source trees were merged several years ago. You flip between them with the
Code:
[*] 64-bit kernel
setting.

We are still trying to get a console for diagnostics. Right now, as long as it works, any console will do.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
V5r29JrRjC576nAY5jQi
n00b
n00b


Joined: 06 Jan 2020
Posts: 19

PostPosted: Tue Jan 07, 2020 12:45 pm    Post subject: Reply with quote

NeddySeagoon wrote:
V5r29JrRjC576nAY5jQi,

If you want to use an NVME block device, fix
Code:
# CONFIG_BLK_DEV_NVME is not set

Grub will read it and load the kernel but the kernel won't see it.

As you have a
Code:
0a:00.0 VGA compatible controller [0300]: NVIDIA Corporation TU104 [GeForce RTX 2070 SUPER] [10de:1e84] (rev a1)
   Subsystem: NVIDIA Corporation TU104 [GeForce RTX 2070 SUPER] [10de:1e84]
nVidia GPU, how you get a framebuffer console depends on the grapics driver you want to use in Xorg. The evil binary blob requires that its the only thing trying to configure the hardware and it does not prove a console at all.
That leaves you with Simple or EFI or without a framebuffer console at all.

If you turn off CONFIG_FRAMEBUFFER_CONSOLE, you should get the old 80x25 text mode display.

If you don't want to use nvidia-drivers, in Xorg, get the testing gentoo-sources and turn on CONFIG_DRM_NOUVEAU.
Your current 4.19.86-gentoo is too old for the nouveau driver to support your GeForce RTX 2070 SUPER GPU.

The kernel detects your arch correctly. The 32 bit and 64 bit kernel source trees were merged several years ago. You flip between them with the
Code:
[*] 64-bit kernel
setting.

We are still trying to get a console for diagnostics. Right now, as long as it works, any console will do.


Turned CONFIG_BLK_DEV_NVME on.
Turned CONFIG_FRAMEBUFFER_CONSOLE off.

Still the same message of loading kernel.
Back to top
View user's profile Send private message
V5r29JrRjC576nAY5jQi
n00b
n00b


Joined: 06 Jan 2020
Posts: 19

PostPosted: Tue Jan 07, 2020 5:20 pm    Post subject: Reply with quote

Finally got it to work. Thank you.

Now kernel panics. Seems like init script failure.
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 45451
Location: 56N 3W

PostPosted: Tue Jan 07, 2020 8:52 pm    Post subject: Reply with quote

V5r29JrRjC576nAY5jQi,

That's a start. What is the panic message. Not all the numbers, just the text?
Put an image of a free image site if you like.

The initrd should drop you to a busybox shell, so you can poke about to see what you have.
You can also run the init script a command at time, using copy/paste.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum