Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[gelöst] lua block?
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
uhai
Veteran
Veteran


Joined: 23 Aug 2007
Posts: 1231
Location: Eppingen, Germany

PostPosted: Tue Jan 14, 2020 8:00 pm    Post subject: [gelöst] lua block? Reply with quote

Hallo zusammen,

ich habe einen jetzt einen Block durch lua... soweit ich das recherchiert habe kann ich den nicht auflösen ohne einen der Auslöser zu deinstallieren, oder?

Code:
* Error: The above package list contains packages which cannot be
* installed at the same time on the same system.
''
(dev-lang/lua-5.1.5-r4:0/0::gentoo, ebuild scheduled for merge) pulled in by
>=dev-lang/lua-5.1:0= required by (media-video/vlc-3.0.8:0/5-9::gentoo, ebuild scheduled for merge)
''
(dev-lang/lua-5.3.5-r1:5.3/5.3::gentoo, installed) pulled in by
dev-lang/lua:= required by (app-text/podofo-0.9.6_p20180715:0/0.9.6::gentoo, installed)
dev-lang/lua:5.3/5.3= required by (app-text/podofo-0.9.6_p20180715:0/0.9.6::gentoo, installed)
dev-lang/lua required by (games-strategy/widelands-0.20_rc1:0/0::mein-repo, installed)


uhai
_________________
Asus 4A785TD-M EVO mit AMD Phenom(tm) II X4 945
Dell Mini 10v
http://www.openstreetmap.org


Last edited by uhai on Sun Jan 19, 2020 2:06 pm; edited 1 time in total
Back to top
View user's profile Send private message
mike155
Advocate
Advocate


Joined: 17 Sep 2010
Posts: 2126
Location: Frankfurt, Germany

PostPosted: Tue Jan 14, 2020 9:10 pm    Post subject: Reply with quote

Bei mir kommen vlc und podofo prima mit Lua 5.1 zurecht.

Aber bei mir ist auch kein Lua 5.3 installiert. Lua 5.3 ist... "masked by package.mask" und "masked by ~keyword". Warum ist das bei Dir installiert?
Back to top
View user's profile Send private message
franzf
Advocate
Advocate


Joined: 29 Mar 2005
Posts: 4507

PostPosted: Wed Jan 15, 2020 8:43 am    Post subject: Reply with quote

lua ist leider kaum supported unter Gentoo. Es gibt im lua-overlay (das du in deinem letzten thread deaktiviert hast, AFAIR) Versuche das geslotted hinzubekommen.
Ein Versuch die eclass nach ::gentoo zu bekommen scheiterte, scheint manchen (einem?) Entwickler nicht zu gefallen. Seitdem ist Ruhe.
Man könnte ja nach :0 ein paar aktuellere Versionen packen, aber hey, ein paar Sachen wollen immer noch lua-5.1...
Mittlerweile ist 5.4 am Horizont.

podofo verlangt "dev-lang/lua:=" was heißt "alles ist OK, aber bitte rebuilds wenn sich der SLOT ändert.
Ich sehe nicht, was Probleme bereiten sollte. emerge -1 lua:0 widelands podofo sollte eigentlich alles ins Reine bringen.
Back to top
View user's profile Send private message
uhai
Veteran
Veteran


Joined: 23 Aug 2007
Posts: 1231
Location: Eppingen, Germany

PostPosted: Wed Jan 15, 2020 7:28 pm    Post subject: Reply with quote

Hallo franzf,

das klappt leider nicht:

Code:
emerge -1a lua:0 widelands podofo

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  NS    ] dev-lang/lua-5.1.5-r4 [5.3.5-r1]
[ebuild   R    ] app-text/podofo-0.9.6_p20180715
[ebuild   R   ~] games-strategy/widelands-0.20_rc1
[blocks B      ] dev-lang/lua:0 ("dev-lang/lua:0" is hard blocking app-eselect/eselect-lua-2)
[blocks B      ] dev-lang/lua:0 ("dev-lang/lua:0" is blocking dev-lang/lua-5.3.5-r1)
''
 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.
''
(dev-lang/lua-5.1.5-r4:0/0::gentoo, ebuild scheduled for merge) pulled in by
lua:0
''
(dev-lang/lua-5.3.5-r1:5.3/5.3::gentoo, installed) pulled in by
dev-lang/lua required by (games-strategy/widelands-0.20_rc1:0/0::mein-repo, ebuild scheduled for merge)
dev-lang/lua:= required by (app-text/podofo-0.9.6_p20180715:0/0.9.6::gentoo, ebuild scheduled for merge)


uhai
_________________
Asus 4A785TD-M EVO mit AMD Phenom(tm) II X4 945
Dell Mini 10v
http://www.openstreetmap.org
Back to top
View user's profile Send private message
franzf
Advocate
Advocate


Joined: 29 Mar 2005
Posts: 4507

PostPosted: Thu Jan 16, 2020 4:37 am    Post subject: Reply with quote

Dann vorher ein emerge -C lua:5.3 eselect-lua
:0 und die Versions-Slots schließen sich aus. Und unsinnigerweise verlangt vieles in Gentoo einfach lua:0, was dich auf die 2012er lua-5.1 einschränkt.
Und das fängt jetzt (endlich!) auch an zu haken, darktable braucht lua >=5.2: https://bugs.gentoo.org/671248#c6
Back to top
View user's profile Send private message
uhai
Veteran
Veteran


Joined: 23 Aug 2007
Posts: 1231
Location: Eppingen, Germany

PostPosted: Thu Jan 16, 2020 7:00 pm    Post subject: Reply with quote

Aber damit lege ich mein darktable nicht lahm, oder? Sonst lasse ich das....

uhai

Funktioniert auch nicht....:
Code:
[blocks B      ] dev-lang/lua:0 ("dev-lang/lua:0" is blocking dev-lang/lua-5.3.5-r1)
[blocks B      ] dev-lang/lua:0 ("dev-lang/lua:0" is hard blocking app-eselect/eselect-lua-2)

Total: 31 packages (20 upgrades, 5 new, 6 reinstalls), Size of downloads: 766.115 KiB
Conflict: 2 blocks (2 unsatisfied)
''
!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:
''
dev-libs/boost:0
''
(dev-libs/boost-1.72.0:0/1.72.0::gentoo, ebuild scheduled for merge) pulled in by
(no parents that aren't satisfied by other packages in this slot)
''
(dev-libs/boost-1.71.0:0/1.71.0::gentoo, installed) pulled in by
dev-libs/boost:0/1.71.0= required by (dev-cpp/libcmis-0.5.2-r1:0.5/0.5::gentoo, installed)
^^^^^^^^^^
(and 10 more with the same problem)
''
dev-util/boost-build:0
''
(dev-util/boost-build-1.72.0:0/0::gentoo, ebuild scheduled for merge) pulled in by
=dev-util/boost-build-1.72* required by (dev-libs/boost-1.72.0:0/1.72.0::gentoo, ebuild scheduled for merge)                                                                                                 
^                     ^^^^^
''
(dev-util/boost-build-1.71.0:0/0::gentoo, installed) pulled in by
=dev-util/boost-build-1.71* required by (dev-libs/boost-1.71.0:0/1.71.0::gentoo, installed)                                                                                                                   
^                     ^^^^^
''
NOTE: Use the '--verbose-conflicts' option to display parents omitted above
''
It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.
''
For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.
''
''
 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.
''
(dev-lang/lua-5.1.5-r4:0/0::gentoo, ebuild scheduled for merge) pulled in by
>=dev-lang/lua-5.1:0= required by (media-video/vlc-3.0.8:0/5-9::gentoo, ebuild scheduled for merge)
''
(dev-lang/lua-5.3.5-r1:5.3/5.3::gentoo, ebuild scheduled for merge) pulled in by
dev-lang/lua:5.3/5.3= required by (app-text/podofo-0.9.6_p20180715:0/0.9.6::gentoo, installed)
dev-lang/lua:= required by (app-text/podofo-0.9.6_p20180715:0/0.9.6::gentoo, installed)
dev-lang/lua required by (games-strategy/widelands-0.20_rc1:0/0::mein-repo, installed)

_________________
Asus 4A785TD-M EVO mit AMD Phenom(tm) II X4 945
Dell Mini 10v
http://www.openstreetmap.org
Back to top
View user's profile Send private message
franzf
Advocate
Advocate


Joined: 29 Mar 2005
Posts: 4507

PostPosted: Fri Jan 17, 2020 4:37 am    Post subject: Reply with quote

Ich hab grad geschaut, keines der darktable ebuilds aktiviert lua, selbst die v2.6.2 braucht schon lua-5.2. Also sollte nichts kaputt gehen.

Und bitte poste doch mal ALLES bei solchen Ausgaben, inklusive dem emerge Befehl.
Das schaut mir wie ein normales emerge -uD @world aus und nicht emerge -C lua:5.3 && emerge -1 lua:0 widelands podofo
Back to top
View user's profile Send private message
uhai
Veteran
Veteran


Joined: 23 Aug 2007
Posts: 1231
Location: Eppingen, Germany

PostPosted: Fri Jan 17, 2020 5:50 pm    Post subject: Reply with quote

Das war jetzt auch ein emerge -auDNtv world, lua-5.3 hatte ich schon vorher entsorgt wie Du angegeben hast. Jetzt sieht das so aus:

Code:
/home/uhai/ emerge -C lua:5.3 && emerge -1 lua:0 widelands podofo
$'[33;01m * $'[39;49;00mThis action can remove important packages! In order to be safer, use
$'[33;01m * $'[39;49;00m`emerge -pv --depclean <atom>` to check for reverse dependencies before
$'[33;01m * $'[39;49;00mremoving packages.

>>> No packages selected for removal by unmerge
''
--- Couldn't find 'lua:5.3' to unmerge.


Und das Update kommt so:

Code:
 emerge -auDNtv world                                 

These are the packages that would be merged, in reverse order:

Calculating dependencies... done!
[nomerge       ] app-portage/genlop-0.30.10-r2::gentoo
[nomerge       ]  dev-perl/libwww-perl-6.270.0::gentoo  USE="ssl -test"
[nomerge       ]   dev-perl/LWP-Protocol-https-6.70.0::gentoo  USE="-test"
[nomerge       ]    dev-perl/IO-Socket-SSL-2.66.0::gentoo  USE="-examples -idn"
[nomerge       ]     dev-perl/Net-SSLeay-1.880.0::gentoo  USE="-examples -libressl -minimal -test"
[nomerge       ]      dev-libs/openssl-1.1.1d-r3:0/1.1::gentoo  USE="asm zlib -bindist -rfc3779 -sctp -sslv3 -static-libs -test -tls-heartbeat -vanilla" ABI_X86="(64) -32 (-x32)" CPU_FLAGS_X86="(sse2)"                                                                 
[nomerge       ]       sys-libs/zlib-1.2.11-r2:0/1::gentoo  USE="minizip (split-usr) -static-libs" ABI_X86="32 (64) (-x32)"
[nomerge       ]        sys-devel/libtool-2.4.6-r6:2::gentoo [2.4.6-r3:2::gentoo] USE="-vanilla"
[nomerge       ]         sys-devel/automake-1.16.1-r1:1.16::gentoo  USE="-test"
[nomerge       ]          sys-apps/help2man-1.47.10::gentoo  USE="nls"
[nomerge       ]           dev-perl/Locale-gettext-1.70.0::gentoo
[nomerge       ]            sys-devel/gettext-0.20.1::gentoo [0.19.8.1::gentoo] USE="acl cxx ncurses nls openmp -cvs -doc -emacs -git -java -static-libs" ABI_X86="(64) -32 (-x32)"
[nomerge       ]             dev-libs/libxml2-2.9.9-r3:2::gentoo  USE="icu ipv6 python readline -debug -examples -lzma -static-libs -test" ABI_X86="(64) -32 (-x32)" PYTHON_TARGETS="python2_7 python3_6 (-python3_7) (-python3_8)"                                       
[nomerge       ]              dev-lang/python-2.7.17:2.7::gentoo  USE="bluetooth gdbm ipv6 ncurses readline sqlite ssl (threads) tk (wide-unicode) xml (-berkdb) -build -doc -examples -hardened -libressl -wininst"                                                     
[nomerge       ]               net-wireless/bluez-5.52:0/3::gentoo  USE="cups mesh obex readline systemd udev -btpclient -debug -deprecated -doc -experimental -extra-tools -midi (-selinux) -test -test-programs -user-session" ABI_X86="(64) -32 (-x32)" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7"
[nomerge       ]                sys-apps/systemd-243-r2:0/2::gentoo  USE="acl gcrypt kmod lz4 pam pcre policykit resolvconf seccomp (split-usr) sysv-utils -apparmor -audit -build -cgroup-hybrid -cryptsetup -curl -dns-over-tls -elfutils -gnuefi -http -idn -importd -lzma -nat -qrcode (-selinux) -static-libs -test -vanilla -xkb" ABI_X86="(64) -32 (-x32)"                                             
[ebuild     U  ]                 sys-libs/pam-1.3.1-r1::gentoo [1.3.0-r2::gentoo] USE="berkdb cracklib filecaps nls pie (split-usr) -audit -debug -nis (-selinux) -static-libs% (-test%) (-vim-syntax%*)" ABI_X86="(64) -32 (-x32)" 733 KiB                               
[ebuild     U  ] net-analyzer/wireshark-3.2.1:0/3.2.1::gentoo [3.0.7:0/3.0.7::gentoo] USE="capinfos captype dftest dumpcap editcap filecaps mergecap minizip%* netlink pcap plugins%* qt5 randpkt randpktdump reordercap sharkd ssl text2pcap tshark udpdump zlib -androiddump -bcg729 -brotli% -ciscodump -doc -dpauxmon -http2 -kerberos -libxml2 -lua -lz4 -maxminddb -plugin-ifdemo% -sbc -sdjournal (-selinux) -smi -snappy -spandsp -sshdump -tfshark (-adns%)" PYTHON_TARGETS="(-python3_6%*) (-python3_7%)" 30.784 KiB                     
[nomerge       ] app-office/scribus-1.5.5::gentoo  USE="boost hunspell osg pdf scripts templates tk -debug -examples -graphicsmagick -minimal" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7"                                                               
[ebuild   R    ]  dev-games/openscenegraph-3.5.5:0/145::gentoo  USE="ffmpeg gif jpeg pdf png sdl svg tiff truetype wxwidgets xine zlib -asio -curl -debug -doc -examples -fltk (-fox) -gdal -glut -gstreamer -las -libav -lua -openexr -openinventor -osgapps -sdl2 -vnc -xrandr (-gtk%*)" 0 KiB                                                                                                               
[nomerge       ] media-sound/audacity-2.2.2::gentoo  USE="alsa ffmpeg flac ladspa lame lv2 mad midi nls portmixer soundtouch vorbis vst -doc -id3tag -jack -libav -sbsms -twolame -vamp" CPU_FLAGS_X86="sse"                                                             
[ebuild     U  ]  media-libs/lv2-1.16.0::gentoo [1.14.0-r1::gentoo] USE="-doc -plugins" ABI_X86="(64) -32 (-x32)" PYTHON_SINGLE_TARGET="python3_6 (-python3_7) (-python2_7%)" PYTHON_TARGETS="python3_6 (-python3_7) (-python2_7%*)" 491 KiB
[ebuild     U ~] media-gfx/gmic-2.8.2::gentoo [2.8.1::gentoo] USE="X cli ffmpeg fftw gimp jpeg openmp png qt5 tiff zlib -curl -graphicsmagick -krita -opencv -openexr -static-libs" 6.026 KiB                                                                             
[ebuild     U  ] mail-client/thunderbird-68.4.1::gentoo [68.3.1::gentoo] USE="dbus gmp-autoupdate startup-notification system-av1 system-harfbuzz system-icu system-jpeg system-libevent system-libvpx system-sqlite system-webp -bindist -clang -custom-cflags -custom-optimization -debug -eme-free -hardened -jack -lightning -lto (-pgo) -pulseaudio (-selinux) -test -wayland -wifi" CPU_FLAGS_X86="-avx2" L10N="de -ar -ast -be -bg -br -ca -cs -cy -da -el -en-GB -es-AR -es-ES -et -eu -fi -fr -fy -ga -gd -gl -he -hr -hsb -hu -hy -id -is -it -ja -ko -lt -nb -nl -nn -pl -pt-BR -pt-PT -rm -ro -ru -si -sk -sl -sq -sr -sv -tr -uk -vi -zh-CN -zh-TW" 324.298 KiB             
[ebuild     U  ] www-plugins/adobe-flash-32.0.0.314:22::gentoo [32.0.0.303:22::gentoo] USE="nsplugin ppapi" ABI_X86="64 -32 (-x32)" 18.297 KiB
[ebuild   R    ] app-portage/portpeek-2.1.27::gentoo  PYTHON_TARGETS="python3_6 (-python3_7) (-python2_7%*)" 0 KiB
[ebuild     U  ] app-office/libreoffice-6.3.4.2::gentoo [6.2.8.2::gentoo] USE="bluetooth branding cups dbus gtk ldap mariadb -accessibility (-coinmp) -debug -eds (-firebird) -googledrive -gstreamer -gtk2 -java -kde -odk -pdfimport -postgres -test" LIBREOFFICE_EXTENSIONS="-nlpsolver -scripting-beanshell -scripting-javascript -wiki-publisher" PYTHON_SINGLE_TARGET="python3_6 (-python3_7) (-python3_8) (-python2_7%)" PYTHON_TARGETS="python3_6 (-python3_7) (-python3_8) (-python2_7%*)" 233.227 KiB
[nomerge       ] kde-apps/kdenlive-19.08.3:5::gentoo  USE="handbook v4l -debug -freesound (-gles2) -semantic-desktop -share -test"
[nomerge       ]  kde-frameworks/solid-5.64.0-r1:5/5.64::gentoo  USE="nls -debug -doc -test"
[nomerge       ]   sys-fs/udisks-2.8.4:2::gentoo  USE="acl introspection nls systemd -debug -elogind -lvm (-selinux) -vdo"
[nomerge       ]    sys-libs/libblockdev-2.20-r2::gentoo  USE="cryptsetup -bcache -device-mapper -dmraid -doc -escrow -kbd -lvm -test -vdo" PYTHON_SINGLE_TARGET="python3_6 -python2_7 (-python3_7)" PYTHON_TARGETS="python2_7 python3_6 (-python3_7)"
[nomerge       ]     sys-fs/cryptsetup-2.2.1-r1:0/12::gentoo  USE="argon2 luks1_default nls openssl udev -gcrypt -kernel -libressl -nettle -pwquality -reencrypt -static -static-libs -urandom"                                                                           
[nomerge       ]      sys-fs/lvm2-2.02.184-r5::gentoo  USE="readline systemd thin udev -device-mapper-only -lvm2create_initrd -sanlock (-selinux) -static -static-libs"                                                                                                   
[nomerge       ]       sys-block/thin-provisioning-tools-0.7.0::gentoo  USE="-static -test"
[ebuild     U  ]        dev-libs/boost-1.72.0:0/1.72.0::gentoo [1.71.0:0/1.71.0::gentoo] USE="bzip2 icu nls python threads zlib -context -debug -doc -lzma -mpi -numpy -static-libs -tools -zstd" ABI_X86="(64) -32 (-x32)" PYTHON_TARGETS="python2_7 python3_6 (-python3_7) (-python3_8)" 104.402 KiB                                                                                                         
[nomerge       ] app-office/libreoffice-6.3.4.2::gentoo [6.2.8.2::gentoo] USE="bluetooth branding cups dbus gtk ldap mariadb -accessibility (-coinmp) -debug -eds (-firebird) -googledrive -gstreamer -gtk2 -java -kde -odk -pdfimport -postgres -test" LIBREOFFICE_EXTENSIONS="-nlpsolver -scripting-beanshell -scripting-javascript -wiki-publisher" PYTHON_SINGLE_TARGET="python3_6 (-python3_7) (-python3_8) (-python2_7%)" PYTHON_TARGETS="python3_6 (-python3_7) (-python3_8) (-python2_7%*)"
[ebuild     U  ]  app-text/libebook-0.1.3::gentoo [0.1.2-r1::gentoo] USE="-doc -test -tools" 499 KiB
[nomerge       ] kde-misc/tellico-3.2.3:5::gentoo  USE="cddb handbook pdf scanner v4l -debug -discid -semantic-desktop -taglib -test -xmp -yaz"                                                                                                                           
[nomerge       ]  kde-frameworks/khtml-5.64.0:5/5.64::gentoo  USE="X -debug -libressl -test"
[nomerge       ]   media-libs/phonon-4.11.1-r1::gentoo  USE="vlc -debug -designer -gstreamer -pulseaudio"
[nomerge       ]    media-libs/phonon-vlc-0.11.1::gentoo  USE="-debug"
[ebuild   R    ]     media-video/vlc-3.0.8:0/5-9::gentoo  USE="X a52 alsa cddb dbus dts dvbpsi dvd encode ffmpeg flac fontconfig gcrypt jpeg libnotify libsamplerate lua* mad matroska* mp3 mpeg ncurses ogg png qt5 ssl svg theora truetype udev v4l vdpau vorbis vpx* x264 xml (-altivec) -aom -archive -aribsub -bidi -bluray -chromaprint -chromecast -dav1d -dc1394 -debug (-directx) -faad -fdk -fluidsynth -gme -gnome-keyring -gstreamer -ieee1394 -jack -kate -libass -libav -libcaca -libtar -libtiger -linsys -lirc -live -macosx-notifications -modplug -mtp -musepack -nfs -omxil -opencv -optimisememory -opus -postproc -projectm -pulseaudio -rdp -run-as-root -samba -sdl-image -sftp -shout -sid -skins -soxr -speex -srt -taglib -test -tremor -twolame -upnp -vaapi -vnc -wayland -x265 -zeroconf -zvbi" CPU_FLAGS_X86="mmx sse" 0 KiB
[ebuild  N     ]      media-libs/libmatroska-1.5.2:0/6::gentoo  64 KiB
[nomerge       ] media-gfx/inkscape-1.0_beta2::gentoo  USE="cdr dbus dia exif graphicsmagick imagemagick inkjar jpeg lcms nls openmp postscript spell visio wpg -jemalloc -static-libs -svg2" PYTHON_SINGLE_TARGET="python3_6 -python3_7" PYTHON_TARGETS="python3_6 -python3_7"                                                                                                                               
[nomerge       ]  app-text/gtkspell-3.0.9:3/0::gentoo  USE="introspection -vala"
[ebuild     U  ]   app-text/iso-codes-4.4::gentoo [3.76::gentoo] 12.988 KiB
[ebuild     U  ] media-gfx/imagemagick-7.0.9.14:0/7.0.9::gentoo [7.0.9.8:0/7.0.9::gentoo] USE="X bzip2 corefonts cxx fftw fontconfig fpx graphviz hdri heif jbig jpeg jpeg2k lcms lqr openmp pango png raw svg tiff truetype webp wmf xml zlib -djvu -lzma (-opencl) -openexr -perl -postscript -q32 -q8 -static-libs -test" 9.264 KiB                                                                         
[nomerge       ] media-video/vlc-3.0.8:0/5-9::gentoo  USE="X a52 alsa cddb dbus dts dvbpsi dvd encode ffmpeg flac fontconfig gcrypt jpeg libnotify libsamplerate lua* mad matroska* mp3 mpeg ncurses ogg png qt5 ssl svg theora truetype udev v4l vdpau vorbis vpx* x264 xml (-altivec) -aom -archive -aribsub -bidi -bluray -chromaprint -chromecast -dav1d -dc1394 -debug (-directx) -faad -fdk -fluidsynth -gme -gnome-keyring -gstreamer -ieee1394 -jack -kate -libass -libav -libcaca -libtar -libtiger -linsys -lirc -live -macosx-notifications -modplug -mtp -musepack -nfs -omxil -opencv -optimisememory -opus -postproc -projectm -pulseaudio -rdp -run-as-root -samba -sdl-image -sftp -shout -sid -skins -soxr -speex -srt -taglib -test -tremor -twolame -upnp -vaapi -vnc -wayland -x265 -zeroconf -zvbi" CPU_FLAGS_X86="mmx sse"
[ebuild  N     ]  dev-libs/libebml-1.3.9:0/4::gentoo  69 KiB
[nomerge       ] kde-apps/kdenlive-19.08.3:5::gentoo  USE="handbook v4l -debug -freesound (-gles2) -semantic-desktop -share -test"
[nomerge       ]  media-libs/mlt-6.16.0-r2::gentoo  USE="ffmpeg fftw frei0r gtk kdenlive melt opengl qt5 sdl xine xml -compressed-lumas -debug -jack -libav -libsamplerate -lua (-opencv) -python -rtaudio -ruby (-vdpau) -vidstab" CPU_FLAGS_X86="mmx sse sse2" PYTHON_SINGLE_TARGET="python3_6 -python2_7 (-python3_7)" PYTHON_TARGETS="python2_7 python3_6 (-python3_7)"
[ebuild   R    ]   x11-libs/gtk+-2.24.32-r1:2::mv [2.24.32-r1:2::gentoo] USE="cups introspection vim-syntax -adwaita-icon-theme% (-aqua) -doc% -examples -test -xinerama" ABI_X86="(64) -32 (-x32)" 0 KiB                                                                 
[nomerge       ] media-sound/clementine-1.3.1_p20190127::gentoo  USE="cdda dbus ipod mms udisks -box -debug -dropbox -googledrive -lastfm -moodbar -mtp -projectm -pulseaudio -seafile -skydrive -test -wiimote"                                                         
[nomerge       ]  sys-fs/udisks-2.8.4:2::gentoo  USE="acl introspection nls systemd -debug -elogind -lvm (-selinux) -vdo"
[nomerge       ]   sys-auth/polkit-0.115-r4::gentoo  USE="gtk introspection nls pam systemd -consolekit -elogind -examples -jit -kde (-selinux) -test"
[nomerge       ]    dev-libs/gobject-introspection-1.60.2::gentoo  USE="cairo -doctool -test" PYTHON_SINGLE_TARGET="python3_6 (-python3_7)" PYTHON_TARGETS="python3_6 (-python3_7)"                                                                                       
[nomerge       ]     x11-libs/cairo-1.16.0-r3::gentoo  USE="X glib opengl svg (-aqua) -debug (-gles2-only) -static-libs -utils -valgrind (-gles2%) (-xcb%*)" ABI_X86="(64) -32 (-x32)"                                                                                   
[nomerge       ]      media-libs/mesa-19.2.8::gentoo  USE="X classic dri3 egl gallium gbm gles2 llvm opencl vdpau -d3d9 -debug -gles1 (-libglvnd) -lm-sensors -osmesa -pax_kernel (-selinux) -test -unwind -vaapi -valgrind -vulkan -vulkan-overlay -wayland -xa -xvmc" ABI_X86="(64) -32 (-x32)" VIDEO_CARDS="(-freedreno) -i915 -i965 -intel -iris (-lima) -nouveau (-panfrost) -r100 -r200 -r300 -r600 -radeon -radeonsi (-vc4) -virgl (-vivante) -vmware"                                                                                       
[nomerge       ]       sys-devel/clang-8.0.1:8::gentoo  USE="static-analyzer xml -debug -default-compiler-rt -default-libcxx -doc -test -z3" ABI_X86="(64) -32 (-x32)" LLVM_TARGETS="AMDGPU BPF NVPTX (X86) -AArch64 -ARM -Hexagon -Lanai -MSP430 -Mips -PowerPC -Sparc -SystemZ -WebAssembly -XCore" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7"                                             
[nomerge       ]        dev-util/cmake-3.14.6::gentoo  USE="ncurses qt5 -doc -emacs -system-jsoncpp -test"
[nomerge       ]         dev-qt/qtcore-5.13.2-r1:5/5.13::gentoo  USE="icu systemd -debug -test"
[nomerge       ]          sys-apps/systemd-243-r2:0/2::gentoo  USE="acl gcrypt kmod lz4 pam pcre policykit resolvconf seccomp (split-usr) sysv-utils -apparmor -audit -build -cgroup-hybrid -cryptsetup -curl -dns-over-tls -elfutils -gnuefi -http -idn -importd -lzma -nat -qrcode (-selinux) -static-libs -test -vanilla -xkb" ABI_X86="(64) -32 (-x32)"                                                   
[ebuild     U  ]           dev-util/meson-0.52.1::gentoo [0.51.2::gentoo] USE="-test" PYTHON_TARGETS="python3_6 (-python3_7) (-python3_8)" 1.473 KiB                                                                                                                     
[ebuild   R    ]            dev-lang/python-3.6.9:3.6/3.6m::mv [3.6.9:3.6/3.6m::gentoo] USE="bluetooth gdbm ipv6 ncurses readline sqlite ssl (threads) tk xml -build -examples -hardened -libressl -test -tinfo% -wininst" 0 KiB                                         
[ebuild     U  ] sys-boot/grub-2.04-r1:2/2.04-r1::gentoo [2.02-r4:2/2.02-r4::gentoo] USE="fonts nls sdl themes truetype -device-mapper -doc -efiemu -libzfs -mount (-test) (-multislot%) (-static%)" GRUB_PLATFORMS="efi-64 -coreboot -efi-32 -emu -ieee1275 -loongson -multiboot -pc -qemu -qemu-mips -uboot -xen -xen-32 -xen-pvh%" 7.549 KiB                                                               
[ebuild     U  ] app-portage/eix-0.33.9-r1::gentoo [0.33.8::gentoo] USE="nls -debug -doc -sqlite" 614 KiB
[nomerge       ] kde-apps/kdenlive-19.08.3:5::gentoo  USE="handbook v4l -debug -freesound (-gles2) -semantic-desktop -share -test"
[nomerge       ]  kde-frameworks/knotifications-5.64.0:5/5.64::gentoo  USE="X dbus nls -debug -doc -phonon -speech"
[nomerge       ]   media-libs/libcanberra-0.30-r5::gentoo  USE="alsa gtk gtk3 sound udev -gnome -gstreamer -oss -pulseaudio -tdb" ABI_X86="(64) -32 (-x32)"
[nomerge       ]    x11-libs/gtk+-3.24.11:3::gentoo  USE="X cups introspection vim-syntax (-aqua) -broadway -cloudprint -colord -examples -gtk-doc -test -wayland -xinerama" ABI_X86="(64) -32 (-x32)"                                                                   
[nomerge       ]     media-libs/harfbuzz-2.6.4:0/0.9.18::gentoo  USE="cairo glib graphite icu introspection truetype -debug -static-libs -test" ABI_X86="(64) -32 (-x32)"                                                                                                 
[nomerge       ]      media-gfx/graphite2-1.3.13::gentoo  USE="-perl -test" ABI_X86="(64) -32 (-x32)"
[nomerge       ]       dev-util/cmake-3.14.6::gentoo  USE="ncurses qt5 -doc -emacs -system-jsoncpp -test"
[nomerge       ]        dev-qt/qtwidgets-5.13.2:5/5.13::gentoo  USE="gtk png xcb -debug (-gles2) -test"
[nomerge       ]         x11-libs/pango-1.42.4-r2::gentoo  USE="X introspection -test" ABI_X86="(64) -32 (-x32)"
[ebuild   R    ]          x11-libs/cairo-1.16.0-r3::gentoo  USE="X glib opengl svg (-aqua) -debug (-gles2-only) -static-libs -utils -valgrind (-gles2%) (-xcb%*)" ABI_X86="(64) -32 (-x32)" 0 KiB                                                                         
[nomerge       ] media-gfx/scrot-0.8_p13-r1::gentoo
[ebuild     U  ]  media-libs/imlib2-1.6.1::gentoo [1.5.1-r1::gentoo] USE="X bzip2 gif jpeg mp3 png shm tiff webp%* zlib -doc -static-libs (-nls%*)" ABI_X86="(64) -32 (-x32)" CPU_FLAGS_X86="sse2 (-mmx)" 1.015 KiB                                                       
[nomerge       ] games-strategy/widelands-0.20_rc1::mein-repo
[ebuild  N    #]  dev-lang/lua-5.3.5-r1:5.3::gentoo  USE="deprecated readline -emacs -static -test -test-complete" ABI_X86="(64) -32 (-x32)" 0 KiB
[ebuild  N    #]   app-eselect/eselect-lua-2::lua  0 KiB
[nomerge       ] app-office/libreoffice-6.3.4.2::gentoo [6.2.8.2::gentoo] USE="bluetooth branding cups dbus gtk ldap mariadb -accessibility (-coinmp) -debug -eds (-firebird) -googledrive -gstreamer -gtk2 -java -kde -odk -pdfimport -postgres -test" LIBREOFFICE_EXTENSIONS="-nlpsolver -scripting-beanshell -scripting-javascript -wiki-publisher" PYTHON_SINGLE_TARGET="python3_6 (-python3_7) (-python3_8) (-python2_7%)" PYTHON_TARGETS="python3_6 (-python3_7) (-python3_8) (-python2_7%*)"
[ebuild     U  ]  app-text/liblangtag-0.6.3::gentoo [0.6.2::gentoo] USE="-debug -doc -introspection -static-libs -test" 738 KiB
[ebuild     U  ] sys-apps/sed-4.7::gentoo [4.5::gentoo] USE="acl nls -forced-sandbox (-selinux) -static" 1.268 KiB
[ebuild     U  ]  sys-devel/gettext-0.20.1::gentoo [0.19.8.1::gentoo] USE="acl cxx ncurses nls openmp -cvs -doc -emacs -git -java -static-libs" ABI_X86="(64) -32 (-x32)" 22.723 KiB                                                                                     
[nomerge       ] media-video/vlc-3.0.8:0/5-9::gentoo  USE="X a52 alsa cddb dbus dts dvbpsi dvd encode ffmpeg flac fontconfig gcrypt jpeg libnotify libsamplerate lua* mad matroska* mp3 mpeg ncurses ogg png qt5 ssl svg theora truetype udev v4l vdpau vorbis vpx* x264 xml (-altivec) -aom -archive -aribsub -bidi -bluray -chromaprint -chromecast -dav1d -dc1394 -debug (-directx) -faad -fdk -fluidsynth -gme -gnome-keyring -gstreamer -ieee1394 -jack -kate -libass -libav -libcaca -libtar -libtiger -linsys -lirc -live -macosx-notifications -modplug -mtp -musepack -nfs -omxil -opencv -optimisememory -opus -postproc -projectm -pulseaudio -rdp -run-as-root -samba -sdl-image -sftp -shout -sid -skins -soxr -speex -srt -taglib -test -tremor -twolame -upnp -vaapi -vnc -wayland -x265 -zeroconf -zvbi" CPU_FLAGS_X86="mmx sse"
[ebuild  N     ]  dev-lang/lua-5.1.5-r4::gentoo  USE="deprecated readline -emacs -static" ABI_X86="(64) -32 (-x32)" 217 KiB
[ebuild     U  ]   sys-devel/libtool-2.4.6-r6:2::gentoo [2.4.6-r3:2::gentoo] USE="-vanilla" 0 KiB
[nomerge       ] net-print/hplip-3.18.12::gentoo  USE="X fax hpcups libnotify policykit qt5 scanner snmp -doc -hpijs -kde -libressl -libusb0 -minimal -parport -static-ppds" PYTHON_SINGLE_TARGET="python3_6 -python2_7" PYTHON_TARGETS="python2_7 python3_6"             
[nomerge       ]  dev-python/PyQt5-5.13.2::gentoo  USE="bluetooth dbus designer gui network opengl printsupport ssl svg webkit widgets -debug -declarative -examples (-gles2) -help -location -multimedia -networkauth -positioning -sensors -serialport -sql -testlib -webchannel -websockets -x11extras -xmlpatterns" PYTHON_TARGETS="python2_7 python3_6 (-python3_7) (-python3_8)"                         
[nomerge       ]   dev-qt/qtwebkit-5.212.0_pre20190629:5/5.212::gentoo  USE="X geolocation hyphen multimedia opengl orientation printsupport webp (-gles2) -gstreamer -jit -nsplugin -qml"                                                                               
[ebuild     U  ]    dev-libs/hyphen-2.8.8-r1::gentoo [2.8.8::gentoo] USE="-static-libs" 0 KiB
[ebuild     U  ] app-office/libreoffice-l10n-6.3.4.2::gentoo [6.2.8.2::gentoo] USE="-offlinehelp" L10N="de -af -am -ar -as -ast -be -bg -bn -bn-IN -bo -br -brx -bs -ca -ca-valencia -cs -cy -da -dgo -dz -el -en -en-GB -en-ZA -eo -es -et -eu -fa -fi -fr -ga -gd -gl -gu -gug -he -hi -hr -hu -id -is -it -ja -ka -kk -km -kmr-Latn -kn -ko -kok -ks -lb -lo -lt -lv -mai -mk -ml -mn -mni -mr -my -nb -ne -nl -nn -nr -nso -oc -om -or -pa -pl -pt -pt-BR -ro -ru -rw -sa -sat -sd -si -sid -sk -sl -sq -sr -sr-Latn -ss -st -sv -sw-TZ -ta -te -tg -th -tn -tr -ts -tt -ug -uk -uz -ve -vi -xh -zh-CN -zh-TW -zu" 21.275 KiB                                                       
[nomerge       ] kde-apps/k3b-19.08.3:5::gentoo  USE="dvd encode ffmpeg flac handbook mad mp3 musepack sndfile sox taglib vcd vorbis -debug (-emovix) -libav -test -webkit"                                                                                               
[nomerge       ]  app-cdr/cdrdao-1.2.4::gentoo  USE="encode mad vorbis"
[ebuild     U  ]   virtual/cdrtools-1::mv [0::gentoo] 0 KiB
[nomerge       ] dev-libs/boost-1.72.0:0/1.72.0::gentoo [1.71.0:0/1.71.0::gentoo] USE="bzip2 icu nls python threads zlib -context -debug -doc -lzma -mpi -numpy -static-libs -tools -zstd" ABI_X86="(64) -32 (-x32)" PYTHON_TARGETS="python2_7 python3_6 (-python3_7) (-python3_8)"                                                                                                                           
[ebuild     U  ]  dev-util/boost-build-1.72.0::gentoo [1.71.0::gentoo] USE="-examples (-python%) (-test%)" PYTHON_SINGLE_TARGET="(-python2_7%*)" PYTHON_TARGETS="(-python2_7%*)" 0 KiB                                                                                   
[blocks B      ] dev-lang/lua:0 ("dev-lang/lua:0" is blocking dev-lang/lua-5.3.5-r1)
[blocks B      ] dev-lang/lua:0 ("dev-lang/lua:0" is hard blocking app-eselect/eselect-lua-2)

Total: 34 packages (23 upgrades, 5 new, 6 reinstalls), Size of downloads: 798.002 KiB
Conflict: 2 blocks (2 unsatisfied)
''
!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:
''
dev-libs/boost:0
''
($'[32mdev-libs/boost-1.72.0:0/1.72.0::gentoo$'[39;49;00m, ebuild scheduled for merge) pulled in by
(no parents that aren't satisfied by other packages in this slot)
''
($'[34mdev-libs/boost-1.71.0:0/1.71.0::gentoo$'[39;49;00m, installed) pulled in by
>=dev-libs/boost-1.67$'[31;01m:0/1.71.0=$'[39;49;00m required by ($'[34mapp-office/scribus-1.5.5:0/0::gentoo$'[39;49;00m, installed)
^^^^^^^^^^
(and 10 more with the same problem)
''
dev-util/boost-build:0
''
($'[32mdev-util/boost-build-1.72.0:0/0::gentoo$'[39;49;00m, ebuild scheduled for merge) pulled in by
$'[31;01m=$'[39;49;00mdev-util/boost-build-$'[31;01m1.72*$'[39;49;00m required by ($'[32mdev-libs/boost-1.72.0:0/1.72.0::gentoo$'[39;49;00m, ebuild scheduled for merge)                                                                                                 
^                     ^^^^^
''
($'[34mdev-util/boost-build-1.71.0:0/0::gentoo$'[39;49;00m, installed) pulled in by
$'[31;01m=$'[39;49;00mdev-util/boost-build-$'[31;01m1.71*$'[39;49;00m required by ($'[34mdev-libs/boost-1.71.0:0/1.71.0::gentoo$'[39;49;00m, installed)                                                                                                                   
^                     ^^^^^
''
$'[32mNOTE: Use the '--verbose-conflicts' option to display parents omitted above$'[39;49;00m
''
It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.
''
For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.
''
''
$'[31;01m * $'[39;49;00mError: The above package list contains packages which cannot be
$'[31;01m * $'[39;49;00minstalled at the same time on the same system.
''
($'[32mdev-lang/lua-5.1.5-r4:0/0::gentoo$'[39;49;00m, ebuild scheduled for merge) pulled in by
>=dev-lang/lua-5.1:0= required by ($'[32mmedia-video/vlc-3.0.8:0/5-9::gentoo$'[39;49;00m, ebuild scheduled for merge)
''
($'[32mdev-lang/lua-5.3.5-r1:5.3/5.3::gentoo$'[39;49;00m, ebuild scheduled for merge) pulled in by
dev-lang/lua required by ($'[34mgames-strategy/widelands-0.20_rc1:0/0::mein-repo$'[39;49;00m, installed)
dev-lang/lua:5.3/5.3= required by ($'[34mapp-text/podofo-0.9.6_p20180715:0/0.9.6::gentoo$'[39;49;00m, installed)
dev-lang/lua:= required by ($'[34mapp-text/podofo-0.9.6_p20180715:0/0.9.6::gentoo$'[39;49;00m, installed)
''
''
For more information about $'[31;01mBlocked Packages$'[39;49;00m, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):
''
https://wiki.gentoo.org/wiki/Handbook:X86/Working/Portage#Blocked_packages
''

_________________
Asus 4A785TD-M EVO mit AMD Phenom(tm) II X4 945
Dell Mini 10v
http://www.openstreetmap.org
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3809
Location: Germany

PostPosted: Fri Jan 17, 2020 7:45 pm    Post subject: Reply with quote

Hi,
uhai wrote:
Code:
[ebuild  N    #]  dev-lang/lua-5.3.5-r1:5.3::gentoo  USE="deprecated readline -emacs -static -test -test-complete" ABI_X86="(64) -32 (-x32)" 0 KiB
[ebuild  N    #]   app-eselect/eselect-lua-2::lua  0 KiB

hast du dev-lang/lua und app-eselect/eselect-lua eventuell noch in der package.unmask gesetzt? Falls ja, nimm die mal bitte raus (und benutze emerge nicht mit autounmask).

Beachte bitte das die eselect-lua-2::lua Version aus dem lua Overlay stammt, welche dein gewünschtes dev-lang/lua:0 hart blockiert.
Back to top
View user's profile Send private message
franzf
Advocate
Advocate


Joined: 29 Mar 2005
Posts: 4507

PostPosted: Sat Jan 18, 2020 4:11 am    Post subject: Reply with quote

Jepp, Josef, stimmt, da ist noch was in der package.unmask.
Außerdem sind podofo und widelands noch mit lua:5.3 in DEPEND installiert, ein world-update wird die nicht anfassen sondern nur zur Ermittlung der Abhängigkeiten heranziehen, und deshalb wieder ein lua:5.3 installieren.
Deshalb hab ich ja ein emerge -1 lua:0 widelands podofo verlangt, damit da die DEPEND in /var/db/pkg... aktualisiert werden.
Also jetz
* ALLE lua und eselect-lua aus package.unmask raushauen (ebenso package.accept_keywords, wenn du das lua-oiverlay noch eingebunden hast)
* schauen, dass lua aus SLOT 5.1, 5.2 und 5.3 deinstalliert sind, ebenso darf kein eselect-lua mehr installiert sein
* emerge -1av lua:0 podofo widelands
* autounmask streichen...
Back to top
View user's profile Send private message
uhai
Veteran
Veteran


Joined: 23 Aug 2007
Posts: 1231
Location: Eppingen, Germany

PostPosted: Sun Jan 19, 2020 2:06 pm    Post subject: Reply with quote

Gefunden... lua-5.3 war unmasked um Plugins für darktable zu nutzen. Das ist einige Zeit her gewesen und ich habe das vergessen... Kommentarzeilen in den files sind manchmal recht hilfreich.
Jedenfalls war sowohl das entfernen der 5.3 und eselect-lua jetzt endgültig erfolgreich als auch das world-update...

Vielen Dank für den Wink mit dem Zaunpfahl.

uhai
_________________
Asus 4A785TD-M EVO mit AMD Phenom(tm) II X4 945
Dell Mini 10v
http://www.openstreetmap.org
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum