Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Error on updating Portage Version
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
lindab72
n00b
n00b


Joined: 17 Jan 2020
Posts: 7
Location: Sarthe (France)

PostPosted: Fri Jan 17, 2020 8:40 am    Post subject: Error on updating Portage Version Reply with quote

I've read a lot of things in Gentoo Forum, but can't find a solution to solve my problems.
Can anyone help me , please ? (sorry for my bad english)
I try this
Code:
emerge portage

But I get thoses errors
Code:
!!! All ebuilds that could satisfy ">=dev-lang/python-exec-2:=[python_targets_python2_7(-)?,python_targets_python3_6(-)?,python_targets_python3_7(-)?,python_targets_python3_8(-)?,-python_single_target_python2_7(-),-python_single_target_python3_6(-),-python_single_target_python3_7(-),-python_single_target_python3_8(-)]" have been masked.
!!! One of the following masked packages is required to complete your request:
- dev-lang/python-exec-9999::gentoo (masked by: EAPI 7)
- dev-lang/python-exec-2.4.6-r1::gentoo (masked by: EAPI 7)

The current version of portage supports EAPI '6'. You must upgrade to a
newer version of portage before EAPI masked packages can be installed.
(dependency required by "sys-apps/portage-2.3.79::gentoo" [ebuild])
(dependency required by "portage" [argument])
For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.


I've try to --clean / --sync / --depclean .. but still the same error ..

Thank you
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 24023
Location: here

PostPosted: Fri Jan 17, 2020 8:50 am    Post subject: Reply with quote

What portage version you installed? You can post your emerge --info?
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
lindab72
n00b
n00b


Joined: 17 Jan 2020
Posts: 7
Location: Sarthe (France)

PostPosted: Fri Jan 17, 2020 10:51 am    Post subject: Reply with quote

Thank you.
Here is the result of emerge --info

Code:
Portage 2.2.28 (python 2.7.10-final-0, default/linux/x86/17.0, gcc-4.8.5, glibc-2.21-r2, 4.4.28-std490-amd64 x86_64)
=================================================================
System uname: Linux-4.4.28-std490-amd64-x86_64-Intel-R-_Celeron-R-_CPU_G3930_@_2.90GHz-with-gentoo-2.2
KiB Mem:     8059680 total,   3732808 free
KiB Swap:          0 total,         0 free
Timestamp of repository gentoo: Fri, 17 Jan 2020 07:30:01 +0000
sh bash 4.3_p48
ld GNU ld (Gentoo 2.25.1 p1.1) 2.25.1
app-shells/bash:          4.3_p48::gentoo
dev-lang/perl:            5.22.2::gentoo
dev-lang/python:          2.7.10-r1::gentoo, 3.6.9::gentoo
dev-util/cmake:           3.5.2-r1::gentoo
dev-util/pkgconfig:       0.28-r2::gentoo
sys-apps/baselayout:      2.2::gentoo
sys-apps/openrc:          0.19.1::gentoo
sys-apps/sandbox:         2.10-r1::gentoo
sys-devel/autoconf:       2.69::gentoo
sys-devel/automake:       1.15.1-r2::gentoo
sys-devel/binutils:       2.25.1-r1::gentoo
sys-devel/gcc:            4.8.5::gentoo
sys-devel/gcc-config:     1.7.3::gentoo
sys-devel/libtool:        2.4.6::gentoo
sys-devel/make:           4.1-r1::gentoo
sys-kernel/linux-headers: 4.3::gentoo (virtual/os-headers)
sys-libs/glibc:           2.21-r2::gentoo
Repositories:

gentoo
    location: /usr/portage
    sync-type: rsync
    sync-uri: rsync://rsync.gentoo.org/gentoo-portage
    priority: -1000

ACCEPT_KEYWORDS="x86"
ACCEPT_LICENSE="*"
CBUILD="i486-pc-linux-gnu"
CFLAGS="-Os -mtune=i686 -pipe"
CHOST="i486-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.6/ext-active/ /etc/php/cgi-php5.6/ext-active/ /etc/php/cli-php5.6/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-Os -mtune=i686 -pipe"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -march=i686 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync"
FFLAGS="-O2 -march=i686 -pipe"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="en_US.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j5"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/var/tmp"
USE="acl berkdb build bzip2 cli crypt cxx dri fortran gdbm iconv ipv6 libtirpc ncurses nls nptl openmp pam pcre png readline seccomp split-usr ssl tcpd truetype unicode usb x86 xattr zlib" ABI_X86="32" ADA_TARGET="gnat_2018" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="karbon sheets words" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock greis isync itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf skytraq superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="libinput keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" NETBEANS_MODULES="apisupport cnd groovy gsf harness ide identity j2ee java mobility nb php profiler soa visualweb webcommon websvccommon xml" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php7-2" POSTGRES_TARGETS="postgres10 postgres11" PYTHON_SINGLE_TARGET="python3_6" PYTHON_TARGETS="python2_7 python3_6" RUBY_TARGETS="ruby24 ruby25" USERLAND="GNU" VIDEO_CARDS="amdgpu vmware i915 i965 intel nouveau radeon radeonsi" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CC, CPPFLAGS, CTARGET, CXX, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, LINGUAS, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS

Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 24023
Location: here

PostPosted: Fri Jan 17, 2020 11:10 am    Post subject: Reply with quote

The problem is that your portage version not manage EAPI 7.
You can try to download latest stable portage unpack it in /root and then run ./portage-portage-2.3.79/bin/emerge -1 portage.
At this point hopefully your portage is update and you can run it normally and you can remove version unpacked in root.
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
lindab72
n00b
n00b


Joined: 17 Jan 2020
Posts: 7
Location: Sarthe (France)

PostPosted: Fri Jan 17, 2020 2:10 pm    Post subject: Reply with quote

Thank you for your prompt response.
As I run ./portage-portage-2.3.79/bin/emerge -1 portage
Here is the result (quite long , sorry)
Code:


 * IMPORTANT: 5 news items need reading for repository 'gentoo'.
 * Use eselect news read to view new items.

Calculating dependencies... done!
[ebuild     U  ] dev-lang/python-exec-2.4.6-r1 [2.0.2] PYTHON_TARGETS="(python3_6%*) (python3_7%*) (python3_8%*)"
[ebuild  N     ] sys-apps/util-linux-2.33.2  USE="build cramfs ncurses nls pam readline (split-usr) suid unicode -caps -fdformat -kill -python (-selinux) -slang -static-libs -systemd -test -tty-helpers -udev" PYTHON_TARGETS="python2_7 python3_6 (-python3_7)"
[ebuild     U #] sys-apps/portage-2.3.79 [2.2.28] USE="native-extensions%* rsync-verify%* -gentoo-dev%" PYTHON_TARGETS="python3_6%* (-python3_7) (-python3_8)"
[blocks B      ] <app-shells/bash-completion-2.7-r1 ("<app-shells/bash-completion-2.7-r1" is blocking sys-apps/util-linux-2.33.2)
[blocks B      ] net-wireless/rfkill ("net-wireless/rfkill" is blocking sys-apps/util-linux-2.33.2)
[blocks B      ] <app-portage/gentoolkit-0.4.6 ("<app-portage/gentoolkit-0.4.6" is blocking sys-apps/portage-2.3.79)

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-lang/python-exec:2

  (dev-lang/python-exec-2.4.6-r1:2/2::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-lang/python-exec-2:=[python_targets_python2_7(-)?,python_targets_python3_6(-)?,python_targets_python3_7(-)?,python_targets_python3_8(-)?,-python_single_target_python2_7(-),-python_single_target_python3_6(-),-python_single_target_python3_7(-),-python_single_target_python3_8(-)] required by (sys-apps/portage-2.3.79:0/0::gentoo, ebuild scheduled for merge)
                                                                                                                                                                                                                                             

  (dev-lang/python-exec-2.0.2:2/2::gentoo, installed) pulled in by
    >=dev-lang/python-exec-2:2/2=[python_targets_python2_7(-),python_targets_python3_4(-),-python_single_target_pypy(-),-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)] required by (dev-python/packaging-16.6:0/0::gentoo, installed)
                                                                                                                                                                                                                                             
    >=dev-lang/python-exec-2:2/2=[python_targets_python2_7(-),python_targets_python3_4(-),-python_single_target_pypy(-),-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_3(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)] required by (dev-python/pycparser-2.14:0/0::gentoo, installed)
                                                                                                                                                                                                                                             
    >=dev-lang/python-exec-2:2/2=[python_targets_python2_7(-),python_targets_python3_4(-),-python_single_target_python2_7(-),-python_single_target_python3_3(-),-python_single_target_python3_4(-)] required by (app-portage/mirrorselect-2.2.2-r2:0/0::gentoo, installed)
                                                                                                                                                                                                                                             
    >=dev-lang/python-exec-2:2/2=[python_targets_python2_7(-),python_targets_python3_4(-),-python_single_target_pypy(-),-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_3(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)] required by (dev-python/lockfile-0.11.0-r1:0/0::gentoo, installed)
                                                                                                                                                                                                                                             
    >=dev-lang/python-exec-2:2/2=[python_targets_python2_7(-),python_targets_python3_4(-),-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)] required by (dev-libs/libxml2-2.9.4:2/2::gentoo, installed)
                                                                                                                                                                                                                                             
    >=dev-lang/python-exec-2:2/2=[python_targets_python2_7(-),python_targets_python3_4(-),-python_single_target_pypy(-),-python_single_target_python2_7(-),-python_single_target_python3_3(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)] required by (dev-python/ssl-fetch-0.3:0/0::gentoo, installed)
                                                                                                                                                                                                                                             
    >=dev-lang/python-exec-2:2/2=[python_targets_python2_7(-),python_targets_python3_4(-),-python_single_target_pypy(-),-python_single_target_python2_7(-),-python_single_target_python3_3(-),-python_single_target_python3_4(-)] required by (dev-python/ply-3.6-r1:0/0::gentoo, installed)
                                                                                                                                                                                                                                             
    >=dev-lang/python-exec-2:2/2=[python_targets_python2_7(-),python_targets_python3_4(-),-python_single_target_pypy(-),-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_3(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)] required by (dev-python/ndg-httpsclient-0.4.0:0/0::gentoo, installed)
                                                                                                                                                                                                                                             
    >=dev-lang/python-exec-2:2/2=[python_targets_python2_7(-),python_targets_python3_4(-),-python_single_target_pypy(-),-python_single_target_python2_7(-),-python_single_target_python3_3(-),-python_single_target_python3_4(-)] required by (dev-python/llfuse-0.40:0/0::gentoo, installed)
                                                                                                                                                                                                                                             
    >=dev-lang/python-exec-2:2/2=[python_targets_python2_7(-),python_targets_python3_4(-),-python_single_target_pypy(-),-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_3(-),-python_single_target_python3_4(-)] required by (dev-python/pyasn1-0.1.8:0/0::gentoo, installed)
                                                                                                                                                                                                                                             
    >=dev-lang/python-exec-2:2/2=[python_targets_python2_7(-),python_targets_python3_4(-),-python_single_target_pypy(-),-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_3(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)] required by (dev-python/py-1.4.30:0/0::gentoo, installed)
                                                                                                                                                                                                                                             
    >=dev-lang/python-exec-2:2/2=[python_targets_python2_7(-),python_targets_python3_4(-),-python_single_target_python2_7(-),-python_single_target_python3_3(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)] required by (dev-python/cffi-1.5.2:0/1.5.2::gentoo, installed)
                                                                                                                                                                                                                                             
    >=dev-lang/python-exec-2:2/2=[python_targets_python2_7(-),python_targets_python3_4(-),-python_single_target_pypy(-),-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_3(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)] required by (dev-python/requests-2.8.1:0/0::gentoo, installed)
                                                                                                                                                                                                                                             
    >=dev-lang/python-exec-2:2/2=[python_targets_python2_7(-),python_targets_python3_4(-),-python_single_target_pypy(-),-python_single_target_python2_7(-),-python_single_target_python3_3(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)] required by (dev-python/cryptography-1.3.4:0/0::gentoo, installed)
                                                                                                                                                                                                                                             
    >=dev-lang/python-exec-2:2/2=[python_targets_python2_7(-),python_targets_python3_4(-),-python_single_target_pypy(-),-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_3(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)] required by (virtual/python-ipaddress-1.0:0/0::gentoo, installed)
                                                                                                                                                                                                                                             
    >=dev-lang/python-exec-2:2/2=[python_targets_python2_7(-),python_targets_python3_4(-),-python_single_target_pypy(-),-python_single_target_python2_7(-),-python_single_target_python3_3(-),-python_single_target_python3_4(-)] required by (app-portage/gentoolkit-0.3.0.9-r2:0/0::gentoo, installed)
                                                                                                                                                                                                                                             
    >=dev-lang/python-exec-2:2/2=[python_targets_python2_7(-),python_targets_python3_4(-),-python_single_target_python2_7(-),-python_single_target_python3_3(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)] required by (sys-process/iotop-0.6:0/0::gentoo, installed)
                                                                                                                                                                                                                                             
    >=dev-lang/python-exec-2:2/2=[python_targets_python2_7(-),python_targets_python3_4(-),-python_single_target_pypy(-),-python_single_target_python2_7(-),-python_single_target_python3_3(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)] required by (dev-python/msgpack-0.4.6:0/0::gentoo, installed)
                                                                                                                                                                                                                                             
    >=dev-lang/python-exec-2:2/2=[python_targets_python2_7(-),python_targets_python3_4(-),-python_single_target_pypy(-),-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)] required by (dev-python/certifi-2015.11.20:0/0::gentoo, installed)
                                                                                                                                                                                                                                             
    >=dev-lang/python-exec-2:2/2=[python_targets_python3_4(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)] required by (app-backup/borgbackup-1.0.7:0/0::gentoo, installed)

    >=dev-lang/python-exec-2:2/2=[python_targets_python2_7(-),python_targets_python3_4(-),-python_single_target_pypy(-),-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)] required by (dev-python/six-1.10.0:0/0::gentoo, installed)
                                                                                                                                                                                                                                             
    >=dev-lang/python-exec-2:2/2=[python_targets_python2_7(-),python_targets_python3_4(-),-python_single_target_pypy(-),-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_3(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)] required by (dev-python/idna-2.0:0/0::gentoo, installed)
                                                                                                                                                                                                                                             
    >=dev-lang/python-exec-2:2/2=[python_targets_python2_7(-),python_targets_python3_4(-),-python_single_target_pypy(-),-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_3(-),-python_single_target_python3_4(-)] required by (dev-python/chardet-2.2.1:0/0::gentoo, installed)
                                                                                                                                                                                                                                             
    >=dev-lang/python-exec-2:2/2=[python_targets_python2_7(-),python_targets_python3_4(-),-python_single_target_pypy(-),-python_single_target_python2_7(-),-python_single_target_python3_3(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)] required by (dev-python/pyopenssl-0.15.1-r1:0/0::gentoo, installed)
                                                                                                                                                                                                                                             
    >=dev-lang/python-exec-2:2/2=[python_targets_python2_7(-),python_targets_python3_4(-),-python_single_target_pypy(-),-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)] required by (dev-python/pyxattr-0.5.5:0/0::gentoo, installed)
                                                                                                                                                                                                                                             
    >=dev-lang/python-exec-2:2/2=[python_targets_python2_7(-),python_targets_python3_4(-),-python_single_target_pypy(-),-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)] required by (sys-apps/portage-2.2.28:0/0::gentoo, installed)
                                                                                                                                                                                                                                             
    >=dev-lang/python-exec-2:2/2=[python_targets_python2_7(-),python_targets_python3_4(-),-python_single_target_pypy(-),-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)] required by (dev-python/pyparsing-2.1.8:0/0::gentoo, installed)
                                                                                                                                                                                                                                             
    >=dev-lang/python-exec-2:2/2=[python_targets_python2_7(-),python_targets_python3_4(-),-python_single_target_pypy(-),-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)] required by (dev-python/setuptools-18.4:0/0::gentoo, installed)
                                                                                                                                                                                                                                             

sys-apps/portage:0

  (sys-apps/portage-2.3.79:0/0::gentoo, ebuild scheduled for merge) pulled in by
    sys-apps/portage (Argument)

  (sys-apps/portage-2.2.28:0/0::gentoo, installed) pulled in by
    sys-apps/portage[python_targets_python2_7(-),python_targets_python3_4(-),-python_single_target_pypy(-),-python_single_target_python2_7(-),-python_single_target_python3_3(-),-python_single_target_python3_4(-)] required by (app-portage/gentoolkit-0.3.0.9-r2:0/0::gentoo, installed)
                                                                                                                                                                                                                                             


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (app-shells/bash-completion-2.3-r2:0/0::gentoo, installed) pulled in by
    app-shells/bash-completion required by @selected

  (sys-apps/util-linux-2.33.2:0/0::gentoo, ebuild scheduled for merge) pulled in by
    >=sys-apps/util-linux-2.16 required by (sys-fs/mtd-utils-1.5.0:0/0::gentoo, installed)
    sys-apps/util-linux required by (sys-fs/cryptsetup-1.7.2:0/0::gentoo, installed)
    sys-apps/util-linux required by (sys-apps/portage-2.3.79:0/0::gentoo, ebuild scheduled for merge)
    >=sys-apps/util-linux-2.24.1-r3[abi_x86_32(-)] required by (x11-libs/libSM-1.2.2-r1:0/0::gentoo, installed)
    >=sys-apps/util-linux-2.20 required by (sys-fs/udev-216:0/0::gentoo, installed)
    >=sys-apps/util-linux-2.16 required by (sys-fs/e2fsprogs-1.43.3:0/0::gentoo, installed)
    sys-apps/util-linux required by @system
    sys-apps/util-linux required by (sys-fs/nilfs-utils-2.2.2:0/0::gentoo, installed)
    >=sys-apps/util-linux-2.16 required by (sys-fs/mdadm-3.3.1-r2:0/0::gentoo, installed)
    sys-apps/util-linux[abi_x86_32(-)] required by (net-misc/networkmanager-1.4.0-r1:0/0::gentoo, installed)
    >=sys-apps/util-linux-2.17.2 required by (sys-fs/xfsprogs-4.5.0:0/0::gentoo, installed)
    >=sys-apps/util-linux-2.20 required by (sys-block/gparted-0.27.0:0/0::sysresccd, installed)
    >=sys-apps/util-linux-2.16 required by (dev-libs/apr-1.5.2:1/1::gentoo, installed)
    sys-apps/util-linux required by (sys-apps/udevil-0.4.4-r1:0/0::gentoo, installed)
    sys-apps/util-linux:0/0= required by (sys-fs/btrfs-progs-4.7.3:0/0::gentoo, installed)
    sys-apps/util-linux required by (sys-block/open-iscsi-2.0.873-r2:0/0::gentoo, installed)
    >=sys-apps/util-linux-2.20.1 required by (sys-block/hpacucli-9.40.12.0:0/0::gentoo, installed)
    sys-apps/util-linux required by (app-admin/testdisk-7.0-r3:0/0::gentoo, installed)
    sys-apps/util-linux required by (app-admin/apache-tools-2.4.23:0/0::gentoo, installed)
    >=sys-apps/util-linux-2.12-r4 required by (app-backup/rsnapshot-1.3.1-r2:0/0::sysresccd, installed)
    sys-apps/util-linux required by (sys-apps/gptfdisk-1.0.1:0/0::gentoo, installed)
    sys-apps/util-linux required by (sys-fs/progsreiserfs-0.3.1_rc8:0/0::gentoo, installed)
    sys-apps/util-linux required by (net-fs/nfs-utils-1.2.9-r3:0/0::gentoo, installed)
    >=sys-apps/util-linux-2.16 required by (sys-fs/lvm2-2.02.116:0/0::gentoo, installed)

  (net-wireless/rfkill-0.5:0/0::gentoo, installed) pulled in by
    net-wireless/rfkill required by @selected

  (app-portage/gentoolkit-0.3.0.9-r2:0/0::gentoo, installed) pulled in by
    app-portage/gentoolkit required by @selected


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

https://wiki.gentoo.org/wiki/Handbook:X86/Working/Portage#Blocked_packages


!!! The following installed packages are masked:
- x11-drivers/xf86-video-trident-1.3.7::gentoo (masked by: package.mask)
/usr/portage/profiles/package.mask:
# Matt Turner <mattst88@gentoo.org> (2019-03-16)
# Previously packaged drivers, now removed from Gentoo.
# Keep this mask in place so users are aware, but can also easily unmask them
# in an overlay if so desired.

- app-backup/tob-0.26-r2::gentoo (masked by: package.mask)
/usr/portage/profiles/package.mask:
# Jonas Stein <jstein@gentoo.org> (2019-12-30)
# Package masked for removal. Broken SRC_URI,
# last upstream activity was ~16 years ago.
# Bug #704316.
# Removal after 2020-03-01

- x11-drivers/xf86-video-i128-1.3.6-r1::gentoo (masked by: package.mask)
- x11-drivers/xf86-video-mach64-6.9.5::gentoo (masked by: package.mask)
- sys-apps/man-1.6g::gentoo (masked by: package.mask)
/usr/portage/profiles/package.mask:
# Mike Gilbert <floppym@gentoo.org> (2019-10-11)
# Inactive upstream for many years.
# Several open bugs.
# Please migrate to sys-apps/man-db.

- sys-devel/gcc-4.8.5::gentoo (masked by: package.mask)
/usr/portage/profiles/package.mask:
# Michał Górny <mgorny@gentoo.org>, Andreas K. Hüttel <dilfridge@gentoo.org>,
# Matthias Maier <tamiko@gentoo.org> (2017-05-21 and later updates)
# These old versions of toolchain packages (binutils, gcc, glibc) are no
# longer officially supported and are not suitable for general use. Using
# these packages can result in build failures (and possible breakage) for
# many packages, and may leave your system vulnerable to known security
# exploits.
# If you still use one of these old toolchain packages, please upgrade (and
# switch the compiler / the binutils) ASAP. If you need them for a specific
# (isolated) use case, feel free to unmask them on your system.

- sys-devel/binutils-2.25.1-r1::gentoo (masked by: package.mask)
- dev-lang/perl-5.22.2::gentoo (masked by: package.mask)
/usr/portage/profiles/package.mask:
# Andreas K. Hüttel <dilfridge@gentoo.org> (2019-05-11)
# Perl 5.24 will be removed soon. Please upgrade.

- sys-libs/binutils-libs-2.25.1-r2::gentoo (masked by: package.mask)
- x11-drivers/xf86-video-i740-1.3.5::gentoo (masked by: package.mask)
- x11-drivers/xf86-video-savage-2.3.8::gentoo (masked by: package.mask)
- sys-libs/glibc-2.21-r2::gentoo (masked by: package.mask)
- x11-drivers/xf86-video-cirrus-1.5.3::gentoo (masked by: package.mask)
- x11-drivers/xf86-video-apm-1.2.5-r1::gentoo (masked by: package.mask)
- virtual/perl-Exporter-5.720.0-r1::gentoo (masked by: package.mask)
/usr/portage/profiles/arch/base/package.mask:
# Andreas K. Hüttel <dilfridge@gentoo.org> (2019-08-30)
# Perl 5.26 will be removed soon. Please upgrade.
# This block is here (and not in ../../package.mask) since we still need
# it and unmask it on hppa and sparc. See bug 676062 and bug 683018.

- dev-libs/libusb-1.0.19-r1::gentoo (masked by: package.mask)
/etc/portage/package.mask:
# fix problems
# move dev-libs/libusbx dev-libs/libusb

- x11-drivers/xf86-video-tdfx-1.4.6::gentoo (masked by: package.mask)
- x11-drivers/xf86-video-sisusb-0.9.6-r1::gentoo (masked by: package.mask)
- x11-drivers/xf86-video-s3-0.6.5-r1::gentoo (masked by: package.mask)
- x11-drivers/xf86-video-rendition-4.2.6::gentoo (masked by: package.mask)
For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 24023
Location: here

PostPosted: Fri Jan 17, 2020 2:29 pm    Post subject: Reply with quote

It's a very old installation, will not be trivial update this system.
Try to remove app-shells/bash-completion, net-wireless/rfkill and app-portage/gentoolkit package and re run portage update
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
lindab72
n00b
n00b


Joined: 17 Jan 2020
Posts: 7
Location: Sarthe (France)

PostPosted: Fri Jan 17, 2020 2:29 pm    Post subject: Reply with quote

what I understand is that I have to manually resolve these conflicts ?
Back to top
View user's profile Send private message
lindab72
n00b
n00b


Joined: 17 Jan 2020
Posts: 7
Location: Sarthe (France)

PostPosted: Fri Jan 17, 2020 3:21 pm    Post subject: Reply with quote

Thank you.
Yes it's an old installation. I think the installation on this server was in 2016 ...
After deleting the Blocked Package as you write, re run portage update
Code:
 ./portage-portage-2.3.79/bin/emerge -1 portage

 * IMPORTANT: 5 news items need reading for repository 'gentoo'.
 * Use eselect news read to view new items.

Calculating dependencies... done!
[ebuild     U  ] dev-lang/python-exec-2.4.6-r1 [2.0.2] PYTHON_TARGETS="(python3_6%*) (python3_7%*) (python3_8%*)"
[ebuild  N     ] sys-apps/util-linux-2.33.2  USE="build cramfs ncurses nls pam readline (split-usr) suid unicode -caps -fdformat -kill -python (-selinux) -slang -static-libs -systemd -test -tty-helpers -udev" PYTHON_TARGETS="python2_7 python3_6 (-python3_7)"
[ebuild     U #] sys-apps/portage-2.3.79 [2.2.28] USE="native-extensions%* rsync-verify%* -gentoo-dev%" PYTHON_TARGETS="python3_6%* (-python3_7) (-python3_8)"

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-lang/python-exec:2

  (dev-lang/python-exec-2.4.6-r1:2/2::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-lang/python-exec-2:=[python_targets_python2_7(-)?,python_targets_python3_6(-)?,python_targets_python3_7(-)?,python_targets_python3_8(-)?,-python_single_target_python2_7(-),-python_single_target_python3_6(-),-python_single_target_python3_7(-),-python_single_target_python3_8(-)] required by (sys-apps/portage-2.3.79:0/0::gentoo, ebuild scheduled for merge)
                                                                                                                                                                                                                                             

  (dev-lang/python-exec-2.0.2:2/2::gentoo, installed) pulled in by
    >=dev-lang/python-exec-2:2/2=[python_targets_python2_7(-),python_targets_python3_4(-),-python_single_target_pypy(-),-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)] required by (dev-python/six-1.10.0:0/0::gentoo, installed)
                                                                                                                                                                                                                                             
    >=dev-lang/python-exec-2:2/2=[python_targets_python2_7(-),python_targets_python3_4(-),-python_single_target_pypy(-),-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)] required by (dev-python/packaging-16.6:0/0::gentoo, installed)
                                                                                                                                                                                                                                             
    >=dev-lang/python-exec-2:2/2=[python_targets_python2_7(-),python_targets_python3_4(-),-python_single_target_python2_7(-),-python_single_target_python3_3(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)] required by (sys-process/iotop-0.6:0/0::gentoo, installed)
                                                                                                                                                                                                                                             
    >=dev-lang/python-exec-2:2/2=[python_targets_python2_7(-),python_targets_python3_4(-),-python_single_target_pypy(-),-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_3(-),-python_single_target_python3_4(-)] required by (dev-python/pyasn1-0.1.8:0/0::gentoo, installed)
                                                                                                                                                                                                                                             
    >=dev-lang/python-exec-2:2/2=[python_targets_python2_7(-),python_targets_python3_4(-),-python_single_target_pypy(-),-python_single_target_python2_7(-),-python_single_target_python3_3(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)] required by (dev-python/pyopenssl-0.15.1-r1:0/0::gentoo, installed)
                                                                                                                                                                                                                                             
    >=dev-lang/python-exec-2:2/2=[python_targets_python2_7(-),python_targets_python3_4(-),-python_single_target_pypy(-),-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_3(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)] required by (dev-python/pycparser-2.14:0/0::gentoo, installed)
                                                                                                                                                                                                                                             
    >=dev-lang/python-exec-2:2/2=[python_targets_python2_7(-),python_targets_python3_4(-),-python_single_target_pypy(-),-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_3(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)] required by (virtual/python-ipaddress-1.0:0/0::gentoo, installed)
                                                                                                                                                                                                                                             
    >=dev-lang/python-exec-2:2/2=[python_targets_python2_7(-),python_targets_python3_4(-),-python_single_target_pypy(-),-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)] required by (dev-python/certifi-2015.11.20:0/0::gentoo, installed)
                                                                                                                                                                                                                                             
    >=dev-lang/python-exec-2:2/2=[python_targets_python2_7(-),python_targets_python3_4(-),-python_single_target_pypy(-),-python_single_target_python2_7(-),-python_single_target_python3_3(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)] required by (dev-python/cryptography-1.3.4:0/0::gentoo, installed)
                                                                                                                                                                                                                                             
    >=dev-lang/python-exec-2:2/2=[python_targets_python2_7(-),python_targets_python3_4(-),-python_single_target_pypy(-),-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)] required by (dev-python/pyxattr-0.5.5:0/0::gentoo, installed)
                                                                                                                                                                                                                                             
    >=dev-lang/python-exec-2:2/2=[python_targets_python3_4(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)] required by (app-backup/borgbackup-1.0.7:0/0::gentoo, installed)

    >=dev-lang/python-exec-2:2/2=[python_targets_python2_7(-),python_targets_python3_4(-),-python_single_target_pypy(-),-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_3(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)] required by (dev-python/py-1.4.30:0/0::gentoo, installed)
                                                                                                                                                                                                                                             
    >=dev-lang/python-exec-2:2/2=[python_targets_python2_7(-),python_targets_python3_4(-),-python_single_target_pypy(-),-python_single_target_python2_7(-),-python_single_target_python3_3(-),-python_single_target_python3_4(-)] required by (dev-python/ply-3.6-r1:0/0::gentoo, installed)
                                                                                                                                                                                                                                             
    >=dev-lang/python-exec-2:2/2=[python_targets_python2_7(-),python_targets_python3_4(-),-python_single_target_pypy(-),-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_3(-),-python_single_target_python3_4(-)] required by (dev-python/chardet-2.2.1:0/0::gentoo, installed)
                                                                                                                                                                                                                                             
    >=dev-lang/python-exec-2:2/2=[python_targets_python2_7(-),python_targets_python3_4(-),-python_single_target_python2_7(-),-python_single_target_python3_3(-),-python_single_target_python3_4(-)] required by (app-portage/mirrorselect-2.2.2-r2:0/0::gentoo, installed)
                                                                                                                                                                                                                                             
    >=dev-lang/python-exec-2:2/2=[python_targets_python2_7(-),python_targets_python3_4(-),-python_single_target_pypy(-),-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)] required by (dev-python/setuptools-18.4:0/0::gentoo, installed)
                                                                                                                                                                                                                                             
    >=dev-lang/python-exec-2:2/2=[python_targets_python2_7(-),python_targets_python3_4(-),-python_single_target_pypy(-),-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_3(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)] required by (dev-python/idna-2.0:0/0::gentoo, installed)
                                                                                                                                                                                                                                             
    >=dev-lang/python-exec-2:2/2=[python_targets_python2_7(-),python_targets_python3_4(-),-python_single_target_pypy(-),-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_3(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)] required by (dev-python/lockfile-0.11.0-r1:0/0::gentoo, installed)
                                                                                                                                                                                                                                             
    >=dev-lang/python-exec-2:2/2=[python_targets_python2_7(-),python_targets_python3_4(-),-python_single_target_pypy(-),-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_3(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)] required by (dev-python/requests-2.8.1:0/0::gentoo, installed)
                                                                                                                                                                                                                                             
    >=dev-lang/python-exec-2:2/2=[python_targets_python2_7(-),python_targets_python3_4(-),-python_single_target_pypy(-),-python_single_target_python2_7(-),-python_single_target_python3_3(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)] required by (dev-python/ssl-fetch-0.3:0/0::gentoo, installed)
                                                                                                                                                                                                                                             
    >=dev-lang/python-exec-2:2/2=[python_targets_python2_7(-),python_targets_python3_4(-),-python_single_target_pypy(-),-python_single_target_python2_7(-),-python_single_target_python3_3(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)] required by (dev-python/msgpack-0.4.6:0/0::gentoo, installed)
                                                                                                                                                                                                                                             
    >=dev-lang/python-exec-2:2/2=[python_targets_python2_7(-),python_targets_python3_4(-),-python_single_target_pypy(-),-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)] required by (dev-python/pyparsing-2.1.8:0/0::gentoo, installed)
                                                                                                                                                                                                                                             
    >=dev-lang/python-exec-2:2/2=[python_targets_python2_7(-),python_targets_python3_4(-),-python_single_target_python2_7(-),-python_single_target_python3_3(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)] required by (dev-python/cffi-1.5.2:0/1.5.2::gentoo, installed)
                                                                                                                                                                                                                                             
    >=dev-lang/python-exec-2:2/2=[python_targets_python2_7(-),python_targets_python3_4(-),-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)] required by (dev-libs/libxml2-2.9.4:2/2::gentoo, installed)
                                                                                                                                                                                                                                             
    >=dev-lang/python-exec-2:2/2=[python_targets_python2_7(-),python_targets_python3_4(-),-python_single_target_pypy(-),-python_single_target_python2_7(-),-python_single_target_python3_3(-),-python_single_target_python3_4(-)] required by (dev-python/llfuse-0.40:0/0::gentoo, installed)
                                                                                                                                                                                                                                             
    >=dev-lang/python-exec-2:2/2=[python_targets_python2_7(-),python_targets_python3_4(-),-python_single_target_pypy(-),-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_3(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)] required by (dev-python/ndg-httpsclient-0.4.0:0/0::gentoo, installed)
                                                                                                                                                                                                                                             


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


!!! The following installed packages are masked:
- x11-drivers/xf86-video-trident-1.3.7::gentoo (masked by: package.mask)
/usr/portage/profiles/package.mask:
# Matt Turner <mattst88@gentoo.org> (2019-03-16)
# Previously packaged drivers, now removed from Gentoo.
# Keep this mask in place so users are aware, but can also easily unmask them
# in an overlay if so desired.

- sys-libs/binutils-libs-2.25.1-r2::gentoo (masked by: package.mask)
/usr/portage/profiles/package.mask:
# Michał Górny <mgorny@gentoo.org>, Andreas K. Hüttel <dilfridge@gentoo.org>,
# Matthias Maier <tamiko@gentoo.org> (2017-05-21 and later updates)
# These old versions of toolchain packages (binutils, gcc, glibc) are no
# longer officially supported and are not suitable for general use. Using
# these packages can result in build failures (and possible breakage) for
# many packages, and may leave your system vulnerable to known security
# exploits.
# If you still use one of these old toolchain packages, please upgrade (and
# switch the compiler / the binutils) ASAP. If you need them for a specific
# (isolated) use case, feel free to unmask them on your system.

- x11-drivers/xf86-video-sisusb-0.9.6-r1::gentoo (masked by: package.mask)
- app-backup/tob-0.26-r2::gentoo (masked by: package.mask)
/usr/portage/profiles/package.mask:
# Jonas Stein <jstein@gentoo.org> (2019-12-30)
# Package masked for removal. Broken SRC_URI,
# last upstream activity was ~16 years ago.
# Bug #704316.
# Removal after 2020-03-01

- x11-drivers/xf86-video-tdfx-1.4.6::gentoo (masked by: package.mask)
- x11-drivers/xf86-video-rendition-4.2.6::gentoo (masked by: package.mask)
- x11-drivers/xf86-video-i740-1.3.5::gentoo (masked by: package.mask)
- x11-drivers/xf86-video-apm-1.2.5-r1::gentoo (masked by: package.mask)
- x11-drivers/xf86-video-savage-2.3.8::gentoo (masked by: package.mask)
- x11-drivers/xf86-video-mach64-6.9.5::gentoo (masked by: package.mask)
- dev-lang/perl-5.22.2::gentoo (masked by: package.mask)
/usr/portage/profiles/package.mask:
# Andreas K. Hüttel <dilfridge@gentoo.org> (2019-05-11)
# Perl 5.24 will be removed soon. Please upgrade.

- sys-devel/gcc-4.8.5::gentoo (masked by: package.mask)
- x11-drivers/xf86-video-cirrus-1.5.3::gentoo (masked by: package.mask)
- sys-libs/glibc-2.21-r2::gentoo (masked by: package.mask)
- virtual/perl-Exporter-5.720.0-r1::gentoo (masked by: package.mask)
/usr/portage/profiles/arch/base/package.mask:
# Andreas K. Hüttel <dilfridge@gentoo.org> (2019-08-30)
# Perl 5.26 will be removed soon. Please upgrade.
# This block is here (and not in ../../package.mask) since we still need
# it and unmask it on hppa and sparc. See bug 676062 and bug 683018.

- dev-libs/libusb-1.0.19-r1::gentoo (masked by: package.mask)
/etc/portage/package.mask:
# fix problems
# move dev-libs/libusbx dev-libs/libusb

- sys-devel/binutils-2.25.1-r1::gentoo (masked by: package.mask)
- x11-drivers/xf86-video-i128-1.3.6-r1::gentoo (masked by: package.mask)
- x11-drivers/xf86-video-s3-0.6.5-r1::gentoo (masked by: package.mask)
- sys-apps/man-1.6g::gentoo (masked by: package.mask)
/usr/portage/profiles/package.mask:
# Mike Gilbert <floppym@gentoo.org> (2019-10-11)
# Inactive upstream for many years.
# Several open bugs.
# Please migrate to sys-apps/man-db.

For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 24023
Location: here

PostPosted: Fri Jan 17, 2020 3:31 pm    Post subject: Reply with quote

Try to add backtrack as portage suggests, emerge -1 portage --backtrack=100 or emerge -uUD portage --backtrack=100
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
lindab72
n00b
n00b


Joined: 17 Jan 2020
Posts: 7
Location: Sarthe (France)

PostPosted: Fri Jan 17, 2020 3:44 pm    Post subject: Reply with quote

Thank a lot for your help but now ...
it looks like an endless loop ..

Code:
!!! All ebuilds that could satisfy ">=dev-lang/python-exec-2:=[python_targets_python2_7(-)?,python_targets_python3_6(-)?,python_targets_python3_7(-)?,python_targets_python3_8(-)?,-python_single_target_python2_7(-),-python_single_target_python3_6(-),-python_single_target_python3_7(-),-python_single_target_python3_8(-)]" have been masked.
!!! One of the following masked packages is required to complete your request:
- dev-lang/python-exec-9999::gentoo (masked by: EAPI 7)
- dev-lang/python-exec-2.4.6-r1::gentoo (masked by: EAPI 7)

The current version of portage supports EAPI '6'. You must upgrade to a
newer version of portage before EAPI masked packages can be installed.
(dependency required by "sys-apps/portage-2.3.79::gentoo" [ebuild])
(dependency required by "portage" [argument])
For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 24023
Location: here

PostPosted: Fri Jan 17, 2020 3:53 pm    Post subject: Reply with quote

Sorry you should use yet portage in your /root directory
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
lindab72
n00b
n00b


Joined: 17 Jan 2020
Posts: 7
Location: Sarthe (France)

PostPosted: Fri Jan 17, 2020 4:36 pm    Post subject: Reply with quote

I don't understand what your message means, please ?
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 24023
Location: here

PostPosted: Fri Jan 17, 2020 5:41 pm    Post subject: Reply with quote

lindab72 wrote:
I don't understand what your message means, please ?

You have run emerge command from your system but you should use that unpacked in root (./portage-portage-2.3.79/bin/emerge).
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum