Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Problem during install
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
Fred Krogh
Veteran
Veteran


Joined: 07 Feb 2005
Posts: 1036
Location: Tujunga, CA

PostPosted: Fri Jan 24, 2020 11:23 pm    Post subject: Problem during install Reply with quote

I'm typing this on another machine with a keyboard I don't like so expect some typos. Is it time for me to give up on gentoo?? This is on a AMD zen2 system. I've trying to use systemd to boot, and not support any 32 bit pakages, both of these for the first time. Help very appreciated.
Fred

Total: 53 packages (2 upgrades, l492 new, 2 in new slots), Size of downloads: 66,446 KiB
Conflict: 4 blocks (4 Unsatisfied)

* Error: The above package list contains packages which cannot be
* installed at the same time on the same system.

(sys_fs/eudev-3.2.9:0/l0: :gentoo, installed) pulled in by
>l=sys-fs/eudev-2.1.1 required by (virtual/udev-217:0/0: :gentoo, installed) USE="(-SYSTEMD)" abi_x86="(64)"

(sys-apps/systemd-244:0/2: :getnoo, ebuild scheduled for merge) pulled in by9
>==sys-apps/sytemd-207 required by 9sys-apps/gentoo-systemd-integration-8:0/0::gentoo, ebuild scheduled for merge) USE="" ABI_X86="(64)"
>=sys-apps/systemd-232:0/2[abi_x86_32(-)?abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_riscv_lp64d(-)?,abi_riscv_lp64(-)?abi_s390_32(-(?)?,abi_s390_64(-)?,static-llibs(-)?] (>=sys-apps/systemd-232:0/2[abi_s86_64(-)?] required by (virtual/libudev-232-r3:0/1: :gentoo, ebuild scheduled for merge) USE="(systemd) (-static-libs)" ABI_X86="(64) 32 (-x32)"
sys-apps/systemd:0= required by (sys-apps/dbus-1.12.16:0/0: :gentoo, ebuild scheduled for merge) USE="systemd -X --debug -doc (-elogind) (-selinux) -static-libs -test -ser-session" ABI_X86="(64) -32 (-x32)"
sys_apps/systemd required by (virtual/tmpfiles-0:0/0: :gentoo, installed) USE="" ABI_X86="(64)"

(sys-apps/sysvinit-2.93:0/0: :gentoo, installed) pulled in by
>=sys-apps/sysvinnit-2.86-r6[selinux?} (>=sys-apps/sysvinit-2.76-r6 required by (sys-apps/openrc-0.42.1:0/0: : gentoo, installed) USE="ncurses netifrc pam (split-usr) unitcode -audit -bash -debug -ewnet (-prefix) (-selinux) -statck-libs -sysv-ultils" ABI_X86="(64)"

For more information about Blocked Packages, please refer to the following section of the Gentoo Lionux x86 Handbook (architecture id irrelevant):

https://wiki.gentoo.org/wiki/Hand book:X86/Working?Portage#Blocke_packages

!!! The following installed packages are masked:
- sys-fs/eudev3.2.9: :gentoo (masked by: package.mask)
/var/db/repos/gentoo/profiles/targets/systemd/paskage.mask:
# Paho Ramos <pacho@gentoo.org> l(2015-04-21)
@ This if for running sys-apps/systemd and also helps
# portage to not try to pull in other providers leading to
# strange blocker.
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 45451
Location: 56N 3W

PostPosted: Fri Jan 24, 2020 11:52 pm    Post subject: Reply with quote

Fred Krogh,

It looks like you have started from the wrong stage3.

Code:
(sys_fs/eudev-3.2.9:0/l0: :gentoo, installed)
says that you have eudev installed already.
You can convert to systemd, or if you are the first update after unpacking the stage3, you can start over.

I don't see a no-multilib systemd stage3 tarball, which is ideally what you want.
Your choices are to start with the systemd multilb stage3 and choose a /no-multilib/ profile or to start with the eudev no multilb stage3 and convert it to systemd sometime later.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
Fred Krogh
Veteran
Veteran


Joined: 07 Feb 2005
Posts: 1036
Location: Tujunga, CA

PostPosted: Mon Jan 27, 2020 3:23 am    Post subject: Reply with quote

I'm sorry to say that (I think) I'm leaving gentoo for xubuntu. I've really appreciated all the help I've gotten here over the years. Getting xubuntu installed was a breeze. On the downside, when logging in I need to give my password twice; connecting a usb flash drive seems to log me out; since gentoo has the latest thunderbird, I can't transfer my profile to this new system until it gets a newer version of thunderbird; copy and paste from an xfce-terminal doesn't work; and I'm sure there is more to discover. I'm hoping with some more experience I'll learn (with help) to work around these things. Of course there are other changes that are not as nice for me, just because I've used Gentoo for so long and there will always be small differences. In summary leaving here is not without risk.
Goodbye all and many thanks for all the help!
Fred
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 45451
Location: 56N 3W

PostPosted: Mon Jan 27, 2020 9:51 am    Post subject: Reply with quote

Fred Krogh,

Enjoy your break from gentoo. :)
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
Hu
Moderator
Moderator


Joined: 06 Mar 2007
Posts: 15334

PostPosted: Tue Jan 28, 2020 3:00 am    Post subject: Reply with quote

Walking away from Gentoo over the stated problem, when you already have a long list of far more serious problems in Xubuntu, seems like an odd choice to me. However, it's your choice. If you decide you want to return to Gentoo, come back and we can pick up debugging where you left off.
Back to top
View user's profile Send private message
krinn
Watchman
Watchman


Joined: 02 May 2003
Posts: 7416

PostPosted: Tue Jan 28, 2020 11:39 am    Post subject: Reply with quote

i was thinking there was a natural choice for someone seeking gentoo+systemd+binarydistro
but well, using a distro is over the logic :)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum