Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
qutebrowser
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
sumati
n00b
n00b


Joined: 10 Nov 2019
Posts: 46

PostPosted: Sat Jan 25, 2020 4:52 pm    Post subject: qutebrowser Reply with quote

I have successfully installed Gentoo, everything is fine with one exception: the Qutebrowser which I have used since long in other linux. I have tried already many times, no success. The problem seems to be caused by dev-qt/qtcore. After a long list of "error" report, I see the following:

Code:
dev-qt/qtcore:5

  (dev-qt/qtcore-5.13.2:5/5.13::gentoo, installed) USE="icu systemd -debug -test" ABI_X86="(64)" pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (dev-qt/qtcore-5.14.0:5/5.14::gentoo, ebuild scheduled for merge) USE="systemd -debug -icu -test" ABI_X86="(64)" pulled in by
    ~dev-qt/qtcore-5.14.0 required by (dev-qt/qtwebengine-5.14.0:5/5.14::gentoo, ebuild scheduled for merge) USE="alsa bindist designer system-ffmpeg system-icu widgets -debug -jumbo-build -pax_kernel -pulseaudio -test" ABI_X86="(64)"
    ^              ^^^^^^


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


!!! The ebuild selected to satisfy "~dev-qt/qtgui-5.14.0" has unmet requirements.
- dev-qt/qtgui-5.14.0-r1::gentoo USE="dbus gif gles2 libinput png udev xcb -accessibility -debug -egl -eglfs -evdev -ibus -jpeg -test -tslib -tuio -vnc -wayland" ABI_X86="(64)"

  The following REQUIRED_USE flag constraints are unsatisfied:
    xcb? ( gles2? ( egl ) )

  The above constraints are a subset of the following complete expression:
    any-of ( eglfs xcb ) accessibility? ( dbus xcb ) eglfs? ( egl ) ibus? ( dbus ) libinput? ( udev ) xcb? ( gles2? ( egl ) )

(dependency required by "dev-qt/qtwebengine-5.14.0::gentoo" [ebuild])
(dependency required by "dev-python/PyQtWebEngine-5.14.0::gentoo" [ebuild])
(dependency required by "www-client/qutebrowser-1.8.3::gentoo" [ebuild])
(dependency required by "qutebrowser" [argument])

Can anyone help me?

[Moderator edit: added [code] tags to preserve output layout. -Hu]
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 24023
Location: here

PostPosted: Sat Jan 25, 2020 7:39 pm    Post subject: Reply with quote

You can post qlist -Iv dev-qt/* output?
For qtgui
Code:
xcb? ( gles2? ( egl ) )

If you enable xcb and gles2 use flags you should also enable egl
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 7720
Location: Austria

PostPosted: Sat Jan 25, 2020 8:12 pm    Post subject: Reply with quote

Why did you unmask gles2 flag?
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
sumati
n00b
n00b


Joined: 10 Nov 2019
Posts: 46

PostPosted: Sun Jan 26, 2020 9:53 am    Post subject: Reply with quote

fedeliallalinea wrote:
You can post qlist -Iv dev-qt/* output?
For qtgui
Code:
xcb? ( gles2? ( egl ) )

If you enable xcb and gles2 use flags you should also enable egl


Hi, thank you for your response. The output of qlist -Iv dev-qt/* is as follows:
Code:
dev-qt/designer-5.13.2
dev-qt/qtchooser-66
dev-qt/qtconcurrent-5.13.2
dev-qt/qtcore-5.13.2
dev-qt/qtdbus-5.13.2
dev-qt/qtdeclarative-5.13.2-r1
dev-qt/qtgui-5.13.2
dev-qt/qtlockedfile-2.4.1_p20171024
dev-qt/qtmultimedia-5.13.2-r1
dev-qt/qtnetwork-5.13.2
dev-qt/qtopengl-5.13.2
dev-qt/qtpositioning-5.13.2
dev-qt/qtprintsupport-5.13.2
dev-qt/qtscript-5.13.2
dev-qt/qtsingleapplication-2.6.1_p20171024
dev-qt/qttest-5.13.2
dev-qt/qtwebchannel-5.13.2
dev-qt/qtwebkit-5.212.0_pre20190629
dev-qt/qtwidgets-5.13.2
dev-qt/qtxml-5.13.2


[Moderator edit: added [code] tags to preserve output layout. -Hu]
Back to top
View user's profile Send private message
sumati
n00b
n00b


Joined: 10 Nov 2019
Posts: 46

PostPosted: Sun Jan 26, 2020 10:10 am    Post subject: Reply with quote

asturm wrote:
Why did you unmask gles2 flag?

because after running emerge --ask www-client/qutebrowser, the output asks me to set the USE
Code:
  dev-qt/qtprintsupport:5

  (dev-qt/qtprintsupport-5.14.0-r1:5/5.14::gentoo, ebuild scheduled for merge) USE="gles2 -cups -debug -test" ABI_X86="(64)" pulled in by
    ~dev-qt/qtprintsupport-5.14.0 required by (dev-qt/qtwebengine-5.14.0:5/5.14::gentoo, ebuild scheduled for merge)         USE="alsa bindist designer system-ffmpeg system-icu widgets -debug -jumbo-build -pax_kernel -pulseaudio -test" ABI_X86="(64)"
    ^                                                                                                                        ^^^^^^ 

However, the other asks me to remove gles2. Can you let me know the complete list of USE flags necessary for installing Qutebrowser?
The whole output resulting from "emerge --ask www-client/qutebrowser" is as follows:
Code:


These are the packages that would be merged, in order:

Calculating dependencies... done!


[ebuild  N     ] www-client/qutebrowser-1.8.3::gentoo  USE="scripts -test" PYTHON_TARGETS="python3_6 -python3_7" 3,550 KiB
[nomerge       ]  dev-python/jinja-2.10.3-r1::gentoo  USE="doc -examples -test" PYTHON_TARGETS="pypy3 python2_7 python3_6 python3_7 python3_8"
[ebuild  N     ]   dev-python/pallets-sphinx-themes-1.1.2::gentoo  PYTHON_TARGETS="python3_6 -pypy3 -python2_7 -python3_7" 17 KiB
[ebuild  N     ]    dev-python/jinja-2.10.3-r1::gentoo  USE="doc -examples -test" PYTHON_TARGETS="pypy3 python2_7 python3_6 python3_7 python3_8" 0 KiB
[ebuild  N     ]     dev-python/sphinx-issues-1.2.0::gentoo  USE="-test" PYTHON_TARGETS="python3_6 -python2_7 -python3_7" 8 KiB
[nomerge       ] app-portage/layman-2.4.2-r2::gentoo  USE="git -bazaar -cvs -darcs -g-sorcery -gpg -mercurial -sqlite -squashfs -subversion -sync-plugin-portage -test" PYTHON_TARGETS="python2_7 python3_6 -python3_7"
[nomerge       ]  dev-python/ssl-fetch-0.4::gentoo  PYTHON_TARGETS="python2_7 python3_6 -pypy -python3_5 -python3_7 -python3_8"
[ebuild   R    ]   dev-python/requests-2.22.0::gentoo  USE="ssl -socks5 -test" PYTHON_TARGETS="pypy3* python2_7 python3_6 python3_7* python3_8* (-pypy%) (-python3_5%)" 0 KiB
[ebuild   R    ]    dev-python/urllib3-1.25.7::gentoo  USE="doc* -brotli -test" PYTHON_TARGETS="pypy3* python2_7 python3_6 python3_7* python3_8* (-pypy%) (-python3_5%)" 0 KiB
[ebuild   R    ]     dev-python/pyopenssl-19.1.0::gentoo  USE="doc* -test" PYTHON_TARGETS="pypy3* python2_7 python3_6 python3_7* python3_8* (-pypy%) (-python3_5%)" 0 KiB
[ebuild     U  ]      dev-python/cryptography-2.8-r1::gentoo [2.8::gentoo] USE="-idna -libressl -test" PYTHON_TARGETS="pypy3* python2_7 python3_6 python3_7* python3_8* (-pypy%) (-python3_5%)" 0 KiB
[ebuild   R    ]       dev-python/cffi-1.13.2:0/1.13.2::gentoo  USE="doc* -test" PYTHON_TARGETS="python2_7 python3_6 python3_7* python3_8* (-python3_5%)" 0 KiB
[nomerge       ] app-admin/system-config-printer-1.5.12::gentoo  USE="-doc -gnome-keyring -policykit" PYTHON_SINGLE_TARGET="python3_6 -python3_5 -python3_7" PYTHON_TARGETS="python3_6 -python3_5 -python3_7"
[nomerge       ]  dev-python/requests-2.22.0::gentoo  USE="ssl -socks5 -test" PYTHON_TARGETS="pypy3* python2_7 python3_6 python3_7* python3_8* (-pypy%) (-python3_5%)"
[nomerge       ]   dev-python/cryptography-2.8-r1::gentoo [2.8::gentoo] USE="-idna -libressl -test" PYTHON_TARGETS="pypy3* python2_7 python3_6 python3_7* python3_8* (-pypy%) (-python3_5%)"
[nomerge       ]    dev-python/six-1.13.0::gentoo  USE="doc* -test" PYTHON_TARGETS="pypy3* python2_7 python3_6 python3_7* python3_8* (-pypy%) (-python3_5%)"
[nomerge       ]     dev-python/sphinx-2.0.1::gentoo  USE="doc latex -test" PYTHON_TARGETS="pypy3 python3_6 python3_7 python3_8"
[ebuild  N     ]      dev-python/Babel-2.8.0::gentoo  USE="doc -test" PYTHON_TARGETS="pypy3 python2_7 python3_6 python3_7 python3_8" 8,247 KiB
[ebuild  N     ]      dev-python/docutils-0.15.2::gentoo  PYTHON_TARGETS="pypy3 python2_7 python3_6 python3_7 python3_8" 1,756 KiB
[ebuild  N     ]      dev-python/packaging-20.0::gentoo  USE="-test" PYTHON_TARGETS="pypy3 python2_7 python3_6 python3_7 python3_8" 71 KiB
[ebuild  N     ]      dev-python/pygments-2.5.2::gentoo  USE="doc -test" PYTHON_TARGETS="pypy3 python2_7 python3_6 python3_7 python3_8" 19,790 KiB
[ebuild   R    ]    dev-python/six-1.13.0::gentoo  USE="doc* -test" PYTHON_TARGETS="pypy3* python2_7 python3_6 python3_7* python3_8* (-pypy%) (-python3_5%)" 0 KiB
[ebuild  N     ]     dev-python/sphinx-2.0.1::gentoo  USE="doc latex -test" PYTHON_TARGETS="pypy3 python3_6 python3_7 python3_8" 5,877 KiB

Total: 15 packages (1 upgrade, 9 new, 5 reinstalls), Size of downloads: 39,312 KiB

 * Error: circular dependencies:

(dev-python/sphinx-2.0.1:0/0::gentoo, ebuild scheduled for merge) depends on
 (dev-python/Babel-2.8.0:0/0::gentoo, ebuild scheduled for merge) (buildtime)
  (dev-python/sphinx-2.0.1:0/0::gentoo, ebuild scheduled for merge) (buildtime)

It might be possible to break this cycle
by applying the following change:
- dev-python/Babel-2.8.0 (Change USE: -doc)

Note that this change can be reverted, once the package has been installed.

Note that the dependency graph contains a lot of cycles.
Several changes might be required to resolve all cycles.
Temporarily changing some use flag for all packages might be the better option.

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-qt/qtcore:5

  (dev-qt/qtcore-5.13.2:5/5.13::gentoo, installed) USE="icu systemd -debug -test" ABI_X86="(64)" pulled in by
    ~dev-qt/qtcore-5.13.2 required by (dev-qt/qtprintsupport-5.13.2:5/5.13::gentoo, installed) USE="-cups -debug -gles2 -test" ABI_X86="(64)"
    ^              ^^^^^^                                                                                                                                                                                                                                                                         
    (and 6 more with the same problem)

  (dev-qt/qtcore-5.14.0:5/5.14::gentoo, ebuild scheduled for merge) USE="systemd -debug -icu -test" ABI_X86="(64)" pulled in by
    ~dev-qt/qtcore-5.14.0 required by (dev-qt/qtnetworkauth-5.14.0:5/5.14::gentoo, ebuild scheduled for merge) USE="-debug -test" ABI_X86="(64)"
    ^              ^^^^^^                                                                                                                                                                                                                                       
    (and 23 more with the same problem)

dev-libs/openssl:0

  (dev-libs/openssl-1.1.1d-r3:0/1.1::gentoo, installed) USE="asm zlib -bindist -rfc3779 -sctp -sslv3 -static-libs -test -tls-heartbeat -vanilla" ABI_X86="(64) -32 (-x32)" CPU_FLAGS_X86="(sse2)" pulled in by
    dev-libs/openssl:0[-bindist(-)] required by (dev-python/cryptography-2.8-r1:0/0::gentoo, ebuild scheduled for merge) USE="-idna -libressl -test" ABI_X86="(64)" PYTHON_TARGETS="pypy3 python2_7 python3_6 python3_7 python3_8"
                                                                                                                                                                                                                                                                                                                                                                                                                             
    dev-libs/openssl:0/1.1=[-bindist] required by (dev-qt/qtnetwork-5.13.2:5/5.13::gentoo, installed) USE="ssl -bindist -connman -debug -libproxy -networkmanager -sctp -test" ABI_X86="(64)"
                            ^^^^^^^^                                                                                                                                                                                                                                                                                                                                                                       
    >=dev-libs/openssl-1.0.2:0/1.1=[-bindist,abi_x86_64(-)] required by (net-libs/nghttp2-1.40.0:0/1.14::gentoo, installed) USE="cxx threads -debug -hpack-tools -jemalloc -libressl -static-libs -test -utils -xml" ABI_X86="(64) -32 (-x32)"
                                    ^^^^^^^^                                                                                                                                                                                                                                                                                                                                                                                                                                                                                             
    >=dev-libs/openssl-1.0.2:0=[-bindist,abi_x86_32(-)?,abi_x86_64(-)?,
      abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,
      abi_riscv_lp64d(-)?,abi_riscv_lp64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] required by (net-libs/nghttp2-1.40.0:0/1.14::gentoo, installed) USE="cxx threads -debug -hpack-tools -jemalloc -libressl -static-libs -test -utils -xml" ABI_X86="(64) -32 (-x32)"
                                ^^^^^^^^                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                       
    dev-libs/openssl:0=[bindist=] required by (dev-qt/qtnetwork-5.13.2:5/5.13::gentoo, installed) USE="ssl -bindist -connman -debug -libproxy -networkmanager -sctp -test" ABI_X86="(64)"
                        ^^^^^^^^                                                                                                                                                                                                                                                                                                                                                                       
    >=dev-libs/openssl-1.1.0g:0[bindist=] required by (net-misc/openssh-8.1_p1-r1:0/0::gentoo, installed) USE="X pam pie ssl -X509 -audit -bindist -debug -hpn -kerberos -ldns -libedit -libressl -livecd -sctp (-selinux) -static -test -xmss" ABI_X86="(64)"
                                ^^^^^^^^                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                     

  (dev-libs/openssl-1.1.1d-r3:0/1.1::gentoo, ebuild scheduled for merge) USE="asm bindist zlib -rfc3779 -sctp -sslv3 -static-libs -test -tls-heartbeat -vanilla" ABI_X86="(64) -32 (-x32)" CPU_FLAGS_X86="(sse2)" pulled in by
    dev-libs/openssl:0=[bindist=] required by (dev-qt/qtnetwork-5.14.0:5/5.14::gentoo, ebuild scheduled for merge) USE="bindist ssl -connman -debug -libproxy -networkmanager -sctp -test" ABI_X86="(64)"
                        ^^^^^^^^                                                                                                                                                                                                                                                                                                                                                                                       

dev-qt/qtprintsupport:5

  (dev-qt/qtprintsupport-5.14.0-r1:5/5.14::gentoo, ebuild scheduled for merge) USE="gles2 -cups -debug -test" ABI_X86="(64)" pulled in by
    ~dev-qt/qtprintsupport-5.14.0 required by (dev-qt/qtwebengine-5.14.0:5/5.14::gentoo, ebuild scheduled for merge) USE="alsa bindist designer system-ffmpeg system-icu widgets -debug -jumbo-build -pax_kernel -pulseaudio -test" ABI_X86="(64)"
    ^                      ^^^^^^                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                           
    (and 1 more with the same problem)

  (dev-qt/qtprintsupport-5.13.2:5/5.13::gentoo, installed) USE="-cups -debug -gles2 -test" ABI_X86="(64)" pulled in by
    dev-qt/qtprintsupport:5[-gles2] required by (net-misc/dropbox-83.4.152:0/0::gentoo, installed) USE="X librsync-bundled (-selinux)" ABI_X86="(64)"
                            ^^^^^^                                                                                                                                                                                                                                   

dev-qt/qtwidgets:5

  (dev-qt/qtwidgets-5.14.0:5/5.14::gentoo, ebuild scheduled for merge) USE="gles2 gtk png xcb -debug -test" ABI_X86="(64)" pulled in by
    ~dev-qt/qtwidgets-5.14.0 required by (dev-qt/qthelp-5.14.0:5/5.14::gentoo, ebuild scheduled for merge) USE="-debug -test" ABI_X86="(64)"
    ^                 ^^^^^^                                                                                                                                                                                                                               
    (and 5 more with the same problem)

  (dev-qt/qtwidgets-5.13.2:5/5.13::gentoo, installed) USE="gtk png xcb -debug -gles2 -test" ABI_X86="(64)" pulled in by
    dev-qt/qtwidgets:5[-gles2] required by (net-misc/dropbox-83.4.152:0/0::gentoo, installed) USE="X librsync-bundled (-selinux)" ABI_X86="(64)"
                       ^^^^^^                                                                                                                                                                                                                                   
    ~dev-qt/qtwidgets-5.13.2[gles2=] required by (dev-qt/qtmultimedia-5.13.2-r1:5/5.13::gentoo, installed) USE="alsa widgets -debug -gles2 -gstreamer -openal -pulseaudio -qml -test" ABI_X86="(64)"
    ^                 ^^^^^^                                                                                                                                                                                                                                                                                                                                                                                                                             
    >=dev-qt/qtwidgets-5.9.1:5/5.13= required by (dev-qt/qtwebkit-5.212.0_pre20190629:5/5.212::gentoo, installed) USE="X gstreamer hyphen jit printsupport -geolocation -gles2 -multimedia -nsplugin -opengl -orientation -qml -webp" ABI_X86="(64)"
                            ^^^^^^^^                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                             
    (and 2 more with the same problems)

dev-qt/qtgui:5

  (dev-qt/qtgui-5.14.0-r1:5/5.14::gentoo, ebuild scheduled for merge) USE="dbus egl gif gles2 libinput png udev xcb -accessibility -debug -eglfs -evdev -ibus -jpeg -test -tslib -tuio -vnc -wayland" ABI_X86="(64)" pulled in by
    ~dev-qt/qtgui-5.14.0 required by (dev-qt/qthelp-5.14.0:5/5.14::gentoo, ebuild scheduled for merge) USE="-debug -test" ABI_X86="(64)"
    ^             ^^^^^^                                                                                                                                                                                                                               
    >=dev-qt/qtgui-5.10:5[gles2=] required by (dev-python/PyQt5-5.14.1:0/0::gentoo, ebuild scheduled for merge) USE="bluetooth dbus declarative designer gles2 gui help location multimedia network networkauth opengl positioning printsupport sensors serialport sql ssl svg testlib webchannel webkit websockets widgets x11extras xmlpatterns -debug -examples" ABI_X86="(64)" PYTHON_TARGETS="python2_7 python3_6 -python3_7 -python3_8"
                          ^^^^^^                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                   
    (and 9 more with the same problems)

  (dev-qt/qtgui-5.13.2:5/5.13::gentoo, installed) USE="dbus gif jpeg libinput png udev xcb -accessibility -debug -egl -eglfs -evdev -gles2 -ibus -test -tslib -tuio -vnc -wayland" ABI_X86="(64)" pulled in by
    dev-qt/qtgui:5[-gles2,xcb] required by (net-misc/dropbox-83.4.152:0/0::gentoo, installed) USE="X librsync-bundled (-selinux)" ABI_X86="(64)"
                   ^^^^^^                                                                                                                                                                                                                                       
    ~dev-qt/qtgui-5.13.2[dbus] required by (dev-qt/qtwidgets-5.13.2:5/5.13::gentoo, installed) USE="gtk png xcb -debug -gles2 -test" ABI_X86="(64)"
    ^             ^^^^^^                                                                                                                                                                                                                                                                                                                       
    (and 4 more with the same problems)

dev-qt/qtdbus:5

  (dev-qt/qtdbus-5.14.0:5/5.14::gentoo, ebuild scheduled for merge) USE="-debug -test" ABI_X86="(64)" pulled in by
    ~dev-qt/qtdbus-5.14.0 required by (dev-qt/qtgui-5.14.0-r1:5/5.14::gentoo, ebuild scheduled for merge) USE="dbus egl gif gles2 libinput png udev xcb -accessibility -debug -eglfs -evdev -ibus -jpeg -test -tslib -tuio -vnc -wayland" ABI_X86="(64)"
    ^              ^^^^^^                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                 
    (and 2 more with the same problem)

  (dev-qt/qtdbus-5.13.2:5/5.13::gentoo, installed) USE="-debug -test" ABI_X86="(64)" pulled in by
    ~dev-qt/qtdbus-5.13.2 required by (dev-qt/qtgui-5.13.2:5/5.13::gentoo, installed) USE="dbus gif jpeg libinput png udev xcb -accessibility -debug -egl -eglfs -evdev -gles2 -ibus -test -tslib -tuio -vnc -wayland" ABI_X86="(64)"
    ^              ^^^^^^                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                               

dev-qt/qtnetwork:5

  (dev-qt/qtnetwork-5.14.0:5/5.14::gentoo, ebuild scheduled for merge) USE="bindist ssl -connman -debug -libproxy -networkmanager -sctp -test" ABI_X86="(64)" pulled in by
    ~dev-qt/qtnetwork-5.14.0 required by (dev-qt/designer-5.14.0:5/5.14::gentoo, ebuild scheduled for merge) USE="declarative webkit -debug -test" ABI_X86="(64)"
    ^                 ^^^^^^                                                                                                                                                                                                                                                                                           
    (and 8 more with the same problem)

  (dev-qt/qtnetwork-5.13.2:5/5.13::gentoo, installed) USE="ssl -bindist -connman -debug -libproxy -networkmanager -sctp -test" ABI_X86="(64)" pulled in by
    ~dev-qt/qtnetwork-5.13.2 required by (dev-qt/qtmultimedia-5.13.2-r1:5/5.13::gentoo, installed) USE="alsa widgets -debug -gles2 -gstreamer -openal -pulseaudio -qml -test" ABI_X86="(64)"
    ^                 ^^^^^^                                                                                                                                                                                                                                                                                                                                                                                                                     

NOTE: Use the '--verbose-conflicts' option to display parents omitted above

It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


[Moderator edit: changed [quote] tags to [code] tags to preserve output layout. -Hu]
Wrapped a long line to make the forum layout behave.Chiitoo
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 24023
Location: here

PostPosted: Sun Jan 26, 2020 11:44 am    Post subject: Reply with quote

sumati wrote:
asturm wrote:
Why did you unmask gles2 flag?

because after running emerge --ask www-client/qutebrowser, the output asks me to set the USE

Because you enable it in PyQt5 package.

You are in a unstable system, right? If yes some packages are not updated, try first to run emerge -uUD @world --backtrack=30.
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
sumati
n00b
n00b


Joined: 10 Nov 2019
Posts: 46

PostPosted: Mon Jan 27, 2020 10:31 am    Post subject: Reply with quote

fedeliallalinea wrote:
sumati wrote:
asturm wrote:
Why did you unmask gles2 flag?

because after running emerge --ask www-client/qutebrowser, the output asks me to set the USE

Because you enable it in PyQt5 package.

You are in a unstable system, right? If yes some packages are not updated, try first to run emerge -uUD @world --backtrack=30.


I have tried the suggestion, the problem of <dependency required by "dev-python/PyQt5-5.14.1::gentoo[webkit]"> is still there.
It is strange for me that in the Gentoo-Wiki (https://wiki.gentoo.org/wiki/Qutebrowser) it is said qutebrowser is available to install with "emerge --ask www-client/qutebrowser", the only required USE flag is "scripts", but it does not work at all. This seems to be not updated. Can anyone who personally uses Qutebrowser give me some concrete workable suggestions?
Back to top
View user's profile Send private message
The Doctor
Moderator
Moderator


Joined: 27 Jul 2010
Posts: 2617

PostPosted: Mon Jan 27, 2020 4:04 pm    Post subject: Reply with quote

qutebrowser user here. What you have is actually fairly common anytime you try to customize your install. This isn't the last time you will face these errors, but in future you will learn to interpret them. The more custom your install the more often this happens. Don't panic, we all have a thread like this somewhere in our history ;)

without seeing the exact error in question I can only guess, however I believe its telling you that to dev-python/PyQt5 installed with the webkit flag requires the package with specific use flags to complete.
_________________
First things first, but not necessarily in that order.

Apologies if I take a while to respond. I'm currently working on the dematerialization circuit for my blue box.
Back to top
View user's profile Send private message
sumati
n00b
n00b


Joined: 10 Nov 2019
Posts: 46

PostPosted: Wed Jan 29, 2020 9:06 pm    Post subject: Reply with quote

The Doctor wrote:
qutebrowser user here. What you have is actually fairly common anytime you try to customize your install. This isn't the last time you will face these errors, but in future you will learn to interpret them. The more custom your install the more often this happens. Don't panic, we all have a thread like this somewhere in our history ;)

without seeing the exact error in question I can only guess, however I believe its telling you that to dev-python/PyQt5 installed with the webkit flag requires the package with specific use flags to complete.

thank you for your nice words! I want to learn Gentoo by using Gentoo. I will try again to install dev-python/PyQt5, and try also to realize where is the problem, then I come back when I need your help.
Back to top
View user's profile Send private message
sumati
n00b
n00b


Joined: 10 Nov 2019
Posts: 46

PostPosted: Thu Jan 30, 2020 10:02 am    Post subject: Reply with quote

Dear all,
for installing Qutebrowser, I tried to install dev-python/PyQt5, no success, here is the output:
Code:
These are the packages that would be merged, in order:
Calculating dependencies \
!!! Problem resolving dependencies for dev-python/PyQt5
... done!
!!! The ebuild selected to satisfy "dev-python/PyQt5" has unmet requirements.
- dev-python/PyQt5-5.14.1::gentoo USE="ssl webkit -bluetooth -dbus -debug -declarative -designer -examples -gles2 -gui -help -location -multimedia -network -networkauth -opengl -positioning -printsupport -sensors -serialport -sql -svg -testlib -webchannel -websockets -widgets -x11extras -xmlpatterns" ABI_X86="(64)" PYTHON_TARGETS="python2_7 python3_6 -python3_7 -python3_8"
  The following REQUIRED_USE flag constraints are unsatisfied:
    webkit? ( gui network printsupport widgets )
  The above constraints are a subset of the following complete expression:
    any-of ( python_targets_python2_7 python_targets_python3_6 python_targets_python3_7 python_targets_python3_8 ) bluetooth? ( gui ) declarative? ( gui network ) designer? ( widgets ) help? ( gui widgets ) location? ( positioning ) multimedia? ( gui network ) networkauth? ( network ) opengl? ( gui widgets ) positioning? ( gui ) printsupport? ( gui widgets ) sensors? ( gui ) serialport? ( gui ) sql? ( widgets ) svg? ( gui widgets ) testlib? ( widgets ) webchannel? ( network ) webkit? ( gui network printsupport widgets ) websockets? ( network ) widgets? ( gui ) xmlpatterns? ( network )
Any suggestions would be greatly appreciated, especially the suggestions directly related to the installation of Qutebrowser, which requires also dev-qt/qtwidgets, dev-qt/qtgui, dev-qt/qtnetwork and dev-qt/qtcore.
By the way, I have read some discussion on installation of Qutebrower, but these are quite old, did not help me.

[Moderator edit: changed [quote] tags to [code] tags to preserve output layout. -Hu]
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 24023
Location: here

PostPosted: Thu Jan 30, 2020 10:08 am    Post subject: Reply with quote

sumati please next time use code tag for emerge output.
Code:
The following REQUIRED_USE flag constraints are unsatisfied:
webkit? ( gui network printsupport widgets )

If you enable webkit use flag in dev-python/PyQt5 you must enable also gui, network, printsupport and widgets use flags
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
dmpogo
Advocate
Advocate


Joined: 02 Sep 2004
Posts: 2686
Location: Canada

PostPosted: Thu Jan 30, 2020 3:16 pm    Post subject: Reply with quote

Why is webkit discussed ? My understanding was that qutebrowser uses qtwebengine, am I wrong ?
Back to top
View user's profile Send private message
Chiitoo
Administrator
Administrator


Joined: 28 Feb 2010
Posts: 2036
Location: Here and Away Again

PostPosted: Fri Jan 31, 2020 1:33 pm    Post subject: ><)))°€ Reply with quote

dmpogo wrote:
Why is webkit discussed ? My understanding was that qutebrowser uses qtwebengine, am I wrong ?

It can use either, though the ebuilds in the Gentoo repository only support qtwebengine.
_________________
Kind regards,
Chiitoo.

You might remember me from Gentoo projects such as Forums, LXQt, Qt, and Wine.
Back to top
View user's profile Send private message
sumati
n00b
n00b


Joined: 10 Nov 2019
Posts: 46

PostPosted: Fri Jan 31, 2020 9:27 pm    Post subject: Reply with quote

fedeliallalinea wrote:
sumati please next time use code tag for emerge output.
Code:
The following REQUIRED_USE flag constraints are unsatisfied:
webkit? ( gui network printsupport widgets )

If you enable webkit use flag in dev-python/PyQt5 you must enable also gui, network, printsupport and widgets use flags

fedeliallalinea, thanks, I will use "code" instead of "quote". Follow your suggestion, I have added gui, network, printsupport and widgets in the line of "USE" in the file /etc/portage/make.conf, however still no success. I have also tried before to install qtwebengine, also failed after taking very long time to compile the package.
Can anyone share with me his experience of installing qutebrowser? There are a lot of dependencies, and conflicts in installing these dependencies. I come from arch, there the installation of qutebrowser is quite simple. In gentoo wiki, I cannot find any useful information about the installation.
Back to top
View user's profile Send private message
Chiitoo
Administrator
Administrator


Joined: 28 Feb 2010
Posts: 2036
Location: Here and Away Again

PostPosted: Fri Jan 31, 2020 9:54 pm    Post subject: Reply with quote

sumati wrote:
I have added gui, network, printsupport and widgets in the line of "USE" in the file /etc/portage/make.conf, however still no success.

You might want to move those into a 'package.use' file/directory, instead of enabling them globally. :]

Quote:
Can anyone share with me his experience of installing qutebrowser? There are a lot of dependencies, and conflicts in installing these dependencies. I come from arch, there the installation of qutebrowser is quite simple. In gentoo wiki, I cannot find any useful information about the installation.

The reason there is no more information in the wiki is probably because there really isn't more that is needed.
Code:
Calculating dependencies                  ... done!
[ebuild  N     ] www-client/qutebrowser-1.8.3::gentoo  USE="-scripts -test" PYTHON_TARGETS="python3_7 -python3_6" 3,550 KiB
[ebuild  N     ]  dev-python/attrs-19.3.0::gentoo  USE="-test" PYTHON_TARGETS="python3_7 python3_8 -pypy3 -python2_7 -python3_6" 130 KiB
[ebuild  N     ]   dev-python/zope-interface-4.7.1::gentoo  USE="-test" PYTHON_TARGETS="python3_7 python3_8 -pypy3 -python2_7 -python3_6" 148 KiB
[ebuild  N     ]    dev-python/namespace-zope-1::gentoo  PYTHON_TARGETS="python3_7 python3_8 -pypy3 -python2_7 -python3_6" 0 KiB
[ebuild  N     ]  dev-python/colorama-0.4.3::gentoo  USE="-examples -test" PYTHON_TARGETS="python3_7 python3_8 -pypy3 -python2_7 -python3_6" 105 KiB
[ebuild  N     ]  dev-python/cssutils-1.0.2-r2::gentoo  USE="-test" PYTHON_TARGETS="python3_7 python3_8 -python2_7 -python3_6" 359 KiB
[ebuild  N     ]  dev-python/jinja-2.10.3-r1::gentoo  USE="-doc -examples -test" PYTHON_TARGETS="python3_7 python3_8 -pypy3 -python2_7 -python3_6" 261 KiB
[ebuild  N     ]  dev-python/pypeg2-2.15.2::gentoo  PYTHON_TARGETS="python3_7 -python2_7 -python3_6" 0 KiB
[ebuild     U  ]  dev-python/pyyaml-5.3::gentoo [5.1.2::gentoo] USE="libyaml* -examples" PYTHON_TARGETS="python3_7 python3_8 -pypy3 -python2_7 -python3_6" 262 KiB
[ebuild  N     ]  app-text/asciidoc-8.6.10_p20181016::gentoo  USE="-examples -graphviz -highlight -test" PYTHON_SINGLE_TARGET="python3_7 -pypy3 -python3_6" PYTHON_TARGETS="python3_7 -pypy3 -python3_6" 0 KiB
[ebuild  N     ]  dev-python/PyQt5-5.14.1::gentoo  USE="declarative gui multimedia network opengl printsupport sql ssl webchannel widgets -bluetooth -dbus -debug -designer -examples -gles2 -help -location -networkauth -positioning -sensors -serialport -svg -testlib -webkit -websockets -x11extras -xmlpatterns" PYTHON_TARGETS="python3_7 python3_8 -python2_7 -python3_6" 3,166 KiB
[ebuild  N     ]   dev-python/PyQt5-sip-4.19.20:0/12::gentoo  PYTHON_TARGETS="python3_7 python3_8 -python2_7 -python3_6" 1,026 KiB
[ebuild   R   *]   dev-qt/qtmultimedia-5.15.9999:5/5.15::qt  USE="alsa openal qml widgets* -debug -gles2 -gstreamer -pulseaudio -test" 0 KiB
[ebuild  N     ]   dev-python/sip-4.19.20:0/12::gentoo  USE="-doc" PYTHON_TARGETS="python3_7 python3_8 -python2_7 -python3_6" 0 KiB
[ebuild  N     ]  dev-python/PyQtWebEngine-5.14.0::gentoo  USE="-debug" PYTHON_TARGETS="python3_7 python3_8 -python2_7 -python3_6" 47 KiB

Total: 15 packages (1 upgrade, 13 new, 1 reinstall), Size of downloads: 9,050 KiB

Mind you, I did not actually go through with the install, but there are no conflicts for me. If you have been throwing USE-flags into 'make.conf' a lot, I suspect that might well be the reason for your conflicts.

In any case, we can't help you if you don't show us what exactly you did, and what the conflicts/build errors are. Please share the emerge command(s) used, as well as the ensuing output (use a 'pastebin' for long ones; qtwebengine builds might not fit completely to those even, so you might need to do it in parts, or/and search for words such as 'failed:', 'error:', 'killed', and others that I'm forgetting right now). A very common cause for 'qtwebengine' builds to fail is the machine running out of RAM (output of 'emerge --info' could be helpful too).
_________________
Kind regards,
Chiitoo.

You might remember me from Gentoo projects such as Forums, LXQt, Qt, and Wine.
Back to top
View user's profile Send private message
sumati
n00b
n00b


Joined: 10 Nov 2019
Posts: 46

PostPosted: Sat Feb 01, 2020 10:30 am    Post subject: Reply with quote

Quote:
In any case, we can't help you if you don't show us what exactly you did, and what the conflicts/build errors are. Please share the emerge command(s) used, as well as the ensuing output (use a 'pastebin' for long ones; qtwebengine builds might not fit completely to those even, so you might need to do it in parts, or/and search for words such as 'failed:', 'error:', 'killed', and others that I'm forgetting right now). A very common cause for 'qtwebengine' builds to fail is the machine running out of RAM (output of 'emerge --info' could be helpful too).

Thanks! I tried again. Here is the output:
Code:
jantumati /home/sumati # emerge --ask  www-client/qutebrowser

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     U  ] dev-python/PyQt5-sip-4.19.20 [4.19.19] PYTHON_TARGETS="-python3_7*"
[ebuild     U  ] dev-python/sip-4.19.20 [4.19.19] PYTHON_TARGETS="-python3_7*"
[ebuild  N     ] dev-python/pyyaml-5.1.2  USE="libyaml -examples" PYTHON_TARGETS="python2_7 python3_6 -pypy3 -python3_7 -python3_8"
[ebuild  N     ] dev-python/colorama-0.4.3  USE="-examples -test" PYTHON_TARGETS="python2_7 python3_6 -pypy3 -python3_7 -python3_8"
[ebuild  N     ] dev-python/pypeg2-2.15.2  PYTHON_TARGETS="python2_7 python3_6 -python3_7"
[ebuild  N     ] dev-python/cssutils-1.0.2-r2  USE="-test" PYTHON_TARGETS="python2_7 python3_6 -python3_7 -python3_8"
[ebuild  N     ] dev-python/pygments-2.5.2  USE="-doc -test" PYTHON_TARGETS="python2_7 python3_6 -pypy3 -python3_7 -python3_8"
[ebuild  N     ] dev-python/jinja-2.10.3-r1  USE="-doc -examples -test" PYTHON_TARGETS="python2_7 python3_6 -pypy3 -python3_7 -python3_8"
[ebuild  N     ] dev-python/namespace-zope-1  PYTHON_TARGETS="python2_7 python3_6 -pypy3 -python3_7 -python3_8"
[ebuild  N     ] dev-python/zope-interface-4.7.1  USE="-test" PYTHON_TARGETS="python2_7 python3_6 -pypy3 -python3_7 -python3_8"
[ebuild  N     ] dev-python/attrs-19.3.0  USE="-test" PYTHON_TARGETS="python2_7 python3_6 -pypy3 -python3_7 -python3_8"
[ebuild     U  ] dev-qt/qtcore-5.14.0 [5.13.2] USE="-icu*"
[ebuild     U  ] dev-qt/qtnetwork-5.14.0 [5.13.2]
[ebuild     U  ] dev-qt/qtdbus-5.14.0 [5.13.2]
[ebuild     U  ] dev-qt/qttest-5.14.0 [5.13.2]
[ebuild  N     ] dev-qt/qtsql-5.14.0  USE="sqlite -debug -freetds -mysql -oci8 -odbc -postgres -test"
[ebuild     U  ] dev-qt/qtgui-5.14.0-r1 [5.13.2] USE="-jpeg*"
[ebuild  r  U  ] dev-qt/qtwidgets-5.14.0 [5.13.2]
[ebuild     U  ] dev-qt/qtdeclarative-5.14.0 [5.13.2-r1]
[ebuild     U  ] dev-qt/qtprintsupport-5.14.0-r1 [5.13.2]
[ebuild     U  ] dev-qt/qtwebchannel-5.14.0 [5.13.2]
[ebuild     U  ] dev-qt/qtpositioning-5.14.0 [5.13.2]
[ebuild  rR    ] dev-qt/qtwebkit-5.212.0_pre20190629
[ebuild   R    ] dev-python/PyQt5-5.13.2  USE="declarative* multimedia* network* opengl* printsupport* sql* webchannel* -dbus*"
[ebuild  N     ] dev-qt/qtwebengine-5.14.0  USE="alsa system-ffmpeg system-icu widgets -bindist -debug -designer -jumbo-build -pax_kernel -pulseaudio -test"
[ebuild  N     ] dev-python/PyQtWebEngine-5.14.0  USE="-debug" PYTHON_TARGETS="python2_7 python3_6 -python3_7 -python3_8"
[ebuild  N     ] www-client/qutebrowser-1.8.3  USE="scripts -test" PYTHON_TARGETS="python3_6 -python3_7"

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-python/PyQt5:0

  (dev-python/PyQt5-5.13.2:0/0::gentoo, ebuild scheduled for merge) USE="declarative gui multimedia network opengl printsupport sql ssl webchannel widgets -bluetooth -dbus -debug -designer -examples -gles2 -help -location -networkauth -positioning -sensors -serialport -svg -testlib -webkit -websockets -x11extras -xmlpatterns" ABI_X86="(64)" PYTHON_TARGETS="python2_7 python3_6 -python3_7 -python3_8" pulled in by
    >=dev-python/PyQt5-5.12[python_targets_python3_6(-)?,python_targets_python3_7(-)?,-python_single_target_python3_6(-),-python_single_target_python3_7(-),declarative,multimedia,gui,network,opengl,printsupport,sql,widgets] required by (www-client/qutebrowser-1.8.3:0/0::gentoo, ebuild scheduled for merge) USE="scripts -test" ABI_X86="(64)" PYTHON_TARGETS="python3_6 -python3_7"
                                                                                                                                                            ^^^^^^^^^^^ ^^^^^^^^^^     ^^^^^^^ ^^^^^^ ^^^^^^^^^^^^ ^^^                                                                                                                                                                                                                                                                                                                                                                                                       
    >=dev-python/PyQt5-5.13.1[gui,network,printsupport,ssl,webchannel,widgets,python_targets_python2_7(-)?,python_targets_python3_6(-)?,python_targets_python3_7(-)?,python_targets_python3_8(-)?,-python_single_target_python2_7(-),-python_single_target_python3_6(-),-python_single_target_python3_7(-),-python_single_target_python3_8(-)] required by (dev-python/PyQtWebEngine-5.14.0:0/0::gentoo, ebuild scheduled for merge) USE="-debug" ABI_X86="(64)" PYTHON_TARGETS="python2_7 python3_6 -python3_7 -python3_8"
                                  ^^^^^^^ ^^^^^^^^^^^^     ^^^^^^^^^^                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                 

  (dev-python/PyQt5-5.13.2:0/0::gentoo, installed) USE="dbus gui ssl widgets -bluetooth -debug -declarative -designer -examples -gles2 -help -location -multimedia -network -networkauth -opengl -positioning -printsupport -sensors -serialport -sql -svg -testlib -webchannel -webkit -websockets -x11extras -xmlpatterns" ABI_X86="(64)" PYTHON_TARGETS="python2_7 python3_6 -python3_5 -python3_7 -python3_8" pulled in by
    >=dev-python/PyQt5-5.5.1[dbus,gui,widgets,python_targets_python2_7(-)?,python_targets_python3_6(-)?,python_targets_python3_7(-)?,-python_single_target_pypy3(-),-python_single_target_python3_8(-),python_single_target_python2_7(+)?,python_single_target_python3_6(+)?,python_single_target_python3_7(+)?] required by (net-print/hplip-3.19.12:0/0::gentoo, installed) USE="X hpcups qt5 scanner snmp static-ppds -doc -fax -hpijs -kde -libnotify -libressl -libusb0 -minimal -parport -policykit" ABI_X86="(64)" PYTHON_SINGLE_TARGET="python3_6 -python2_7 -python3_5 -python3_7" PYTHON_TARGETS="python2_7 python3_6 -python3_5 -python3_7"
                             ^^^^                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                   

dev-qt/qtwidgets:5

  (dev-qt/qtwidgets-5.14.0:5/5.14::gentoo, ebuild scheduled for merge) USE="gtk png xcb -debug -gles2 -test" ABI_X86="(64)" pulled in by
    ~dev-qt/qtwidgets-5.14.0[gles2=] required by (dev-qt/qtdeclarative-5.14.0:5/5.14::gentoo, ebuild scheduled for merge) USE="jit widgets -debug -gles2 -localstorage -test" ABI_X86="(64)"
    ^                 ^^^^^^                                                                                                                                                                                                                                                                                                                                                           
    (and 2 more with the same problem)

  (dev-qt/qtwidgets-5.13.2:5/5.13::gentoo, installed) USE="gtk png xcb -debug -gles2 -test" ABI_X86="(64)" pulled in by
    ~dev-qt/qtwidgets-5.13.2[gles2=] required by (dev-qt/qtmultimedia-5.13.2-r1:5/5.13::gentoo, installed) USE="alsa widgets -debug -gles2 -gstreamer -openal -pulseaudio -qml -test" ABI_X86="(64)"
    ^                 ^^^^^^                                                                                                                                                                                                                                                                                                                                                                                                                             
    (and 1 more with the same problem)

dev-qt/qtgui:5

  (dev-qt/qtgui-5.14.0-r1:5/5.14::gentoo, ebuild scheduled for merge) USE="dbus gif libinput png udev xcb -accessibility -debug -egl -eglfs -evdev -gles2 -ibus -jpeg -test -tslib -tuio -vnc -wayland" ABI_X86="(64)" pulled in by
    ~dev-qt/qtgui-5.14.0[gles2=] required by (dev-qt/qtdeclarative-5.14.0:5/5.14::gentoo, ebuild scheduled for merge) USE="jit widgets -debug -gles2 -localstorage -test" ABI_X86="(64)"
    ^             ^^^^^^                                                                                                                                                                                                                                                                                                                                                           
    (and 4 more with the same problem)

  (dev-qt/qtgui-5.13.2:5/5.13::gentoo, installed) USE="dbus gif jpeg libinput png udev xcb -accessibility -debug -egl -eglfs -evdev -gles2 -ibus -test -tslib -tuio -vnc -wayland" ABI_X86="(64)" pulled in by
    ~dev-qt/qtgui-5.13.2[dbus] required by (dev-qt/qtwidgets-5.13.2:5/5.13::gentoo, installed) USE="gtk png xcb -debug -gles2 -test" ABI_X86="(64)"
    ^             ^^^^^^                                                                                                                                                                                                                                                                                                                       
    (and 3 more with the same problem)

dev-qt/qtdbus:5

  (dev-qt/qtdbus-5.14.0:5/5.14::gentoo, ebuild scheduled for merge) USE="-debug -test" ABI_X86="(64)" pulled in by
    ~dev-qt/qtdbus-5.14.0 required by (dev-qt/qtgui-5.14.0-r1:5/5.14::gentoo, ebuild scheduled for merge) USE="dbus gif libinput png udev xcb -accessibility -debug -egl -eglfs -evdev -gles2 -ibus -jpeg -test -tslib -tuio -vnc -wayland" ABI_X86="(64)"
    ^              ^^^^^^                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                   

  (dev-qt/qtdbus-5.13.2:5/5.13::gentoo, installed) USE="-debug -test" ABI_X86="(64)" pulled in by
    ~dev-qt/qtdbus-5.13.2 required by (dev-qt/qtgui-5.13.2:5/5.13::gentoo, installed) USE="dbus gif jpeg libinput png udev xcb -accessibility -debug -egl -eglfs -evdev -gles2 -ibus -test -tslib -tuio -vnc -wayland" ABI_X86="(64)"
    ^              ^^^^^^                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                               

dev-qt/qtcore:5

  (dev-qt/qtcore-5.14.0:5/5.14::gentoo, ebuild scheduled for merge) USE="systemd -debug -icu -test" ABI_X86="(64)" pulled in by
    ~dev-qt/qtcore-5.14.0 required by (dev-qt/qttest-5.14.0:5/5.14::gentoo, ebuild scheduled for merge) USE="-debug -test" ABI_X86="(64)"
    ^              ^^^^^^                                                                                                                                                                                                                               
    (and 10 more with the same problem)

  (dev-qt/qtcore-5.13.2:5/5.13::gentoo, installed) USE="icu systemd -debug -test" ABI_X86="(64)" pulled in by
    ~dev-qt/qtcore-5.13.2 required by (dev-qt/qtgui-5.13.2:5/5.13::gentoo, installed) USE="dbus gif jpeg libinput png udev xcb -accessibility -debug -egl -eglfs -evdev -gles2 -ibus -test -tslib -tuio -vnc -wayland" ABI_X86="(64)"
    ^              ^^^^^^                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                               
    (and 6 more with the same problem)

dev-qt/qtnetwork:5

  (dev-qt/qtnetwork-5.14.0:5/5.14::gentoo, ebuild scheduled for merge) USE="ssl -bindist -connman -debug -libproxy -networkmanager -sctp -test" ABI_X86="(64)" pulled in by
    ~dev-qt/qtnetwork-5.14.0 required by (dev-qt/qtwebengine-5.14.0:5/5.14::gentoo, ebuild scheduled for merge) USE="alsa system-ffmpeg system-icu widgets -bindist -debug -designer -jumbo-build -pax_kernel -pulseaudio -test" ABI_X86="(64)"
    ^                 ^^^^^^                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                             
    (and 1 more with the same problem)

  (dev-qt/qtnetwork-5.13.2:5/5.13::gentoo, installed) USE="ssl -bindist -connman -debug -libproxy -networkmanager -sctp -test" ABI_X86="(64)" pulled in by
    ~dev-qt/qtnetwork-5.13.2 required by (dev-qt/qtmultimedia-5.13.2-r1:5/5.13::gentoo, installed) USE="alsa widgets -debug -gles2 -gstreamer -openal -pulseaudio -qml -test" ABI_X86="(64)"
    ^                 ^^^^^^                                                                                                                                                                                                                                                                                                                                                                                                                     

NOTE: Use the '--verbose-conflicts' option to display parents omitted above

It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


The following packages are causing rebuilds:

  (dev-qt/qtwidgets-5.14.0:5/5.14::gentoo, ebuild scheduled for merge) causes rebuilds for:
    (dev-qt/qtwebkit-5.212.0_pre20190629:5/5.212::gentoo, ebuild scheduled for merge)

The following USE changes are necessary to proceed:
 (see "package.use" in the portage(5) man page for more details)
# required by dev-python/PyQtWebEngine-5.14.0::gentoo
# required by www-client/qutebrowser-1.8.3::gentoo
# required by www-client/qutebrowser (argument)
=dev-python/PyQt5-5.13.2 webchannel network opengl gui multimedia declarative sql widgets printsupport

Would you like to add these changes to your config files? [Yes/No] y

Autounmask changes successfully written.

 * IMPORTANT: config file '/etc/portage/package.use' needs updating.
 * See the CONFIGURATION FILES and CONFIGURATION FILES UPDATE TOOLS
 * sections of the emerge man page to learn how to update config files.

 * In order to avoid wasting time, backtracking has terminated early
 * due to the above autounmask change(s). The --autounmask-backtrack=y
 * option can be used to force further backtracking, but there is no
 * guarantee that it will produce a solution.

The out of emerge-infor:
Code:
sumati@jantumati ~ $ emerge --info
Portage 2.3.83 (python 2.7.17-final-0, default/linux/amd64/17.0/systemd, gcc-9.2.0, glibc-2.30-r3, 4.19.86-gentoo x86_64)
=================================================================
System uname: Linux-4.19.86-gentoo-x86_64-Intel-R-_Core-TM-_i7-4770_CPU_@_3.40GHz-with-gentoo-2.6
KiB Mem:    16329256 total,  13937652 free
KiB Swap:    8388604 total,   8388604 free
Timestamp of repository gentoo: Wed, 15 Jan 2020 11:30:01 +0000
Head commit of repository gentoo: 27485d2a804d749ded14dcc41a1caaf18d3c73cb
sh bash 5.0_p11
ld GNU ld (Gentoo 2.33.1 p1) 2.33.1
app-shells/bash:          5.0_p11::gentoo
dev-lang/perl:            5.30.1::gentoo
dev-lang/python:          2.7.17::gentoo, 3.6.10::gentoo, 3.7.6::gentoo
dev-util/cmake:           3.16.2-r1::gentoo
sys-apps/baselayout:      2.6-r1::gentoo
sys-apps/sandbox:         2.18::gentoo
sys-devel/autoconf:       2.69-r5::gentoo
sys-devel/automake:       1.13.4-r2::gentoo, 1.16.1-r2::gentoo
sys-devel/binutils:       2.33.1::gentoo
sys-devel/gcc:            9.2.0-r3::gentoo
sys-devel/gcc-config:     2.1::gentoo
sys-devel/libtool:        2.4.6-r5::gentoo
sys-devel/make:           4.2.1-r4::gentoo
sys-kernel/linux-headers: 5.4::gentoo (virtual/os-headers)
sys-libs/glibc:           2.30-r3::gentoo
Repositories:

gentoo
    location: /var/db/repos/gentoo
    sync-type: rsync
    sync-uri: rsync://rsync.gentoo.org/gentoo-portage
    priority: -1000
    sync-rsync-verify-jobs: 1
    sync-rsync-verify-metamanifest: yes
    sync-rsync-extra-opts:
    sync-rsync-verify-max-age: 24

petkovich
    location: /var/lib/layman/petkovich
    masters: gentoo
    priority: 50

ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="@FREE"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php7.4/ext-active/ /etc/php/cgi-php7.4/ext-active/ /etc/php/cli-php7.4/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-O2 -pipe"
DISTDIR="/var/cache/distfiles"
ENV_UNSET="DBUS_SESSION_BUS_ADDRESS DISPLAY GOBIN PERL5LIB PERL5OPT PERLPREFIX PERL_CORE PERL_MB_OPT PERL_MM_OPT XAUTHORITY XDG_CACHE_HOME XDG_CONFIG_HOME XDG_DATA_HOME XDG_RUNTIME_DIR"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-docompress binpkg-dostrip binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles ipc-sandbox merge-sync multilib-strict network-sandbox news parallel-fetch pid-sandbox preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="https://mirror.eu.oneandone.net/linux/distributions/gentoo/gentoo/ http://mirror.eu.oneandone.net/linux/distributions/gentoo/gentoo/ rsync://mirror.eu.oneandone.net/gentoo/ ftp://mirror.netcologne.de/gentoo/ https://mirror.netcologne.de/gentoo/ http://mirror.netcologne.de/gentoo/ rsync://mirror.netcologne.de/gentoo/"
LANG="en_US.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j8"
PKGDIR="/var/cache/binpkgs"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/var/tmp"
USE="X acl alsa amd64 berkdb bzip2 cli core2 crypt cxx dri efi-32 efi-64i fortran gdbm gtk iconv ipv6 libtirpc mmx multilib ncurses nls nptl openmp pam pcre readline scripts seccomp split-usr sse ssl systemd tcpd udev unicode xattr zlib" ABI_X86="64" ADA_TARGET="gnat_2018" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="karbon sheets words" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="mmx mmxext sse sse2" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock greis isync itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf skytraq superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="libinput keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" NETBEANS_MODULES="apisupport cnd groovy gsf harness ide identity j2ee java mobility nb php profiler soa visualweb webcommon websvccommon xml" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php7-2" POSTGRES_TARGETS="postgres10 postgres11" PYTHON_SINGLE_TARGET="python3_6" PYTHON_TARGETS="python2_7 python3_6" RUBY_TARGETS="ruby24 ruby25" SANE_BACKENDS="hp" USERLAND="GNU" VIDEO_CARDS="amdgpu fbdev intel nouveau radeon radeonsi vesa dummy v4l" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CC, CPPFLAGS, CTARGET, CXX, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, LINGUAS, PORTAGE_BINHOST, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS

Please let know what I should do, thanks!
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 24023
Location: here

PostPosted: Sat Feb 01, 2020 11:01 am    Post subject: Reply with quote

Before install www-client/qutebrowser you should update your system, so run emerge -uUD @world.
Quote:
I have added gui, network, printsupport and widgets in the line of "USE" in the file /etc/portage/make.conf, however still no success. I have also tried before to install qtwebengine, also failed after taking very long time to compile the package.

This isn't true (I don't see that in your emerge --info) but usually is better, since these use flags are required by only a package, use /etc/portage/package.use and portage as done this for you
Code:
The following USE changes are necessary to proceed:
 (see "package.use" in the portage(5) man page for more details)
# required by dev-python/PyQtWebEngine-5.14.0::gentoo
# required by www-client/qutebrowser-1.8.3::gentoo
# required by www-client/qutebrowser (argument)
=dev-python/PyQt5-5.13.2 webchannel network opengl gui multimedia declarative sql widgets printsupport

Would you like to add these changes to your config files? [Yes/No] y

Autounmask changes successfully written.

 * IMPORTANT: config file '/etc/portage/package.use' needs updating.
 * See the CONFIGURATION FILES and CONFIGURATION FILES UPDATE TOOLS
 * sections of the emerge man page to learn how to update config files.

and you need to run etc-update or dispatch-conf.
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
sumati
n00b
n00b


Joined: 10 Nov 2019
Posts: 46

PostPosted: Sat Feb 01, 2020 4:16 pm    Post subject: Reply with quote

Quote:
This isn't true (I don't see that in your emerge --info) but usually is better, since these use flags are required by only a package, use /etc/portage/package.use and portage as done this for you
I had added them in my make.conf, and moved them to package.use following your suggestion. But then I got the error-report:
Code:
Invalid atom in /etc/portage/package.use: gui
. Now I added them again in package-use, here is the new output:
Code:
jantumati /home/sumati # emerge --info
--- Invalid atom in /etc/portage/package.use: gui
Portage 2.3.83 (python 2.7.17-final-0, default/linux/amd64/17.0/systemd, gcc-9.2.0, glibc-2.30-r3, 4.19.86-gentoo x86_64)
=================================================================
System uname: Linux-4.19.86-gentoo-x86_64-Intel-R-_Core-TM-_i7-4770_CPU_@_3.40GHz-with-gentoo-2.6
KiB Mem:    16329240 total,  13995756 free
KiB Swap:    8388604 total,   8388604 free
Timestamp of repository gentoo: Wed, 15 Jan 2020 11:30:01 +0000
Head commit of repository gentoo: 27485d2a804d749ded14dcc41a1caaf18d3c73cb
sh bash 5.0_p11
ld GNU ld (Gentoo 2.33.1 p1) 2.33.1
app-shells/bash:          5.0_p11::gentoo
dev-lang/perl:            5.30.1::gentoo
dev-lang/python:          2.7.17::gentoo, 3.6.10::gentoo, 3.7.6::gentoo
dev-util/cmake:           3.16.2-r1::gentoo
sys-apps/baselayout:      2.6-r1::gentoo
sys-apps/sandbox:         2.18::gentoo
sys-devel/autoconf:       2.69-r5::gentoo
sys-devel/automake:       1.13.4-r2::gentoo, 1.16.1-r2::gentoo
sys-devel/binutils:       2.33.1::gentoo
sys-devel/gcc:            9.2.0-r3::gentoo
sys-devel/gcc-config:     2.1::gentoo
sys-devel/libtool:        2.4.6-r5::gentoo
sys-devel/make:           4.2.1-r4::gentoo
sys-kernel/linux-headers: 5.4::gentoo (virtual/os-headers)
sys-libs/glibc:           2.30-r3::gentoo
Repositories:

gentoo
    location: /var/db/repos/gentoo
    sync-type: rsync
    sync-uri: rsync://rsync.gentoo.org/gentoo-portage
    priority: -1000
    sync-rsync-verify-jobs: 1
    sync-rsync-verify-metamanifest: yes
    sync-rsync-extra-opts:
    sync-rsync-verify-max-age: 24

petkovich
    location: /var/lib/layman/petkovich
    masters: gentoo
    priority: 50

ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="@FREE"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php7.4/ext-active/ /etc/php/cgi-php7.4/ext-active/ /etc/php/cli-php7.4/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-O2 -pipe"
DISTDIR="/var/cache/distfiles"
ENV_UNSET="DBUS_SESSION_BUS_ADDRESS DISPLAY GOBIN PERL5LIB PERL5OPT PERLPREFIX PERL_CORE PERL_MB_OPT PERL_MM_OPT XAUTHORITY XDG_CACHE_HOME XDG_CONFIG_HOME XDG_DATA_HOME XDG_RUNTIME_DIR"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-docompress binpkg-dostrip binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles ipc-sandbox merge-sync multilib-strict network-sandbox news parallel-fetch pid-sandbox preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="https://mirror.eu.oneandone.net/linux/distributions/gentoo/gentoo/ http://mirror.eu.oneandone.net/linux/distributions/gentoo/gentoo/ rsync://mirror.eu.oneandone.net/gentoo/ ftp://mirror.netcologne.de/gentoo/ https://mirror.netcologne.de/gentoo/ http://mirror.netcologne.de/gentoo/ rsync://mirror.netcologne.de/gentoo/"
LANG="en_US.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j8"
PKGDIR="/var/cache/binpkgs"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/var/tmp"
USE="X acl alsa amd64 berkdb bzip2 cli core2 crypt cxx dri efi-32 efi-64i fortran gdbm gtk iconv ipv6 libtirpc mmx multilib ncurses nls nptl openmp pam pcre readline scripts seccomp split-usr sse ssl systemd tcpd udev unicode xattr zlib" ABI_X86="64" ADA_TARGET="gnat_2018" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="karbon sheets words" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="mmx mmxext sse sse2" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock greis isync itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf skytraq superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="libinput keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" NETBEANS_MODULES="apisupport cnd groovy gsf harness ide identity j2ee java mobility nb php profiler soa visualweb webcommon websvccommon xml" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php7-2" POSTGRES_TARGETS="postgres10 postgres11" PYTHON_SINGLE_TARGET="python3_6" PYTHON_TARGETS="python2_7 python3_6" RUBY_TARGETS="ruby24 ruby25" SANE_BACKENDS="hp" USERLAND="GNU" VIDEO_CARDS="amdgpu fbdev intel nouveau radeon radeonsi vesa dummy v4l" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CC, CPPFLAGS, CTARGET, CXX, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, LINGUAS, PORTAGE_BINHOST, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 24023
Location: here

PostPosted: Sat Feb 01, 2020 4:33 pm    Post subject: Reply with quote

sumati wrote:
I had added them in my make.conf, and moved them to package.use following your suggestion. But then I got the error-report:
Code:
Invalid atom in /etc/portage/package.use: gui
. Now I added them again in package-use, here is the new output:
Code:
jantumati /home/sumati # emerge --info
--- Invalid atom in /etc/portage/package.use: gui

You have added this line:
Code:
=dev-python/PyQt5-5.13.2 webchannel network opengl gui multimedia declarative sql widgets printsupport

in /etc/portage/package.use?
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
sumati
n00b
n00b


Joined: 10 Nov 2019
Posts: 46

PostPosted: Sat Feb 01, 2020 10:16 pm    Post subject: Reply with quote

fedeliallalinea wrote:
You have added this line:
Code:
=dev-python/PyQt5-5.13.2 webchannel network opengl gui multimedia declarative sql widgets printsupport

in /etc/portage/package.use?

fedeliallalinea, thanks. I have added those but without "=dev-python/PyQt5-5.13.2". Now, I have added also =dev-python/PyQt5-5.13.2 in etc/package-use. After running dispatch-conf and emerge -uUD @world, there was still problems with regard to conflicted packages. Luckily, in https://wiki.gentoo.org/wiki/Troubleshooting I found the solution, by running
Code:
emerge --ask --verbose --update --newuse --deep @world
and other commands like
Code:
emerge --ask --oneshot =[the newest version of package]
, the problems are solved. Thus I came to the final step of installing qutebrowser. After taking several hours to compile the dev-qt/qtwebengine-5.14.0 which the qutebrowser requires, I successfully installed qutebrowser. Thank you and all other who read my posts patiently and gave me various suggestions and supports.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum