Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
sysvinit is blocking sys-apps/systemd-239-r2
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
albrechtmyers
n00b
n00b


Joined: 28 Jan 2020
Posts: 1
Location: Glenolden

PostPosted: Tue Jan 28, 2020 9:08 am    Post subject: sysvinit is blocking sys-apps/systemd-239-r2 Reply with quote

I put a fresh system (by handbook) - stage3-amd64-systemd-20181108.tar.bz2
But when installing the network - emerge --ask --noreplace net-misc / netifrc
getting addiction
Code:
chroot) livecd / # emerge --ask --noreplace net-misc/netifrc

* IMPORTANT: 13 news items need reading for repository 'gentoo'.
* Use eselect news read to view new items.

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild N ] virtual/tmpfiles-0
[ebuild N ] sys-apps/sysvinit-2.88-r9 USE="(-ibm) (-selinux) -static"
[ebuild N ] sys-apps/openrc-0.38.3 USE="ncurses netifrc pam unicode -audit -debug -newnet (-prefix) (-selinux) -static-libs"
[ebuild N ] net-misc/netifrc-0.5.1
[blocks B ] sys-apps/sysvinit ("sys-apps/sysvinit" is blocking sys-apps/systemd-239-r2)

* Error: The above package list contains packages which cannot be
* installed at the same time on the same system.

(sys-apps/sysvinit-2.88-r9:0/0::gentoo, ebuild scheduled for merge) pulled in by
>=sys-apps/sysvinit-2.86-r6[selinux?] (>=sys-apps/sysvinit-2.86-r6) required by (sys-apps/openrc-0.38.3:0/0::gentoo, ebuild scheduled for merge)

(sys-apps/systemd-239-r2:0/2::gentoo, installed) pulled in by
sys-apps/systemd required by (virtual/tmpfiles-0:0/0::gentoo, ebuild scheduled for merge)

For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

https://wiki.gentoo.org/wiki/Handbook:X86/Working/Portage#Blocked_packages

(chroot) livecd / #
how to install / compile 17.0 Plasma + systemd from scratch?
_________________
;)
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 24023
Location: here

PostPosted: Tue Jan 28, 2020 9:39 am    Post subject: Reply with quote

https://www.gentoo.org/support/news-items/2018-01-23-systemd-blocker.html

EDIT: why you use an old profile (latest available is 17.1) and stage3 build? There is a new build stage3 systemd [1]

[1] http://distfiles.gentoo.org/releases/amd64/autobuilds/current-stage3-amd64-systemd/
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
phil_r
Apprentice
Apprentice


Joined: 14 Mar 2006
Posts: 220
Location: Lincoln, NE, USA

PostPosted: Fri Jan 31, 2020 2:56 pm    Post subject: Reply with quote

I'm having a very similar issue when doing emerge -auDN @world - all of a sudden, sysvinit is trying to install but I'm a systemd setup.

This was a clean build from about a week ago.
Used the latest stage3.

Everything was fine until about two days ago when this started happening.
I have the 17.1/desktop/plasma/systemd (stable) profile selected.

Anyone have any ideas?

--- snip ---
[ebuild U ] xfce-base/thunar-1.8.12 [1.8.11]
[blocks B ] sys-apps/sysvinit ("sys-apps/sysvinit" is blocking sys-apps/systemd-244)

* Error: The above package list contains packages which cannot be
* installed at the same time on the same system.

(sys-apps/sysvinit-2.96:0/0::gentoo, ebuild scheduled for merge) pulled in by
>=sys-apps/sysvinit-2.86-r6[selinux?] (>=sys-apps/sysvinit-2.86-r6) required by (sys-apps/openrc-0.42.1:0/0::gentoo, installed) USE="ncurses netifrc pam (split-usr) unicode -audit -bash -debug -newnet (-prefix) (-selinux) -static-libs -sysv-utils" ABI_X86="(64)"

(sys-apps/systemd-244:0/2::gentoo, installed) pulled in by
>=sys-apps/systemd-186:0/2= required by (sys-apps/accountsservice-0.6.50-r1:0/0::gentoo, installed) USE="introspection systemd (-consolekit) -doc (-elogind) (-selinux)"ABI_X86="(64)"
(lots of other similar messages)
--- snip ---


Like I said it was fine until sysvinit decided it needs to install. I can't even tell what it is that's trying to pull that in to begin with.
_________________
Just when you think you know the answers, I change the questions.

AMD64 Phenom-II 6-core, 440Gb Intel SSD NVMe, 4Tb SATA II, 20576Mb, 1Gb Ethernet, GeForce GTS 950, x64
MacBook, ESX servers, many other toys
Back to top
View user's profile Send private message
fturco
Veteran
Veteran


Joined: 08 Dec 2010
Posts: 1038
Location: Italy

PostPosted: Fri Jan 31, 2020 4:37 pm    Post subject: Reply with quote

@phil_r: It seems sysvinit is required by openrc, which should not be installed on a machine with systemd. Try to check the contents of /var/lib/portage/world.
Back to top
View user's profile Send private message
dmpogo
Advocate
Advocate


Joined: 02 Sep 2004
Posts: 2686
Location: Canada

PostPosted: Fri Jan 31, 2020 4:38 pm    Post subject: Reply with quote

Main question why do you have openrc installed (which then of course pulls in sysvinit)

Last edited by dmpogo on Fri Jan 31, 2020 5:07 pm; edited 1 time in total
Back to top
View user's profile Send private message
phil_r
Apprentice
Apprentice


Joined: 14 Mar 2006
Posts: 220
Location: Lincoln, NE, USA

PostPosted: Fri Jan 31, 2020 4:50 pm    Post subject: Reply with quote

@fturco - there's no reference to openrc in the world file.

@dmpogo - as far as I was aware, it wasn't. I don't know why it is/was.


I just did an emerge --unmerge openrc and it got removed.
The emerge -auDN @world isn't throwing errors now.

I guess next time I reboot I'll know if I did the right thing or not...

Thanks for the pointers!
_________________
Just when you think you know the answers, I change the questions.

AMD64 Phenom-II 6-core, 440Gb Intel SSD NVMe, 4Tb SATA II, 20576Mb, 1Gb Ethernet, GeForce GTS 950, x64
MacBook, ESX servers, many other toys
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum