Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
libQt5Core.so.5: No such file or directory
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
heikkikk
Tux's lil' helper
Tux's lil' helper


Joined: 05 Feb 2008
Posts: 125

PostPosted: Wed Jan 29, 2020 4:31 am    Post subject: libQt5Core.so.5: No such file or directory Reply with quote

Trying to run emerge --ask --verbose --update --deep --newuse @world

ERROR: dev-qt/qtgui-5.14.0-r3::gentoo failed

Code:
/var/tmp/portage/dev-qt/qtgui-5.14.0-r3/work/qtbase-everywhere-src-5.14.0/bin/qvkgen: error while loading shared libraries: libQt5Core.so.5: cannot open shared object file: No such file or directory


But i do have it.
Code:
# ls -la /usr/lib64/libQt5Core.so.5*
lrwxrwxrwx 1 root root      20 ene 28 20:29 /usr/lib64/libQt5Core.so.5 -> libQt5Core.so.5.14.0
lrwxrwxrwx 1 root root      20 ene 28 20:29 /usr/lib64/libQt5Core.so.5.14 -> libQt5Core.so.5.14.0
-rwxr-xr-x 1 root root 5482576 ene 28 20:29 /usr/lib64/libQt5Core.so.5.14.0


I do not understand why this happens.
Back to top
View user's profile Send private message
mike155
Advocate
Advocate


Joined: 17 Sep 2010
Posts: 2117
Location: Frankfurt, Germany

PostPosted: Wed Jan 29, 2020 4:51 am    Post subject: Reply with quote

Could be https://bugs.gentoo.org/show_bug.cgi?id=669994
Back to top
View user's profile Send private message
heikkikk
Tux's lil' helper
Tux's lil' helper


Joined: 05 Feb 2008
Posts: 125

PostPosted: Wed Jan 29, 2020 5:09 am    Post subject: Reply with quote

a year old bug??
did a fresh install lately.

mike155 wrote:
Could be https://bugs.gentoo.org/show_bug.cgi?id=669994
Back to top
View user's profile Send private message
Perfect Gentleman
l33t
l33t


Joined: 18 May 2014
Posts: 936

PostPosted: Wed Jan 29, 2020 6:33 am    Post subject: Reply with quote

Code:
file /usr/lib64/libQt5Core.so.5.14.0


Code:
~ $ file /usr/lib64/libQt5Core.so.5.14.1
/usr/lib64/libQt5Core.so.5.14.1: ELF 64-bit LSB shared object, x86-64, version 1 (SYSV), statically linked, for GNU/Linux 3.17.0, stripped
Back to top
View user's profile Send private message
heikkikk
Tux's lil' helper
Tux's lil' helper


Joined: 05 Feb 2008
Posts: 125

PostPosted: Sun Feb 02, 2020 12:57 am    Post subject: Reply with quote

Perfect Gentleman wrote:
Code:
file /usr/lib64/libQt5Core.so.5.14.0


Code:
# file /usr/lib64/libQt5Core.so.5
/usr/lib64/libQt5Core.so.5: symbolic link to libQt5Core.so.5.14.0


Code:
#file /usr/lib64/libQt5Core.so.5.14.0
/usr/lib64/libQt5Core.so.5.14.0: ELF 64-bit LSB shared object, x86-64, version 1 (GNU/Linux), dynamically linked, interpreter /lib64/ld-linux-x86-64.so.2, for GNU/Linux 3.17.0, stripped


Still not finding it even tho the file exists :(
Back to top
View user's profile Send private message
Hu
Moderator
Moderator


Joined: 06 Mar 2007
Posts: 15294

PostPosted: Sun Feb 02, 2020 1:18 am    Post subject: Reply with quote

When the build failed, Portage should have told you to post the output of emerge --info. Please do so.
Back to top
View user's profile Send private message
mike155
Advocate
Advocate


Joined: 17 Sep 2010
Posts: 2117
Location: Frankfurt, Germany

PostPosted: Sun Feb 02, 2020 2:43 am    Post subject: Reply with quote

heikkikk wrote:
a year old bug??
did a fresh install lately.

I'm pretty sure that it is https://bugs.gentoo.org/show_bug.cgi?id=669994.

One of the commenters suggested a workaround. Did you try it and does it solve the issue?
Quote:
As above

strip --remove-section=.note.ABI-tag 'EPREFIX'/usr/lib64/libQt5Core.so

fixes things.
Back to top
View user's profile Send private message
heikkikk
Tux's lil' helper
Tux's lil' helper


Joined: 05 Feb 2008
Posts: 125

PostPosted: Mon Feb 03, 2020 1:27 am    Post subject: Reply with quote

mike155 wrote:
I'm pretty sure that it is https://bugs.gentoo.org/show_bug.cgi?id=669994.

One of the commenters suggested a workaround. Did you try it and does it solve the issue?
Quote:
As above

strip --remove-section=.note.ABI-tag 'EPREFIX'/usr/lib64/libQt5Core.so

fixes things.


Code:
make[1]: Entering directory '/var/tmp/portage/dev-qt/qtgui-5.14.0-r3/work/qtbase-everywhere-src-5.14.0/src/plugins/imageformats/gif'
x86_64-pc-linux-gnu-g++ -c -O2 -pipe -std=c++1z -fvisibility=hidden -fvisibility-inlines-hidden -fno-exceptions -Wall -Wextra -Wvla -Wdate-time -Wshif
t-overflow=2 -Wduplicated-cond -Wno-stringop-overflow -Wno-format-overflow -D_REENTRANT -fPIC -DQT_NO_LINKED_LIST -DQT_NO_JAVA_STYLE_ITERATORS -DQT_DE
PRECATED_WARNINGS -DQT_NO_NARROWING_CONVERSIONS_IN_CONNECT -DQT_NO_EXCEPTIONS -D_LARGEFILE64_SOURCE -D_LARGEFILE_SOURCE -DQT_NO_DEBUG -DQT_PLUGIN -DQT
_GUI_LIB -DQT_CORE_LIB -I. -I../../../../include -I../../../../include/QtGui -isystem /usr/include/qt5 -isystem /usr/include/qt5/QtCore -I.moc -isyste
m /usr/include/libdrm -I../../../../mkspecs/linux-g++ -o .obj/main.o main.cpp
rm -f libqjpeg.so
x86_64-pc-linux-gnu-g++ -Wl,-O1 -Wl,--as-needed -Wl,--no-undefined -Wl,--enable-new-dtags -shared -o libqjpeg.so .obj/main.o .obj/qjpeghandler.o .obj/
moc_main.o  /var/tmp/portage/dev-qt/qtgui-5.14.0-r3/work/qtbase-everywhere-src-5.14.0/lib/libQt5Gui.so /usr/lib64/libQt5Core.so -lGL -lpthread -ljpeg

collect2: fatal error: ld terminated with signal 11 [Segmentation fault]
compilation terminated.


Nope, not working.... Gentoo is trying my nerves. Every day a new problem.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum