Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] Install problem
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
cowboy0629
Tux's lil' helper
Tux's lil' helper


Joined: 11 May 2016
Posts: 105
Location: Kawartha Lakes, Ontario

PostPosted: Tue Mar 03, 2020 1:03 am    Post subject: [SOLVED] Install problem Reply with quote

Hi All I have been trying to install Gentoo all day with

Gentoo Minimal CD (install-amd64-minimal-20200301T214502Z.iso)
STAGE3 (stage3-amd64-20200301T214502Z.tar.xz)

I have Downloaded and remade my USB Drive 20 times now and started the installation over 20 times now and keep having the same results
I have also tried to download the stage 3 from multiple mirrors with no success

Code:
(chroot) livecd / # emerge --ask --verbose --update --deep --newuse @world

 * IMPORTANT: 6 news items need reading for repository 'gentoo'.
 * Use eselect news read to view new items.


These are the packages that would be merged, in order:

Calculating dependencies -

!!! Invalid or corrupt dependency specification:

'NoneType' object has no attribute 'depth'

(net-misc/openssh-8.1_p1-r2:0/0::gentoo, installed)

Portage is unable to process the dependencies of the 'net-
misc/openssh-8.1_p1-r2' package. In order to correct this problem, the
package should be uninstalled, reinstalled, or upgraded. As a temporary
workaround, the --nodeps option can be used to ignore all dependencies.
For reference, the problematic dependencies can be found in the *DEPEND
files located in '/var/db/pkg/net-misc/openssh-8.1_p1-r2/'.
... done!
Traceback (most recent call last):
  File "/usr/lib/python-exec/python3.6/emerge", line 53, in <module>
    retval = emerge_main()
  File "/usr/lib64/python3.6/site-packages/_emerge/main.py", line 1309, in emerge_main
    return run_action(emerge_config)
  File "/usr/lib64/python3.6/site-packages/_emerge/actions.py", line 3371, in run_action
    retval = action_build(emerge_config, spinner=spinner)
  File "/usr/lib64/python3.6/site-packages/_emerge/actions.py", line 358, in action_build
    settings, trees, myopts, myparams, myaction, myfiles, spinner)
  File "/usr/lib64/python3.6/site-packages/_emerge/depgraph.py", line 9912, in backtrack_depgraph
    myaction, myfiles, spinner)
  File "/usr/lib64/python3.6/site-packages/_emerge/depgraph.py", line 9949, in _backtrack_depgraph
    success, favorites = mydepgraph.select_files(myfiles)
  File "/usr/lib64/python3.6/site-packages/_emerge/depgraph.py", line 4002, in select_files
    return self._select_files(args)  File "/usr/lib64/python3.6/site-packages/_emerge/depgraph.py", line 4345, in _select_files
    return self._resolve(myfavorites)
  File "/usr/lib64/python3.6/site-packages/_emerge/depgraph.py", line 4501, in _resolve
    self.altlist()
  File "/usr/lib64/python3.6/site-packages/_emerge/depgraph.py", line 7485, in altlist
    self._resolve_conflicts()
  File "/usr/lib64/python3.6/site-packages/_emerge/depgraph.py", line 7612, in _resolve_conflicts
    self._process_slot_conflicts()
  File "/usr/lib64/python3.6/site-packages/_emerge/depgraph.py", line 1712, in _process_slot_conflicts
    if not self._validate_blockers():
  File "/usr/lib64/python3.6/site-packages/_emerge/depgraph.py", line 7227, in _validate_blockers
    trees=self._dynamic_config._graph_trees, myroot=myroot)
  File "/usr/lib64/python3.6/site-packages/portage/dep/dep_check.py", line 850, in dep_check
    use_binaries=use_binaries, trees=trees, minimize_slots=dnf)
  File "/usr/lib64/python3.6/site-packages/portage/dep/dep_check.py", line 319, in dep_zapdeps
    minimize_slots=minimize_slots)
  File "/usr/lib64/python3.6/site-packages/portage/dep/dep_check.py", line 513, in dep_zapdeps
    if graph_interface.want_update_pkg(parent, avail_pkg):
  File "/usr/lib64/python3.6/site-packages/_emerge/depgraph.py", line 5850, in _want_update_pkg
    depth = parent.depth or 0
AttributeError: 'NoneType' object has no attribute 'depth'
(chroot) livecd / #


Last edited by cowboy0629 on Tue Mar 03, 2020 1:31 am; edited 1 time in total
Back to top
View user's profile Send private message
mike155
Advocate
Advocate


Joined: 17 Sep 2010
Posts: 2117
Location: Frankfurt, Germany

PostPosted: Tue Mar 03, 2020 1:18 am    Post subject: Reply with quote

I've never seen that message before...

But I think I would simply do what the message says: reinstall OpenSSH.

Code:
emerge --oneshot openssh
or
Code:
emerge --oneshot --nodeps openssh

Don't do this if your machine is far away from you and if you're connected to your machine via SSH. It could be that OpenSSH won't work after re-installing it (there was a news item "openssh-8.2-service-breakage" which seems to be removed now?).


Last edited by mike155 on Tue Mar 03, 2020 1:28 am; edited 2 times in total
Back to top
View user's profile Send private message
Ionen
l33t
l33t


Joined: 06 Dec 2018
Posts: 691

PostPosted: Tue Mar 03, 2020 1:23 am    Post subject: Reply with quote

I just downloaded the same stage3, ran the same command, and also built openssh... can't reproduce, it's just working normally :?

Not that I exactly went by the book and was just a quick test.
Back to top
View user's profile Send private message
cowboy0629
Tux's lil' helper
Tux's lil' helper


Joined: 11 May 2016
Posts: 105
Location: Kawartha Lakes, Ontario

PostPosted: Tue Mar 03, 2020 1:30 am    Post subject: Reply with quote

mike155,

Thank-you for the the help!!! I did try emerge -c net-misc/openssh and emerge -a net-misc/openssh and this did not work

I used your second option

Code:
emerge --oneshot --nodeps openssh


this fixed the problem I didn't think to use the --oneshot


Thanks again
Mike
Back to top
View user's profile Send private message
Ionen
l33t
l33t


Joined: 06 Dec 2018
Posts: 691

PostPosted: Tue Mar 03, 2020 11:32 am    Post subject: Reply with quote

For reference, it was bug #711400 which led to a 2.3.89-r1 revbump that was immediately stabilized, I'd assume it'll be in the next stage 3. Meanwhile, just sync and oneshot update portage if still have problems.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum