Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
emerge blender from ArtSoftware overlay failed
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
ROGA
Tux's lil' helper
Tux's lil' helper


Joined: 17 Feb 2018
Posts: 106
Location: Zurich, Switzerland

PostPosted: Wed Mar 04, 2020 12:59 pm    Post subject: emerge blender from ArtSoftware overlay failed Reply with quote

Hi,

I tried to emerge media-gfx/blender-2.81a-r2 from the ArtSoftware overlay but without luck. Blender from the official gentoo portage does work but isn't the latest version.

unfortunately I can't post my build.log with wgetpaste because the file is to large. Any better idea how I could post it?

It would be nice, if anybody could help me to emerge the latest blender.
_________________
regards,

Roland
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 23496
Location: here

PostPosted: Wed Mar 04, 2020 1:00 pm    Post subject: Re: emerge blender from ArtSoftware overlay failed Reply with quote

ROGA wrote:
unfortunately I can't post my build.log with wgetpaste because the file is to large. Any better idea how I could post it?

You can use Firefox Send
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
ROGA
Tux's lil' helper
Tux's lil' helper


Joined: 17 Feb 2018
Posts: 106
Location: Zurich, Switzerland

PostPosted: Wed Mar 04, 2020 1:54 pm    Post subject: Reply with quote

@fedeliallalinea:

I tried it but the upload will not work. I also created a new account and received the same upload error.

The build.log has a size of 7.9MB, is it too large?
_________________
regards,

Roland
Back to top
View user's profile Send private message
Jaglover
Watchman
Watchman


Joined: 29 May 2005
Posts: 7497
Location: Saint Amant, Acadiana

PostPosted: Wed Mar 04, 2020 2:31 pm    Post subject: Reply with quote

You could drop at least a few hundred lines from the end into a pastebin, the error is likely there. You are building with MAKEOPTS=-j1 for troubleshooting?
_________________
Please learn how to denote units correctly!
Back to top
View user's profile Send private message
ROGA
Tux's lil' helper
Tux's lil' helper


Joined: 17 Feb 2018
Posts: 106
Location: Zurich, Switzerland

PostPosted: Wed Mar 04, 2020 2:49 pm    Post subject: Reply with quote

@Jaglover,

Quote:
You could drop at least a few hundred lines from the end into a pastebin, the error is likely there.


ok, here is my build.log but only the last 150 lines, more wasn't able

Quote:
You are building with MAKEOPTS=-j1 for troubleshooting?


No, I'm building with MAKEOPTS="-j9 -l8" but I will try it with the option -j1 I think, this will be need a long time to compile.

I will post the result asap
_________________
regards,

Roland
Back to top
View user's profile Send private message
Jaglover
Watchman
Watchman


Joined: 29 May 2005
Posts: 7497
Location: Saint Amant, Acadiana

PostPosted: Wed Mar 04, 2020 2:54 pm    Post subject: Reply with quote

Quote:
ok, here is my build.log but only the last 150 lines, more wasn't able

Why, doesn't your install have /bin/tail utility? And wgetpaste is in portage.
_________________
Please learn how to denote units correctly!
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 23496
Location: here

PostPosted: Wed Mar 04, 2020 3:04 pm    Post subject: Reply with quote

In your 150 lines there is no real error, you should search the 'error:' keyword and post some line before/after this
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
ROGA
Tux's lil' helper
Tux's lil' helper


Joined: 17 Feb 2018
Posts: 106
Location: Zurich, Switzerland

PostPosted: Wed Mar 04, 2020 3:19 pm    Post subject: Reply with quote

@Jaglover,

Quote:
Why, doesn't your install have /bin/tail utility? And wgetpaste is in portage.


I don't understand exactly why you ask me this but what I did was this

Code:
tail -n 150 /var/tmp/portage/media-gfx/blender-2.81a-r2/temp/build.log | wgetpaste --verbose


and then posted the url here.

In the meantime, Emerge has already crashed at 37% of the compilation with the option -j1 previously crashed at 91%

here's my build.log (only the last 100 lines because wgetpaste fails with more lines)

Any Idea?
_________________
regards,

Roland
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 23496
Location: here

PostPosted: Wed Mar 04, 2020 3:30 pm    Post subject: Reply with quote

Code:
/var/tmp/portage/media-gfx/blender-2.81a-r2/work/blender-2.81a/source/blender/blenkernel/intern/pbvh_parallel.cc:31:12:fatal error: Ktbb/tbb.h: No such file or directory
   31 | #  include <tbb/tbb.h>
      |            ^~~~~~~~~~~

You installed dev-cpp/tbb?
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
Hu
Moderator
Moderator


Joined: 06 Mar 2007
Posts: 14944

PostPosted: Thu Mar 05, 2020 3:08 am    Post subject: Reply with quote

ROGA wrote:
here's my build.log (only the last 100 lines because wgetpaste fails with more lines)
How does it fail?

As a general comment, that build system is behaving badly. One line from that log comes in at 5205 bytes, but I can get it to less than half that by omitting the cd (which the caller could have done once, instead of doing every time in every sub-shell) and using relative paths everywhere (which is a good idea for other reasons too).
Back to top
View user's profile Send private message
ROGA
Tux's lil' helper
Tux's lil' helper


Joined: 17 Feb 2018
Posts: 106
Location: Zurich, Switzerland

PostPosted: Thu Mar 05, 2020 5:32 am    Post subject: Reply with quote

@fedeliallalinea

Quote:
You installed dev-cpp/tbb?


No, this package isn't installed at the moment but I installed it now manually

Code:
emerge -av1 tbb


and after that emerge media-gfx/blender-2.81a-r2 was happy (me too)

fedeliallalinea you are greate! Thank you very much for your help.

Is this a bug in dependencies of the blender package? Should I inform the maintainer of this package?

@Hu

Quote:
How does it fail?


The error from wgetpaste was similar like this

Code:
error 413 too large


so, when I only put the last 150 lines, wgetpaste was satisfied
_________________
regards,

Roland
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 23496
Location: here

PostPosted: Thu Mar 05, 2020 6:31 am    Post subject: Reply with quote

ROGA wrote:
Is this a bug in dependencies of the blender package? Should I inform the maintainer of this package?

Probably yes, dev-cpp/tbb is a dependency only if openvdb use flag is enabled but not seems correct
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
shunlir
n00b
n00b


Joined: 03 Mar 2020
Posts: 7

PostPosted: Wed Mar 18, 2020 3:33 pm    Post subject: Reply with quote

Manually installing dev-cpp/tbb does work for me too!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum