Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
HOWTO CUPS+Samba: printing from Windows & Linux
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3 ... 6, 7, 8, 9, 10, 11  Next  
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks
View previous topic :: View next topic  
Author Message
theklone
n00b
n00b


Joined: 02 Jun 2002
Posts: 8
Location: Melbourne, Australia

PostPosted: Sat Sep 25, 2004 2:23 am    Post subject: Reply with quote

Code:
Password for root required to access localhost via SAMBA:
Running command: rpcclient localhost -N -U'root%########' -c 'setdriver ML1510 ML1510'
Succesfully set ML1510 to driver ML1510.

I've got the same problem, what cups version are you using?
Using cups-1.1.20-r2 here on ~x86 system.
Back to top
View user's profile Send private message
blibbleage
Tux's lil' helper
Tux's lil' helper


Joined: 19 Aug 2004
Posts: 84
Location: Cambridge, UK

PostPosted: Sat Sep 25, 2004 9:06 am    Post subject: Reply with quote

theklone wrote:
Code:
Password for root required to access localhost via SAMBA:
Running command: rpcclient localhost -N -U'root%########' -c 'setdriver ML1510 ML1510'
Succesfully set ML1510 to driver ML1510.

I've got the same problem, what cups version are you using?
Using cups-1.1.20-r2 here on ~x86 system.


I'm using cups-1.1.21, also on ~x86. Does anyone out there know why this isn't working?

Thanks!
Back to top
View user's profile Send private message
Manouweb
n00b
n00b


Joined: 03 Apr 2004
Posts: 8

PostPosted: Sun Sep 26, 2004 10:59 pm    Post subject: Reply with quote

Hello,

I wanted to thank your for your great work about this tutorial. i followed it line per line, i managed to install my hp 970C printer on my linux server/gateway/router, i can print the test page.
However after downloading the cups drivers for windows and launching the cupsaddsmb, it tells me to enter a password, i try to enter it many times it just keep asking for the password. I can't install the printer for windows clients so.

here is my config file :
Code:
[global]
workgroup = ESI
server string = Manoups Samba Server %v
printcap name = cups
printing = cups
load printers = yes
browseable = yes
#lock directory = /usr/local/samba/var/lock
log file = /var/log/samba/log.%m
max log size = 50
socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192
interfaces = lo eth0
bind interfaces only = yes
hosts allow = 127.0.0.1 192.168.0.0/24
hosts deny = 0.0.0.0/0
security = share
guest account = samba
guest ok = yes
vfs object = vscan-clamav
vscan-clamav: config-file = /etc/samba/vscan-clamav.conf

[print$]
comment = Printer Drivers
path = /etc/samba/printer
guest ok = yes
browseable = yes

[HPDeskJet970C]
comment = HP DeskJet 970C Network Printer
printable = yes
path = /var/spool/samba
public = yes
guest ok = yes
printer admin = manou,root

[printers]   
comment = All Printers
browseable = no
printable = yes   
writable = no
public = yes   
guest ok = yes
path = /var/spool/samba
printer admin = manou,root

[public]
comment = Public Files
browseable = yes
public = yes
create mode = 0766
guest ok = yes
path = /home/samba/public


Please help me :)
Back to top
View user's profile Send private message
tophfisher
n00b
n00b


Joined: 07 Mar 2004
Posts: 20
Location: Seattle

PostPosted: Mon Sep 27, 2004 6:12 pm    Post subject: setdriver perm denied Reply with quote

I know this is an old thread... But I hope some one out there can help!

I am far into my SMB setup, but when I use cupsaddsmb command to set a printer driver, I get this error:

Code:
result was WERR_ACCESS_DENIED


From what I can tell from the verbose output, I can copy the drivers to the print$ share just fine, the part that fails is the setdriver command...

Now I have set all the correct settings so that the user account I am using can set drivers... But no luck.. I will attach my smb.conf settings maybe someone can see something that I missed?


Code:

[printers]
        comment = All Printers
        path = /var/tmp
        printer admin = FRONTIER\chris.admin
        read only = no
        create mask = 0600
        printable = Yes
        browseable = No

[print$]
        comment = Printer Drivers
        path = /var/lib/samba/printers
        admin users = FRONITER\chris.admin
        read only = No
        create mask = 0764
        directory mask = 0775
        nt acl support = No
        hide dot files = No
        hide unreadable = No
Back to top
View user's profile Send private message
tophfisher
n00b
n00b


Joined: 07 Mar 2004
Posts: 20
Location: Seattle

PostPosted: Mon Sep 27, 2004 6:13 pm    Post subject: Reply with quote

This is the same problem I just posted about... Could it be our version of samba? I am running: Version 3.0.7

(If you find a fix, please post it!)
-Chris


Manouweb wrote:
Hello,

I wanted to thank your for your great work about this tutorial. i followed it line per line, i managed to install my hp 970C printer on my linux server/gateway/router, i can print the test page.
However after downloading the cups drivers for windows and launching the cupsaddsmb, it tells me to enter a password, i try to enter it many times it just keep asking for the password. I can't install the printer for windows clients so.

here is my config file :
Code:
[global]
workgroup = ESI
server string = Manoups Samba Server %v
printcap name = cups
printing = cups
load printers = yes
browseable = yes
#lock directory = /usr/local/samba/var/lock
log file = /var/log/samba/log.%m
max log size = 50
socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192
interfaces = lo eth0
bind interfaces only = yes
hosts allow = 127.0.0.1 192.168.0.0/24
hosts deny = 0.0.0.0/0
security = share
guest account = samba
guest ok = yes
vfs object = vscan-clamav
vscan-clamav: config-file = /etc/samba/vscan-clamav.conf

[print$]
comment = Printer Drivers
path = /etc/samba/printer
guest ok = yes
browseable = yes

[HPDeskJet970C]
comment = HP DeskJet 970C Network Printer
printable = yes
path = /var/spool/samba
public = yes
guest ok = yes
printer admin = manou,root

[printers]   
comment = All Printers
browseable = no
printable = yes   
writable = no
public = yes   
guest ok = yes
path = /var/spool/samba
printer admin = manou,root

[public]
comment = Public Files
browseable = yes
public = yes
create mode = 0766
guest ok = yes
path = /home/samba/public


Please help me :)
Back to top
View user's profile Send private message
tophfisher
n00b
n00b


Joined: 07 Mar 2004
Posts: 20
Location: Seattle

PostPosted: Mon Sep 27, 2004 6:33 pm    Post subject: Reply with quote

OK! I have an update to this, and possilby the other post' issue, it appears this is a bug in Samba that affect you if you run in ADS mode.. Here is what I found on the Samba website:


=================================
Release Notes for Samba 3.0.8pre1
Sept 24, 2004
=================================

This is a preview release of the Samba 3.0.8 code base.
It is *not* intended for production use but rather is
provided to allow people to test the bug fixes and new
features in the upcoming 3.0.8 release. Use at your own
risk.

Common bugs fixed in 3.0.8pre1 include:

o Compile fixes for HP-UX
o Fixes for the printer publishing code used when
joined to an AD domain.
o Incompatibilities with file system quotas.

New features included in the 3.0.8pre1 release are:

o New migration functionality added the the net tool
for files/directories, printers, and shares.

tophfisher wrote:
This is the same problem I just posted about... Could it be our version of samba? I am running: Version 3.0.7

(If you find a fix, please post it!)
-Chris


Manouweb wrote:
Hello,

I wanted to thank your for your great work about this tutorial. i followed it line per line, i managed to install my hp 970C printer on my linux server/gateway/router, i can print the test page.
However after downloading the cups drivers for windows and launching the cupsaddsmb, it tells me to enter a password, i try to enter it many times it just keep asking for the password. I can't install the printer for windows clients so.

here is my config file :
Code:
[global]
workgroup = ESI
server string = Manoups Samba Server %v
printcap name = cups
printing = cups
load printers = yes
browseable = yes
#lock directory = /usr/local/samba/var/lock
log file = /var/log/samba/log.%m
max log size = 50
socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192
interfaces = lo eth0
bind interfaces only = yes
hosts allow = 127.0.0.1 192.168.0.0/24
hosts deny = 0.0.0.0/0
security = share
guest account = samba
guest ok = yes
vfs object = vscan-clamav
vscan-clamav: config-file = /etc/samba/vscan-clamav.conf

[print$]
comment = Printer Drivers
path = /etc/samba/printer
guest ok = yes
browseable = yes

[HPDeskJet970C]
comment = HP DeskJet 970C Network Printer
printable = yes
path = /var/spool/samba
public = yes
guest ok = yes
printer admin = manou,root

[printers]   
comment = All Printers
browseable = no
printable = yes   
writable = no
public = yes   
guest ok = yes
path = /var/spool/samba
printer admin = manou,root

[public]
comment = Public Files
browseable = yes
public = yes
create mode = 0766
guest ok = yes
path = /home/samba/public


Please help me :)
Back to top
View user's profile Send private message
neurosis
Apprentice
Apprentice


Joined: 04 May 2003
Posts: 170
Location: Ottawa, Canada

PostPosted: Tue Sep 28, 2004 12:34 am    Post subject: Reply with quote

blibbleage wrote:
theklone wrote:
Code:
Password for root required to access localhost via SAMBA:
Running command: rpcclient localhost -N -U'root%########' -c 'setdriver ML1510 ML1510'
Succesfully set ML1510 to driver ML1510.

I've got the same problem, what cups version are you using?
Using cups-1.1.20-r2 here on ~x86 system.


I'm using cups-1.1.21, also on ~x86. Does anyone out there know why this isn't working?

Thanks!


Same problem here. I got it working by looking through the thread at some people who actually had this command work, and by manually executing the commands that cupsaddsmb executes.

ie:

Code:

mkdir /etc/samba/printer/W32X86
(move the .dlls, .hlp, and .ppd to this directory)
Then..
rpcclient hektor -N -U'root%XXXXXX' -c 'adddriver "Windows NT x86" \ "lp:cupsdrv5.dll:lp.ppd:cupsui5.dll:cups5.hlp:NULL:RAW:NULL"'


Careful, the 'lp' corresponds to my printer name - yours will be different. Printer is a Samsung ML-1740 and now seems to be working well. At least the Windows clients can auto-install drivers and whatnot :)
_________________
There is no evil greater than that committed by those who claim to do their deeds in the name of God.

-unknown
Back to top
View user's profile Send private message
blibbleage
Tux's lil' helper
Tux's lil' helper


Joined: 19 Aug 2004
Posts: 84
Location: Cambridge, UK

PostPosted: Tue Sep 28, 2004 7:44 am    Post subject: Reply with quote

neurosis wrote:
Same problem here. I got it working by looking through the thread at some people who actually had this command work, and by manually executing the commands that cupsaddsmb executes.

ie:

Code:

mkdir /etc/samba/printer/W32X86
(move the .dlls, .hlp, and .ppd to this directory)
Then..
rpcclient hektor -N -U'root%XXXXXX' -c 'adddriver "Windows NT x86" \ "lp:cupsdrv5.dll:lp.ppd:cupsui5.dll:cups5.hlp:NULL:RAW:NULL"'


Careful, the 'lp' corresponds to my printer name - yours will be different. Printer is a Samsung ML-1740 and now seems to be working well. At least the Windows clients can auto-install drivers and whatnot :)


Thanks for that, but no luck here. My smb.conf specifies /var/lib/samba/printers as the [print$] share, so I used that directory instead. I executed the above commands and got:
Code:
result was DOS code 0x00000003


I then created the directory /var/lib/samba/printers/W32X86/2 and executed the rpcclient command again. This time, the result was:
Code:
result was DOS code 0x00000013


Neither command copied the drivers to the 2/ subdirectory, and the printer still doesn't work from winXP. Any ideas what the DOS codes mean? or why it's not working, come to that?

Thanks!
Back to top
View user's profile Send private message
neurosis
Apprentice
Apprentice


Joined: 04 May 2003
Posts: 170
Location: Ottawa, Canada

PostPosted: Tue Sep 28, 2004 9:39 pm    Post subject: Reply with quote

I didn't create the 2 directory. Just the W32X86 one.. just a subtle difference.
_________________
There is no evil greater than that committed by those who claim to do their deeds in the name of God.

-unknown
Back to top
View user's profile Send private message
blibbleage
Tux's lil' helper
Tux's lil' helper


Joined: 19 Aug 2004
Posts: 84
Location: Cambridge, UK

PostPosted: Tue Sep 28, 2004 10:27 pm    Post subject: Reply with quote

neurosis wrote:
I didn't create the 2 directory. Just the W32X86 one.. just a subtle difference.


I tried that first, but it didn't work. Do you know what results you got from rpcclient? (which DOS code and/or other message?)

Thanks!
Back to top
View user's profile Send private message
neurosis
Apprentice
Apprentice


Joined: 04 May 2003
Posts: 170
Location: Ottawa, Canada

PostPosted: Wed Sep 29, 2004 12:21 am    Post subject: Reply with quote

I don't recall offhand, but it was the same result/output as if the command were run with cupsaddsmb.
_________________
There is no evil greater than that committed by those who claim to do their deeds in the name of God.

-unknown
Back to top
View user's profile Send private message
theklone
n00b
n00b


Joined: 02 Jun 2002
Posts: 8
Location: Melbourne, Australia

PostPosted: Fri Oct 01, 2004 8:36 am    Post subject: Reply with quote

blibbleage wrote:
theklone wrote:
Code:
Password for root required to access localhost via SAMBA:
Running command: rpcclient localhost -N -U'root%########' -c 'setdriver ML1510 ML1510'
Succesfully set ML1510 to driver ML1510.

I've got the same problem, what cups version are you using?
Using cups-1.1.20-r2 here on ~x86 system.


I'm using cups-1.1.21, also on ~x86. Does anyone out there know why this isn't working?

Thanks!


For some reason I said I was using cups-1.1.20-r2 in the above post which I was not, I was using cups-1.1.21, I must of got it confused somewhere.
Anyway it appears cupsaddsmb in cups-1.1.21 requires CUPS v6 PostScript printer driver for Windows which doesn't appear to be available yet.
You could either downgrade to cups-1.1.20 which I did, or use the Adobe PostScript drivers with cups-1.1.21.
Back to top
View user's profile Send private message
blibbleage
Tux's lil' helper
Tux's lil' helper


Joined: 19 Aug 2004
Posts: 84
Location: Cambridge, UK

PostPosted: Fri Oct 01, 2004 4:14 pm    Post subject: Reply with quote

theklone wrote:
For some reason I said I was using cups-1.1.20-r2 in the above post which I was not, I was using cups-1.1.21, I must of got it confused somewhere.
Anyway it appears cupsaddsmb in cups-1.1.21 requires CUPS v6 PostScript printer driver for Windows which doesn't appear to be available yet.
You could either downgrade to cups-1.1.20 which I did, or use the Adobe PostScript drivers with cups-1.1.21.


Thanks for the tip. I've downgraded to cups-1.1.20-r2, restarted cups then installed the drivers again and copied them to /var/lib/samba/printers/W32X86/. I then ran the two rpcclient commands (adddriver and setdriver) but it still couldn't install them from a windows xp client. Thanks for your help, everyone, but I think I'll give up and maybe try again when version 6 of the cups drivers for windows come out.
Back to top
View user's profile Send private message
hpxchan
n00b
n00b


Joined: 26 Aug 2004
Posts: 39

PostPosted: Mon Oct 11, 2004 5:05 pm    Post subject: Reply with quote

First of all (this is only sort of on-topic), when I tell the printer to print a test page, it goes here. ???

Other than that, though, the printer works pretty well. It prints, that is.

I get "Warning: No PPD file for printer "hpxPrinter" - skipping! when I enter:
cupsaddsmb -H PrintServer -U root -h PrintServer -v hpxPrinter
and the same thing happens when I enter:
cupsaddsmb -H localhost -U root -h localhost -v hpxPrinter

I started off with the gentoo samba-cups guide, and changed some stuff around once I got to the cupsaddsmb part.

here is my smb.conf:
Code:
[global]
# Replace MYWORKGROUPNAME with your workgroup/domain
workgroup = HOME
# Of course this has no REAL purpose other than letting
# everyone know its not Windows!
# %v prints the version of Samba we are using.
server string = Samba Server %v
# We are going to use cups, so we are going to put it in here ;-)
printcap name = cups
printing = cups
load printers = yes
browseable = yes
printing = cups
encrypt passwords = yes
lock directory = /usr/local/samba/var/lock
# We want a log file and we do not want it to get bigger than 50kb.
log file = /var/log/samba/log.%m
max log size = 100
# We are going to set some options for our interfaces...
socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192
# This is a good idea, what we are doing is binding the
# samba server to our local network.
# For example, if eth0 is our local network device
interfaces = lo eth0
bind interfaces only = yes
# Now we are going to specify who we allow, we are afterall
# very security conscience, since this configuration does
# not use passwords!
hosts allow = 127.0.0.1 192.168.1.103 192.168.1.101 192.168.1.105 192.168.1.104 192.168.1.0/24
hosts deny = 0.0.0.0/0
# Other options for this are USER, DOMAIN, ADS, and SERVER
# The default is user
security = user
# No passwords, so we're going to use a guest account!
guest account = samba
guest ok = yes
# We now will implement the on access virus scanner.
# NOTE: By putting this in our [Global] section, we enable
# scanning of ALL shares, you could optionally move
# these to a specific share and only scan it.
passdb backend = tdbsam

# For Samba 3.x
vfs object = vscan-clamav
vscan-clamav: config-file = /etc/samba/vscan-clamav.conf

# For Samba 2.2.x
#vfs object = /usr/lib/samba/vfs/vscan-clamav.so
#vfs options = config-file = /etc/samba/vscan-clamav.conf

# Now we setup our print drivers information!
[print$]
comment = Printer Drivers
path = /etc/samba/printer # this path holds the driver structure
guest ok = no
browseable = yes
read only = yes
# Modify this to "username,root" if you don't want root to
# be the only printer admin)
write list = root

# Now we'll setup a printer to share, while the name is arbitrary
# it should be consistent throughout Samba and CUPS!
[hpxPrinter]
comment = hpxunil default printer
printable = yes
path = /var/spool/samba
public = yes
guest ok = yes
# Modify this to "username,root" if you don't want root to
# be the only printer admin)
printer admin = root

# Now we setup our printers share.  This should be
# browseable, printable, public.
[printers]   
comment = All Printers
browseable = no
printable = yes   
writable = no
public = yes   
guest ok = yes
path = /var/spool/samba
# Modify this to "username,root" if you don't want root to
# be the only printer admin)
printer admin = root

# We create a new share that we can read/write to from anywhere
# This is kind of like a public temp share, anyone can do what
# they want here.
[public]
comment = Public Files
browseable = yes
public = yes
create mode = 0766
guest ok = yes
path = /home/samba/public


help, please? :(

hpxchan
Back to top
View user's profile Send private message
Parasietje
Apprentice
Apprentice


Joined: 25 Jan 2004
Posts: 194

PostPosted: Tue Nov 02, 2004 12:19 pm    Post subject: Reply with quote

Hi.
Maybe it's a good idea to use the user 'lp'. That way, you don't have to create an extra user for /etc/passwd.
Also, maybe it's good to add "RunAsUser" in cupsd.conf.

But now:
I added the drivers for CUPS by using cupsaddsmb. All worked, but when I try to connect to the printer in windows, it states "An incorrect driver has been installed on the server where this printer is served. Do you want to attempt to install the drivers locally?"
Installing locally lasts forever...
Back to top
View user's profile Send private message
cato`
Guru
Guru


Joined: 03 Jun 2002
Posts: 430
Location: Norway, Trondheim

PostPosted: Tue Nov 02, 2004 1:55 pm    Post subject: Reply with quote

Quote:
result was WERR_ACCESS_DENIED


I solved this problem by:
1)
mkdir /etc/samba/printer/W32X86 and move the .dlls, .hlp, and .ppd to this directory
2)
comment the "use client driver = yes" line in smb.conf
3)
run cupsaddsmb -H PrintServer -U root -h PrintServer -v HPDeskJet930C
4)
uncomment "use client driver = yes" line in smb.conf

and it works! :D
_________________
Don't mess with the Penguin.
Back to top
View user's profile Send private message
tophfisher
n00b
n00b


Joined: 07 Mar 2004
Posts: 20
Location: Seattle

PostPosted: Tue Nov 02, 2004 4:18 pm    Post subject: Reply with quote

THANKS!! I will give this a try, if it works, you just saved my butt at work!

Thanks for posting the fix,
-Chris

cato` wrote:
Quote:
result was WERR_ACCESS_DENIED


I solved this problem by:
1)
mkdir /etc/samba/printer/W32X86 and move the .dlls, .hlp, and .ppd to this directory
2)
comment the "use client driver = yes" line in smb.conf
3)
run cupsaddsmb -H PrintServer -U root -h PrintServer -v HPDeskJet930C
4)
uncomment "use client driver = yes" line in smb.conf

and it works! :D
Back to top
View user's profile Send private message
theklone
n00b
n00b


Joined: 02 Jun 2002
Posts: 8
Location: Melbourne, Australia

PostPosted: Wed Nov 03, 2004 4:14 am    Post subject: Reply with quote

cato` wrote:
Quote:
result was WERR_ACCESS_DENIED


I solved this problem by:
1)
mkdir /etc/samba/printer/W32X86 and move the .dlls, .hlp, and .ppd to this directory
2)
comment the "use client driver = yes" line in smb.conf
3)
run cupsaddsmb -H PrintServer -U root -h PrintServer -v HPDeskJet930C
4)
uncomment "use client driver = yes" line in smb.conf

and it works! :D


Problem:
Code:
result was WERR_ACCESS_DENIED

Solution:
Quote:
In your smb.conf, you have the option "use client driver" set to "yes".
When it is "yes", it will not allow you to set the driver. You need to
delete the "use client driver" line, reload samba and it should work.
http://lists.samba.org/archive/samba/2004-January/078630.html

All you needed to do was 2) and it should of worked.
Back to top
View user's profile Send private message
fourhead
l33t
l33t


Joined: 03 Sep 2003
Posts: 875
Location: Cologne, Germany

PostPosted: Sun Nov 21, 2004 12:24 am    Post subject: Reply with quote

I hope somebody can help me, I'm really stuck. CUPS is working fine on my system with an Kyocera Mita FS-1010. Samba is also working fine as a PDC for my Winxp VMware guest with bridged networking. I've read several times it's possible to add drivers to Winxp this way:

As Admin, go to "network neighborhood", browse to the Sama server, browse to the printer, open propieties. Then, choose to install a driver, select driver, proceed. This should install the printer driver ON THE SERVER. When I do this, I always get a "permission denied", although I'm Admin, I have root in smbpasswd, I have a usermap that maps Admin to root and so on. As I said, the "rest" of Samba works perfectly under all circumstances. Here's my smb.conf:

Code:

[global]
        netbios name = scratchy
        server string = Samba %v
        workgroup = GEEKSPOT

        hosts allow = 192.168.1.
        encrypt passwords = yes
        security = user

        logon script = %u.bat
        logon path = \\%N\profiles\%U
        logon drive = l:
        logon home = \\%N\%U

#       admin user = root
        domain logons = yes
        domain master = yes
        preferred master = yes
        wins support = yes
        os level = 65

        create mask = 640
        directory mask = 750
        dos charset = 850
        unix charset = ISO8859-15

        load printers = yes
        printing = cups
        printcap name = cups
        printer admin = root, elektro
        username map = /etc/samba/username.map
        socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192

[home]
        path = /home
        writeable = yes

[profiles]
        path = /var/lib/samba/profiles
        writeable = yes
        create mask = 600
        directory mask = 700

[netlogon]
        path = /var/lib/samba/netlogon
        writeable = no
        create mask = 740
        directory mask = 750

[printers]
        path = /var/spool/samba
        browseable = no
        writeable = no
        printable = yes
        printer admin = root,elektro

[print$]
   # this path holds the driver structure
        path = /var/lib/samba/printers
        writeable = yes
        browsable = yes


Permissions on /var/spool/samba and on /var/lib/samba/printers are 777. Any help would be appreciated, since I'm really, really stuck.

Tom
Back to top
View user's profile Send private message
Stormmind
Tux's lil' helper
Tux's lil' helper


Joined: 11 Aug 2002
Posts: 112
Location: Sweden

PostPosted: Sun Nov 21, 2004 11:22 am    Post subject: Reply with quote

Any help with my post here would be greatly appreciated:

https://forums.gentoo.org/viewtopic.php?t=253985
Back to top
View user's profile Send private message
localghost
Apprentice
Apprentice


Joined: 28 Oct 2004
Posts: 185
Location: Sint-Niklaas, Belgium

PostPosted: Sun Nov 21, 2004 10:31 pm    Post subject: Reply with quote

You should mention somewhere that a user "samba" has to be added using
Code:
useradd samba

This one gave me 3 hours of total frustration... :cry:
Back to top
View user's profile Send private message
theonlymcc
Apprentice
Apprentice


Joined: 16 Sep 2003
Posts: 274
Location: NC

PostPosted: Thu Dec 02, 2004 2:45 am    Post subject: Reply with quote

Instead of using SAMBA to print, why not just use the socket? Thats what I do at work and it works without a problem.
Back to top
View user's profile Send private message
fourhead
l33t
l33t


Joined: 03 Sep 2003
Posts: 875
Location: Cologne, Germany

PostPosted: Tue Dec 07, 2004 12:45 am    Post subject: Reply with quote

Me again. I've given up trying to install the driver from within Windows. Instead, I want to use the Windows driver that CUPS offers. I downloaded it, untared it, ran the install script and it copied two DLL files to /usr/share/cups/drivers. There was no .hlp file in the tar archive. When I run cupsaddsmb -a or cupsaddsmb -H hostname -U root -H hostname -a nothing happens. No output, no error, the /etc/samba/printer dir for the print$ share is still empty. What's going wrong here?

Tom

Edit: Didn' know I could run cupsaddsmb in verbose mode. I get this with the -v option:

scratchy : cupsaddsmb -H scratchy -U GEEKSPOT\\root -h scratchy -a -v
Password for GEEKSPOT\root required to access scratchy via SAMBA:
Running command: rpcclient scratchy -N -U'GEEKSPOT\root%XXXXXX' -c 'setdriver KyoceraMitaFS-1010 KyoceraMitaFS-1010'
Succesfully set KyoceraMitaFS-1010 to driver KyoceraMitaFS-1010.

With XXXX being my root passwd. But still, no files in /etc/samba/printer :-(
Back to top
View user's profile Send private message
fourhead
l33t
l33t


Joined: 03 Sep 2003
Posts: 875
Location: Cologne, Germany

PostPosted: Tue Dec 07, 2004 12:35 pm    Post subject: Reply with quote

FINALLY! Finally, it works. I missed one single step: When you create the directory for the print$ share (/etc/amba/printer), you also have to create the appropiate subdirectory (i.e. W32X86 or whatever you need. What the hell, this took me weeks to find out! It then was easy to use the APW to install the driver on the Samba server.

Tom
Back to top
View user's profile Send private message
shagrat
Apprentice
Apprentice


Joined: 10 Mar 2003
Posts: 218
Location: Norway

PostPosted: Tue Dec 07, 2004 7:32 pm    Post subject: Reply with quote

sepulchron wrote:
do you remember the "NT_STATUS_BAD_NETWORK_NAME - problem"?
some posts before a few people had this but as far as i could see, the prob wasn't solved...
if it is solved please tell me how :-)
because i am facing this problem now...

at least i found out some additional information which could help to solve the problem. First i'd like to repeat the problem:

alright, it is about the "cupsaddsmb"
i always get this:
Code:

Yggdrasil root # cupsaddsmb -H Yggdrasil -h Yggdrasil -U root -v -a                 Password for root required to access Yggdrasil via SAMBA:
Running command: smbclient //Yggdrasil/print\$ -N -U'root%********' -c 'mkdir W32X86;put /var/spool/cups/tmp/411d1e700b92e W32X86/Epson.ppd;put /usr/share/cups/drivers/cupsdrv5.dll W32X86/cupsdrv5.dll;put /usr/share/cups/drivers/cupsui5.dll W32X86/cupsui5.dll;put /usr/share/cups/drivers/cups5.hlp W32X86/cups5.hlp'
Domain=[YGGDRASIL] OS=[Unix] Server=[Samba 3.0.5]
tree connect failed: NT_STATUS_BAD_NETWORK_NAME


smbclient is working fine on all shared stuff.
EXCEPT on this [print$] share in which the drivers shall be copied.
watch this:
Code:

Yggdrasil root # smbclient //Yggdrasil/print\$ -U root
Password:
Domain=[YGGDRASIL] OS=[Unix] Server=[Samba 3.0.5]
tree connect failed: NT_STATUS_BAD_NETWORK_NAME


testparm says that everything is fine...here its output:
Code:

[global]
workgroup = Niflheimr
server string = Yggdrasil
netbios name = Yggdrasil
encrypt passwords = True
security = user
smb passwd file = /etc/samba/private/smbpasswd
log file = /var/log/samba/log.%m
socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192
bind interfaces only = True
interfaces = lo eth0
hosts deny = 0.0.0.0/0
hosts allow = 192.168.8.20 192.168.8.18 192.168.8.17 127.0.0.1
printcap name = cups
load printers = yes
printing = yes

[print$]
comment = Printer Drivers
path = /etc/samba/printer       # path to the driver structure
guest ok = no
browsable = yes
read only = yes
write list = root,flo

[printers]
comment = All Printers
path = /var/spool/samba
browseable = no
public = yes
guest ok = yes
writeable = no
printable = yes
printer admin = root

[public]
comment = Public Files
browsable = yes
public = yes
writeable = yes
create mode = 0766
guest ok = no
path = /home/samba/public


hope we can solve this problem, since many seem to face it...


After doing a reinstall of gentoo from the bottom on my server today, I faced this problem. All I had to do to resolv it was to:

Code:
mkdir /etc/samba/drivers
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks All times are GMT
Goto page Previous  1, 2, 3 ... 6, 7, 8, 9, 10, 11  Next
Page 7 of 11

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum