Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ GLSA 202003-03 ] PostgreSQL
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index News & Announcements
View previous topic :: View next topic  
Author Message
GLSA
Advocate
Advocate


Joined: 12 May 2004
Posts: 2308

PostPosted: Thu Mar 12, 2020 9:26 pm    Post subject: [ GLSA 202003-03 ] PostgreSQL Reply with quote

Gentoo Linux Security Advisory

Title: PostgreSQL: Multiple vulnerabilities (GLSA 202003-03)
Severity: normal
Exploitable: local, remote
Date: 2020-03-12
Bug(s): #685846, #688420, #709708
ID: 202003-03

Synopsis

Multiple vulnerabilities have been found in PostgreSQL, the worst
of which could result in the execution of arbitrary code.


Background

PostgreSQL is an open source object-relational database management
system.


Affected Packages

Package: dev-db/postgresql
Vulnerable: < 9.4.26
Vulnerable: < 9.5.21
Vulnerable: < 9.6.17
Vulnerable: < 10.12
Vulnerable: < 11.7
Vulnerable: < 12.2
Unaffected: >= 9.4.26
Unaffected: >= 9.5.21
Unaffected: >= 9.6.17
Unaffected: >= 10.12
Unaffected: >= 11.7
Unaffected: >= 12.2
Architectures: All supported architectures


Description

Multiple vulnerabilities have been discovered in PostgreSQL. Please
review the CVE identifiers referenced below for details.


Impact

A remote attacker could possibly execute arbitrary code with the
privileges of the process, bypass certain client-side connection security
features, read arbitrary server memory, alter certain data or cause a
Denial of Service condition.


Workaround

There is no known workaround at this time.

Resolution

All PostgreSQL 9.4.x users should upgrade to the latest version:
Code:
# emerge --sync
      # emerge --ask --oneshot --verbose ">=dev-db/postgresql-9.4.26:9.4"
   
All PostgreSQL 9.5.x users should upgrade to the latest version:
Code:
# emerge --sync
      # emerge --ask --oneshot --verbose ">=dev-db/postgresql-9.5.21:9.5"
   
All PostgreSQL 9.6.x users should upgrade to the latest version:
Code:
# emerge --sync
      # emerge --ask --oneshot --verbose ">=dev-db/postgresql-9.6.17:9.6"
   
All PostgreSQL 10.x users should upgrade to the latest version:
Code:
# emerge --sync
      # emerge --ask --oneshot --verbose ">=dev-db/postgresql-10.12:10"
   
All PostgreSQL 11.x users should upgrade to the latest version:
Code:
# emerge --sync
      # emerge --ask --oneshot --verbose ">=dev-db/postgresql-11.7:11"
   
All PostgreSQL 12.x users should upgrade to the latest version:
Code:
# emerge --sync
      # emerge --ask --oneshot --verbose ">=dev-db/postgresql-12.2:12"
   


References

CVE-2019-10129
CVE-2019-10130
CVE-2019-10164
CVE-2020-1720
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index News & Announcements All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum