Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ GLSA 202003-04 ] Vim, gVim
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index News & Announcements
View previous topic :: View next topic  
Author Message
GLSA
Advocate
Advocate


Joined: 12 May 2004
Posts: 2308

PostPosted: Thu Mar 12, 2020 10:26 pm    Post subject: [ GLSA 202003-04 ] Vim, gVim Reply with quote

Gentoo Linux Security Advisory

Title: Vim, gVim: Remote execution of arbitrary code (GLSA 202003-04)
Severity: normal
Exploitable: local, remote
Date: 2020-03-12
Bug(s): #687394
ID: 202003-04

Synopsis

A vulnerability has been found in Vim and gVim concerning how
certain modeline options are treated.


Background

Vim is an efficient, highly configurable improved version of the classic
‘vi’ text editor. gVim is the GUI version of Vim.


Affected Packages

Package: app-editors/vim
Vulnerable: < 8.1.1486
Unaffected: >= 8.1.1486
Architectures: All supported architectures

Package: app-editors/gvim
Vulnerable: < 8.1.1486
Unaffected: >= 8.1.1486
Architectures: All supported architectures


Description


It was found that the command was not restricted by
the sandbox mode. If modeline was explicitly enabled, opening a specially
crafted text file in vim could result in arbitrary command execution.


Impact

A remote attacker could entice a user to open a specially crafted file
using Vim or gVim, possibly resulting in execution of arbitrary code with
the privileges of the process or a Denial of Service condition.


Workaround

There is no known workaround at this time.

Resolution

All Vim users should upgrade to the latest version:
Code:
# emerge --sync
      # emerge --ask --oneshot --verbose ">=app-editors/vim-8.1.1486"
   
All gVim users should upgrade to the latest version:
Code:
# emerge --sync
      # emerge --ask --oneshot --verbose ">=app-editors/gvim-8.1.1486"
   


References

CVE-2019-12735
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index News & Announcements All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum