Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Block nvidia-drivers und opengl
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
uhai
Veteran
Veteran


Joined: 23 Aug 2007
Posts: 1231
Location: Eppingen, Germany

PostPosted: Sat Mar 14, 2020 1:59 pm    Post subject: Block nvidia-drivers und opengl Reply with quote

wiedermal ein Block, den ich nicht verstehe:

Code:
[blocks B      ] x11-drivers/nvidia-drivers[-libglvnd(-)] ("x11-drivers/nvidia-drivers[-libglvnd(-)]" is hard blocking x11-base/xorg-server-1.20.7)
[blocks B      ] app-eselect/eselect-opengl ("app-eselect/eselect-opengl" is blocking x11-base/xorg-server-1.20.7, media-libs/mesa-19.3.5)


Heißt das nvidia-drivers braucht USE=libglvnd ? Und wie muß ich den zweiten Block deuten? Hat das etwas mit der news 2020-03-09-opencl-abi_x86_32-phaseout zu tun? opencl ist doch ein anderes Modul als opengl....????

uhai
_________________
Asus 4A785TD-M EVO mit AMD Phenom(tm) II X4 945
Dell Mini 10v
http://www.openstreetmap.org
Back to top
View user's profile Send private message
uhai
Veteran
Veteran


Joined: 23 Aug 2007
Posts: 1231
Location: Eppingen, Germany

PostPosted: Sat Mar 14, 2020 9:30 pm    Post subject: Reply with quote

Ist wohl ein bekannter Fehler für den schon ein Patch vorgeschlagen ist. Probiere ich morgen mal aus....

uhai
_________________
Asus 4A785TD-M EVO mit AMD Phenom(tm) II X4 945
Dell Mini 10v
http://www.openstreetmap.org
Back to top
View user's profile Send private message
michael_w
Guru
Guru


Joined: 22 Feb 2006
Posts: 438
Location: 09xxx

PostPosted: Fri Mar 20, 2020 10:24 am    Post subject: Reply with quote

Bist Du da weitergekommen? Bei mir gibt es da immer noch einen Block:

Code:

[ebuild  N     ] app-eselect/eselect-opengl-1.3.1-r4::gentoo  0 KiB
[blocks B      ] app-eselect/eselect-opengl ("app-eselect/eselect-opengl" is blocking x11-base/xorg-server-1.20.7, x11-drivers/nvidia-drivers-440.59, media-libs/mesa-19.3.5)


nvidia-drivers ist mit USE="libglvnd" gebaut.
_________________
Linux ryzen 4.19.97-gentoo #1 SMP Fri Mar 27 09:10:25 CET 2020 x86_64 AMD Ryzen 7 3700X 8-Core Processor AuthenticAMD GNU/Linux
Back to top
View user's profile Send private message
flammenflitzer
Advocate
Advocate


Joined: 25 Nov 2003
Posts: 3183
Location: Berlin

PostPosted: Fri Mar 20, 2020 2:13 pm    Post subject: Reply with quote

Funktioniert bei mir nur mit
Code:
USE="-libglvnd" emerge x11-drivers/nvidia-drivers
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3809
Location: Germany

PostPosted: Fri Mar 20, 2020 11:14 pm    Post subject: Reply with quote

@uhai,
ich denke mit deiner nvidia-drivers-390er-Version solltest vermutlich erst mal in der make.conf USE="-libglvnd" setzen,
oder beim fixen von Bug 713546 mithelfen :)

_____________________________________________________________________________
@michael_w,
ich denke du mit deiner nvidia-drivers-440er-Version solltest in der make.conf USE="libglvnd" setzen,
vermutlich hat eines der installierten Pakete aus einem Overlay (steam?) libglvnd noch nicht im ebuild per default enabled (wild geraten).
Falls das noch nicht hilft, dann poste bitte den kompletten emerge -avuDN --tree @world output (via Pastebin-Service) -- damit wird man dann vermutlich besser weiterhelfen können.
Back to top
View user's profile Send private message
uhai
Veteran
Veteran


Joined: 23 Aug 2007
Posts: 1231
Location: Eppingen, Germany

PostPosted: Sat Mar 21, 2020 11:20 am    Post subject: Reply with quote

Sorry,
konnte mich um das Thema nicht weiter kümmern weil ich überraschend "Pandemie-Beauftragter" wurde und auf einmal die Firma umkrempeln darf/muss.

Scheint so, als ob der mit Patch zwar den Block beseitigt, aber nicht funktioniert? Habe ich das richtig verstanden?

Wie kann ich den anderen Bug unterstützen? Ich kann mein emerge- -info hochladen und das Problem von hier aus bestätigen, aber weiter?

uhai

PS: mit USE=-libglvnd ist der Block weg und emerge läuft....
_________________
Asus 4A785TD-M EVO mit AMD Phenom(tm) II X4 945
Dell Mini 10v
http://www.openstreetmap.org
Back to top
View user's profile Send private message
tazinblack
Veteran
Veteran


Joined: 23 Jan 2005
Posts: 1136
Location: Baden / Germany

PostPosted: Sun Mar 22, 2020 7:15 pm    Post subject: Reply with quote

Hallo zusammen,

also bei mir hat er beim update von x11-libs/cairo immer mit nem Linkerfehler gegen libGL abgebrochen.
Den Block hat er aber selbststänfig aufgelöst.
Hab dann
Code:
eselect opengl set xorg-x11
oder so probiert, dann lief alles durch.

Und nvidia-drivers sieht jetzt so aus:

Code:
emerge -pv nvidia-drivers

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R    ] x11-drivers/nvidia-drivers-440.59:0/440::gentoo  USE="X acpi driver kms libglvnd multilib tools -compat -gtk3 -static-libs -uvm -wayland" ABI_X86="32 (64) (-x32)" 0 KiB


Und nach den Updates gibt es eselect opengl nicht mehr :?

Code:
eselect
Usage: eselect <global options> <module name> <module options>

Global options:
  --brief                   Make output shorter
  --colour=<yes|no|auto>    Enable or disable colour output (default 'auto')

Built-in modules:
  help                      Display a help message
  usage                     Display a usage message
  version                   Display version information

Extra modules:
  binutils                  Manage installed versions of sys-devel/binutils
  cdparanoia                Manage /usr/bin/cdparanoia implementation
  ecj                       Manage ECJ targets
  editor                    Manage the EDITOR environment variable
  env                       Manage environment variables set in /etc/env.d/
  fontconfig                Manage fontconfig /etc/fonts/conf.d/ symlinks
  gcc                       Manage installed versions of sys-devel/gcc
  java-vm                   Manage the Java system and user VM
  kernel                    Manage the /usr/src/linux symlink
  locale                    Manage the LANG environment variable
  maven                     Manage Maven targets
  modules                   Query eselect modules
  mpg123                    Manage /usr/bin/mpg123 implementation
  news                      Read Gentoo ("GLEP 42") news items
  notify-send               Manage /usr/bin/notify-send implementation
  opencl                    Manage the OpenCL implementation used by your system
  pager                     Manage the PAGER environment variable
  php                       Manage php installations
  pinentry                  Manage /usr/bin/pinentry implementation
  profile                   Manage the make.profile symlink
  python                    Manage Python interpreter preferences
  rc                        Manage /etc/init.d scripts in runlevels
  ruby                      Manage Ruby symlinks
  vi                        Manage /usr/bin/vi implementations
  visual                    Manage the VISUAL environment variable
  wxwidgets                 Manage the system default wxWidgets profile
  xvmc                      Manage the XvMC implementation used by your system


Gabs da irgendwelche Infos zu?
_________________
Gruß / Regards
tazinblack
_______________________________________________________
what's the point in being grown up if you can't be childish sometimes
Back to top
View user's profile Send private message
flammenflitzer
Advocate
Advocate


Joined: 25 Nov 2003
Posts: 3183
Location: Berlin

PostPosted: Sun May 24, 2020 5:28 pm    Post subject: Reply with quote

Die gleiche Frage beschäftigt mich auch gerade. Mit welchem Kommando kann ich jetzt listen und ggf. umschalten?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum