Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ GLSA 202003-31 ] gdb
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index News & Announcements
View previous topic :: View next topic  
Author Message
GLSA
Advocate
Advocate


Joined: 12 May 2004
Posts: 2308

PostPosted: Sun Mar 15, 2020 11:26 pm    Post subject: [ GLSA 202003-31 ] gdb Reply with quote

Gentoo Linux Security Advisory

Title: gdb: Buffer overflow (GLSA 202003-31)
Severity: normal
Exploitable: local, remote
Date: 2020-03-15
Bug(s): #690582
ID: 202003-31

Synopsis

A buffer overflow in gdb might allow a remote attacker to cause a
Denial of Service condition.


Background

gdb is the GNU project’s debugger, facilitating the analysis and
debugging of applications. The BFD library provides a uniform method of
accessing a variety of object file formats.


Affected Packages

Package: sys-devel/gdb
Vulnerable: < 9.1
Unaffected: >= 9.1
Architectures: All supported architectures


Description

It was discovered that gdb didn’t properly validate the ELF section
sizes from input file.


Impact

A remote attacker could entice a user to open a specially crafted ELF
binary using gdb, possibly resulting in information disclosure or a
Denial of Service condition.


Workaround

There is no known workaround at this time.

Resolution

All gdb users should upgrade to the latest version:
Code:
# emerge --sync
      # emerge --ask --oneshot --verbose ">=sys-devel/gdb-9.1"
   


References


CVE-2019-1010180
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index News & Announcements All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum