Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
pulseaudio picks profiles seemingly at random
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
krotuss
Apprentice
Apprentice


Joined: 01 Aug 2008
Posts: 167

PostPosted: Thu Mar 19, 2020 12:43 pm    Post subject: pulseaudio picks profiles seemingly at random Reply with quote

Hello,

I am not able to get my jabra headset to work reliably. It usually gets recognized only either as input or output device, very rarely both:

Code:
    index: 19
        name: <alsa_card.usb-GN_Netcom_A_S_Jabra_EVOLVE_20_MS_0002971FACF207-00>
        driver: <module-alsa-card.c>
        owner module: 53
        properties:
                alsa.card = "1"
                alsa.card_name = "Jabra EVOLVE 20 MS"
                alsa.long_card_name = "GN Netcom A/S Jabra EVOLVE 20 MS at usb-0000:00:14.0-3, full speed"
                alsa.driver_name = "snd_usb_audio"
                device.bus_path = "pci-0000:00:14.0-usb-0:3:1.0"
                sysfs.path = "/devices/pci0000:00/0000:00:14.0/usb3/3-3/3-3:1.0/sound/card1"
                udev.id = "usb-GN_Netcom_A_S_Jabra_EVOLVE_20_MS_0002971FACF207-00"
                device.bus = "usb"
                device.vendor.id = "0b0e"
                device.vendor.name = "GN Netcom"
                device.product.id = "0300"
                device.product.name = "Jabra EVOLVE 20 MS"
                device.serial = "GN_Netcom_A_S_Jabra_EVOLVE_20_MS_EDITED_OUT"
                device.string = "1"
                device.description = "Jabra EVOLVE 20 MS"
                module-udev-detect.discovered = "1"
                device.icon_name = "audio-card-usb"
        profiles:
                output:analog-stereo: Analog Stereo Output (priority 6500, available: unknown)
                output:iec958-stereo: Digital Stereo (IEC958) Output (priority 5500, available: unknown)
                off: Off (priority 0, available: unknown)
        active profile: <off>
        ports:
                analog-output-headphones: Headphones (priority 9900, latency offset 0 usec, available: unknown)
                        properties:
                                device.icon_name = "audio-headphones"
                iec958-stereo-output: Digital Output (S/PDIF) (priority 0, latency offset 0 usec, available: unknown)
                        properties:


Code:
    index: 20
        name: <alsa_card.usb-GN_Netcom_A_S_Jabra_EVOLVE_20_MS_0002971FACF207-00>
        driver: <module-alsa-card.c>
        owner module: 54
        properties:
                alsa.card = "1"
                alsa.card_name = "Jabra EVOLVE 20 MS"
                alsa.long_card_name = "GN Netcom A/S Jabra EVOLVE 20 MS at usb-0000:00:14.0-3, full speed"
                alsa.driver_name = "snd_usb_audio"
                device.bus_path = "pci-0000:00:14.0-usb-0:3:1.0"
                sysfs.path = "/devices/pci0000:00/0000:00:14.0/usb3/3-3/3-3:1.0/sound/card1"
                udev.id = "usb-GN_Netcom_A_S_Jabra_EVOLVE_20_MS_0002971FACF207-00"
                device.bus = "usb"
                device.vendor.id = "0b0e"
                device.vendor.name = "GN Netcom"
                device.product.id = "0300"
                device.product.name = "Jabra EVOLVE 20 MS"
                device.serial = "GN_Netcom_A_S_Jabra_EVOLVE_20_MS_EDITED_OUT"
                device.string = "1"
                device.description = "Jabra EVOLVE 20 MS"
                module-udev-detect.discovered = "1"
                device.icon_name = "audio-card-usb"
        profiles:
                input:mono-fallback: Mono Input (priority 1, available: unknown)
                input:multichannel-input: Multichannel Input (priority 1, available: unknown)
                off: Off (priority 0, available: unknown)
        active profile: <input:mono-fallback>
        sources:
                alsa_input.usb-GN_Netcom_A_S_Jabra_EVOLVE_20_MS_0002971FACF207-00.mono-fallback/#47: Jabra EVOLVE 20 MS Mono
        ports:
                analog-input-headset-mic: Headset Microphone (priority 8800, latency offset 0 usec, available: unknown)
                        properties:
                                device.icon_name = "audio-input-microphone"
                multichannel-input: Multichannel Input (priority 0, latency offset 0 usec, available: unknown)
                        properties:


How PA determines what profiles are made available for device? Is there a way to fix this? Thanks.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum