Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ GLSA 202003-38 ] PECL Imagick
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index News & Announcements
View previous topic :: View next topic  
Author Message
GLSA
Advocate
Advocate


Joined: 12 May 2004
Posts: 2308

PostPosted: Thu Mar 19, 2020 4:26 pm    Post subject: [ GLSA 202003-38 ] PECL Imagick Reply with quote

Gentoo Linux Security Advisory

Title: PECL Imagick: Arbitrary code execution (GLSA 202003-38)
Severity: high
Exploitable: remote
Date: 2020-03-19
Bug(s): #687030
ID: 202003-38

Synopsis

A vulnerability in Imagick PHP extension might allow an attacker to
execute arbitrary code.


Background

Imagick is a PHP extension to create and modify images using the
ImageMagick library.


Affected Packages

Package: dev-php/pecl-imagick
Vulnerable: < 3.4.4
Unaffected: >= 3.4.4
Architectures: All supported architectures


Description

An out-of-bounds write vulnerability was discovered in the Imagick PHP
extension.


Impact

A remote attacker, able to upload specially crafted images which will
get processed by Imagick, could possibly execute arbitrary code with the
privileges of the process or cause a Denial of Service condition.


Workaround

There is no known workaround at this time.

Resolution

All Imagick PHP extension users should upgrade to the latest version:
Code:
# emerge --sync
      # emerge --ask --oneshot --verbose ">=dev-php/pecl-imagick-3.4.4"
   


References

CVE-2019-11037
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index News & Announcements All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum