Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
AMDGPU - Hibernate and S3 issues.
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
spiriteh
n00b
n00b


Joined: 24 Jul 2019
Posts: 4

PostPosted: Tue Mar 31, 2020 12:32 am    Post subject: AMDGPU - Hibernate and S3 issues. Reply with quote

Hello,

I'm having an issue with amdgpu where it isn't playing nice with S3 and hibernate. I'm hoping that someone has experience of this and can assist.

Thank-you in advance for any help.


Hardware:
Thinkpad A485 (2700U).

lspci -k :
Code:

00:00.0 Host bridge: Advanced Micro Devices, Inc. [AMD] Raven/Raven2 Root Complex
   Subsystem: Advanced Micro Devices, Inc. [AMD] Raven/Raven2 Root Complex
00:00.2 IOMMU: Advanced Micro Devices, Inc. [AMD] Raven/Raven2 IOMMU
   Subsystem: Advanced Micro Devices, Inc. [AMD] Raven/Raven2 IOMMU
00:01.0 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 17h (Models 00h-1fh) PCIe Dummy Host Bridge
00:01.1 PCI bridge: Advanced Micro Devices, Inc. [AMD] Raven/Raven2 PCIe GPP Bridge [6:0]
   Kernel driver in use: pcieport
00:01.2 PCI bridge: Advanced Micro Devices, Inc. [AMD] Raven/Raven2 PCIe GPP Bridge [6:0]
   Kernel driver in use: pcieport
00:01.4 PCI bridge: Advanced Micro Devices, Inc. [AMD] Raven/Raven2 PCIe GPP Bridge [6:0]
   Kernel driver in use: pcieport
00:01.5 PCI bridge: Advanced Micro Devices, Inc. [AMD] Raven/Raven2 PCIe GPP Bridge [6:0]
   Kernel driver in use: pcieport
00:01.6 PCI bridge: Advanced Micro Devices, Inc. [AMD] Raven/Raven2 PCIe GPP Bridge [6:0]
   Kernel driver in use: pcieport
00:08.0 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 17h (Models 00h-1fh) PCIe Dummy Host Bridge
00:08.1 PCI bridge: Advanced Micro Devices, Inc. [AMD] Raven/Raven2 Internal PCIe GPP Bridge 0 to Bus A
   Kernel driver in use: pcieport
00:08.2 PCI bridge: Advanced Micro Devices, Inc. [AMD] Raven/Raven2 Internal PCIe GPP Bridge 0 to Bus B
   Kernel driver in use: pcieport
00:14.0 SMBus: Advanced Micro Devices, Inc. [AMD] FCH SMBus Controller (rev 61)
   Subsystem: Lenovo FCH SMBus Controller
00:14.3 ISA bridge: Advanced Micro Devices, Inc. [AMD] FCH LPC Bridge (rev 51)
   Subsystem: Lenovo FCH LPC Bridge
00:18.0 Host bridge: Advanced Micro Devices, Inc. [AMD] Raven/Raven2 Device 24: Function 0
00:18.1 Host bridge: Advanced Micro Devices, Inc. [AMD] Raven/Raven2 Device 24: Function 1
00:18.2 Host bridge: Advanced Micro Devices, Inc. [AMD] Raven/Raven2 Device 24: Function 2
00:18.3 Host bridge: Advanced Micro Devices, Inc. [AMD] Raven/Raven2 Device 24: Function 3
   Kernel driver in use: k10temp
00:18.4 Host bridge: Advanced Micro Devices, Inc. [AMD] Raven/Raven2 Device 24: Function 4
00:18.5 Host bridge: Advanced Micro Devices, Inc. [AMD] Raven/Raven2 Device 24: Function 5
00:18.6 Host bridge: Advanced Micro Devices, Inc. [AMD] Raven/Raven2 Device 24: Function 6
00:18.7 Host bridge: Advanced Micro Devices, Inc. [AMD] Raven/Raven2 Device 24: Function 7
01:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. RTS522A PCI Express Card Reader (rev 01)
   Subsystem: Lenovo RTS522A PCI Express Card Reader
   Kernel driver in use: rtsx_pci
02:00.0 Network controller: Realtek Semiconductor Co., Ltd. RTL8822BE 802.11a/b/g/n/ac WiFi adapter
   Subsystem: Lenovo RTL8822BE 802.11a/b/g/n/ac WiFi adapter
   Kernel driver in use: rtw_pci
   Kernel modules: rtwpci
03:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 0e)
   Subsystem: Lenovo RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
   Kernel driver in use: r8169
   Kernel modules: r8169
03:00.1 Serial controller: Realtek Semiconductor Co., Ltd. Device 816a (rev 0e)
   Subsystem: Lenovo Device 5122
03:00.2 Serial controller: Realtek Semiconductor Co., Ltd. Device 816b (rev 0e)
   Subsystem: Lenovo Device 5122
03:00.3 IPMI Interface: Realtek Semiconductor Co., Ltd. Device 816c (rev 0e)
   Subsystem: Lenovo Device 5122
   Kernel modules: ipmi_si
03:00.4 USB controller: Realtek Semiconductor Co., Ltd. Device 816d (rev 0e)
   Subsystem: Lenovo Device 5122
   Kernel driver in use: ehci-pci
04:00.0 Non-Volatile memory controller: Toshiba Corporation BG3 NVMe SSD Controller (rev 01)
   Subsystem: Toshiba Corporation BG3 NVMe SSD Controller
   Kernel driver in use: nvme
05:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 10)
   Subsystem: Lenovo RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
   Kernel driver in use: r8169
   Kernel modules: r8169
06:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Raven Ridge [Radeon Vega Series / Radeon Vega Mobile Series] (rev d0)
   Subsystem: Lenovo Raven Ridge [Radeon Vega Series / Radeon Vega Mobile Series]
   Kernel driver in use: amdgpu
06:00.1 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] Raven/Raven2/Fenghuang HDMI/DP Audio Controller
   Subsystem: Lenovo Raven/Raven2/Fenghuang HDMI/DP Audio Controller
   Kernel driver in use: snd_hda_intel
06:00.2 Encryption controller: Advanced Micro Devices, Inc. [AMD] Family 17h (Models 10h-1fh) Platform Security Processor
   Subsystem: Lenovo Family 17h (Models 10h-1fh) Platform Security Processor
06:00.3 USB controller: Advanced Micro Devices, Inc. [AMD] Raven USB 3.1
   Subsystem: Lenovo Raven USB 3.1
   Kernel driver in use: xhci_hcd
06:00.4 USB controller: Advanced Micro Devices, Inc. [AMD] Raven USB 3.1
   Subsystem: Lenovo Raven USB 3.1
   Kernel driver in use: xhci_hcd
06:00.6 Audio device: Advanced Micro Devices, Inc. [AMD] Family 17h (Models 10h-1fh) HD Audio Controller
   Subsystem: Lenovo Family 17h (Models 10h-1fh) HD Audio Controller
   Kernel driver in use: snd_hda_intel
07:00.0 SATA controller: Advanced Micro Devices, Inc. [AMD] FCH SATA Controller [AHCI mode] (rev 61)
   Subsystem: Lenovo FCH SATA Controller [AHCI mode]
   Kernel driver in use: ahci
   Kernel modules: ahci


Issue:
S3 doesn't give anything in dmesg however it sometimes just powers down when attempting to resume (as soon as triggered) and sometimes comes back without input devices working in X, however TTY is 'fine'. On occasion it even works.

Hibernate gives the below error from amdgpu in dmesg.


Software:
System is using EFI as per Sakaki install guide.

I think this is all the relevant software listed:
Code:

[I] x11-drivers/xf86-video-amdgpu - 19.1.0{tbz2}(04:28:16 29/03/20)(udev)

[I] sys-kernel/gentoo-sources - 5.6.0(5.6.0)^bs{tbz2}(17:17:23 30/03/20)(experimental -build -symlink)

[I] media-libs/mesa - 19.3.5^t{tbz2}(04:40:28 29/03/20)(X classic dri3 egl gallium gbm gles2 libglvnd llvm -d3d9 -debug -gles1 -lm-sensors -opencl -osmesa -pax_kernel -selinux -test -unwind -vaapi -valgrind -vdpau -vulkan -vulkan-overlay -wayland -xa -xvmc ABI_MIPS="-n32 -n64 -o32" ABI_RISCV="-lp64 -lp64d" ABI_S390="-32 -64" ABI_X86="64 -32 -x32" VIDEO_CARDS="radeonsi -freedreno -i915 -i965 -intel -iris -lima -nouveau -panfrost -r100 -r200 -r300 -r600 -radeon -vc4 -virgl -vivante -vmware")

[I] sys-power/pm-utils - 1.4.1-r7{tbz2}(04:19:27 29/03/20)(alsa -debug -ntp VIDEO_CARDS="-intel -radeon")


Error posted following resume from hibernation by amdgpu:
Code:

[  578.715119] amdgpu 0000:06:00.0: [gfxhub0] no-retry page fault (src_id:0 ring:222 vmid:2 pasid:0, for process  pid 0 thread  pid 0)
[  578.715123] amdgpu 0000:06:00.0:   in page starting at address 0x0000800000020000 from client 27
[  578.715125] amdgpu 0000:06:00.0: VM_L2_PROTECTION_FAULT_STATUS:0x002009BC
[  578.715127] amdgpu 0000:06:00.0:     MORE_FAULTS: 0x0
[  578.715129] amdgpu 0000:06:00.0:     WALKER_ERROR: 0x6
[  578.715130] amdgpu 0000:06:00.0:     PERMISSION_FAULTS: 0xb
[  578.715132] amdgpu 0000:06:00.0:     MAPPING_ERROR: 0x1
[  578.715134] amdgpu 0000:06:00.0:     RW: 0x0

[  579.881117] amdgpu 0000:06:00.0: [drm:amdgpu_ib_ring_tests] *ERROR* IB test failed on gfx (-110).
[  579.881125] [drm:process_one_work] *ERROR* ib ring test failed (-110).



Full dmesg following resume from hibernation:
Code:

  578.012468] PM: Restoring platform NVS memory
[  578.017371] ACPI: EC: EC started
[  578.018278] Enabling non-boot CPUs ...
[  578.018377] x86: Booting SMP configuration:
[  578.018379] smpboot: Booting Node 0 Processor 1 APIC 0x1
[  578.018913] microcode: CPU1: patch_level=0x0810100b
[  578.021296] ACPI: \_PR_.C001: Found 2 idle states
[  578.021676] CPU1 is up
[  578.021781] smpboot: Booting Node 0 Processor 2 APIC 0x2
[  578.022180] microcode: CPU2: patch_level=0x0810100b
[  578.024510] ACPI: \_PR_.C002: Found 2 idle states
[  578.024879] CPU2 is up
[  578.024970] smpboot: Booting Node 0 Processor 3 APIC 0x3
[  578.025337] microcode: CPU3: patch_level=0x0810100b
[  578.027658] ACPI: \_PR_.C003: Found 2 idle states
[  578.028046] CPU3 is up
[  578.028133] smpboot: Booting Node 0 Processor 4 APIC 0x4
[  578.028912] microcode: CPU4: patch_level=0x0810100b
[  578.031239] ACPI: \_PR_.C004: Found 2 idle states
[  578.031634] CPU4 is up
[  578.031723] smpboot: Booting Node 0 Processor 5 APIC 0x5
[  578.032093] microcode: CPU5: patch_level=0x0810100b
[  578.034402] ACPI: \_PR_.C005: Found 2 idle states
[  578.034835] CPU5 is up
[  578.034922] smpboot: Booting Node 0 Processor 6 APIC 0x6
[  578.035299] microcode: CPU6: patch_level=0x0810100b
[  578.037623] ACPI: \_PR_.C006: Found 2 idle states
[  578.038021] CPU6 is up
[  578.038123] smpboot: Booting Node 0 Processor 7 APIC 0x7
[  578.038512] microcode: CPU7: patch_level=0x0810100b
[  578.040835] ACPI: \_PR_.C007: Found 2 idle states
[  578.041365] CPU7 is up
[  578.051529] ACPI: Waking up from system sleep state S4
[  578.071437] ACPI: EC: interrupt unblocked
[  578.272075] ACPI: EC: event unblocked
[  578.272190] usb usb1: root hub lost power or was reset
[  578.272197] usb usb2: root hub lost power or was reset
[  578.272219] usb usb3: root hub lost power or was reset
[  578.272246] usb usb4: root hub lost power or was reset
[  578.272249] usb usb5: root hub lost power or was reset
[  578.272401] xhci_hcd 0000:06:00.4: AMD-Vi: Event logged [IO_PAGE_FAULT domain=0x0010 address=0xfff851c0 flags=0x0020]
[  578.272416] xhci_hcd 0000:06:00.4: AMD-Vi: Event logged [IO_PAGE_FAULT domain=0x0010 address=0xfff85040 flags=0x0020]
[  578.273265] [drm] PCIE GART of 1024M enabled (table at 0x000000F400900000).
[  578.273326] [drm] PSP is resuming...
[  578.279471] sd 2:0:0:0: [sda] Starting disk
[  578.293366] [drm] reserve 0x400000 from 0xf43f800000 for PSP TMR
[  578.296990] [drm] psp command (0x5) failed and response status is (0xFFFF0007)
[  578.350128] r8169 0000:03:00.0 enp3s0f0: Link is Down
[  578.353277] r8169 0000:05:00.0 enp5s0: Link is Down
[  578.375023] amdgpu 0000:06:00.0: RAS: ras ta ucode is not available
[  578.512470] usb 3-2: reset SuperSpeed Gen 1 USB device number 2 using xhci_hcd
[  578.531035] nvme nvme0: 16/0/0 default/read/poll queues
[  578.612296] usb 4-2: reset high-speed USB device number 3 using xhci_hcd
[  578.715119] amdgpu 0000:06:00.0: [gfxhub0] no-retry page fault (src_id:0 ring:222 vmid:2 pasid:0, for process  pid 0 thread  pid 0)
[  578.715123] amdgpu 0000:06:00.0:   in page starting at address 0x0000800000020000 from client 27
[  578.715125] amdgpu 0000:06:00.0: VM_L2_PROTECTION_FAULT_STATUS:0x002009BC
[  578.715127] amdgpu 0000:06:00.0:     MORE_FAULTS: 0x0
[  578.715129] amdgpu 0000:06:00.0:     WALKER_ERROR: 0x6
[  578.715130] amdgpu 0000:06:00.0:     PERMISSION_FAULTS: 0xb
[  578.715132] amdgpu 0000:06:00.0:     MAPPING_ERROR: 0x1
[  578.715134] amdgpu 0000:06:00.0:     RW: 0x0
[  578.715248] [drm] kiq ring mec 2 pipe 1 q 0
[  578.723470] amdgpu: [powerplay] dpm has been enabled
[  578.739915] usb 4-1: reset high-speed USB device number 2 using xhci_hcd
[  578.752347] ata2: SATA link up 6.0 Gbps (SStatus 133 SControl 300)
[  578.752727] ata2.00: supports DRM functions and may not be fully accessible
[  578.756141] ata2.00: supports DRM functions and may not be fully accessible
[  578.759099] ata2.00: configured for UDMA/133
[  578.769450] ata2.00: Enabling discard_zeroes_data
[  578.859917] [drm] VCN decode and encode initialized successfully(under SPG Mode).
[  578.859938] amdgpu 0000:06:00.0: ring gfx uses VM inv eng 0 on hub 0
[  578.859940] amdgpu 0000:06:00.0: ring comp_1.0.0 uses VM inv eng 1 on hub 0
[  578.859942] amdgpu 0000:06:00.0: ring comp_1.1.0 uses VM inv eng 4 on hub 0
[  578.859944] amdgpu 0000:06:00.0: ring comp_1.2.0 uses VM inv eng 5 on hub 0
[  578.859946] amdgpu 0000:06:00.0: ring comp_1.3.0 uses VM inv eng 6 on hub 0
[  578.859948] amdgpu 0000:06:00.0: ring comp_1.0.1 uses VM inv eng 7 on hub 0
[  578.859950] amdgpu 0000:06:00.0: ring comp_1.1.1 uses VM inv eng 8 on hub 0
[  578.859952] amdgpu 0000:06:00.0: ring comp_1.2.1 uses VM inv eng 9 on hub 0
[  578.859954] amdgpu 0000:06:00.0: ring comp_1.3.1 uses VM inv eng 10 on hub 0
[  578.859955] amdgpu 0000:06:00.0: ring kiq_2.1.0 uses VM inv eng 11 on hub 0
[  578.859957] amdgpu 0000:06:00.0: ring sdma0 uses VM inv eng 0 on hub 1
[  578.859959] amdgpu 0000:06:00.0: ring vcn_dec uses VM inv eng 1 on hub 1
[  578.859961] amdgpu 0000:06:00.0: ring vcn_enc0 uses VM inv eng 4 on hub 1
[  578.859962] amdgpu 0000:06:00.0: ring vcn_enc1 uses VM inv eng 5 on hub 1
[  578.859964] amdgpu 0000:06:00.0: ring jpeg_dec uses VM inv eng 6 on hub 1
[  578.979196] usb 4-2.2: reset full-speed USB device number 5 using xhci_hcd
[  579.126404] usb 4-2.4: reset high-speed USB device number 7 using xhci_hcd
[  579.205436] usb 4-1.4: reset full-speed USB device number 6 using xhci_hcd
[  579.336446] [drm] Fence fallback timer expired on ring sdma0
[  579.357160] usb 4-1.1: reset full-speed USB device number 4 using xhci_hcd
[  579.881117] amdgpu 0000:06:00.0: [drm:amdgpu_ib_ring_tests] *ERROR* IB test failed on gfx (-110).
[  579.881125] [drm:process_one_work] *ERROR* ib ring test failed (-110).
[  579.886751] thinkpad_acpi: acpi_evalf(STRW, vd, ...) failed: AE_NOT_FOUND
[  579.886752] thinkpad_acpi: Cannot set adaptive keyboard mode.
[  579.900763] acpi LNXPOWER:03: Turning OFF
[  579.900808] acpi LNXPOWER:00: Turning OFF
[  579.900904] PM: hibernation: Basic memory bitmaps freed
[  579.900910] OOM killer enabled.
[  579.900910] Restarting tasks ... done.
[  579.904145] Bluetooth: hci0: RTL: examining hci_ver=07 hci_rev=000b lmp_ver=07 lmp_subver=8822
[  579.907131] Bluetooth: hci0: RTL: rom_version status=0 version=2
[  579.907135] Bluetooth: hci0: RTL: loading rtl_bt/rtl8822b_fw.bin
[  579.907150] Bluetooth: hci0: RTL: loading rtl_bt/rtl8822b_config.bin
[  579.907163] Bluetooth: hci0: RTL: cfg_sz 14, total sz 20270
[  579.975878] PM: hibernation: hibernation exit
[  580.638284] psmouse serio1: synaptics: queried max coordinates: x [..5676], y [..4690]
[  580.676215] psmouse serio1: synaptics: queried min coordinates: x [1266..], y [1162..]
[  580.812157] Bluetooth: hci0: RTL: fw version 0xab6b705c
[  580.836701] r8169 0000:05:00.0 enp5s0: Link is Up - 100Mbps/Full - flow control rx/tx
[  590.965307] broken atomic modeset userspace detected, disabling atomic
[ 1098.728255] psmouse serio2: trackpoint: IBM TrackPoint firmware: 0x0e, buttons: 3/3
[ 1098.943037] input: TPPS/2 IBM TrackPoint as /devices/platform/i8042/serio1/serio2/input/input16
Back to top
View user's profile Send private message
Goverp
l33t
l33t


Joined: 07 Mar 2007
Posts: 837

PostPosted: Tue Mar 31, 2020 8:38 am    Post subject: Reply with quote

spiriteh,

I've had an HP laptop with built in AMD graphics card for a couple of years. Suspend to RAM (S3) works fine, but I've never had hibernate (S4) work. I started trying to debug the problem but only got as far as identifying that (surprise) it was amdgpu module that causes the problem. This has been the case for all kernel 5 series below 5.5 - I can't get 5.5 or later to build for some reason buried in the kernel config.

AFAIR, the only time anyone reported getting hibernate to work was when they used more generic drivers such as VESA framebuffers, but that destroys graphics performance. I've not looked for the last year. so some heavy Googling might help.

As to sleep: I doubt this is the problem, but I note/deduce you have specified VIDEO_CARDS="radeonsi" in make.conf; why not VIDEO_CARDS="radeonsi amdgpu"? I presume you just emerged amdgpu directly.

I'll see if I can extract the kernel log info for a suspend/resume and post it - I'm currently on my desktop machine, which doesn't have suspend or hibernate support.
_________________
Greybeard
Back to top
View user's profile Send private message
spiriteh
n00b
n00b


Joined: 24 Jul 2019
Posts: 4

PostPosted: Tue Mar 31, 2020 1:32 pm    Post subject: Reply with quote

Goverp wrote:
spiriteh,

I've had an HP laptop with built in AMD graphics card for a couple of years. Suspend to RAM (S3) works fine, but I've never had hibernate (S4) work. I started trying to debug the problem but only got as far as identifying that (surprise) it was amdgpu module that causes the problem. This has been the case for all kernel 5 series below 5.5 - I can't get 5.5 or later to build for some reason buried in the kernel config.

AFAIR, the only time anyone reported getting hibernate to work was when they used more generic drivers such as VESA framebuffers, but that destroys graphics performance. I've not looked for the last year. so some heavy Googling might help.

As to sleep: I doubt this is the problem, but I note/deduce you have specified VIDEO_CARDS="radeonsi" in make.conf; why not VIDEO_CARDS="radeonsi amdgpu"? I presume you just emerged amdgpu directly.

I'll see if I can extract the kernel log info for a suspend/resume and post it - I'm currently on my desktop machine, which doesn't have suspend or hibernate support.



I think there was a bug that caused this ages ago but I was under the impression it was fixed in like kernel 4.2~.

I do have amdgpu set under VIDEO_CARDS, and no amdgpu driver was pulled by profile (due to this flag I guess?).

Thank-you, any help would be great.
Back to top
View user's profile Send private message
Goverp
l33t
l33t


Joined: 07 Mar 2007
Posts: 837

PostPosted: Wed Apr 01, 2020 8:00 am    Post subject: Reply with quote

I doubt this will help much, but here's my syslog around a suspend event. It might show some useful differences from yours:
Code:

Apr  1 08:40:54 hp acpid[1771]: received input layer event "button/lid LID close"
Apr  1 08:40:54 hp acpid[1771]: rule from /etc/acpi/events/default matched
Apr  1 08:40:54 hp acpid[2905]: executing action "/etc/acpi/default.sh button/lid LID close"
Apr  1 08:40:54 hp [  119.717091] elogind-daemon[1555]: Lid closed.
Apr  1 08:40:54 hp root[2906]: ACPI event unhandled: button/lid LID close
Apr  1 08:40:54 hp acpid[1771]: action exited with status 0
Apr  1 08:40:54 hp acpid[1771]: 1 total rule matched
Apr  1 08:40:54 hp acpid[1771]: completed input layer event "button/lid LID close"
Apr  1 08:40:55 hp [  120.864874] elogind-daemon[1555]: Suspending system...
Apr  1 08:40:55 hp kernel: [  120.864886] PM: suspend entry (deep)
Apr  1 08:41:06 hp kernel: [  120.973270] Filesystems sync: 0.108 seconds
Apr  1 08:41:06 hp kernel: [  120.973492] Freezing user space processes ... (elapsed 0.024 seconds) done.
Apr  1 08:41:06 hp kernel: [  120.997679] OOM killer disabled.
Apr  1 08:41:06 hp kernel: [  120.997680] Freezing remaining freezable tasks ... (elapsed 0.001 seconds) done.
Apr  1 08:41:06 hp kernel: [  120.998970] printk: Suspending console(s) (use no_console_suspend to debug)
Apr  1 08:41:06 hp kernel: [  120.999285] wlan0: deauthenticating from 60:e3:27:37:e9:00 by local choice (Reason: 3=DEAUTH_LEAVING)
Apr  1 08:41:06 hp kernel: [  121.011761] sd 0:0:0:0: [sda] Synchronizing SCSI cache
Apr  1 08:41:06 hp kernel: [  121.039925] sd 0:0:0:0: [sda] Stopping disk
Apr  1 08:41:06 hp kernel: [  121.149634] r8169 0000:02:00.0 eth0: Link is Down
Apr  1 08:41:06 hp kernel: [  122.089911] ACPI: EC: interrupt blocked
Apr  1 08:41:06 hp kernel: [  122.113800] ACPI: Preparing to enter system sleep state S3
Apr  1 08:41:06 hp kernel: [  122.117036] ACPI: EC: event blocked
Apr  1 08:41:06 hp kernel: [  122.117037] ACPI: EC: EC stopped
Apr  1 08:41:06 hp kernel: [  122.117038] PM: Saving platform NVS memory
Apr  1 08:41:06 hp kernel: [  122.117104] Disabling non-boot CPUs ...
Apr  1 08:41:06 hp kernel: [  122.118588] smpboot: CPU 1 is now offline
Apr  1 08:41:06 hp kernel: [  122.119082] ACPI: Low-level resume complete
Apr  1 08:41:06 hp kernel: [  122.119120] ACPI: EC: EC started
Apr  1 08:41:06 hp kernel: [  122.119120] PM: Restoring platform NVS memory
Apr  1 08:41:06 hp kernel: [  122.119212] LVT offset 0 assigned for vector 0x400
Apr  1 08:41:06 hp kernel: [  122.119469] Enabling non-boot CPUs ...
Apr  1 08:41:06 hp kernel: [  122.119529] x86: Booting SMP configuration:
Apr  1 08:41:06 hp kernel: [  122.119530] smpboot: Booting Node 0 Processor 1 APIC 0x11
Apr  1 08:41:06 hp kernel: [  122.119649] microcode: CPU1: patch_level=0x06006705
Apr  1 08:41:06 hp kernel: [  122.122033] CPU1 is up
Apr  1 08:41:06 hp kernel: [  122.122454] ACPI: Waking up from system sleep state S3
Apr  1 08:41:06 hp kernel: [  122.152742] ACPI: EC: interrupt unblocked
Apr  1 08:41:06 hp kernel: [  122.176850] ACPI: EC: event unblocked
Apr  1 08:41:06 hp kernel: [  122.177451] [drm] PCIE GART of 1024M enabled (table at 0x000000F400000000).
Apr  1 08:41:06 hp kernel: [  122.177463] smu version 26.17.00
Apr  1 08:41:06 hp kernel: [  122.199234] rtlwifi: rtlwifi: wireless switch is on
Apr  1 08:41:06 hp kernel: [  122.204854] sd 0:0:0:0: [sda] Starting disk
Apr  1 08:41:06 hp kernel: [  122.281220] r8169 0000:02:00.0 eth0: Link is Down
Apr  1 08:41:06 hp kernel: [  122.434322] usb 1-1.4: reset full-speed USB device number 3 using ehci-pci
Apr  1 08:41:06 hp kernel: [  122.717333] [drm] Fence fallback timer expired on ring sdma0
Apr  1 08:41:06 hp kernel: [  122.764309] [drm] UVD initialized successfully.
Apr  1 08:41:06 hp kernel: [  122.865507] [drm] VCE initialized successfully.
Apr  1 08:41:06 hp kernel: [  124.003957] acpi LNXPOWER:05: Turning OFF
Apr  1 08:41:06 hp kernel: [  124.004009] OOM killer enabled.

Apr  1 08:41:06 hp acpid[1771]: received input layer event "button/lid LID open"
Apr  1 08:41:06 hp acpid[1771]: rule from /etc/acpi/events/default matched
Apr  1 08:41:06 hp dhcpcd[1846]: wlan0: carrier lost
Apr  1 08:41:06 hp acpid[2948]: executing action "/etc/acpi/default.sh button/lid LID open"
Apr  1 08:41:06 hp root[2950]: ACPI event unhandled: button/lid LID open
Apr  1 08:41:06 hp acpid[1771]: action exited with status 0
Apr  1 08:41:06 hp acpid[1771]: 1 total rule matched
Apr  1 08:41:06 hp acpid[1771]: completed input layer event "button/lid LID open"
Apr  1 08:41:06 hp kernel: [  124.004009] Restarting tasks ... done.
Apr  1 08:41:06 hp kernel: [  124.033312] PM: suspend exit
Apr  1 08:41:06 hp [  124.033342] elogind-daemon[1555]: System resumed.
Apr  1 08:41:06 hp [  124.034019] elogind-daemon[1555]: Lid opened.
Apr  1 08:41:06 hp kernel: [  124.035435] Bluetooth: hci0: RTL: examining hci_ver=08 hci_rev=000d lmp_ver=08 lmp_subver=8723
Apr  1 08:41:06 hp kernel: [  124.036423] Bluetooth: hci0: RTL: rom_version status=0 version=2
Apr  1 08:41:06 hp kernel: [  124.036425] Bluetooth: hci0: RTL: loading rtl_bt/rtl8723d_fw.bin
Apr  1 08:41:06 hp kernel: [  124.036446] Bluetooth: hci0: RTL: loading rtl_bt/rtl8723d_config.bin
Apr  1 08:41:06 hp kernel: [  124.036474] Bluetooth: hci0: RTL: cfg_sz 10, total sz 33266
Apr  1 08:41:06 hp dhcpcd[1846]: wlan0: deleting address fe80::699c:57c4:e738:a13d
Apr  1 08:41:06 hp dhcpcd[1846]: wlan0: deleting route to 192.168.1.0/24
Apr  1 08:41:06 hp dhcpcd[1846]: wlan0: deleting default route via 192.168.1.1
Apr  1 08:41:07 hp kernel: [  124.300481] Bluetooth: hci0: RTL: fw version 0x828a96f1
Apr  1 08:41:07 hp kernel: [  124.807380] ata1: SATA link up 6.0 Gbps (SStatus 133 SControl 300)
Apr  1 08:41:07 hp kernel: [  124.840791] ata1.00: configured for UDMA/100
Apr  1 08:41:08 hp ntpd[1921]: Deleting interface #5 wlan0, fe80::699c:57c4:e738:a13d%3#123, interface stats: received=0, sent=0, dropped=0, active_time=98 secs
Apr  1 08:41:08 hp ntpd[1921]: Deleting interface #6 wlan0, 192.168.1.106#123, interface stats: received=8, sent=8, dropped=0, active_time=94 secs
Apr  1 08:41:08 hp ntpd[1921]: 178.79.145.244 local addr 192.168.1.106 -> <null>
Apr  1 08:41:08 hp ntpd[1921]: 82.68.224.138 local addr 192.168.1.106 -> <null>
Apr  1 08:41:08 hp ntpd[1921]: 109.74.206.120 local addr 192.168.1.106 -> <null>
Apr  1 08:41:08 hp ntpd[1921]: 188.114.116.1 local addr 192.168.1.106 -> <null>
Apr  1 08:41:09 hp kernel: [  126.352200] wlan0: authenticate with 60:e3:27:37:e9:00
Apr  1 08:41:09 hp kernel: [  126.370731] wlan0: send auth to 60:e3:27:37:e9:00 (try 1/3)
Apr  1 08:41:09 hp kernel: [  126.372543] wlan0: authenticated
Apr  1 08:41:09 hp kernel: [  126.373512] wlan0: associate with 60:e3:27:37:e9:00 (try 1/3)
Apr  1 08:41:09 hp kernel: [  126.377068] wlan0: RX AssocResp from 60:e3:27:37:e9:00 (capab=0x431 status=0 aid=3)
Apr  1 08:41:09 hp kernel: [  126.481996] wlan0: associated
Apr  1 08:41:10 hp dhcpcd[1846]: wlan0: carrier acquired
Apr  1 08:41:10 hp dhcpcd[1846]: wlan0: IAID f2:09:1a:11
Apr  1 08:41:10 hp dhcpcd[1846]: wlan0: adding address fe80::699c:57c4:e738:a13d
Apr  1 08:41:11 hp dhcpcd[1846]: wlan0: rebinding lease of 192.168.1.106
Apr  1 08:41:11 hp dhcpcd[1846]: wlan0: probing address 192.168.1.106/24
Apr  1 08:41:11 hp dhcpcd[1846]: wlan0: soliciting an IPv6 router
Apr  1 08:41:11 hp dhcpcd[1846]: wlan0: Router Advertisement from fe80::62e3:27ff:fe37:e900
Apr  1 08:41:11 hp dhcpcd[1846]: wlan0: requesting DHCPv6 information
Apr  1 08:41:12 hp ntpd[1921]: Listen normally on 7 wlan0 [fe80::699c:57c4:e738:a13d%3]:123
Apr  1 08:41:15 hp dhcpcd[1846]: wlan0: leased 192.168.1.106 for 86400 seconds
Apr  1 08:41:15 hp dhcpcd[1846]: wlan0: adding route to 192.168.1.0/24
Apr  1 08:41:15 hp dhcpcd[1846]: wlan0: adding default route via 192.168.1.1
Apr  1 08:41:16 hp ntpd[1921]: Listen normally on 8 wlan0 192.168.1.106:123
Apr  1 08:41:21 hp dhcpcd[1846]: wlan0: failed to request information

_________________
Greybeard
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum