Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ GLSA 202004-05 ] ledger
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index News & Announcements
View previous topic :: View next topic  
Author Message
GLSA
Advocate
Advocate


Joined: 12 May 2004
Posts: 2331

PostPosted: Thu Apr 02, 2020 12:26 am    Post subject: [ GLSA 202004-05 ] ledger Reply with quote

Gentoo Linux Security Advisory

Title: ledger: Multiple vulnerabilities (GLSA 202004-05)
Severity: normal
Exploitable: remote
Date: 2020-04-01
Bug(s): #627060
ID: 202004-05

Synopsis

Multiple vulnerabilities have been found in ledger, the worst of
which could result in the arbitrary execution of code.


Background

Ledger is a powerful, double-entry accounting system that is accessed
from the UNIX command-line.


Affected Packages

Package: app-office/ledger
Vulnerable: < 3.1.2
Unaffected: >= 3.1.2
Architectures: All supported architectures


Description

Multiple vulnerabilities have been discovered in ledger. Please review
the CVE identifiers referenced below for details.


Impact

A remote attacker could entice a user to process a specially crafted
file using ledger, possibly resulting in execution of arbitrary code with
the privileges of the process or a Denial of Service condition.


Workaround

There is no known workaround at this time.

Resolution

All ledger users should upgrade to the latest version:
Code:
# emerge --sync
      # emerge --ask --oneshot --verbose ">=app-office/ledger-3.1.2"
   


References

CVE-2017-12481
CVE-2017-12482
CVE-2017-2807
CVE-2017-2808
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index News & Announcements All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum