Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] Updating: dev-qt/qtwayland blocks dev-qt/qtgui
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
Draenin
n00b
n00b


Joined: 24 Mar 2016
Posts: 60

PostPosted: Sat Apr 04, 2020 11:38 pm    Post subject: [SOLVED] Updating: dev-qt/qtwayland blocks dev-qt/qtgui Reply with quote

Hello,

It has been almost 1 month since I last time updated the system. I am trying to do it now and I am having some issues.

Code:
[blocks B      ] <dev-qt/qtwayland-5.14.0:5 ("<dev-qt/qtwayland-5.14.0:5" is blocking dev-qt/qtgui-5.14.1-r4)


emerge --ask --verbose --newuse --update --deep --with-bdeps=y --changed-deps=y --backtrack=100 --verbose-conflicts --keep-going @world
https://pastebin.com/2nTbChtq

emerge --info --verbose
https://pastebin.com/bAJVBV0r

Thanks in advance for the help.
_________________
Linux enthusiast


Last edited by Draenin on Mon May 04, 2020 9:06 pm; edited 5 times in total
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 24023
Location: here

PostPosted: Sun Apr 05, 2020 7:39 am    Post subject: Reply with quote

You can try to update qt package first with emerge -1 $(qlist -I 'dev-qt/*') command.
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
Draenin
n00b
n00b


Joined: 24 Mar 2016
Posts: 60

PostPosted: Sun Apr 05, 2020 11:06 am    Post subject: Reply with quote

Ok. It seems the same problem still remains.

I synchronized again today against Gentoo repository. I did it yesterday before my first update attempt, but just in case.

And this is the error message from # emerge -1 --backtrack=100 --verbose-conflicts $(qlist -I 'dev-qt/*'):
https://pastebin.com/A4LLgANk
_________________
Linux enthusiast


Last edited by Draenin on Sun Apr 05, 2020 5:49 pm; edited 1 time in total
Back to top
View user's profile Send private message
Chiitoo
Administrator
Administrator


Joined: 28 Feb 2010
Posts: 2036
Location: Here and Away Again

PostPosted: Sun Apr 05, 2020 11:48 am    Post subject: ><)))°€ Reply with quote

If possible, I'd recommend using a different pastebin service, perhaps something 'app-text/wgetpaste' lists for example. This 'JustPaste' seems to be more for something else, as it might be using a non-monospace font, and doesn't even provide a 'plain-text' view as far as I can tell. Makes reading them logs kind of annoying. :]

Actually, these might not be too long for the forums even, so you could just inline them within them 'code' tags.

In any case, part of the issue might be things like this:

Code:
(dev-qt/qtgui-5.13.2:5/5.13::gentoo, installed) USE="dbus egl gif jpeg libinput png udev wayland xcb -accessibility -debug -eglfs -evdev -gles2 -ibus -test -tslib -tuio -vnc" pulled in by
   dev-qt/qtgui:5[-gles2] required by (media-sound/fmit-1.0.15-r1:0/0::gentoo, installed) USE="alsa -jack -oss -portaudio"
                  ^^^^^^

Package 'media-sound/fmit-1.0.15-r1' is no longer in the repository, and it still has the 'gles2' USE-flag. This is not the case with '1.0.15-r3' which has been updated for the flag renaming to 'gles2-only'.

I might try the full update path again after a fresh sync (the 'fmit' update was about 40 hours ago).
_________________
Kind regards,
Chiitoo.

You might remember me from Gentoo projects such as Forums, LXQt, Qt, and Wine.
Back to top
View user's profile Send private message
Draenin
n00b
n00b


Joined: 24 Mar 2016
Posts: 60

PostPosted: Sun Apr 05, 2020 12:48 pm    Post subject: Reply with quote

Ok. Just to quickly confirm.

media-sound/fmit was the problem. I depclean (uninstall) that package and everything seems to be working fine. My system is updating right now, it will take some time.

Later I'll come back and clean up this thread: update the final result of the update, change the posts from justpaste to app-text/wgetpaste (already changed from justpast.it to pastebin.com), and so on.

Thank you very much.
_________________
Linux enthusiast


Last edited by Draenin on Sun Apr 05, 2020 5:52 pm; edited 1 time in total
Back to top
View user's profile Send private message
Draenin
n00b
n00b


Joined: 24 Mar 2016
Posts: 60

PostPosted: Sun Apr 05, 2020 5:42 pm    Post subject: Reply with quote

Ok. This update is becoming a pain in the butt. emerge [...] @world fails every now and then.

First, after installing a couple of packages, it failed with kde-frameworks/kitemwiews-5.67.00. After the failure, I emerge preserve build, because it required it. That installed: media-libs/opencv and sys-block/partitionmanager.

Then I tried an emerge @world, and after installing a couple of packages, it failed again. This time kde-plasma/breeze was the culprit. Also no preserved libraries to build.

Next, I just tried to install package by package, one after another, instead of a global update. But I am just encountering problem after problem. And it is getting a bit tiresome.

It seems, from my ignorance, that Qt is at the center of the problems.

Anyway, let me post the output of the current emerge @world. Given that I am unable to update the system I haven't installed app-text/wgetpaste, but I will try another pastebin service.

emerge --ask --verbose --newuse --update --deep --with-bdeps=y --changed-deps=y --backtrack=100 --verbose-conflicts --keep-going @world
https://pastebin.com/UyqR4iG1

And here the output of the previous emerge failing at the very first package:
https://pastebin.com/DBsf1XwR

emerge --info '=kde-frameworks/kdeclarative-5.67.0::gentoo'
https://pastebin.com/10p9uDM1

Thanks in advance.

[*UPDATE*]
After rebooting the PC, KDE Plasma doesn't work. It just shows the mouse in a black screen. The mouse works though, so I can click my big empty space, click the nothingness.

The tty's work. Except tty7 of course.
_________________
Linux enthusiast
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 24023
Location: here

PostPosted: Sun Apr 05, 2020 6:21 pm    Post subject: Reply with quote

You should post also /var/tmp/portage/kde-frameworks/kdeclarative-5.67.0/temp/build.log
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 7720
Location: Austria

PostPosted: Sun Apr 05, 2020 6:31 pm    Post subject: Reply with quote

Draenin wrote:
emerge [...] @world fails every now and then.

You should clear up why that is, not work around the problem. For that we need the full build.log.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
Draenin
n00b
n00b


Joined: 24 Mar 2016
Posts: 60

PostPosted: Sun Apr 05, 2020 10:00 pm    Post subject: Reply with quote

Let's see.

/var/tmp/portage/kde-frameworks/kdeclarative-5.67.0/temp/build.log
http://dpaste.com/1XG4CKG

Additionally, I also have the log of another package that failed in these emerge attempts.

/var/tmp/portage/kde-frameworks/kitemviews-5.67.0/temp/build.log
http://dpaste.com/04F0S9T

Thanks.
_________________
Linux enthusiast
Back to top
View user's profile Send private message
Draenin
n00b
n00b


Joined: 24 Mar 2016
Posts: 60

PostPosted: Mon Apr 06, 2020 10:37 pm    Post subject: Reply with quote

I LOVE btrfs.

I just rolled back the whole system to the snapshot I took just before beginning this last update. I have a very busy couple of weeks coming and I really don't have time for this. Afterwards, I will try the update again.

All this mess gone! like a bad nightmare. Did I say how much I love btrfs? :)
_________________
Linux enthusiast
Back to top
View user's profile Send private message
Draenin
n00b
n00b


Joined: 24 Mar 2016
Posts: 60

PostPosted: Mon May 04, 2020 9:06 pm    Post subject: Reply with quote

This problem was solved in this other thread.

Short version:
  • Remove the 'gles2-only' USE flag. Both from make.conf and package.use. I probably shouldn't had to set it on at all to begin with.
  • Update all packages emerge [...] @world.
  • ...
  • Profit.

Thank you very much @asturm and everybody else.
_________________
Linux enthusiast
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum