Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
System Update schlägt fehl
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
misterxx
Guru
Guru


Joined: 18 Apr 2004
Posts: 437

PostPosted: Mon Apr 06, 2020 10:43 am    Post subject: System Update schlägt fehl Reply with quote

Hallo Leute,

ich wollte wieder mal mein System updaten. Habe gelesen, dass man die Einstellungen

Code:
PYTHON_TARGETS
und
Code:
PYTHON_SINGLE_TARGET


aus make.conf entfernen soll, habe ich auch gemacht.

Leider kann immer noch nicht updaten. Bitte im Unterstützung und danke im Voraus! Wie soll ich weiter vorgehen?

Code:
matrixstorage ~ # emerge --deep --update --newuse --changed-deps --with-bdeps=y @world -pv

These are the packages that would be merged, in order:

Calculating dependencies... done!

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-lang/perl:0

  (dev-lang/perl-5.30.1:0/5.30::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (dev-lang/perl-5.26.2:0/5.26::gentoo, installed) pulled in by
    dev-lang/perl:0/5.26=[-build(-)] required by (dev-perl/IPC-System-Simple-1.250.0:0/0::gentoo, installed)
                 ^^^^^^^^                                                                                                                       
    (and 16 more with the same problem)

dev-python/setuptools:0

  (dev-python/setuptools-45.3.0:0/0::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-python/setuptools-42.0.2[python_targets_python3_6(-)?,python_targets_python3_7(-)?,python_targets_python3_8(-)?,-python_single_target_python3_6(-),-python_single_target_python3_7(-),-python_single_target_python3_8(-)] required by (dev-util/meson-0.53.1:0/0::gentoo, ebuild scheduled for merge)
    ^^                      ^^^^^^                                                                                                                                                                                                                                                                                                                                   
    (and 2 more with the same problem)

  (dev-python/setuptools-44.1.0:0/0::gentoo, ebuild scheduled for merge) pulled in by
    dev-python/setuptools[python_targets_pypy3(-)?,python_targets_python2_7(-)?,python_targets_python3_6(-)?,python_targets_python3_7(-)?,python_targets_python3_8(-)?,-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_6(-),-python_single_target_python3_7(-),-python_single_target_python3_8(-)] required by (dev-python/requests-2.22.0:0/0::gentoo, ebuild scheduled for merge)
                                                                                                                                                                                                                                                                                                                                                                                                                                                   
    dev-python/setuptools[python_targets_pypy3(-)?,python_targets_python2_7(-)?,python_targets_python3_6(-)?,python_targets_python3_7(-)?,-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_6(-),-python_single_target_python3_7(-)] required by (dev-python/pyblake2-1.1.2:0/0::gentoo, ebuild scheduled for merge)
                                                                                                                                                                                                                                                                                                                                                                                   
    >=dev-python/setuptools-1.0[python_targets_pypy3(-)?,python_targets_python2_7(-)?,python_targets_python3_6(-)?,python_targets_python3_7(-)?,python_targets_python3_8(-)?,-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_6(-),-python_single_target_python3_7(-),-python_single_target_python3_8(-)] required by (dev-python/cryptography-2.8-r1:0/0::gentoo, ebuild scheduled for merge)
                                                                                                                                                                                                                                                                                                                                                                                                                                                             
    dev-python/setuptools[python_targets_pypy3(-)?,python_targets_python2_7(-)?,python_targets_python3_6(-)?,python_targets_python3_7(-)?,python_targets_python3_8(-)?,-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_6(-),-python_single_target_python3_7(-),-python_single_target_python3_8(-)] required by (dev-python/idna-2.8:0/0::gentoo, ebuild scheduled for merge)
                                                                                                                                                                                                                                                                                                                                                                                                                                             
    [python_targets_pypy3(-)?,python_targets_python2_7(-)?,python_targets_python3_6(-)?,python_targets_python3_7(-)?,python_targets_python3_8(-)?,-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_6(-),-python_single_target_python3_7(-),-python_single_target_python3_8(-)] required by (dev-python/PySocks-1.7.1:0/0::gentoo, ebuild scheduled for merge)
    ^^                      ^^^^^^                                                                                                                                                                                                                                                                                                                                                                                           
    [python_targets_pypy3(-)?,python_targets_python2_7(-)?,python_targets_python3_6(-)?,python_targets_python3_7(-)?,python_targets_python3_8(-)?,-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_6(-),-python_single_target_python3_7(-),-python_single_target_python3_8(-)] required by (dev-python/idna-2.8:0/0::gentoo, ebuild scheduled for merge)
    ^^                      ^^^^^^                                                                                                                                                                                                                                                                                                                                                                                       
    dev-python/setuptools[python_targets_pypy3(-)?,python_targets_python2_7(-)?,python_targets_python3_6(-)?,-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_6(-)] required by (dev-python/setuptools_scm-1.15.6-r1:0/0::gentoo, installed)
                                                                                                                                                                                                                                                                                                           
    [python_targets_pypy3(-)?,python_targets_python2_7(-)?,python_targets_python3_6(-)?,python_targets_python3_7(-)?,python_targets_python3_8(-)?,-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_6(-),-python_single_target_python3_7(-),-python_single_target_python3_8(-)] required by (dev-python/extras-1.0.0:0/0::gentoo, ebuild scheduled for merge)
    ^^                      ^^^^^^                                                                                                                                                                                                                                                                                                                                                                                           
    [python_targets_pypy3(-)?,python_targets_python2_7(-)?,python_targets_python3_6(-)?,python_targets_python3_7(-)?,python_targets_python3_8(-)?,-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_6(-),-python_single_target_python3_7(-),-python_single_target_python3_8(-)] required by (dev-python/ply-3.11:0/3.11::gentoo, ebuild scheduled for merge)
    ^^                      ^^^^^^                                                                                                                                                                                                                                                                                                                                                                                         
    [python_targets_python2_7(-)?,python_targets_python3_6(-)?,python_targets_python3_7(-)?,python_targets_python3_8(-)?,-python_single_target_python2_7(-),-python_single_target_python3_6(-),-python_single_target_python3_7(-),-python_single_target_python3_8(-)] required by (dev-python/zope-component-4.4.1:0/0::gentoo, installed)
    ^^                      ^^^^^^                                                                                                                                                                                                                                                                                                                         
    [python_targets_pypy3(-)?,python_targets_python2_7(-)?,python_targets_python3_6(-)?,python_targets_python3_7(-)?,python_targets_python3_8(-)?,-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_6(-),-python_single_target_python3_7(-),-python_single_target_python3_8(-)] required by (dev-python/requests-2.22.0:0/0::gentoo, ebuild scheduled for merge)
    ^^                      ^^^^^^                                                                                                                                                                                                                                                                                                                                                                                             
    [python_targets_pypy3(-)?,python_targets_python2_7(-)?,python_targets_python3_6(-)?,python_targets_python3_7(-)?,python_targets_python3_8(-)?,-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_6(-),-python_single_target_python3_7(-),-python_single_target_python3_8(-)] required by (dev-python/fixtures-3.0.0:0/0::gentoo, ebuild scheduled for merge)
    ^^                      ^^^^^^                                                                                                                                                                                                                                                                                                                                                                                             
    [python_targets_pypy3(-)?,python_targets_python2_7(-)?,python_targets_python3_6(-)?,python_targets_python3_7(-)?,python_targets_python3_8(-)?,-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_6(-),-python_single_target_python3_7(-),-python_single_target_python3_8(-)] required by (dev-python/pycparser-2.19-r1:0/0::gentoo, ebuild scheduled for merge)
    ^^                      ^^^^^^                                                                                                                                                                                                                                                                                                                                                                                               
    dev-python/setuptools[python_targets_pypy3(-)?,python_targets_python2_7(-)?,python_targets_python3_6(-)?,python_targets_python3_7(-)?,python_targets_python3_8(-)?,-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_6(-),-python_single_target_python3_7(-),-python_single_target_python3_8(-)] required by (dev-python/mimeparse-1.6.0:0/0::gentoo, ebuild scheduled for merge)
                                                                                                                                                                                                                                                                                                                                                                                                                                                   
    [python_targets_pypy3(-)?,python_targets_python2_7(-)?,python_targets_python3_6(-)?,python_targets_python3_7(-)?,python_targets_python3_8(-)?,-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_6(-),-python_single_target_python3_7(-),-python_single_target_python3_8(-)] required by (dev-python/zope-event-4.4:0/0::gentoo, ebuild scheduled for merge)
    ^^                      ^^^^^^                                                                                                                                                                                                                                                                                                                                                                                             
    dev-python/setuptools[python_targets_pypy3(-)?,python_targets_python2_7(-)?,python_targets_python3_6(-)?,python_targets_python3_7(-)?,python_targets_python3_8(-)?,-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_6(-),-python_single_target_python3_7(-),-python_single_target_python3_8(-)] required by (dev-python/cryptography-2.8-r1:0/0::gentoo, ebuild scheduled for merge)
                                                                                                                                                                                                                                                                                                                                                                                                                                                       
    [python_targets_pypy3(-)?,python_targets_python2_7(-)?,python_targets_python3_6(-)?,python_targets_python3_7(-)?,python_targets_python3_8(-)?,-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_6(-),-python_single_target_python3_7(-),-python_single_target_python3_8(-)] required by (dev-python/traceback2-1.4.0:0/0::gentoo, ebuild scheduled for merge)
    ^^                      ^^^^^^                                                                                                                                                                                                                                                                                                                                                                                               
    dev-python/setuptools[python_targets_pypy3(-)?,python_targets_python2_7(-)?,python_targets_python3_6(-)?,python_targets_python3_7(-)?,python_targets_python3_8(-)?,-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_6(-),-python_single_target_python3_7(-),-python_single_target_python3_8(-)] required by (dev-python/cython-0.29.15:0/0::gentoo, ebuild scheduled for merge)
                                                                                                                                                                                                                                                                                                                                                                                                                                                   
    dev-python/setuptools[python_targets_pypy3(-)?,python_targets_python2_7(-)?,python_targets_python3_6(-)?,python_targets_python3_7(-)?,python_targets_python3_8(-)?,-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_6(-),-python_single_target_python3_7(-),-python_single_target_python3_8(-)] required by (dev-python/ply-3.11:0/3.11::gentoo, ebuild scheduled for merge)
                                                                                                                                                                                                                                                                                                                                                                                                                                               
    [python_targets_python2_7(-)?,python_targets_python3_6(-)?,python_targets_python3_7(-)?,python_targets_python3_8(-)?,-python_single_target_python2_7(-),-python_single_target_python3_6(-),-python_single_target_python3_7(-),-python_single_target_python3_8(-)] required by (dev-python/cffi-1.14.0:0/1.14.0::gentoo, ebuild scheduled for merge)
    ^^                      ^^^^^^                                                                                                                                                                                                                                                                                                                                       
    dev-python/setuptools[python_targets_pypy3(-)?,python_targets_python2_7(-)?,python_targets_python3_6(-)?,python_targets_python3_7(-)?,python_targets_python3_8(-)?,-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_6(-),-python_single_target_python3_7(-),-python_single_target_python3_8(-)] required by (dev-python/extras-1.0.0:0/0::gentoo, ebuild scheduled for merge)
                                                                                                                                                                                                                                                                                                                                                                                                                                                 
    dev-python/setuptools[python_targets_pypy3(-)?,python_targets_python2_7(-)?,python_targets_python3_6(-)?,python_targets_python3_7(-)?,python_targets_python3_8(-)?,-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_6(-),-python_single_target_python3_7(-),-python_single_target_python3_8(-)] required by (dev-python/pycparser-2.19-r1:0/0::gentoo, ebuild scheduled for merge)
                                                                                                                                                                                                                                                                                                                                                                                                                                                     
    [python_targets_pypy3(-)?,python_targets_python2_7(-)?,python_targets_python3_6(-)?,-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_6(-)] required by (dev-python/zope-interface-4.4.3:0/0::gentoo, installed)
    ^^                      ^^^^^^                                                                                                                                                                                                                                                 
    dev-python/setuptools[python_targets_pypy3(-)?,python_targets_python2_7(-)?,python_targets_python3_6(-)?,python_targets_python3_7(-)?,python_targets_python3_8(-)?,-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_6(-),-python_single_target_python3_7(-),-python_single_target_python3_8(-)] required by (dev-python/testtools-2.3.0:0/0::gentoo, ebuild scheduled for merge)
                                                                                                                                                                                                                                                                                                                                                                                                                                                   
    dev-python/setuptools[python_targets_pypy3(-)?,python_targets_python2_7(-)?,python_targets_python3_6(-)?,python_targets_python3_7(-)?,python_targets_python3_8(-)?,-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_6(-),-python_single_target_python3_7(-),-python_single_target_python3_8(-)] required by (dev-python/certifi-2019.11.28:0/0::gentoo, ebuild scheduled for merge)
                                                                                                                                                                                                                                                                                                                                                                                                                                                       
    dev-python/setuptools[python_targets_pypy3(-)?,python_targets_python2_7(-)?,python_targets_python3_6(-)?,python_targets_python3_7(-)?,python_targets_python3_8(-)?,-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_6(-),-python_single_target_python3_7(-),-python_single_target_python3_8(-)] required by (dev-python/pyrsistent-0.15.6:0/0::gentoo, ebuild scheduled for merge)
                                                                                                                                                                                                                                                                                                                                                                                                                                                     
    dev-python/setuptools[python_targets_pypy3(-)?,python_targets_python2_7(-)?,python_targets_python3_6(-)?,python_targets_python3_7(-)?,python_targets_python3_8(-)?,-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_6(-),-python_single_target_python3_7(-),-python_single_target_python3_8(-)] required by (dev-python/chardet-3.0.4:0/0::gentoo, ebuild scheduled for merge)
                                                                                                                                                                                                                                                                                                                                                                                                                                                 
    dev-python/setuptools[python_targets_pypy3(-)?,python_targets_python2_7(-)?,python_targets_python3_6(-)?,python_targets_python3_7(-)?,python_targets_python3_8(-)?,-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_6(-),-python_single_target_python3_7(-),-python_single_target_python3_8(-)] required by (dev-python/linecache2-1.0.0:0/0::gentoo, ebuild scheduled for merge)
                                                                                                                                                                                                                                                                                                                                                                                                                                                     
    [python_targets_pypy3(-)?,python_targets_python2_7(-)?,python_targets_python3_6(-)?,-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_6(-)] required by (dev-python/pbr-3.1.1:0/0::gentoo, ebuild scheduled for merge)
    ^^                      ^^^^^^                                                                                                                                                                                                                                                       
    [python_targets_pypy3(-)?,python_targets_python2_7(-)?,python_targets_python3_6(-)?,python_targets_python3_7(-)?,python_targets_python3_8(-)?,-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_6(-),-python_single_target_python3_7(-),-python_single_target_python3_8(-)] required by (dev-python/future-0.18.2:0/0::gentoo, ebuild scheduled for merge)
    ^^                      ^^^^^^                                                                                                                                                                                                                                                                                                                                                                                           
    dev-python/setuptools[python_targets_python2_7(-)?,-python_single_target_python2_7(-)] required by (dev-python/ipaddress-1.0.23:0/0::gentoo, ebuild scheduled for merge)
                                                                                                                                                                                             
    [python_targets_pypy3(-)?,python_targets_python2_7(-)?,python_targets_python3_6(-)?,python_targets_python3_7(-)?,python_targets_python3_8(-)?,-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_6(-),-python_single_target_python3_7(-),-python_single_target_python3_8(-)] required by (app-portage/gemato-14.3:0/0::gentoo, ebuild scheduled for merge)
    ^^                      ^^^^^^                                                                                                                                                                                                                                                                                                                                                                                           
    dev-python/setuptools[python_targets_pypy3(-)?,python_targets_python2_7(-)?,python_targets_python3_6(-)?,python_targets_python3_7(-)?,python_targets_python3_8(-)?,-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_6(-),-python_single_target_python3_7(-),-python_single_target_python3_8(-)] required by (dev-python/unittest2-1.1.0:0/0::gentoo, ebuild scheduled for merge)
                                                                                                                                                                                                                                                                                                                                                                                                                                                   
    [

....


  (dev-python/cryptography-2.8-r1:0/0::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-python/cryptography-2.8[python_targets_pypy3(-)?,python_targets_python2_7(-)?,python_targets_python3_6(-)?,python_targets_python3_7(-)?,python_targets_python3_8(-)?,-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_6(-),-python_single_target_python3_7(-),-python_single_target_python3_8(-)] required by (dev-python/pyopenssl-19.1.0:0/0::gentoo, ebuild scheduled for merge)
    ^^                        ^^^                                                                                                                                                                                                                                                                                                                                                                                                                                                                 

  (dev-python/cryptography-2.2.2-r1:0/0::gentoo, installed) pulled in by
    >=dev-python/cryptography-1.2[python_targets_python2_7(-),python_targets_python3_5(-),-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)] required by (app-crypt/certbot-0.19.0:0/0::gentoo, installed)
                                                                                                                                                                                                                                                                                                                     
    >=dev-python/cryptography-2.1.4[python_targets_python2_7(-),python_targets_python3_4(-),python_targets_python3_5(-),python_targets_python3_6(-),-python_single_target_pypy(-),-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-),-python_single_target_python3_7(-)] required by (dev-python/pyopenssl-17.5.0:0/0::gentoo, installed)
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                 

dev-python/pyopenssl:0

  (dev-python/pyopenssl-19.1.0:0/0::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (dev-python/pyopenssl-17.5.0:0/0::gentoo, installed) pulled in by
    dev-python/pyopenssl[python_targets_python2_7(-),python_targets_python3_5(-),-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)] required by (app-crypt/certbot-0.19.0:0/0::gentoo, installed)
                                                                                                                                                                                                                                                                                                           

dev-python/six:0

  (dev-python/six-1.14.0:0/0::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (dev-python/six-1.11.0:0/0::gentoo, installed) pulled in by
    dev-python/six[python_targets_python2_7(-),python_targets_python3_5(-),-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)] required by (app-crypt/certbot-0.19.0:0/0::gentoo, installed)
                                                                                                                                                                                                                                                                                                     
    >=dev-python/six-1.5.2[python_targets_python2_7(-),python_targets_python3_4(-),python_targets_python3_5(-),python_targets_python3_6(-),-python_single_target_pypy(-),-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-),-python_single_target_python3_7(-)] required by (dev-python/pyopenssl-17.5.0:0/0::gentoo, installed)
                                                                                                                                                                                                                                                                                                                                                                                                                                                                         

NOTE: Use the '--verbose-conflicts' option to display parents omitted above

!!! The slot conflict(s) shown above involve package(s) which may need to
!!! be rebuilt in order to solve the conflict(s). However, the following
!!! package(s) cannot be rebuilt for the reason(s) shown:

  (dev-lang/python-3.5.5:3.5/3.5m::gentoo, installed): ebuild is masked or unavailable
  (dev-lang/python-3.4.8:3.4/3.4m::gentoo, installed): ebuild is masked or unavailable


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


emerge: there are no ebuilds to satisfy "dev-python/setuptools[python_targets_python2_7(-),python_targets_python3_4(-),python_targets_python3_5(-),python_targets_python3_6(-),-python_single_target_pypy(-),-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-),-python_single_target_python3_7(-)]".
(dependency required by "dev-python/cryptography-2.2.2-r1::gentoo" [installed])
(dependency required by "dev-python/pyopenssl-17.5.0::gentoo" [installed])
(dependency required by "app-crypt/certbot-0.19.0::gentoo" [installed])
(dependency required by "@selected" [set])
(dependency required by "@world" [argument])
Back to top
View user's profile Send private message
misterxx
Guru
Guru


Joined: 18 Apr 2004
Posts: 437

PostPosted: Wed Apr 08, 2020 6:40 am    Post subject: Reply with quote

Hallo Leute,

hat keine einen Vorschlag, wie ich bei dem Problem vorgehen sollte???

Danke im Voraus!
Back to top
View user's profile Send private message
schmidicom
Veteran
Veteran


Joined: 09 Mar 2006
Posts: 1622
Location: Schweiz

PostPosted: Wed Apr 08, 2020 8:55 am    Post subject: Reply with quote

Ich würde dir gerne helfen, und andere sicher auch, aber leider sind die Meldungen von emerge manchmal echt nicht einfach zu lesen/verstehen und gerade bei deinem aktuellen Problem wüsste ich persönlich jetzt auch nicht wo man anfangen sollte.
Vielleicht findet sich im englischsprachigen Teil des Forums eher jemand der dir da helfen kann denn dort dürften auch mehr Gentoo-Devs unterwegs sein.
_________________
GPG: 0x3FC78AEE51E5FB95
Back to top
View user's profile Send private message
misterxx
Guru
Guru


Joined: 18 Apr 2004
Posts: 437

PostPosted: Wed Apr 08, 2020 12:13 pm    Post subject: Reply with quote

Versuche erst den Perl zu aktualisieren. Dabei bekomme ich folgende Ausgabe

Code:
matrixstorage /var/log # emerge -au perl

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     U  ] dev-lang/perl-5.30.1 [5.26.2]

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-lang/perl:0

  (dev-lang/perl-5.30.1:0/5.30::gentoo, ebuild scheduled for merge) pulled in by
    dev-lang/perl (Argument)

  (dev-lang/perl-5.26.2:0/5.26::gentoo, installed) pulled in by
    dev-lang/perl:0/5.26= required by (virtual/perl-File-Temp-0.230.400-r5:0/0::gentoo, installed)
                 ^^^^^^^^                                                                                                             
    dev-lang/perl:0/5.26= required by (virtual/perl-Digest-SHA-5.960.0:0/0::gentoo, installed)
                 ^^^^^^^^                                                                                                         
    dev-lang/perl:0/5.26= required by (dev-perl/IO-Socket-SSL-2.52.0:0/0::gentoo, installed)
                 ^^^^^^^^                                                                                                       
    dev-lang/perl:0/5.26= required by (virtual/perl-CPAN-Meta-2.150.10-r1:0/0::gentoo, installed)
                 ^^^^^^^^                                                                                                           
    dev-lang/perl:0/5.26= required by (virtual/perl-Exporter-5.720.0-r3:0/0::gentoo, installed)
                 ^^^^^^^^                                                                                                         
    dev-lang/perl:0/5.26= required by (virtual/perl-ExtUtils-MakeMaker-7.240.0:0/0::gentoo, installed)
                 ^^^^^^^^                                                                                                                 
    dev-lang/perl:0/5.26= required by (virtual/perl-XSLoader-0.270.0:0/0::gentoo, installed)
                 ^^^^^^^^                                                                                                       
    dev-lang/perl:0/5.26= required by (virtual/perl-Parse-CPAN-Meta-2.150.10-r1:0/0::gentoo, installed)
                 ^^^^^^^^                                                                                                                 
    dev-lang/perl:0/5.26= required by (virtual/perl-Test-Harness-3.380.0:0/0::gentoo, installed)
                 ^^^^^^^^                                                                                                           
    dev-lang/perl:0/5.26= required by (virtual/perl-Compress-Raw-Zlib-2.74.0:0/0::gentoo, installed)
                 ^^^^^^^^                                                                                                               
    dev-lang/perl:0/5.26= required by (virtual/perl-Encode-2.880.0:0/0::gentoo, installed)
                 ^^^^^^^^                                                                                                     
    dev-lang/perl:0/5.26= required by (virtual/perl-ExtUtils-Install-2.40.0-r3:0/0::gentoo, installed)
                 ^^^^^^^^                                                                                                                 
    dev-lang/perl:0/5.26= required by (virtual/perl-Scalar-List-Utils-1.460.200_rc:0/0::gentoo, installed)
                 ^^^^^^^^                                                                                                                     
    dev-lang/perl:0/5.26= required by (virtual/perl-Perl-OSType-1.10.0-r1:0/0::gentoo, installed)
                 ^^^^^^^^                                                                                                           
    dev-lang/perl:0/5.26= required by (virtual/perl-File-Path-2.130.0:0/0::gentoo, installed)
                 ^^^^^^^^                                                                                                       
    dev-lang/perl:0/5.26= required by (virtual/perl-ExtUtils-ParseXS-3.340.0:0/0::gentoo, installed)
                 ^^^^^^^^                                                                                                               
    dev-lang/perl:0/5.26= required by (virtual/perl-IO-1.380.0:0/0::gentoo, installed)
                 ^^^^^^^^                                                                                                 
    dev-lang/perl:0/5.26= required by (virtual/perl-JSON-PP-2.274.0.200_rc:0/0::gentoo, installed)
                 ^^^^^^^^                                                                                                             
    dev-lang/perl:0/5.26= required by (virtual/perl-podlators-4.90.0:0/0::gentoo, installed)
                 ^^^^^^^^                                                                                                       
    dev-lang/perl:0/5.26= required by (virtual/perl-Compress-Raw-Bzip2-2.74.0-r1:0/0::gentoo, installed)
                 ^^^^^^^^                                                                                                                   
    dev-lang/perl:0/5.26=[-build(-)] required by (perl-core/File-Temp-0.230.400-r1:0/0::gentoo, installed)
                 ^^^^^^^^                                                                                                                     
    dev-lang/perl:0/5.26= required by (virtual/perl-IO-Socket-IP-0.380.0:0/0::gentoo, installed)
                 ^^^^^^^^                                                                                                           
    dev-lang/perl:0/5.26= required by (virtual/perl-Storable-2.620.0:0/0::gentoo, installed)
                 ^^^^^^^^                                                                                                       
    dev-lang/perl:0/5.26= required by (virtual/perl-Getopt-Long-2.490.0:0/0::gentoo, installed)
                 ^^^^^^^^                                                                                                         
    dev-lang/perl:0/5.26= required by (virtual/perl-Module-Metadata-1.0.33-r1:0/0::gentoo, installed)
                 ^^^^^^^^                                                                                                               
    dev-lang/perl:0/5.26= required by (virtual/perl-File-Spec-3.670.0:0/0::gentoo, installed)
                 ^^^^^^^^                                                                                                       
    dev-lang/perl:0/5.26= required by (virtual/perl-Text-ParseWords-3.300.0-r4:0/0::gentoo, installed)
                 ^^^^^^^^                                                                                                                 
    dev-lang/perl:0/5.26= required by (virtual/perl-Carp-1.420.0:0/0::gentoo, installed)
                 ^^^^^^^^                                                                                                   
    dev-lang/perl:0/5.26= required by (virtual/perl-ExtUtils-Manifest-1.700.0-r5:0/0::gentoo, installed)
                 ^^^^^^^^                                                                                                                   
    dev-lang/perl:0/5.26= required by (virtual/perl-Data-Dumper-2.167.0:0/0::gentoo, installed)
                 ^^^^^^^^                                                                                                         
    dev-lang/perl:0/5.26= required by (virtual/perl-MIME-Base64-3.150.0-r4:0/0::gentoo, installed)
                 ^^^^^^^^                                                                                                             
    dev-lang/perl:0/5.26= required by (virtual/perl-Digest-MD5-2.550.0:0/0::gentoo, installed)
                 ^^^^^^^^                                                                                                         
    dev-lang/perl:0/5.26= required by (virtual/perl-CPAN-Meta-YAML-0.18.0-r3:0/0::gentoo, installed)
                 ^^^^^^^^                                                                                                               
    dev-lang/perl:0/5.26= required by (virtual/perl-version-0.991.700:0/0::gentoo, installed)
                 ^^^^^^^^                                                                                                       
    dev-lang/perl:0/5.26= required by (virtual/perl-Time-HiRes-1.974.100-r2:0/0::gentoo, installed)
                 ^^^^^^^^                                                                                                             
    dev-lang/perl:0/5.26= required by (virtual/perl-parent-0.236.0-r1:0/0::gentoo, installed)
                 ^^^^^^^^                                                                                                       
    =dev-lang/perl-5.26* required by (virtual/perl-Exporter-5.720.0-r3:0/0::gentoo, installed)
    ^              ^^^^^                                                                                                                             
    dev-lang/perl:0/5.26= required by (virtual/perl-IO-Compress-2.74.0-r1:0/0::gentoo, installed)
                 ^^^^^^^^                                                                                                           
    dev-lang/perl:0/5.26= required by (virtual/perl-libnet-3.100.0:0/0::gentoo, installed)
                 ^^^^^^^^                                                                                                     
    dev-lang/perl:0/5.26= required by (virtual/perl-ExtUtils-CBuilder-0.280.225-r2:0/0::gentoo, installed)
                 ^^^^^^^^                                                                                                                     
    dev-lang/perl:0/5.26= required by (virtual/perl-Time-Local-1.250.0-r1:0/0::gentoo, installed)
                 ^^^^^^^^                                                                                                           
    dev-lang/perl:0/5.26=[-build(-)] required by (dev-perl/Lchown-1.10.0-r1:0/0::gentoo, installed)
                 ^^^^^^^^                                                                                                             
    (and 78 more with the same problems)

NOTE: Use the '--verbose-conflicts' option to display parents omitted above

!!! The slot conflict(s) shown above involve package(s) which may need to
!!! be rebuilt in order to solve the conflict(s). However, the following
!!! package(s) cannot be rebuilt for the reason(s) shown:

  (virtual/perl-libnet-3.100.0:0/0::gentoo, installed): ebuild is masked or unavailable
  (virtual/perl-Compress-Raw-Bzip2-2.74.0-r1:0/0::gentoo, installed): ebuild is masked or unavailable
  (virtual/perl-Getopt-Long-2.490.0:0/0::gentoo, installed): ebuild is masked or unavailable
  (virtual/perl-Test-Harness-3.380.0:0/0::gentoo, installed): ebuild is masked or unavailable
  (virtual/perl-JSON-PP-2.274.0.200_rc:0/0::gentoo, installed): ebuild is masked or unavailable
  (virtual/perl-Data-Dumper-2.167.0:0/0::gentoo, installed): ebuild is masked or unavailable
  (virtual/perl-ExtUtils-Install-2.40.0-r3:0/0::gentoo, installed): ebuild is masked or unavailable
  (virtual/perl-Digest-MD5-2.550.0:0/0::gentoo, installed): ebuild is masked or unavailable
  (virtual/perl-Digest-SHA-5.960.0:0/0::gentoo, installed): ebuild is masked or unavailable
  (virtual/perl-CPAN-Meta-2.150.10-r1:0/0::gentoo, installed): ebuild is masked or unavailable
  (virtual/perl-Time-HiRes-1.974.100-r2:0/0::gentoo, installed): ebuild is masked or unavailable
  (virtual/perl-Perl-OSType-1.10.0-r1:0/0::gentoo, installed): ebuild is masked or unavailable
  (virtual/perl-Module-Metadata-1.0.33-r1:0/0::gentoo, installed): ebuild is masked or unavailable
  (virtual/perl-Storable-2.620.0:0/0::gentoo, installed): ebuild is masked or unavailable
  (virtual/perl-CPAN-Meta-YAML-0.18.0-r3:0/0::gentoo, installed): ebuild is masked or unavailable
  (virtual/perl-ExtUtils-ParseXS-3.340.0:0/0::gentoo, installed): ebuild is masked or unavailable
  (virtual/perl-File-Temp-0.230.400-r5:0/0::gentoo, installed): ebuild is masked or unavailable
  (virtual/perl-XSLoader-0.270.0:0/0::gentoo, installed): ebuild is masked or unavailable
  (virtual/perl-IO-Socket-IP-0.380.0:0/0::gentoo, installed): ebuild is masked or unavailable
  (virtual/perl-version-0.991.700:0/0::gentoo, installed): ebuild is masked or unavailable
  (virtual/perl-ExtUtils-CBuilder-0.280.225-r2:0/0::gentoo, installed): ebuild is masked or unavailable
  (virtual/perl-File-Spec-3.670.0:0/0::gentoo, installed): ebuild is masked or unavailable
  (virtual/perl-Compress-Raw-Zlib-2.74.0:0/0::gentoo, installed): ebuild is masked or unavailable
  (virtual/perl-Carp-1.420.0:0/0::gentoo, installed): ebuild is masked or unavailable
  (virtual/perl-podlators-4.90.0:0/0::gentoo, installed): ebuild is masked or unavailable
  (virtual/perl-ExtUtils-Manifest-1.700.0-r5:0/0::gentoo, installed): ebuild is masked or unavailable
  (virtual/perl-Time-Local-1.250.0-r1:0/0::gentoo, installed): ebuild is masked or unavailable
  (virtual/perl-File-Path-2.130.0:0/0::gentoo, installed): ebuild is masked or unavailable
  (virtual/perl-Text-ParseWords-3.300.0-r4:0/0::gentoo, installed): ebuild is masked or unavailable
  (virtual/perl-Encode-2.880.0:0/0::gentoo, installed): ebuild is masked or unavailable
  (virtual/perl-MIME-Base64-3.150.0-r4:0/0::gentoo, installed): ebuild is masked or unavailable
  (virtual/perl-parent-0.236.0-r1:0/0::gentoo, installed): ebuild is masked or unavailable
  (virtual/perl-Exporter-5.720.0-r3:0/0::gentoo, installed): ebuild is masked or unavailable
  (virtual/perl-ExtUtils-MakeMaker-7.240.0:0/0::gentoo, installed): ebuild is masked or unavailable
  (perl-core/File-Temp-0.230.400-r1:0/0::gentoo, installed): ebuild is masked or unavailable
  (virtual/perl-IO-1.380.0:0/0::gentoo, installed): ebuild is masked or unavailable
  (virtual/perl-IO-Compress-2.74.0-r1:0/0::gentoo, installed): ebuild is masked or unavailable
  (dev-perl/Lchown-1.10.0-r1:0/0::gentoo, installed): ebuild is masked or unavailable
  (virtual/perl-Parse-CPAN-Meta-2.150.10-r1:0/0::gentoo, installed): ebuild is masked or unavailable
  (virtual/perl-Scalar-List-Utils-1.460.200_rc:0/0::gentoo, installed): ebuild is masked or unavailable


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


Vieles ist vom Perl 5.26 abhängig, warum kann es auf Perl 5.30 nicht switches? Es ist ja nicht ein sonder viele Packete.

Jemand eine Idee?
Back to top
View user's profile Send private message
Christian99
Veteran
Veteran


Joined: 28 May 2009
Posts: 1201

PostPosted: Wed Apr 08, 2020 1:53 pm    Post subject: Reply with quote

das sieht ein bisschen seltsam aus.

Ich würde mal versuchen, alle Pakete, die portage mit auflistet mit zu bauen, also sowas wie
Code:
emerge -a1 perl virtual/perl-File-Temp virtual/perl-Digest-SHA ....


die virtual pakete könntest du mit eix so machen:
Code:
emerge -a1 perl $(eix --only-names -I -C virtual perl-)


und dann die paar , über die sich portage noch beschwert per hand hinzufügen
Back to top
View user's profile Send private message
Max Steel
Advocate
Advocate


Joined: 12 Feb 2007
Posts: 2090
Location: My own world! I and Gentoo!

PostPosted: Wed Apr 08, 2020 4:30 pm    Post subject: Reply with quote

Was ist eigentlich aus update-perl geworden?
_________________
mfg
Steel
___________________
Sorry for my bad English.

Heim-PC: Intel i7-5820K, 32GB RAM, GTX 1080
Laptop: Intel Core i5-4300U, 16GB RAM, Intel Graphic
Arbeit-PC: Intel i5-3470S, 16GB RAM, Intel Graphic
Back to top
View user's profile Send private message
misterxx
Guru
Guru


Joined: 18 Apr 2004
Posts: 437

PostPosted: Thu Apr 09, 2020 5:44 am    Post subject: Reply with quote

Hallo Leute,

vielen Dank für eure Rückmeldungen.

Ich habe gestern noch auf diesen Thread gestossen: https://forums.gentoo.org/viewtopic-t-1107662-postdays-0-postorder-asc-start-0.html?sid=2bf33a07bf8eefb5b753451b2e40ac44

Dort wurden Probleme mit meinem System sehr ähnlichen Symptomen behandelt. So bin ich wie dort beschrieben vorgegangen.

- PYTHON_SINGLE_TARGET and PYTHON_TARGETS aus make.conf entfern
- meine Einstellungen bezogen auf mask und unmask bereinigt (alles was Python anging entfern und teilweise andere Sachen angepasst)
- von Portage-9999 erst zu portage-2.3.69 und im Anschluss auf aktuell stabile gewechselt
- System upgrade gestartet

Aktuell läuft System Upgrade, es sollen 321 Pakete gebaut werden.

Danach schaue ich ob es mit dem Perl sich gelöst hat und ob das Update World erneut funktionieren wird.

Ich werde im Anschluss darüber hier berichten.
Back to top
View user's profile Send private message
misterxx
Guru
Guru


Joined: 18 Apr 2004
Posts: 437

PostPosted: Fri Apr 10, 2020 8:24 am    Post subject: Reply with quote

System Upgrade ist durch. Perl Problem hat sich gelöst.

Nächstes Problem beim update world.

Code:
[blocks B      ] app-eselect/eselect-opengl ("app-eselect/eselect-opengl" is blocking media-libs/mesa-19.3.5, x11-base/xorg-server-1.20.7)

Total: 149 packages (108 upgrades, 16 new, 5 in new slots, 20 reinstalls), Size of downloads: 397.427 KiB
Conflict: 3 blocks (1 unsatisfied)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (app-eselect/eselect-opengl-1.3.1-r4:0/0::gentoo, ebuild scheduled for merge) pulled in by
    app-eselect/eselect-opengl required by @selected

  (media-libs/mesa-19.3.5:0/0::gentoo, installed) pulled in by
    media-libs/mesa[X(+),abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_riscv_lp64d(-)?,abi_riscv_lp64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] (media-libs/mesa[X(+)]) required by (x11-libs/gtk+-3.24.13:3/3::gentoo, installed) USE="X cups introspection (-aqua) -broadway (-cloudprint) (-colord) -examples -gtk-doc -test -vim-syntax -wayland -xinerama"
    media-libs/mesa[egl] required by (dev-qt/qtgui-5.13.2-r1:5/5.13::gentoo, installed) USE="dbus egl gif jpeg libinput png udev xcb -accessibility -debug -eglfs -evdev -gles2-only -ibus -test -tslib -tuio -vnc -wayland"
    >=media-libs/mesa-9.1.6[egl,X(+),abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_riscv_lp64d(-)?,abi_riscv_lp64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] (>=media-libs/mesa-9.1.6[egl,X(+)]) required by (x11-libs/cairo-1.16.0-r3:0/0::gentoo, installed) USE="X glib opengl svg (-aqua) -debug (-gles2-only) -static-libs -utils -valgrind"
    >=media-libs/mesa-9.1.6[X(+),abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_riscv_lp64d(-)?,abi_riscv_lp64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] (>=media-libs/mesa-9.1.6[X(+)]) required by (virtual/opengl-7.0-r2:0/0::gentoo, installed) USE=""
    >=media-libs/mesa-10.2:* required by (www-client/firefox-52.3.0:0/0::gentoo, installed) USE="dbus gmp-autoupdate jemalloc startup-notification -bindist -custom-cflags -custom-optimization -debug -gtk2 (-hardened) -hwaccel -jack -neon (-pgo) -pulseaudio (-rust) (-selinux) (-system-cairo) -system-harfbuzz -system-icu -system-jpeg -system-libevent -system-libvpx -system-sqlite -test -wifi" L10N="de ru -ach -af -an -ar -as -ast -az -bg -bn-BD -bn-IN -br -bs -ca -cak -cs -cy -da -dsb -el -en-GB -en-ZA -eo -es-AR -es-CL -es-ES -es-MX -et -eu -fa -ff -fi -fr -fy -ga -gd -gl -gn -gu -he -hi -hr -hsb -hu -hy -id -is -it -ja -ka -kab -kk -km -kn -ko -lij -lt -lv -mai -mk -ml -mr -ms -nb -nl -nn -or -pa -pl -pt-BR -pt-PT -rm -ro -si -sk -sl -son -sq -sr -sv -ta -te -th -tr -uk -uz -vi -xh -zh-CN -zh-TW"
    media-libs/mesa[egl,abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_riscv_lp64d(-)?,abi_riscv_lp64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] (media-libs/mesa[egl]) required by (media-libs/libepoxy-1.5.4:0/0::gentoo, installed) USE="X egl -test"
    >=media-libs/mesa-18[X(+),egl,gbm] required by (x11-base/xorg-server-1.20.7:0/1.20.7::gentoo, ebuild scheduled for merge) USE="ipv6 libglvnd suid udev xorg -debug -dmx -doc -elogind -kdrive -libressl -minimal (-selinux) -static-libs -systemd -unwind -wayland -xcsecurity -xephyr -xnest -xvfb"

  (x11-base/xorg-server-1.20.7:0/1.20.7::gentoo, ebuild scheduled for merge) pulled in by
    x11-base/xorg-server[xorg] required by (x11-drivers/xf86-video-fbdev-0.5.0:0/0::gentoo, installed) USE=""
    x11-base/xorg-server[xorg] required by (x11-drivers/xf86-input-evdev-2.10.6:0/0::gentoo, installed) USE=""
    x11-base/xorg-server[-minimal] required by (x11-drivers/xf86-video-omap-0.4.5:0/0::gentoo, installed) USE=""
    x11-base/xorg-server:= required by (x11-drivers/xf86-video-dummy-0.3.8:0/0::gentoo, installed) USE="-dga"
    >=x11-base/xorg-server-1.18[udev] required by (x11-drivers/xf86-input-evdev-2.10.6:0/0::gentoo, installed) USE=""
    x11-base/xorg-server:= required by (x11-drivers/xf86-video-armsoc-1.4.1:0/0::hossie, installed) USE=""
    x11-base/xorg-server:= required by (x11-drivers/xf86-video-fbdev-0.5.0:0/0::gentoo, installed) USE=""
    x11-base/xorg-server:= required by (x11-drivers/xf86-input-evdev-2.10.6:0/0::gentoo, installed) USE=""
    x11-base/xorg-server[xorg] required by (x11-drivers/xf86-video-dummy-0.3.8:0/0::gentoo, installed) USE="-dga"
    >=x11-base/xorg-server-1.14 required by (x11-drivers/xf86-input-synaptics-1.9.1:0/0::gentoo, installed) USE=""
    x11-base/xorg-server[xorg] required by (x11-drivers/xf86-video-armsoc-1.4.1:0/0::hossie, installed) USE=""
    >=x11-base/xorg-server-1.0.99 required by (x11-drivers/xf86-video-dummy-0.3.8:0/0::gentoo, installed) USE="-dga"
    x11-base/xorg-server:= required by (x11-drivers/xf86-input-synaptics-1.9.1:0/0::gentoo, installed) USE=""
    x11-base/xorg-server[xorg] required by (x11-drivers/xf86-video-omap-0.4.5:0/0::gentoo, installed) USE=""
    x11-base/xorg-server required by (x11-drivers/xf86-video-fbdev-0.5.0:0/0::gentoo, installed) USE=""
    >=x11-base/xorg-server-1.3 required by (x11-drivers/xf86-video-omap-0.4.5:0/0::gentoo, installed) USE=""
    x11-base/xorg-server[xorg] required by (x11-drivers/xf86-input-synaptics-1.9.1:0/0::gentoo, installed) USE=""
    x11-base/xorg-server:= required by (x11-drivers/xf86-video-omap-0.4.5:0/0::gentoo, installed) USE=""


Ich verstehe es so dass entweder mesa oder eselect-opengl installiert werde können. mesa ist installiert aber warum wird die Installation von eselect-opengl gefordert?

Und was sollte man hier am besten tun?
Back to top
View user's profile Send private message
misterxx
Guru
Guru


Joined: 18 Apr 2004
Posts: 437

PostPosted: Fri Apr 10, 2020 8:41 am    Post subject: Reply with quote

gelöst in dem ich den Atom in /var/lib/portage/world aaskommentiert habe.

Nun nächste Aktion
Code:
emerge -avuDN @world --with-bdeps=y --backtrack=200
gestartet.

Code:
Total: 162 packages (101 upgrades, 13 new, 5 in new slots, 43 reinstalls), Size of downloads: 390.111 KiB
Back to top
View user's profile Send private message
misterxx
Guru
Guru


Joined: 18 Apr 2004
Posts: 437

PostPosted: Sat Apr 11, 2020 7:08 am    Post subject: Reply with quote

Code:
Total: 162 packages (101 upgrades, 13 new, 5 in new slots, 43 reinstalls), Size of downloads: 390.111 KiB


Aktion erfolgreich abgeschlossen.

Code:
matrixstorage ~ # emerge --info
Portage 2.3.97 (python 3.6.10-final-0, default/linux/arm/17.0/armv7a/desktop, gcc-8.2.0, glibc-2.29-r7, 4.9.44 armv7l)
=================================================================
System uname: Linux-4.9.44-armv7l-ARMv7_Processor_rev_3_-v7l-with-gentoo-2.6
KiB Mem:     2041904 total,    173528 free
KiB Swap:    4189180 total,   4088480 free
Timestamp of repository gentoo: Wed, 08 Apr 2020 12:00:01 +0000
Head commit of repository gentoo: b90f8a15f0c3f23c6b901275faea75c772bc9067
sh bash 4.4_p23-r1
ld GNU ld (Gentoo 2.31.1 p5) 2.31.1
app-shells/bash:          4.4_p23-r1::gentoo
dev-java/java-config:     2.2.0-r4::gentoo
dev-lang/perl:            5.30.1::gentoo
dev-lang/python:          2.7.17-r2::gentoo, 3.4.8::gentoo, 3.5.5::gentoo, 3.6.10-r1::gentoo, 3.7.7-r1::gentoo
dev-util/cmake:           3.16.5::gentoo
dev-util/pkgconfig:       0.29.2::gentoo
sys-apps/baselayout:      2.6-r1::gentoo
sys-apps/openrc:          0.42.1::gentoo
sys-apps/sandbox:         2.13::gentoo
sys-devel/autoconf:       2.13-r1::gentoo, 2.69-r4::gentoo
sys-devel/automake:       1.11.6-r3::gentoo, 1.15.1-r2::gentoo, 1.16.1-r1::gentoo
sys-devel/binutils:       2.30-r4::gentoo, 2.31.1-r4::gentoo, 2.33.1-r1::gentoo
sys-devel/gcc:            8.2.0-r6::gentoo, 9.2.0-r2::gentoo
sys-devel/gcc-config:     2.2.1::gentoo
sys-devel/libtool:        2.4.6-r6::gentoo
sys-devel/make:           4.2.1-r4::gentoo
sys-kernel/linux-headers: 5.4::gentoo (virtual/os-headers)
sys-libs/glibc:           2.29-r7::gentoo
Repositories:

gentoo
    location: /usr/portage
    sync-type: rsync
    sync-uri: rsync://rsync.gentoo.org/gentoo-portage
    priority: -1000
    sync-rsync-verify-jobs: 1
    sync-rsync-verify-metamanifest: yes
    sync-rsync-extra-opts:
    sync-rsync-verify-max-age: 24

fkmclane
    location: /var/lib/layman/fkmclane
    masters: gentoo
    priority: 50

hossie
    location: /var/lib/layman/hossie
    masters: gentoo
    priority: 50

ACCEPT_KEYWORDS="arm"
ACCEPT_LICENSE="@FREE"
CBUILD="armv7a-hardfloat-linux-gnueabi"
CFLAGS="-O2 -pipe -march=armv7-a -mfpu=vfpv3-d16 -mfloat-abi=hard"
CHOST="armv7a-hardfloat-linux-gnueabi"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt /var/bind"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php7.2/ext-active/ /etc/php/apache2-php7.3/ext-active/ /etc/php/apache2-php7.4/ext-active/ /etc/php/cgi-php7.2/ext-active/ /etc/php/cgi-php7.3/ext-active/ /etc/php/cgi-php7.4/ext-active/ /etc/php/cli-php7.2/ext-active/ /etc/php/cli-php7.3/ext-active/ /etc/php/cli-php7.4/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -pipe -march=armv7-a -mfpu=vfpv3-d16 -mfloat-abi=hard"
DISTDIR="/usr/portage/distfiles"
ENV_UNSET="DBUS_SESSION_BUS_ADDRESS DISPLAY GOBIN PERL5LIB PERL5OPT PERLPREFIX PERL_CORE PERL_MB_OPT PERL_MM_OPT XAUTHORITY XDG_CACHE_HOME XDG_CONFIG_HOME XDG_DATA_HOME XDG_RUNTIME_DIR"
FCFLAGS="-O2 -pipe -march=armv7-a"
FEATURES="assume-digests binpkg-docompress binpkg-dostrip binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles ipc-sandbox merge-sync multilib-strict network-sandbox news parallel-fetch pid-sandbox preserve-libs protect-owned qa-unresolved-soname-deps sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe -march=armv7-a"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="de_DE.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="de en"
MAKEOPTS="-j8"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/var/tmp"
USE="X a52 aac acl airplay alsa apache2 arm armv5te armv6 armv6t2 berkdb bluetooth bluray branding bzip2 cairo caps cdda cdr cec cli consolekit crypt css cups curl dbus dri dts dvd dvdr emboss encode exif flac fortran fpm ftp gd gdbm gif gpm gtk iconv icu ipv6 java jce jpeg lcms ldap libnotify mad mng mp3 mp4 mpeg ncurses nls nptl nsplugin ogg opengl openmp pam pango pcre pdf pdo php phython png policykit postgres ppds qt5 readline sdl seccomp spell split-usr sqlite ssl startup-notification svg tcpd threads tiff truetype udev udisks unicode upower usb vorbis wxwidgets x264 xattr xcb xml xmlreader xmlwriter xv xvid zip zlib" ADA_TARGET="gnat_2018" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="karbon sheets words" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_ARM="edsp thumb thumb2 v4 v5 v6 v7 vfp" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock greis isync itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf skytraq superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="evdev synaptics" KERNEL="linux" L10N="de en ru" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php7-2" POSTGRES_TARGETS="postgres10 postgres11" PYTHON_SINGLE_TARGET="python3_6" PYTHON_TARGETS="python2_7 python3_6" RUBY_TARGETS="ruby24 ruby25" USERLAND="GNU" VIDEO_CARDS="exynos fbdev omap dummy v4l" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CC, CPPFLAGS, CTARGET, CXX, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BINHOST, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS



Nun der Aufruf von
Code:
emerge --update --newuse --deep --with-bdeps=y @world


Es scheiterte bei ev-python/setuptools_scm

Code:
writing requirements to src/setuptools_scm.egg-info/requires.txt
writing src/setuptools_scm.egg-info/PKG-INFO
writing top-level names to src/setuptools_scm.egg-info/top_level.txt
writing dependency_links to src/setuptools_scm.egg-info/dependency_links.txt
writing entry points to src/setuptools_scm.egg-info/entry_points.txt
Traceback (most recent call last):
  File "setup.py", line 123, in <module>
    setuptools.setup(**arguments)
  File "/usr/lib/python2.7/site-packages/setuptools/__init__.py", line 145, in setup
    return distutils.core.setup(**attrs)
  File "/usr/lib/python2.7/distutils/core.py", line 151, in setup
    dist.run_commands()
  File "/usr/lib/python2.7/distutils/dist.py", line 953, in run_commands
    self.run_command(cmd)
  File "/usr/lib/python2.7/distutils/dist.py", line 972, in run_command
    cmd_obj.run()
  File "/usr/lib/python2.7/site-packages/setuptools/command/install.py", line 61, in run
    return orig.install.run(self)
  File "/usr/lib/python2.7/distutils/command/install.py", line 575, in run
    self.run_command(cmd_name)
  File "/usr/lib/python2.7/distutils/cmd.py", line 326, in run_command
    self.distribution.run_command(command)
  File "/usr/lib/python2.7/distutils/dist.py", line 972, in run_command
    cmd_obj.run()
  File "/usr/lib/python2.7/site-packages/setuptools/command/install_egg_info.py", line 34, in run
    self.run_command('egg_info')
  File "/usr/lib/python2.7/distutils/cmd.py", line 326, in run_command
    self.distribution.run_command(command)
  File "/usr/lib/python2.7/distutils/dist.py", line 972, in run_command
    cmd_obj.run()
  File "/usr/lib/python2.7/site-packages/setuptools/command/egg_info.py", line 296, in run
    self.find_sources()
  File "/usr/lib/python2.7/site-packages/setuptools/command/egg_info.py", line 303, in find_sources
    mm.run()
  File "/usr/lib/python2.7/site-packages/setuptools/command/egg_info.py", line 534, in run
    self.add_defaults()
  File "/usr/lib/python2.7/site-packages/setuptools/command/egg_info.py", line 574, in add_defaults
    rcfiles = list(walk_revctrl())
  File "/usr/lib/python2.7/site-packages/setuptools/command/sdist.py", line 20, in walk_revctrl
    for item in ep.load()(dirname):
  File "/var/tmp/portage/dev-python/setuptools_scm-3.5.0/work/setuptools_scm-3.5.0/src/setuptools_scm/integration.py", line 22, in find_files
    command = ep.load()
  File "/usr/lib/python2.7/site-packages/pkg_resources/__init__.py", line 2443, in load
    return self.resolve()
  File "/usr/lib/python2.7/site-packages/pkg_resources/__init__.py", line 2453, in resolve
    raise ImportError(str(exc))
ImportError: 'module' object has no attribute 'FILES_COMMAND'
 * ERROR: dev-python/setuptools_scm-3.5.0::gentoo failed (install phase):
 *   (no error message)
 *
 * Call stack:
 *     ebuild.sh, line  125:  Called src_install
 *   environment, line 2870:  Called distutils-r1_src_install
 *   environment, line 1186:  Called _distutils-r1_run_foreach_impl 'distutils-r1_python_install'
 *   environment, line  417:  Called python_foreach_impl 'distutils-r1_run_phase' 'distutils-r1_python_install'
 *   environment, line 2486:  Called multibuild_foreach_variant '_python_multibuild_wrapper' 'distutils-r1_run_phase' 'distutils-r1_python_install'
 *   environment, line 1999:  Called _multibuild_run '_python_multibuild_wrapper' 'distutils-r1_run_phase' 'distutils-r1_python_install'
 *   environment, line 1997:  Called _python_multibuild_wrapper 'distutils-r1_run_phase' 'distutils-r1_python_install'
 *   environment, line  805:  Called distutils-r1_run_phase 'distutils-r1_python_install'
 *   environment, line 1154:  Called distutils-r1_python_install
 *   environment, line 1068:  Called esetup.py 'install' '--root=/var/tmp/portage/dev-python/setuptools_scm-3.5.0/image/_python2.7'
 *   environment, line 1543:  Called die
 * The specific snippet of code:
 *       "${@}" || die "${die_args[@]}";
 *
 * If you need support, post the output of `emerge --info '=dev-python/setuptools_scm-3.5.0::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=dev-python/setuptools_scm-3.5.0::gentoo'`.
 * The complete build log is located at '/var/tmp/portage/dev-python/setuptools_scm-3.5.0/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/dev-python/setuptools_scm-3.5.0/temp/environment'.
 * Working directory: '/var/tmp/portage/dev-python/setuptools_scm-3.5.0/work/setuptools_scm-3.5.0'
 * S: '/var/tmp/portage/dev-python/setuptools_scm-3.5.0/work/setuptools_scm-3.5.0'

>>> Failed to emerge dev-python/setuptools_scm-3.5.0, Log file:

>>>  '/var/tmp/portage/dev-python/setuptools_scm-3.5.0/temp/build.log'

 * Messages for package dev-python/setuptools_scm-3.5.0:

 * ERROR: dev-python/setuptools_scm-3.5.0::gentoo failed (install phase):
 *   (no error message)
 *
 * Call stack:
 *     ebuild.sh, line  125:  Called src_install
 *   environment, line 2870:  Called distutils-r1_src_install
 *   environment, line 1186:  Called _distutils-r1_run_foreach_impl 'distutils-r1_python_install'
 *   environment, line  417:  Called python_foreach_impl 'distutils-r1_run_phase' 'distutils-r1_python_install'
 *   environment, line 2486:  Called multibuild_foreach_variant '_python_multibuild_wrapper' 'distutils-r1_run_phase' 'distutils-r1_python_install'
 *   environment, line 1999:  Called _multibuild_run '_python_multibuild_wrapper' 'distutils-r1_run_phase' 'distutils-r1_python_install'
 *   environment, line 1997:  Called _python_multibuild_wrapper 'distutils-r1_run_phase' 'distutils-r1_python_install'
 *   environment, line  805:  Called distutils-r1_run_phase 'distutils-r1_python_install'
 *   environment, line 1154:  Called distutils-r1_python_install
 *   environment, line 1068:  Called esetup.py 'install' '--root=/var/tmp/portage/dev-python/setuptools_scm-3.5.0/image/_python2.7'
 *   environment, line 1543:  Called die
 * The specific snippet of code:
 *       "${@}" || die "${die_args[@]}";
 *
 * If you need support, post the output of `emerge --info '=dev-python/setuptools_scm-3.5.0::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=dev-python/setuptools_scm-3.5.0::gentoo'`.
 * The complete build log is located at '/var/tmp/portage/dev-python/setuptools_scm-3.5.0/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/dev-python/setuptools_scm-3.5.0/temp/environment'.
 * Working directory: '/var/tmp/portage/dev-python/setuptools_scm-3.5.0/work/setuptools_scm-3.5.0'
 * S: '/var/tmp/portage/dev-python/setuptools_scm-3.5.0/work/setuptools_scm-3.5.0'


Hier komme ich aktuell nicht weiter. Jemand eine Idee?

Danke im Voraus!
Back to top
View user's profile Send private message
misterxx
Guru
Guru


Joined: 18 Apr 2004
Posts: 437

PostPosted: Sat Apr 11, 2020 7:15 am    Post subject: Reply with quote

Interessante Weise liefert emerge --info

Code:
dev-lang/python:          2.7.17-r2::gentoo, 3.4.8::gentoo, 3.5.5::gentoo, 3.6.10-r1::gentoo, 3.7.7-r1::gentoo


aber

Code:
matrixstorage ~ # eselect python list
Available Python interpreters, in order of preference:
  [1]   python3.6
  [2]   python2.7


Installiert ist aber 3.7.7-r1

Code:
matrixstorage /etc/conf.d # emerge -pv python

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R    ] dev-lang/python-3.7.7-r1:3.7/3.7m::gentoo  USE="bluetooth gdbm ipv6 ncurses readline sqlite ssl xml -build -examples (-hardened) -libressl -test -tk -wininst" 0 KiB



Wie ist es zu verstehen? Oder ist etwas falsch?

Danke im Voraus!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum