Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
deepin package dev-qt/qcef-1.1.7-r1 fails to emerge[SOLVED]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
mikefot
l33t
l33t


Joined: 19 Nov 2014
Posts: 642

PostPosted: Tue Apr 21, 2020 7:06 pm    Post subject: deepin package dev-qt/qcef-1.1.7-r1 fails to emerge[SOLVED] Reply with quote

Dear All,

I am running gentoo stable an amd64 kaveri box.

I have been trying to install deepin desktop.

A number of packages have failed to emerge.

One is

Code:
dev-qt/qcef-1.1.7-r1::deepin


The build log file is here:

http://dpaste.com/2J6QXK6

Comments appreciated on this.

Regards

Michael Fothergill


Last edited by mikefot on Wed Apr 22, 2020 12:09 pm; edited 1 time in total
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 24079
Location: here

PostPosted: Tue Apr 21, 2020 7:46 pm    Post subject: Reply with quote

In qt-5.14 QFileDialog::setConfirmOverwrite(bool) is deprecated and developer should change with QFileDialog::setOption(QFileDialog::Option option, bool on = true).
You can workaround this problem adding -Wno-deprecated-declarations CXXFLAGS to this package with package.env
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
mikefot
l33t
l33t


Joined: 19 Nov 2014
Posts: 642

PostPosted: Tue Apr 21, 2020 8:01 pm    Post subject: Reply with quote

Many thanks again.

I am looking into this.

Regards


MF
Back to top
View user's profile Send private message
mikefot
l33t
l33t


Joined: 19 Nov 2014
Posts: 642

PostPosted: Wed Apr 22, 2020 11:39 am    Post subject: Reply with quote

Many thanks again.

The deepin developer has kindly fixed the bugs.

I ran
Code:
emerge --sync deepin


and then ran the emerge command for the deepin desktop and these and 22 other packages installed.

When I log in now the deepin start up interface appears.

It is not quite working properly yet.

I will persist with it and see if I can get it to run correctly.

Cheers

MF

PS

I have now got deepin running reasonably well.

Cheers
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum