Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
s2ram extra line and disk thrashing (?) upon resume
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
in_vitro_gentrification
n00b
n00b


Joined: 26 Feb 2020
Posts: 4

PostPosted: Wed Apr 29, 2020 2:42 am    Post subject: s2ram extra line and disk thrashing (?) upon resume Reply with quote

I have been having two issues with s2ram on my machine, one more important than the other.

The less important bug is that there sometimes appears an extra line in my terminal after I resume. Something like this in zsh:
Code:
[~]% sudo s2ram
[~]%
[~]% [] <-- thats the cursor
Looks like this in bash:
Code:
[~]$ sudo s2ram
[~]$
[~]$ []
And this in dash:
Code:
$ sudo s2ram

$ $ []

I'd like to know why this is happening and maybe figure out where to report this bug.

The more serious issue I'm having is that sometimes when I'm resuming it will take a while before the s2ram command exits. My computer also starts making a strange clicking noise. It seems to happen at random, but it's more likely to happen if I quickly resume then suspend then try to resume. Sometimes my computer completely locks up and becomes unresponsive for about thirty seconds until the clicking goes away and the s2ram command exits.

Is there any way I can investigate why this is happening? Is it a hardware issue? If it's a bug, where should I report it?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum