Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
ksplashqml crash on login [with clang]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
trainz-are-kul
n00b
n00b


Joined: 25 Jun 2018
Posts: 11

PostPosted: Sat May 02, 2020 9:54 am    Post subject: ksplashqml crash on login [with clang] Reply with quote

After rebuilding some KDE-9999 packages, I can no longer enter KDE plasma. When I try log in with sddm, Dr Konqi comes up saying ksplashqml crashed. Interestingly, opening a KDE program from XFCE like kate, I get a lot of
Code:
QObject::connect: signal not found in
errors (before Kate freezes): https://pastebin.com/erj6KmXD
Xorg.0.log: https://pastebin.com/Y9sMfEFi
sddm.log: https://pastebin.com/acM4dUzT

I have tried rebuilding qtcore and qtwidgets with no luck

EDIT: ksplashqml seems to be part of kde-plasma/plasma-workspace
Thanks in advance :D

EDIT2: switching to gcc seamed to have fixed this


Last edited by trainz-are-kul on Wed May 06, 2020 3:36 am; edited 1 time in total
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 7746
Location: Austria

PostPosted: Sun May 03, 2020 8:46 am    Post subject: Re: ksplashqml crash on login, unable to enter kde Reply with quote

trainz-are-kul wrote:
After rebuilding some KDE-9999 packages

Do you randomly do that? Or are you using smart-live-rebuild as you should?
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
trainz-are-kul
n00b
n00b


Joined: 25 Jun 2018
Posts: 11

PostPosted: Sun May 03, 2020 9:58 am    Post subject: Reply with quote

I use smart-live-rebuild, should have made that clear in original post, sorry
Back to top
View user's profile Send private message
trainz-are-kul
n00b
n00b


Joined: 25 Jun 2018
Posts: 11

PostPosted: Tue May 05, 2020 1:49 am    Post subject: Reply with quote

I tried downgrading back to testing from live, with no luck, as well as logging in with another user
Back to top
View user's profile Send private message
trainz-are-kul
n00b
n00b


Joined: 25 Jun 2018
Posts: 11

PostPosted: Wed May 06, 2020 3:37 am    Post subject: Reply with quote

Switching to gcc from clang and recompiling the packages seems to have fixed this :D
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum