Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
understanding emerge conflict
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
javeree
Guru
Guru


Joined: 29 Jan 2006
Posts: 401

PostPosted: Tue May 05, 2020 5:37 pm    Post subject: understanding emerge conflict Reply with quote

I get the following conflict message:

Quote:
WARNING: One or more updates/rebuilds have been skipped due to a dependency conflict:

x11-libs/libXdamage:0

(x11-libs/libXdamage-1.1.5:0/0::gentoo, ebuild scheduled for merge) USE="-static-libs" ABI_X86="(64) -32 (-x32)" conflicts with
>=x11-libs/libXdamage-1.1.4-r1:=[abi_x86_32(-),abi_x86_64(-)] required by (media-libs/mesa-19.3.5:0/0::gentoo, installed) USE="X dri3 egl gallium gbm libglvnd llvm vdpau -classic -d3d9 -debug -gles1 -gles2 -lm-sensors -opencl -osmesa -pax_kernel (-selinux) -test -unwind -vaapi -valgrind -vulkan -vulkan-overlay -wayland -xa -xvmc" ABI_X86="32 (64) (-x32)" VIDEO_CARDS="(-freedreno) -i915 -i965 -intel -iris (-lima) -nouveau (-panfrost) -r100 -r200 -r300 -r600 -radeon -radeonsi (-vc4) -virgl (-vivante) -vmware"

>=x11-libs/libXdamage-1.1.4-r1:0/0=[abi_x86_32(-),abi_x86_64(-)] required by (media-libs/mesa-19.3.5:0/0::gentoo, installed) USE="X dri3 egl gallium gbm libglvnd llvm vdpau -classic -d3d9 -debug -gles1 -gles2 -lm-sensors -opencl -osmesa -pax_kernel (-selinux) -test -unwind -vaapi -valgrind -vulkan -vulkan-overlay -wayland -xa -xvmc" ABI_X86="32 (64) (-x32)" VIDEO_CARDS="(-freedreno) -i915 -i965 -intel -iris (-lima) -nouveau (-panfrost) -r100 -r200 -r300 -r600 -radeon -radeonsi (-vc4) -virgl (-vivante) -vmware"


How can a single package be requesting conflicting versions ? The only difference I see is that the first line does not specify a slot, whereas the second one does.

[/quote]
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 24023
Location: here

PostPosted: Tue May 05, 2020 6:27 pm    Post subject: Reply with quote

Mesa is compiled with abi_x86_32 use flag and also old libXdamage version, the problem is that x11-libs/libXdamage-1.1.5 has no abi_x86_32 enabled but mesa require it.
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
javeree
Guru
Guru


Joined: 29 Jan 2006
Posts: 401

PostPosted: Fri May 08, 2020 4:01 pm    Post subject: Reply with quote

OK, I see it now. Thanks
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum