Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED]Scanner Brother MFC-J850DN : not found by scaneimage
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
Shiru
n00b
n00b


Joined: 20 Oct 2014
Posts: 23

PostPosted: Wed May 20, 2020 1:44 pm    Post subject: [SOLVED]Scanner Brother MFC-J850DN : not found by scaneimage Reply with quote

it's my first time installing a scanner on Linux so i think i am at the origin of the problem, but i did lots of search and read documentation before opening this thread.

I am using a Brother MFC-J850DN (Japanese Printer Scanner) and i have this issue with the scanner part.
First, i installed Brother drivers using deb package.

Then,willing to install the scanner, i run :

Code:
  brsaneconfig3 -a name=SCANNER model=MFC ip=192.168.11.4


Then, as i installed the Brother tools drivers, i run
Code:
brscan-skey

Doing so, i tried to scan from the scanner and root or my username (depending on which i ran the command) appears on printer screen...but nothing changed on computer.

Next, i decided to run :
Code:
# sane-find-scanner

  # sane-find-scanner will now attempt to detect your scanner. If the
  # result is different from what you expected, first make sure your
  # scanner is powered up and properly connected to your computer.

  # No SCSI scanners found. If you expected something different, make sure that
  # you have loaded a kernel SCSI driver for your SCSI adapter.

found USB scanner (vendor=0x04f9 [Brother], product=0x0261 [MFC-J850DN]) at libusb:003:002
  # Your USB scanner was (probably) detected. It may or may not be supported by
  # SANE. Try scanimage -L and read the backend's manpage.

  # Not checking for parallel port scanners.

  # Most Scanners connected to the parallel port or other proprietary ports
  # can't be detected by this program.


So the scanner was found but if i run :

Code:
# scanimage -L

No scanners were identified. If you were expecting something different,
check that the scanner is plugged in, turned on and detected by the
sane-find-scanner tool (if appropriate). Please read the documentation
which came with this software (README, FAQ, manpages).


No scanner destected.

I thought it might come from the config file. But as i want to use my scanner a a network one, i emerge sane with the "net" USE flag. I also edited the fille /etc/sane.d/net.conf :
Code:
# This is the net backend config file.

## net backend options
# Timeout for the initial connection to saned. This will prevent the backend
# from blocking for several minutes trying to connect to an unresponsive
# saned host (network outage, host down, ...). Value in seconds.
# connect_timeout = 60

## saned hosts
# Each line names a host to attach to.
# If you list "localhost" then your backends can be accessed either
# directly or through the net backend.  Going through the net backend
# may be necessary to access devices that need special privileges.
# localhost
usb 0x04f9 0x0261
192.168.11.4


and finally i noticed something strange. If i run "brsaneconfig3 -d" i found this :
Code:

-----------------------------
ls -R -all /proc/bus/usb
ls: cannot access '/proc/bus/usb': No such file or directory
-----------------------------
cat /proc/bus/usb/devices
cat: /proc/bus/usb/devices: No such file or directory
-----------------------------


But when i searched about it, it seems that actual Linux Kernel locates those files in /dev/bus/usb and i just found my files here : /dev/bus/usb/003/002

Finally, if i run dmesg, i found this line :
Code:

[ 7103.906003] usblp0: removed
[ 7103.908435] usblp 3-1:1.0: usblp0: USB Bidirectional printer dev 2 if 0 alt 0 proto 2 vid 0x04F9 pid 0x0261
[ 7254.893894] usblp0: removed
[ 7254.896520] usblp 3-1:1.0: usblp0: USB Bidirectional printer dev 2 if 0 alt 0 proto 2 vid 0x04F9 pid 0x0261
[  229.760586] brscan-skey-0.2[4861]: segfault at 0 ip 000000000040e163 sp 00007ffe816c5c10 error 4 in brscan-skey-0.2.4-0[400000+15000]


I don't have any issue with the printer.

Additional information :
- i edited /etc/saned.d/saned.conf by adding the scanner/printer IP : 192.168.11.4
- i noticed the file /etc/sane.d/dll.conf contains "brother3"

EDIT : i give an another try and GIMP launched but with an error message and nothing has been scanned.
Code:
Opening '/root/brscan/brscan.hhZhHi' failed: Unknown file type


Plus i got an another error message from the console :
Code:
gimp_device_info_set_device: trying to set GdkDevice 'ELECOM ELECOM BlueLED Mouse' on GimpDeviceInfo which already has a device



I think i wrote all the changed i've made and information i noticed.

If someone can help to understand i would really appreciate it.

Shiru


Last edited by Shiru on Sun May 24, 2020 2:41 am; edited 1 time in total
Back to top
View user's profile Send private message
Shiru
n00b
n00b


Joined: 20 Oct 2014
Posts: 23

PostPosted: Sun May 24, 2020 2:41 am    Post subject: Reply with quote

Hello here,

i joined the IRC channel (#gentoo) and folks over there are very nice.
I solved this issue but i am not sure how. I added the ulm overlay in order to download brscan4 (i an using brscan3) and the download failed (the file is not on the server).
After that, i tied scanimage and it works perfectly... So just adding the overlay was the key ? I am not sure about that but if someone meet the same issue, you could try this one.

Shiru
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum