Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
HOWTO: qmail vpopmail qmail-scanner courier squirrelmail
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3 ... 8, 9, 10 ... 15, 16, 17  Next  
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks
View previous topic :: View next topic  
Author Message
nianderson
Guru
Guru


Joined: 06 May 2003
Posts: 369
Location: Lawrence, KS

PostPosted: Tue Mar 09, 2004 1:59 pm    Post subject: Reply with quote

post it i do fresh installs all the time.ill do one as son as you post the howto
Back to top
View user's profile Send private message
blubbi
Guru
Guru


Joined: 27 Apr 2003
Posts: 555
Location: Halle (Saale), Germany

PostPosted: Tue Mar 09, 2004 2:25 pm    Post subject: Reply with quote

nianderson wrote:
post it i do fresh installs all the time.ill do one as son as you post the howto


here it is:
Blubbi’s

Qmail vpopmail qmail-scanner courier-IMAP SquirrelMail ezmlm-idx-mysql maildrop Mail-SpamAssassin f-prot clamav pyzor razor net-ping dcc

HOWTOget them work together

for Gentoo-Linux

http://ws1-iut.medizin.uni-halle.de/qmail-howto.htm

If you want to contact me so we can work out the perfekt howto, you'll find my mailaddress on this site http://ws1-iut.medizin.uni-halle.de/contact_en.htm in the "contact" sektion. Just mailto the Webmaster :-)

nianderson: one thing you could test at once: try without the USE flag "clearpasswd"
Back to top
View user's profile Send private message
Skywacker
n00b
n00b


Joined: 23 Jan 2004
Posts: 72
Location: Missouri

PostPosted: Tue Mar 09, 2004 4:52 pm    Post subject: Reply with quote

will your howto have working smtp-auth or pop-before-smtp?

-Sky
Back to top
View user's profile Send private message
blubbi
Guru
Guru


Joined: 27 Apr 2003
Posts: 555
Location: Halle (Saale), Germany

PostPosted: Tue Mar 09, 2004 6:32 pm    Post subject: Reply with quote

Skywacker wrote:
will your howto have working smtp-auth or pop-before-smtp?

-Sky



mmmh, I didn't bother about pop befor smtp. But this shouldn't be the problem. I'll include smtp after pop. SMTP-AUTH still doesn't work I have no clue why.
Back to top
View user's profile Send private message
nianderson
Guru
Guru


Joined: 06 May 2003
Posts: 369
Location: Lawrence, KS

PostPosted: Tue Mar 09, 2004 7:15 pm    Post subject: Reply with quote

id be more than happy to help ya work out the kinks ill get in contact with you later today. and ill do a reinstall asap.

i was thinking it would be nice to just have a qmail-toaster ebuild wonder if thats possible.
Back to top
View user's profile Send private message
Skywacker
n00b
n00b


Joined: 23 Jan 2004
Posts: 72
Location: Missouri

PostPosted: Tue Mar 09, 2004 7:59 pm    Post subject: Reply with quote

[


mmmh, I didn't bother about pop befor smtp. But this shouldn't be the problem. I'll include smtp after pop. SMTP-AUTH still doesn't work I have no clue why.[/quote]

well, anything that allows remote email clients send email through the server. Squirrelmail is nice, but many people prefer to use their usual client even while travelling.
Back to top
View user's profile Send private message
nianderson
Guru
Guru


Joined: 06 May 2003
Posts: 369
Location: Lawrence, KS

PostPosted: Tue Mar 09, 2004 9:55 pm    Post subject: Reply with quote

pop before smtp is an ok temporary solution but i dont use pop we prefer imap solutions so it will be really nice when we figure out how to get smtp-auth working.
Back to top
View user's profile Send private message
blubbi
Guru
Guru


Joined: 27 Apr 2003
Posts: 555
Location: Halle (Saale), Germany

PostPosted: Wed Mar 10, 2004 7:58 am    Post subject: Reply with quote

Skywacker wrote:
[
well, anything that allows remote email clients send email through the server. Squirrelmail is nice, but many people prefer to use their usual client even while travelling.


It's a bit tricky to get smtp after pop to work with courier-pop3d. For qmails pop3d it is no problem. I'll see If i can figure out how it works wit the courier pop3d.


-------------EDIT----------------

I have updated my howto. now it contains a section for smtp after pop/imap.
I can not verify if it is woking, cause I have no system to test it on.

Oh, I vorgot one thing to mention: DONT FORGETT TO EDIT YOUR TCP RULES to allow every IP to relay (if it's that what you want smtp after pop for)
http://ws1-iut.medizin.uni-halle.de/qmail-howto.htm

-----------EDIT-------------------
Back to top
View user's profile Send private message
blubbi
Guru
Guru


Joined: 27 Apr 2003
Posts: 555
Location: Halle (Saale), Germany

PostPosted: Wed Mar 10, 2004 2:22 pm    Post subject: Reply with quote

Added info how to fix permissinoproblems with the qmail-scanner-queue.
Back to top
View user's profile Send private message
SpanKY
Developer
Developer


Joined: 18 Apr 2002
Posts: 321
Location: Worcester, MA

PostPosted: Thu Mar 11, 2004 3:33 am    Post subject: Reply with quote

qmail (and everything maildir related in portage) work off of .maildir

it slipped my mind to add in the '.maildir' arguement after `makemaildir` which is why the howto reads incorrectly

ive fixed it in cvs
Back to top
View user's profile Send private message
blubbi
Guru
Guru


Joined: 27 Apr 2003
Posts: 555
Location: Halle (Saale), Germany

PostPosted: Thu Mar 11, 2004 11:32 am    Post subject: Reply with quote

SpanKY wrote:
qmail (and everything maildir related in portage) work off of .maildir

it slipped my mind to add in the '.maildir' arguement after `makemaildir` which is why the howto reads incorrectly

ive fixed it in cvs


Had no problems with .maildir and Maildir .... oki

But do you have any clou why SMTP-AUTH isn't working ?
Back to top
View user's profile Send private message
outspoken
Guru
Guru


Joined: 14 Feb 2004
Posts: 464
Location: orlando, fl

PostPosted: Thu Mar 11, 2004 11:43 am    Post subject: Reply with quote

well i was able to get my installation to work!!

following this howto:

http://www.gentoo.org/doc/en/qmail-howto.xml

there were some issues that i ran into when first installation but they were cleared up rather quickly and the howto has been updated to reflect those issues.

one thing im running into now that others may run into as well if trying to install qmail-scanner is that the berkley db version 4.1.25_p1-r3 is not happy with maildrop-1.5.3.-r1, so if you plan on emerging qmail-scanner then you need to either unmerge db-4.1.25_p1-r3 and emerge db-4.0.14-r3 or muddle with the ebuild scripts for maildrop or econf respectively. I've done neither as I'm currently syncing my system to get db-4.2.52_p1 and test that out as I would rather go forwards than backwards in versions if I can help it.

best of luck to all your qmail hopefuls, i'm very happy with the above mentioned howto and was able to get my qmail/vpopmail/ssl/horde/imap system up and running rather quick.
Back to top
View user's profile Send private message
blubbi
Guru
Guru


Joined: 27 Apr 2003
Posts: 555
Location: Halle (Saale), Germany

PostPosted: Thu Mar 11, 2004 1:10 pm    Post subject: Reply with quote

outspoken wrote:
well i was able to get my installation to work!!

following this howto:

http://www.gentoo.org/doc/en/qmail-howto.xml

there were some issues that i ran into when first installation but they were cleared up rather quickly and the howto has been updated to reflect those issues.

one thing im running into now that others may run into as well if trying to install qmail-scanner is that the berkley db version 4.1.25_p1-r3 is not happy with maildrop-1.5.3.-r1, so if you plan on emerging qmail-scanner then you need to either unmerge db-4.1.25_p1-r3 and emerge db-4.0.14-r3 or muddle with the ebuild scripts for maildrop or econf respectively. I've done neither as I'm currently syncing my system to get db-4.2.52_p1 and test that out as I would rather go forwards than backwards in versions if I can help it.

best of luck to all your qmail hopefuls, i'm very happy with the above mentioned howto and was able to get my qmail/vpopmail/ssl/horde/imap system up and running rather quick.


Where was the problem with maildrop ??? It works like a charm for me no problems with mysql. Ther was no problem to get qmail running with this howto (just a view permission problems an the starrting problem with Maildir and .maildir due to some version missmatches)
Back to top
View user's profile Send private message
SpanKY
Developer
Developer


Joined: 18 Apr 2002
Posts: 321
Location: Worcester, MA

PostPosted: Thu Mar 11, 2004 2:07 pm    Post subject: Reply with quote

blubbi wrote:
But do you have any clou why SMTP-AUTH isn't working ?


afaik SMTP-AUTH utilizes vchkpw which should have been setup in /var/qmail/control/conf-smtpd ... so if vchkpw (and vpopmail) are working correctly, and you setup the QMAIL_SMTP_CHECKPASSWORD vars correctly in conf-smtpd, everything else should fall into place
Back to top
View user's profile Send private message
nianderson
Guru
Guru


Joined: 06 May 2003
Posts: 369
Location: Lawrence, KS

PostPosted: Fri Mar 12, 2004 2:43 am    Post subject: Reply with quote

im using kmail for a client and it does not appear to be able to work with smtp-auth

want to see any configs to verrify?
Back to top
View user's profile Send private message
SpanKY
Developer
Developer


Joined: 18 Apr 2002
Posts: 321
Location: Worcester, MA

PostPosted: Fri Mar 12, 2004 11:08 am    Post subject: Reply with quote

make sure you tell it to use user@host as the username (i.e. vapier@wh0rd.org) instead of just user (i.e. vapier)

i use kmail as my client and it works as advertised :x
Back to top
View user's profile Send private message
outspoken
Guru
Guru


Joined: 14 Feb 2004
Posts: 464
Location: orlando, fl

PostPosted: Fri Mar 12, 2004 11:53 am    Post subject: Reply with quote

blubbi wrote:
outspoken wrote:
well i was able to get my installation to work!!

following this howto:

http://www.gentoo.org/doc/en/qmail-howto.xml

there were some issues that i ran into when first installation but they were cleared up rather quickly and the howto has been updated to reflect those issues.

one thing im running into now that others may run into as well if trying to install qmail-scanner is that the berkley db version 4.1.25_p1-r3 is not happy with maildrop-1.5.3.-r1, so if you plan on emerging qmail-scanner then you need to either unmerge db-4.1.25_p1-r3 and emerge db-4.0.14-r3 or muddle with the ebuild scripts for maildrop or econf respectively. I've done neither as I'm currently syncing my system to get db-4.2.52_p1 and test that out as I would rather go forwards than backwards in versions if I can help it.

best of luck to all your qmail hopefuls, i'm very happy with the above mentioned howto and was able to get my qmail/vpopmail/ssl/horde/imap system up and running rather quick.


Where was the problem with maildrop ??? It works like a charm for me no problems with mysql. Ther was no problem to get qmail running with this howto (just a view permission problems an the starrting problem with Maildir and .maildir due to some version missmatches)


it was a known issue between maildrop 1.5.3 and certain versions of db. there are many threads on it here in the forums. it worked fine for me using maildrop 1.5.3-r1 and db-4.2.52_p1.

i'm using your howto for anti-virus and spam busting blubbi. ive just finished the merging, now im going to install a new HD before i update the spam list as you say it takes a lot of space and im running out on that pc. im going to make a new directory specifically for the spam and just call it /spam, giving it the same permissions and details as the /root directory. is that what you would suggest?

thanks!
Back to top
View user's profile Send private message
nianderson
Guru
Guru


Joined: 06 May 2003
Posts: 369
Location: Lawrence, KS

PostPosted: Fri Mar 12, 2004 1:47 pm    Post subject: Reply with quote

SpanKY wrote:
make sure you tell it to use user@host as the username (i.e. vapier@wh0rd.org) instead of just user (i.e. vapier)

i use kmail as my client and it works as advertised :x


i do when i try to auth without encryption it says i must starttls first and when i try with tls it says something abut not being able too
Back to top
View user's profile Send private message
Skywacker
n00b
n00b


Joined: 23 Jan 2004
Posts: 72
Location: Missouri

PostPosted: Fri Mar 12, 2004 3:58 pm    Post subject: Reply with quote

blubbi, your link to your howto is broken.
Back to top
View user's profile Send private message
SpanKY
Developer
Developer


Joined: 18 Apr 2002
Posts: 321
Location: Worcester, MA

PostPosted: Fri Mar 12, 2004 6:56 pm    Post subject: Reply with quote

nianderson wrote:
i do when i try to auth without encryption it says i must starttls first and when i try with tls it says something abut not being able too


hrm, that smily wasnt the one i wanted ... oh well ...

try using tls with plain login ... if that doesnt work, try clicking the 'check what server supports' button
Back to top
View user's profile Send private message
Skywacker
n00b
n00b


Joined: 23 Jan 2004
Posts: 72
Location: Missouri

PostPosted: Fri Mar 12, 2004 7:27 pm    Post subject: Reply with quote

spanky,
are you saying that you have a vpopmail install with MySQL that has smtp-auth working?
Back to top
View user's profile Send private message
SpanKY
Developer
Developer


Joined: 18 Apr 2002
Posts: 321
Location: Worcester, MA

PostPosted: Fri Mar 12, 2004 9:45 pm    Post subject: Reply with quote

Skywacker wrote:
spanky,
are you saying that you have a vpopmail install with MySQL that has smtp-auth working?


considering thats what my HOWTO describes, i would say yes :P
Back to top
View user's profile Send private message
Skywacker
n00b
n00b


Joined: 23 Jan 2004
Posts: 72
Location: Missouri

PostPosted: Fri Mar 12, 2004 11:06 pm    Post subject: Reply with quote

Link to your howto?

As far as I can see you didnt show up in this thread until page 9. Sorry if I missed the link to your thread.

-Skywacker
Back to top
View user's profile Send private message
outspoken
Guru
Guru


Joined: 14 Feb 2004
Posts: 464
Location: orlando, fl

PostPosted: Fri Mar 12, 2004 11:08 pm    Post subject: Reply with quote

Skywacker wrote:
Link to your howto?

As far as I can see you didnt show up in this thread until page 9. Sorry if I missed the link to your thread.

-Skywacker


hes got a great howto.. thats where i finally was able to get my qmail working from. http://www.gentoo.org/doc/en/qmail-howto.xml
Back to top
View user's profile Send private message
Skywacker
n00b
n00b


Joined: 23 Jan 2004
Posts: 72
Location: Missouri

PostPosted: Fri Mar 12, 2004 11:48 pm    Post subject: Reply with quote

I'll give it a try.

ty
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks All times are GMT
Goto page Previous  1, 2, 3 ... 8, 9, 10 ... 15, 16, 17  Next
Page 9 of 17

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum