Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
HOWTO: qmail vpopmail qmail-scanner courier squirrelmail
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3 ... 11, 12, 13 ... 15, 16, 17  Next  
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks
View previous topic :: View next topic  
Author Message
petterg
Guru
Guru


Joined: 25 Mar 2004
Posts: 500
Location: Oslo, Norway

PostPosted: Sat Mar 27, 2004 1:21 pm    Post subject: 1/2 + 1/2 = 1 - almost got it working Reply with quote

Ok, so tried the howto at http://www.gentoo.org/doc/en/qmail-howto.xml on a 3rd server. There I got spam checking and smtp-auth working. At least that is what it looks like in the log. This server does not put mails in the mailboxes! (I have no idea of where they go!)
While the two servers I put up using the howto in this thread are sending and recieving mail, but does not do any spam-check nor smtp-auth.
It's time to compare config files.

---
There is still a couple of things I need some help to figure out:
My server often get virus infected mails sent to [some unknown user]@mydomain.com. Is there any way to just drop these mails? It is really pointless that the server stores a new infected mail every 10 minuttes when it wasn't even adressed to any of my users! It is also wasted resources that it responds to the sender saying that it found a virus in these cases. Just as pointless to fill the postmaster mailbox with this.

And I also need a spamfilter that totally drops all mails from postmaster@[whatever] or mailer-deamon@[whatever] addressed to [some unknown user]@mydomain.com, without wasting resources on checking for further spam or viruses. Nor sending any reply to the fake-sender nor postmaster@pgdom.com about it.
My server receives between 14.000 and 36.000 of these mails everyday, wich is quite a lot for a server serving only 5 users! Storing them takes up a lot of space - sending replys is killing my 768kbit upload capacity!

Once again, thanks for these two great howtos.
-pg
Back to top
View user's profile Send private message
blubbi
Guru
Guru


Joined: 27 Apr 2003
Posts: 555
Location: Halle (Saale), Germany

PostPosted: Sat Mar 27, 2004 5:49 pm    Post subject: Reply with quote

Skywacker wrote:
Blubbi-
You can confirm that the pop-before-smtp works via your howto. I used your howto for that portion and it's working for me.

Thanks a lot!

-Skywacker


THX for the reply that a good news :-)
Back to top
View user's profile Send private message
blubbi
Guru
Guru


Joined: 27 Apr 2003
Posts: 555
Location: Halle (Saale), Germany

PostPosted: Sat Mar 27, 2004 5:52 pm    Post subject: Reply with quote

Skywacker wrote:
Eltech- qmailadmin- you are correct, but this howto has you install it manually from source.

Blubbi - regarding your howto: i just updated my qmail-scanner to 1.2 and used your section 6 to get it working. where you said: "do chown -R qscand:vpopmail /var/spool/qmailscan && chmod -R 664 /var/spool/qmailscan/* and try again"

It needs to be qmaild not qscand as the user. Once I did this all was well.



THX a lot I will update my HowTo as soon as possible.
Back to top
View user's profile Send private message
blubbi
Guru
Guru


Joined: 27 Apr 2003
Posts: 555
Location: Halle (Saale), Germany

PostPosted: Sat Mar 27, 2004 5:55 pm    Post subject: Reply with quote

Skywacker wrote:
FYI-
when updating to qmail-scanner 1.20 the options for spamd are kept in /etc/conf.d/spam instead of /etc/conf.d/spam.conf.

This is noted somewhat in Blubbi's howto, but I'm just saying that it's qmail-scanner being updated that breaks/changes this.

I kept getting a bunch of this in my logs till i figured out why:

" cmrlmail spamd[9428]: connection from localhost [127.0.0.1] at port 50583
Mar 22 18:40:45 cmrlmail spamd[9553]: handle_user: unable to find user 'user@domain'!
Mar 22 18:40:45 cmrlmail spamd[9553]: Still running as root: user not specified with -u, not found, or set to root. Fall back to nobody.
Mar 22 18:40:45 cmrlmail spamd[9553]: checking message (unknown) for user@domain:65534.
Mar 22 18:40:47 cmrlmail spamd[9553]: identified spam (8.8/5.0) for user@domain:65534 in 1.6 seconds, 10167 bytes.
"


have you specified the correct user "-u someuser" in spamd ?
SPAMD_OPTS="-d -u vpopmail -v -L -x -C /usr/share/spamassassin/local.cf"
Back to top
View user's profile Send private message
petterg
Guru
Guru


Joined: 25 Mar 2004
Posts: 500
Location: Oslo, Norway

PostPosted: Mon Mar 29, 2004 9:32 am    Post subject: Possible smtp-auth fix Reply with quote

Those who have trouble with smtp-auth may have forgotten to do this:
chmod 4711 /var/vpopmail/bin/vchkpw
Back to top
View user's profile Send private message
petterg
Guru
Guru


Joined: 25 Mar 2004
Posts: 500
Location: Oslo, Norway

PostPosted: Mon Mar 29, 2004 1:01 pm    Post subject: Why so slow spamc? Reply with quote

Does anyone else have trouble with spamc spending upto 60 seconds checking each mail?

Any clues why it is so slow? I haven't changed any settings relevant to spamassassin other than those mentioned in this howto.
Back to top
View user's profile Send private message
Sull
n00b
n00b


Joined: 09 Oct 2003
Posts: 25

PostPosted: Mon Mar 29, 2004 7:19 pm    Post subject: prob Reply with quote

i got some problem with mysql and vpopmail

igot this error when i try to add a domain

Quote:
Please enter password for postmaster:
enter password again:
Failure while attempting to remove_line() the locals file
Error. Failed to add domain to assign file
Error: Could not update file


and when i try to add a user
Quote:
vmysql: sql error[3]: Table 'vpopmail.vpopmail' doesn't exist
Error: Unable to chdir to vpopmail/domains directory


and that is my vpopmail.conf

Quote:
# Read-only DB
localhost|0|vpopmail|topsecret|vpopmail
# Write DB
localhost|0|vpopmail|topsecret|vpopmail



what can i do?
* i already have deleted and remake the sql database*
Back to top
View user's profile Send private message
Skywacker
n00b
n00b


Joined: 23 Jan 2004
Posts: 72
Location: Missouri

PostPosted: Mon Mar 29, 2004 8:33 pm    Post subject: Reply with quote

Further update on this-
At 3am a my daily cron job ran this script: /etc/cron.daily/qmail-scanner

It's contents were:
#!/bin/bash
/var/qmail/bin/qmail-scanner-queue -z

This reset the permissions on /var/spool/qmailscan and mail stopped being accepted/delivered.
qmail-scanner-queue-version.txt was getting reset to qscand.root with 600 permissions. I tried mutiliple owner/group's but they were always reset.

I ultimately added this line to /etc/cron.daily/qmail-scanner:

chmod +r /var/spool/qmailscan/qmail-scanner-queue-version.txt

Now everything works perfectly.

------------------------------------------------------



blubbi wrote:
Skywacker wrote:
Blubbi - regarding your howto: i just updated my qmail-scanner to 1.2 and used your section 6 to get it working. where you said: "do chown -R qscand:vpopmail /var/spool/qmailscan && chmod -R 664 /var/spool/qmailscan/* and try again"

It needs to be qmaild not qscand as the user. Once I did this all was well.



THX a lot I will update my HowTo as soon as possible.
Back to top
View user's profile Send private message
Skywacker
n00b
n00b


Joined: 23 Jan 2004
Posts: 72
Location: Missouri

PostPosted: Mon Mar 29, 2004 8:35 pm    Post subject: Reply with quote

blubbi wrote:
Skywacker wrote:
FYI-
when updating to qmail-scanner 1.20 the options for spamd are kept in /etc/conf.d/spam instead of /etc/conf.d/spam.conf.

This is noted somewhat in Blubbi's howto, but I'm just saying that it's qmail-scanner being updated that breaks/changes this.

I kept getting a bunch of this in my logs till i figured out why:

" cmrlmail spamd[9428]: connection from localhost [127.0.0.1] at port 50583
Mar 22 18:40:45 cmrlmail spamd[9553]: handle_user: unable to find user 'user@domain'!
Mar 22 18:40:45 cmrlmail spamd[9553]: Still running as root: user not specified with -u, not found, or set to root. Fall back to nobody.
Mar 22 18:40:45 cmrlmail spamd[9553]: checking message (unknown) for user@domain:65534.
Mar 22 18:40:47 cmrlmail spamd[9553]: identified spam (8.8/5.0) for user@domain:65534 in 1.6 seconds, 10167 bytes.
"


have you specified the correct user "-u someuser" in spamd ?
SPAMD_OPTS="-d -u vpopmail -v -L -x -C /usr/share/spamassassin/local.cf"



Blubbi-
I was just saying that qmail-scanner started looking in a different config file when I updated. Copying the contents of spamd.conf to spamd is all I needed to do to get it to work.

-Sky
Back to top
View user's profile Send private message
skh
n00b
n00b


Joined: 14 Aug 2003
Posts: 35

PostPosted: Tue Mar 30, 2004 1:24 pm    Post subject: Reply with quote

beat me if this has been answered yet but shouldnt this whole thing work so that all users have a .maildir dir in their homedir to wich all mail is delivered and which is used by courier-imap?
i got all that working and i encountered no probs with auth and stuff (at least none i couldnt figure out yet) the only thing is that courier-imap reads from /var/vpopmail/domains/mydomain.bleh/mailman/.maildir instead of /home/mailman/.maildir.
however qmail and all the other progs seem to work right since i never get any mail to that dir but to .maildir in the homedir (which is exactly what i want).
please somebody enlighten me.

any hints really really much appreciated
thanks in advance
Back to top
View user's profile Send private message
Skywacker
n00b
n00b


Joined: 23 Jan 2004
Posts: 72
Location: Missouri

PostPosted: Tue Mar 30, 2004 2:31 pm    Post subject: Reply with quote

The setup following the 3 howto's in this thread (my setup is a hybrid of them all), will put mail in /var/vpopmail/domains/mydomain.com/skywacker/.maildir/

If you want things in /home/skywacker/.maildir, just make a link one way or the other.

ln -s /var/vpopmail/domains/mydomain.com/skywacker/ /home/skywacker/


If you have tons of accounts/domains and your /home is your large partition, just move the entire /var/vpopmail/domains over there and create a link.

-Skywacker
Back to top
View user's profile Send private message
skh
n00b
n00b


Joined: 14 Aug 2003
Posts: 35

PostPosted: Tue Mar 30, 2004 3:48 pm    Post subject: Reply with quote

thats what i had in mind as some kind of 'last option'
perhaps there is a way thats a bit more elegant?
i bet its possible to config all the stuff to use home maildirs isnt there?
i already searched through the forum and googled around but i somehow couldnt find anything on this

edit:
btw mail *is* delivered to /home/mailman/.maildir and not to the vpop domain dir
the only thing that doesnt work right is imap
Back to top
View user's profile Send private message
petterg
Guru
Guru


Joined: 25 Mar 2004
Posts: 500
Location: Oslo, Norway

PostPosted: Wed Mar 31, 2004 12:40 pm    Post subject: smtp-auth Reply with quote

Have anyone figured out why smtp-auth works with the howto at
http://www.gentoo.org/doc/en/qmail-howto.xml
and not with the howto in this thread?

I've done 2 installs using the linked howto, and smtp-auth works in both. I've also done 2 installs using the howto in this thread, and smtp-auth does not work in any of them. Then, fianlly I made a install mixing them where I followed the linked howto with everything I can imagine beeing relevant to smtp-auth, but still smtp-auth didn't work!


One thing I figured out while using the linked howto... This happened to me on all 2+1 installs using that howto: It didn't store any mails. According to the log, mails got in, passed the clamav and spam scanning, and disapared. No logs gave any clues what went wrong.
The solution turned out to be deleting the domain using vdeldomain (and all domain aliases) and recreate them using vadddomain.
Back to top
View user's profile Send private message
blubbi
Guru
Guru


Joined: 27 Apr 2003
Posts: 555
Location: Halle (Saale), Germany

PostPosted: Wed Mar 31, 2004 5:28 pm    Post subject: Reply with quote

Skywacker wrote:
Further update on this-

blubbi wrote:
Skywacker wrote:
Blubbi - regarding your howto: i just updated my qmail-scanner to 1.2 and used your section 6 to get it working. where you said: "do chown -R qscand:vpopmail /var/spool/qmailscan && chmod -R 664 /var/spool/qmailscan/* and try again"

It needs to be qmaild not qscand as the user. Once I did this all was well.



THX a lot I will update my HowTo as soon as possible.



This didn't work for me ... I cant figure out which user I have to use.
Back to top
View user's profile Send private message
Skywacker
n00b
n00b


Joined: 23 Jan 2004
Posts: 72
Location: Missouri

PostPosted: Wed Mar 31, 2004 6:22 pm    Post subject: Reply with quote

well, the script run by cron.daily called qmail-scanner changed my permissions and ownership of my /var/spool/qmailscan/qmail-scanner-queue-version.txt file.

Is this true for you?

I found no matter what perms/owner I had on this file it didnt matter because they got reset daily.

chmod +r on the file solved it for me. Is this what you are saying didn't work for you?

-Sky
Back to top
View user's profile Send private message
blubbi
Guru
Guru


Joined: 27 Apr 2003
Posts: 555
Location: Halle (Saale), Germany

PostPosted: Wed Mar 31, 2004 7:53 pm    Post subject: Reply with quote

Skywacker wrote:
well, the script run by cron.daily called qmail-scanner changed my permissions and ownership of my /var/spool/qmailscan/qmail-scanner-queue-version.txt file.

Is this true for you?

I found no matter what perms/owner I had on this file it didnt matter because they got reset daily.

chmod +r on the file solved it for me. Is this what you are saying didn't work for you?

-Sky


my problem is: I am running world readable on /var/spool/qmail-scanner/

Code:

drwxrwxrwx    6 qmaild   vpopmail     4.0K Mar 17 10:40 ./
drwxr-xr-x   11 root     root         4.0K Mar 17 09:51 ../
-rwxrwxrwx    1 qmaild   vpopmail        0 Mar 17 10:38 .keep*
drwxrwxrwx    5 qmaild   vpopmail     4.0K Dec  6 18:06 archive/
-rwxrwxrwx    1 qmaild   vpopmail     103K Mar 31 21:26 mailstats.csv*
-rwxrwxrwx    1 qmaild   vpopmail     2.1M Mar 31 21:26 qmail-queue.log*
-rwxrwxrwx    1 qmaild   vpopmail     8.4K Mar 10 17:27 qmail-queue.log.mail*
-rwxrwxrwx    1 qmaild   vpopmail       59 Mar 17 10:40 qmail-scanner-queue-version.txt*
drwxrwxrwx    5 qmaild   vpopmail     4.0K Dec  6 18:06 quarantine/
-rwxrwxrwx    1 qmaild   vpopmail      12K Mar 17 10:38 quarantine-attachments.db*
-rwxrwxrwx    1 qmaild   vpopmail     4.2K Mar 17 10:38 quarantine-attachments.txt*
-rwxrwxrwx    1 qmaild   vpopmail      215 Mar 23 14:03 quarantine.log*
drwxrwxrwx    2 qmaild   vpopmail     4.0K Mar 31 21:26 tmp/
lrwxrwxrwx    1 qmaild   vpopmail       14 Mar 17 10:38 viruses.log -> quarantine.log*
drwxrwxrwx    5 qmaild   vpopmail     4.0K Dec  6 18:06 working/


this ist not what I want. I want to set the minimal permissions. But I cna not figure aut which user tries to write in the tmp and working dir.
Back to top
View user's profile Send private message
blubbi
Guru
Guru


Joined: 27 Apr 2003
Posts: 555
Location: Halle (Saale), Germany

PostPosted: Thu Apr 01, 2004 12:09 pm    Post subject: Reply with quote

Skywacker wrote:
Further update on this-
At 3am a my daily cron job ran this script: /etc/cron.daily/qmail-scanner

It's contents were:
#!/bin/bash
/var/qmail/bin/qmail-scanner-queue -z

This reset the permissions on /var/spool/qmailscan and mail stopped being accepted/delivered.
qmail-scanner-queue-version.txt was getting reset to qscand.root with 600 permissions. I tried mutiliple owner/group's but they were always reset.

I ultimately added this line to /etc/cron.daily/qmail-scanner:

chmod +r /var/spool/qmailscan/qmail-scanner-queue-version.txt

Now everything works perfectly.

------------------------------------------------------





Why did you add

Code:
#!/bin/bash
/var/qmail/bin/qmail-scanner-queue -z


to a cronjob ??? I don't see any reasons for that !?!?!
Back to top
View user's profile Send private message
Skywacker
n00b
n00b


Joined: 23 Jan 2004
Posts: 72
Location: Missouri

PostPosted: Thu Apr 01, 2004 1:27 pm    Post subject: Reply with quote

I didn't. It was put there by one of the emerges. Check your /etc/cron.daily/ directory, I bet you have one too.

-Sky
Back to top
View user's profile Send private message
Skywacker
n00b
n00b


Joined: 23 Jan 2004
Posts: 72
Location: Missouri

PostPosted: Fri Apr 02, 2004 10:13 pm    Post subject: QSS: Qmail-Scanner Statistics Reply with quote

http://sourceforge.net/projects/qss/

I could not get this to have working graphics until I re-emerged mod_php with gd built in.

See this thread: https://forums.gentoo.org/viewtopic.php?t=143464&highlight=gd

Pretty cool I think. Now I need something similar for SPAM graphing.

-Skywacker
Back to top
View user's profile Send private message
ARC2300
Apprentice
Apprentice


Joined: 30 Mar 2003
Posts: 260
Location: Odenton, MD

PostPosted: Sat Apr 03, 2004 5:29 am    Post subject: Reply with quote

Okay. . .so I finally got at least squirrelmail working with the modified vpopmail.conf someone posted.

However, I can't login with remote clients such as thunderbird from another computer. . .

In the log file, it just says "LOGIN FAILED". It happens when I use both pop3 and imap.

Any clues?
_________________
It's fun to take a trip
Put acid in your veins
Back to top
View user's profile Send private message
Skywacker
n00b
n00b


Joined: 23 Jan 2004
Posts: 72
Location: Missouri

PostPosted: Sat Apr 03, 2004 2:38 pm    Post subject: Reply with quote

You could turning on debugging mode logging of imap and pop3 to see the full extent of what is happening in the login process. When you do, paste the actual log excerpts into this thread.

My quick suggestion without more info:
make sure you are trying to log in with your full email address as your username.

username= skywacker@domain.com
pass= password

If not, post those actual logs.

-Sky
Back to top
View user's profile Send private message
biex
n00b
n00b


Joined: 03 Apr 2004
Posts: 4
Location: Gothenburg - Sweden

PostPosted: Sat Apr 03, 2004 5:03 pm    Post subject: Reply with quote

When i run this "command"

Code:
/etc/init.d/courier-pop3d start


i get a error

Code:
 * Starting courier-pop3d...
bind: Address already in use
ll_daemon_start: Resource temporarily unavailable 


What to do??? HELP!

Can only send email right now not get... is it because of that or is it something else?

Thanks!
_________________
\\ Andreas
Back to top
View user's profile Send private message
nianderson
Guru
Guru


Joined: 06 May 2003
Posts: 369
Location: Lawrence, KS

PostPosted: Tue Apr 06, 2004 9:45 pm    Post subject: Reply with quote

dang
well i used the doc from gentoo documentation and got a successful install.
was working fine for several days
added some accounts with qmailadmin today and now all email i send gets bounced back saying the user is over quota.

but no quotas are set.

need soem help please
Back to top
View user's profile Send private message
IWBCMAN
Guru
Guru


Joined: 25 Jun 2002
Posts: 474

PostPosted: Wed Apr 07, 2004 1:36 am    Post subject: Reply with quote

skywacker,

perhaps you could explain something to me...

My mail is being sent to /var/vpopmail/domains/blah/.maildir

so far so good.

Yet nothing lands in my /home/user/.maildir

You addressed a similiar question already by skh.

Yet you suggest linking(ln-s) the .maildir under /var/blah/blah/bla to /home/user/

This sounds good. But mutt simply barfs-of course the permissions are wrong.

/var/blah/blah/blah/.maildir has
vpopmail:vpopmail

whereas /home/user/.maildir has
user:users

simply linking isn't going to work-unless of course one can change the permissions of /var/blah/blah/blah to user:users.....

Is such ok to do ? is it safe ? would it even work?
(by the way I had run maildirmake in my home directory prior to running mutt-I tried sending some email, the mail was sent-I could read it in horde, but it only made it into the /home/user/.maidir-sent/tmp directory, I don't know if this is significant or not--*blindly* stumbling where angels dare to tread.....)

and while we are on this topic-I wonder how one configures any other email reader
mozilla or evolution or slypheed or balsa etc. to show the incomming mail-I am using courier-imap-ssl w/ qmail/vpopmail/horde
-I've tried to get it working but no luck so far....
Back to top
View user's profile Send private message
blubbi
Guru
Guru


Joined: 27 Apr 2003
Posts: 555
Location: Halle (Saale), Germany

PostPosted: Wed Apr 07, 2004 1:59 pm    Post subject: Reply with quote

I thing you are missunderstanding a thing.

Everybody who install vpopmail wants to supply mailaccounts which are not systemaccounts.
If you just want to provide mail to users who have an systemaccount, install qmail without vpopmail.
Than you mail will end up in /home/user/.maildir or something similar ...
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks All times are GMT
Goto page Previous  1, 2, 3 ... 11, 12, 13 ... 15, 16, 17  Next
Page 12 of 17

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum