Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Kernel 2.6.0 (final) ainda em gentoo-dev-sources?
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Portuguese
View previous topic :: View next topic  
Author Message
fernandotcl
Veteran
Veteran


Joined: 20 Nov 2003
Posts: 1396
Location: Sao Paulo, Brazil

PostPosted: Fri Dec 19, 2003 6:17 pm    Post subject: Kernel 2.6.0 (final) ainda em gentoo-dev-sources? Reply with quote

Alguém sabe dizer por quê o kernel 2.6.0 (final) ainda está no portage como gentoo-dev-sources-2.6.0 e não como gentoo-sources-2.6.0? Já que é uma versão estável, não deveria não ser classificado como dev sources? Ou será que eles só vão tirar do dev-sources quando os kernels 2.7.x forem lançados?
Back to top
View user's profile Send private message
RoadRunner
Bodhisattva
Bodhisattva


Joined: 12 Jun 2002
Posts: 490
Location: Coimbra, Portugal

PostPosted: Sat Dec 20, 2003 2:55 am    Post subject: Reply with quote

Porque neste momento existem 3 tarefas que levam um kernel a ser considerado gentoo-sources (isto não é oficial, é o que eu penso que acontece de acordo com a nomenclatura e descrição):

1 - o novo kernel é colocado nas gentoo-dev-sources, são sources para os developers de gentoo testarem novos pathes, etc.

2 - as gentoo-dev-sources são consideradas boas, passam então a gentoo-test-sources

3 - as gentoo-test-sources são maduras e passam a gentoo-sources.

O facto de o 2.6 estar nas gentoo-dev-sources quer apenas dizer que eles abandonaram já o branch 2.4 e passaram ao 2.6

O que é estranho é não haver (ainda) as vanilla-sources-2.6.0, uma vez que neste momento são estas as consideradas estáveis. Aí sim poderão estar os dev's à espera que seja iniciado o branch 2.7.. mas isto são apenas suposições.
Back to top
View user's profile Send private message
fernandotcl
Veteran
Veteran


Joined: 20 Nov 2003
Posts: 1396
Location: Sao Paulo, Brazil

PostPosted: Sat Dec 20, 2003 3:32 pm    Post subject: Reply with quote

Pode ser. Mas talvez o kernel 2.6.0 ainda esteja no gentoo-dev-sources porque o genkernel ainda não funciona (?) com ele.
Back to top
View user's profile Send private message
To
Veteran
Veteran


Joined: 12 Apr 2003
Posts: 1145
Location: Coimbra, Portugal

PostPosted: Sun Dec 21, 2003 6:35 pm    Post subject: Reply with quote

Eu que tal como todas as versões x.0 o melhor é aguardar até algumas arestas estejam limadas. Isto pq estamos a falar da branch de pordução, logo opta-se pela opção mais estável.


_________________

------------------------------------------------
Linux Gandalf 3.2.35-grsec
Gentoo Base System version 2.2
------------------------------------------------
Back to top
View user's profile Send private message
humpback
Retired Dev
Retired Dev


Joined: 19 Oct 2002
Posts: 394
Location: Coimbra - Portugal

PostPosted: Mon Dec 22, 2003 1:59 am    Post subject: Reply with quote

Tenho neste momento duas maquinas com o 2.6.0. Um laptop que está a funcionar maravilhosamente e uma worstation dual. Acho que toda a gente poderia mudar para o 2.6 em maquinas worstation (servisores convem esperar talvez pelo 2.6.2 ou .3 que é quando o kernel começa a limpar as arestas).
_________________
Gustavo Felisberto
Humpback @ #gentoo-pt
------------
It's most certainly GNU/Linux, not Linux. Read more at
http://www.gnu.org/gnu/why-gnu-linux.html .
-------------
Back to top
View user's profile Send private message
dioo
n00b
n00b


Joined: 16 Dec 2003
Posts: 36
Location: Porto Alegre - RS

PostPosted: Mon Dec 22, 2003 2:17 am    Post subject: Reply with quote

Eu "emergi" o 2.6 e o meu jogo Neverwinter não quis mais rodar... Parece que há uma incompatibilidade... que coisa =/
O jeito é esperar eles arrumarem um patch pro jogo e continuar a usar o 2.4 mesmo hehehe
Back to top
View user's profile Send private message
To
Veteran
Veteran


Joined: 12 Apr 2003
Posts: 1145
Location: Coimbra, Portugal

PostPosted: Mon Dec 22, 2003 12:12 pm    Post subject: Reply with quote

Eu sou da tua opinião, alias quando dizia para esperar estava-me a referir a nível de servidores, porque eu no meu comp já ando com as mm-sources à algum tempo e só me posso queixar de não usar à mais tempo.



humpback wrote:
Tenho neste momento duas maquinas com o 2.6.0. Um laptop que está a funcionar maravilhosamente e uma worstation dual. Acho que toda a gente poderia mudar para o 2.6 em maquinas worstation (servisores convem esperar talvez pelo 2.6.2 ou .3 que é quando o kernel começa a limpar as arestas).

_________________

------------------------------------------------
Linux Gandalf 3.2.35-grsec
Gentoo Base System version 2.2
------------------------------------------------
Back to top
View user's profile Send private message
pilla
Administrator
Administrator


Joined: 07 Aug 2002
Posts: 7695
Location: Pelotas, BR

PostPosted: Mon Dec 22, 2003 2:08 pm    Post subject: Reply with quote

minha ultima tentativa com 2.6.0test11 no meu notebook nao foi interessante do ponto de vista do APM. Como isso eh mais importante em um notebook que todo o desempenho a mais que o 2.6.0 possa trazer, vou ficar mais um tempo com o 2.4.22 patched com cpufreq e ck2
_________________
"I'm just very selective about the reality I choose to accept." -- Calvin
Back to top
View user's profile Send private message
rmalheiro
n00b
n00b


Joined: 04 Nov 2003
Posts: 6
Location: Lisboa, Portugal

PostPosted: Tue Dec 23, 2003 2:04 pm    Post subject: Reply with quote

Estou a correr com development-sources desde a 2.5.50 e nunca tive problemas de maior. Desde a 2.6.0-test5 que o kernel está estavel para máquinas desktop. NMHO.

No entanto ainda há bastantes problemas com algumas aplicações que não compilam como deve ser com o 2.6.0, o que deve ser o principal motivo para manter a 2.6 em development. Penso que a 2.6 deve ficar em development enquanto não forem resolvidos todos os bug-report de aplicações que não compilam com o novo kernel.
_________________
Rui Malheiro
Back to top
View user's profile Send private message
To
Veteran
Veteran


Joined: 12 Apr 2003
Posts: 1145
Location: Coimbra, Portugal

PostPosted: Thu Dec 25, 2003 10:25 am    Post subject: Reply with quote

Quase todos esses problemas são resolvidos com as versões mais recentes que existem na portage, isto para ~x86. Claro que mais uma vez se poderá falar da questão da estabilidde... enfim.


_________________

------------------------------------------------
Linux Gandalf 3.2.35-grsec
Gentoo Base System version 2.2
------------------------------------------------
Back to top
View user's profile Send private message
Maxwell
Tux's lil' helper
Tux's lil' helper


Joined: 10 Dec 2003
Posts: 96

PostPosted: Wed Dec 31, 2003 11:27 am    Post subject: Instabilidade Reply with quote

Eu também estou contente com o o kernel 2.6, no entanto, por alguma razão o meu sistema de vez em quando bloqueia qdo tou a trabalhar no X. Parece um problema entre o qt e o enlightenment e o proprio X, só que como as headers do 2.6 não estão disponíveis (que eu saiba) n posso recompilar/actualizar estes pacotes.

Outra coisa que eu gostava de saber era porque o xfree 4.3.99.15 suportava portugues e com o xfree 4.3.0 tenho mensagens de erro.
Alguem tem alguma ideia acerca disto?
_________________
Freedom works. Use it!
Linux, by Gentoo
Back to top
View user's profile Send private message
gmichels
Guru
Guru


Joined: 20 Jun 2003
Posts: 480
Location: Brazil

PostPosted: Sat Jan 03, 2004 6:48 pm    Post subject: Reply with quote

pilla wrote:
minha ultima tentativa com 2.6.0test11 no meu notebook nao foi interessante do ponto de vista do APM. Como isso eh mais importante em um notebook que todo o desempenho a mais que o 2.6.0 possa trazer, vou ficar mais um tempo com o 2.4.22 patched com cpufreq e ck2


E por que nao usa ACPI? Eu tenho um notebook e o unico problema que tive foi ter de desativar APIC e IO-APIC. De resto, funciona tudo normalmente, ate mesmo cpufreq. Estou com 2.6.0 final.
Back to top
View user's profile Send private message
Vanquirius
Retired Dev
Retired Dev


Joined: 14 Jun 2002
Posts: 1297
Location: Ethereal plains

PostPosted: Sat Jan 03, 2004 10:21 pm    Post subject: Reply with quote

rmalheiro wrote:
No entanto ainda há bastantes problemas com algumas aplicações que não compilam como deve ser com o 2.6.0, o que deve ser o principal motivo para manter a 2.6 em development.


Hmmm... Eu dei um emerge -e world após mudar para o 2.6 (gcc3.3, testando flags), e a única coisa que não compilou foi o lirc, que já devem ter consertado. Todas as outras aplicacões que a versão estável não compilou, a ~x86 já tinha um fix.
Agora compilar com linux-headers-2.6.0, isso sim deve ser um pesadelo.
Pessoalmente acho que pelo menos o 2.6.0 já deveria estar no vanilla-sources ao invés de development-sources, mas acho que estão esperando uma versão estável do udev para atualizar a documentacão oficial :?:
Back to top
View user's profile Send private message
humpback
Retired Dev
Retired Dev


Joined: 19 Oct 2002
Posts: 394
Location: Coimbra - Portugal

PostPosted: Sat Jan 03, 2004 10:27 pm    Post subject: Reply with quote

ManuChao wrote:
Eu dei um emerge -e world após mudar para o 2.6 (gcc3.3, testando flags), e a única coisa que não compilou foi o lirc, que já devem ter consertado. Todas as outras aplicacões que a versão estável não compilou, a ~x86 já tinha um fix.
Agora compilar com linux-headers-2.6.0, isso sim deve ser um pesadelo.

A questão é mesmo esta, estar a correr o kernel 2.4 ou o 2.6 e compilar as coisas com os headers do 2.4 é quase a mesma coisa. Eu estou a usar os headers do 2.6 e tenho tido alguns problemas. Mas tudo se está a resolver com calma.
_________________
Gustavo Felisberto
Humpback @ #gentoo-pt
------------
It's most certainly GNU/Linux, not Linux. Read more at
http://www.gnu.org/gnu/why-gnu-linux.html .
-------------
Back to top
View user's profile Send private message
Festrati
Tux's lil' helper
Tux's lil' helper


Joined: 30 Jan 2003
Posts: 105
Location: Brasil

PostPosted: Thu Jan 08, 2004 8:54 pm    Post subject: Reply with quote

O brabo que estou tendo problema agora com o 2.4.22-r3 ir para o 2.6 ralar vai ser massa...

ja que estou ralando mesmo.
Back to top
View user's profile Send private message
iJ
n00b
n00b


Joined: 25 Feb 2003
Posts: 13

PostPosted: Wed Jan 14, 2004 3:15 pm    Post subject: Reply with quote

Resumindo, ainda é cedo para mudar para o 2.6.
Back to top
View user's profile Send private message
RoadRunner
Bodhisattva
Bodhisattva


Joined: 12 Jun 2002
Posts: 490
Location: Coimbra, Portugal

PostPosted: Wed Jan 14, 2004 3:23 pm    Post subject: Reply with quote

iJ wrote:
Resumindo, ainda é cedo para mudar para o 2.6.


Há as pessoas que defendem que antes de passarem umas 5 ou 6 releases de uma nova branch do kernel não vale a pena. sinceramente, o único kernel que tive problemas foi com as 2.6.1_rc1 que por vezes bloqueavam. Agora com a 2.6.1 voltei a ter a estabilidade que tinha nas _test. Não me parece cedo, parece-me a altura ideal. No entanto não o faria numa máquina de produção, como é óbvio. No servidor vou esperar essas 4 ou 5 releases =)
Back to top
View user's profile Send private message
To
Veteran
Veteran


Joined: 12 Apr 2003
Posts: 1145
Location: Coimbra, Portugal

PostPosted: Wed Jan 14, 2004 5:18 pm    Post subject: Reply with quote

Já fiz um emerge -e world com as headers do 2.6. Até ver está a correr :lol:


_________________

------------------------------------------------
Linux Gandalf 3.2.35-grsec
Gentoo Base System version 2.2
------------------------------------------------
Back to top
View user's profile Send private message
AngusYoung
Retired Dev
Retired Dev


Joined: 20 Dec 2002
Posts: 473
Location: Campinas, SP - Brazil

PostPosted: Wed Jan 14, 2004 8:29 pm    Post subject: Reply with quote

Linux-headers 2.6 aqui também (a algumas semanas) e até agora nenhum problema (com a glibc recompilada).
_________________
N.U.S.: A cross platform C++ application development framework
My blog (in Portuguese)
Back to top
View user's profile Send private message
nafre
Guru
Guru


Joined: 27 Dec 2003
Posts: 388

PostPosted: Thu Jan 15, 2004 2:19 am    Post subject: Reply with quote

aqui tudo certo recompilei o kernel para o 2.6 ate agora ta tudo uma maravilha!

obs ainda não atualizei nada!

espero não ter problemas...
_________________
Nome- Felipe
Nick- Nafre
Idade- 25
Salvador - Bahia - Brasil
Back to top
View user's profile Send private message
Proton
Apprentice
Apprentice


Joined: 16 Mar 2003
Posts: 195
Location: Estoril, Portugal

PostPosted: Thu Jan 15, 2004 3:37 am    Post subject: Reply with quote

Então e quem não tem nenhum pacote linux-headers instalado, quais é que está a usar? Os do kernel em /usr/linux? Ou outros?

Estou a usar um kernel 2.6.1 (instalei o básico nesta máquina com um 2.4, depois instalei o 2.6, glibc e recompilei tudo), mas o kernel com o qual a glibc e a maioria das coisas foram compiladas foi o 2.6.0-test9. Há problema? Acham que devo instalar os linux-headers 2.6.0?
_________________
Sérgio @ Portugal
IST - LEIC
Back to top
View user's profile Send private message
Vanquirius
Retired Dev
Retired Dev


Joined: 14 Jun 2002
Posts: 1297
Location: Ethereal plains

PostPosted: Thu Jan 15, 2004 3:37 am    Post subject: Reply with quote

nafre wrote:
espero não ter problemas...


Hummm, você não tem uma webcam da Intel por acaso?
Isso sim é divertido de consertar! :lol:
Quem sabe até o final de Janeiro eu consigo! :-)
_________________
Hello.
Back to top
View user's profile Send private message
rmalheiro
n00b
n00b


Joined: 04 Nov 2003
Posts: 6
Location: Lisboa, Portugal

PostPosted: Fri Jan 16, 2004 11:03 am    Post subject: Reply with quote

A correr 2.6 num laptop Fujitsu/Siemens AMILO D desde a _test1 *apenas* com os seguintes problemas:

- Drivers (propietários) para ao winmodem não compilavam para a 2.6. Resolvido com nova versão dos drivers (slmodem). Ver bug #34399

- Drivers para a ATI deram problemas no início, resolvido desde a _test9. A quem tem uma AT Radeon aconselho o emerge dos útimos ati-drivers (~x86) que apresentam um bom aumento de desempenho em OpenGL.

- GnuCash não completa o emerge com a 2.6 devido a problemas com o db2 durante o registo do ficheiros de ajuda. Ver bug #27978

- "Sobresaltos" com os drivers do kernel para o touchpad Synaptics. De vez em quando havia regressões mas parece estar resolvido desde a 2.6.1.

- Encontrei alguns problemas com a glibc compilada com USE=nptl (problemas de compilação, não sei se está limitado ao kernel 2.6) nomeadamente não consegui compilar o valgrind. Ver bug #32966

Estou a usar as mm-sources. Entretanto o meu disco está em fase terminal (tipo 10 bad-sectors/sec) e assim que chegar um novo disco vou fazer uma instalação limpa do Gentoo Linux 2004, a partir da stage 1 com mm-sources. Espero conseguir ter "sossego" para conseguir documentar os passos necessários para implementar o sistema em Unicode (pt_PT.UTF-8 )

Quanto ao tópico, acho que faz sentido manter as gentoo-sources com o 2.4 enquanto as novas versões do 2.6 andarem a ser lançadas *semanalmente*. De momento as mm-sources estão com a 2.6 o que faz todo o sentido, sendo o Anrew Morton o mantainer do novo kernel.
_________________
Rui Malheiro
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portuguese All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum