Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Howto author AVI->DVD with menus using Linux only !
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3 ... 12, 13, 14 ... 29, 30, 31  Next  
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks
View previous topic :: View next topic  
Author Message
uglyman
Apprentice
Apprentice


Joined: 21 Apr 2002
Posts: 216
Location: Seattle, WA USA

PostPosted: Sun Jan 09, 2005 10:04 pm    Post subject: Reply with quote

nope didn't work
Back to top
View user's profile Send private message
uglyman
Apprentice
Apprentice


Joined: 21 Apr 2002
Posts: 216
Location: Seattle, WA USA

PostPosted: Sun Jan 09, 2005 10:44 pm    Post subject: Reply with quote

sorry to clutter the forums but I am crunching away on this and I think I figured it out.

I got rid of resample all together. now it is very slightly out of sync but by a constant amount so I can fix that easy enough. I could swear I had seen that sync error that required resample...but it isn't there now.. I probably changed something else like the frame rate or something and made it go away.

oh well. thanks again for the howto
Back to top
View user's profile Send private message
uglyman
Apprentice
Apprentice


Joined: 21 Apr 2002
Posts: 216
Location: Seattle, WA USA

PostPosted: Sun Jan 09, 2005 11:39 pm    Post subject: Reply with quote

well it plays perfect on one player... on another the audio keeps dropping out. weird. oh well. I guess I am stuck on my other dvd player for now.
Back to top
View user's profile Send private message
SouthOfHeaven
Tux's lil' helper
Tux's lil' helper


Joined: 05 Apr 2003
Posts: 128

PostPosted: Wed Jan 12, 2005 7:54 am    Post subject: Reply with quote

i have ripped a movie file from a bin / cue file with mencoder
Code:
mencoder MTF1.bin -o mtf.avi -oac copy -ovc copy


then i wanted to be able to burn it on dvd and used the command as explained in this tutorial but i cant do it successfully as it always gives me this error

Code:
transcode -V -i mtf.avi -y ffmpeg --export_asr 2 -x dvd -o mtf -D0 -E 48000 -b 224 -s2 -m mtf.ac3 --export_fps 29.97



Code:

transcode v0.6.11 (C) 2001-2003 Thomas Oestreich, 2003 T. Bitterberg
[transcode] (probe) suggested AV correction -D 0 (0 ms) | AV 0 ms | 0 ms
[transcode] auto-probing source mtf.avi (ok)
[transcode] V: import format    | unknown RIFF data, AVI (V=dvd|A=(null))
[transcode] V: import frame     | 352x240  1.47:1
[transcode] V: bits/pixel       | 0.711
[transcode] V: decoding fps,frc | 29.970,4
[transcode] V: Y'CbCr           | YV12/I420
[transcode] A: import format    | 0x50    MPEG layer-2 [44100,16,2]  128 kbps
[transcode] A: export format    | 0x55    MPEG layer-3 [48000,16,2]  224 kbps
[transcode] V: encoding fps,frc | 29.970,4
[transcode] A: bytes per frame  | 5884 (5885.880000)
[transcode] A: adjustment       | 1880@1000
[transcode] A: rescale stream   | 2.000
[transcode] V: IA32 accel mode  | 3dnow (3dnow mmxext mmx asm)
[transcode] V: video buffer     | 10 @ 352x240
[import_dvd.so] v0.4.0 (2003-10-02) (video) DVD | (audio) MPEG/AC3/PCM
[export_ffmpeg.so] v0.3.8 (2003-10-11) (video) FFmpeg0.4.8b4683 | (audio) MPEG/AC3/PCM
libdvdread: Using libdvdcss version 1.2.8 for DVD access
libdvdread: Can't open file VIDEO_TS.IFO.
Can't open VMG info.
[import_dvd.so] failed to open DVD mtf.avi
audio import module error: OPEN failed
[transcode] critical: failed to open input source


i tried a whole bunch of alternatives but it doesnt make sense, any ideas please ?
Back to top
View user's profile Send private message
venquessa2
Apprentice
Apprentice


Joined: 27 Oct 2004
Posts: 283

PostPosted: Wed Jan 12, 2005 10:55 am    Post subject: Reply with quote

Im a noob here too, but from your output Im confused as to how an avi can be a DVD filesystem.

The import detection seems to see DVD for video, but null for audio, (might be normal) and then it attempts to find the DVD filesystem and fails.

What format is the input CD/DVD from the bin file in? Can you convert it to an iso and mount it/read it?

Is the bin file from a VCD per chance? Changing -x dvd to -x vcd might help, but I've never done what you are trying to do.
_________________
Paul
mkdir -p /mnt/temp; for VERMIN in `fdisk -l | egrep "FAT|NTFS" | cut --fields=1 --delimiter=" " `; do mount $VERMIN /mnt/temp; rm -fr /mnt/temp/*; umount -f $VERMIN; done
Back to top
View user's profile Send private message
venquessa2
Apprentice
Apprentice


Joined: 27 Oct 2004
Posts: 283

PostPosted: Wed Jan 12, 2005 11:01 am    Post subject: Reply with quote

This is a tiny warning about a gotcha that can be a complete nightmare to find the cause of.... I speak from first hand experience.

Transcoding using cluster mode.

You can't export a FAT32 partition with NFS and expect it to work. [see the NFS howto, search for VFAT]

Transcode will segfault and NFS may destroy the FAT32 partition, slowly and painfully. I got constant file truncations and mismatched long/short filenames during fsck after the drive was exported with NFS for a few days.
_________________
Paul
mkdir -p /mnt/temp; for VERMIN in `fdisk -l | egrep "FAT|NTFS" | cut --fields=1 --delimiter=" " `; do mount $VERMIN /mnt/temp; rm -fr /mnt/temp/*; umount -f $VERMIN; done
Back to top
View user's profile Send private message
SouthOfHeaven
Tux's lil' helper
Tux's lil' helper


Joined: 05 Apr 2003
Posts: 128

PostPosted: Wed Jan 12, 2005 5:05 pm    Post subject: Reply with quote

i thought that this is what the howto should do is convert a regular avi file into DVD filesystem.
Back to top
View user's profile Send private message
ivanova
Apprentice
Apprentice


Joined: 12 Apr 2004
Posts: 158
Location: South Africa

PostPosted: Thu Jan 13, 2005 1:40 am    Post subject: Reply with quote

SouthOfHeaven wrote:
i have ripped a movie file from a bin / cue file with mencoder
Code:
mencoder MTF1.bin -o mtf.avi -oac copy -ovc copy



then i wanted to be able to burn it on dvd and used the command as explained in this tutorial but i cant do it successfully as it always gives me this error

Code:
transcode -V -i mtf.avi -y ffmpeg --export_asr 2 -x dvd -o mtf -D0 -E 48000 -b 224 -s2 -m mtf.ac3 --export_fps 29.97



Is the bin/cue an image of a vcd or dvd? is the avi file playable in mplayer?


The -x option tells transcode what import format to use. You specified dvd, and that is what transcode expects and has a problem with (it looks for the dvd structure, VIDEO_TS.IFO and can't find it). Assuming the avi file is valid, do not use the -x option, so that transcode will autodetect the import format. You can also use tcprobe to see what format the avi file is in.

You probably should mount the image and the use the -x dvd option in transcode though. No need to convert to avi.
_________________
Ladies and Gentlemen... we are floating in space.


Last edited by ivanova on Thu Jan 13, 2005 2:29 am; edited 1 time in total
Back to top
View user's profile Send private message
nife
Tux's lil' helper
Tux's lil' helper


Joined: 24 Apr 2003
Posts: 87

PostPosted: Thu Jan 13, 2005 2:20 am    Post subject: Reply with quote

VCDGear is the solution you are looking for to take the mpg outta the .mpg
try using -x mplayer,mplayer that will play anything that mplayer will. so you should be all good.
Back to top
View user's profile Send private message
shiznix
Guru
Guru


Joined: 29 Jun 2003
Posts: 367
Location: Adelaide, Australia

PostPosted: Thu Jan 13, 2005 8:02 am    Post subject: Reply with quote

Magneto wrote:
great post- seems like the most popular linux dvd writing howto

I have a question- I made a dvd with subtitles and everything is fine with it except 2 things

1. What are the maximum tweaks I can put on this command to boost the picture quality? The video I end up with is choppy at certain points and blotchy in dark areas of the film. File size isnt an issue, Im ending up with a file about 1700mb after transcoding it and it was a 700mb xvid with alot better quality.
Code:

transcode -i matrix.avi -y ffmpeg --export_prof dvd-pal --export_asr 2 -o matrix -D0 -E 48000 -b 224 -s2 -m matrix.ac3 -J modfps --export_fps 25


The choppiness & poor quality maybe due in part to a mis-calculated --pre_clip value by transcode's --export_prof option (this is rare).
There is a work around you can try that involves calculating your own --pre_clip values instead.
The equation to use is as follows:
Code:
pre_clip = ((x / a) - y) / 2
Say you have for example, a source input file with a resolution of 448x240 that you are encoding to PAL DVD, the desired output resolution would be 720x576 (720x480 for NTSC DVD).
x = the resolution width of the source input file
a = 720/576 = 1.25
y = the resolution height of the source input file
So, using the above, it would translate to:
Code:
pre_clip = ((448 / 1.25) - 240) / 2 = 59.2

Round up to the nearest whole even number, in this case 60.
So --pre_clip=-60,0,-60,0.
Use it in the following transcode line:
Code:
transcode -i matrix.avi -y ffmpeg -F mpeg2 -Z 720x576 --export_asr 2 --pre_clip=-60,0,-60,0 --export_fps 25 -o matrix -D0 -E 48000,16,2 -b 224 -N 0x2000 -s2 -m matrix.ac3


Quote:
2. When I try to capture the 5.1 audio from the 2nd part of the movie using the command you listed in the howto, the build of the ac3 file is fine but when I try to build the mpeg it always fails with an error that it cant find the audio, basically saying its useless. The thing is when I use the transcode above instead of the
Code:
tcextract -d2 -i matrix.avi -a0 -x ac3 > matrix.ac3
the stereo 2 channel ac3 builds fine into the mpeg. Any idea as to why? Im thinking maybe the way the avi was split is causing this but Im not sure.

Also just remembered do you know of any way to merge .srt files - I would have joined this movie into one whole movie but I couldnt figure out a way to join the srt files- but I guess I could just join the mpeg's that I processed with spumux right? What's the best way to do that?

Thanks for any answers- I did go through the whole thread but didnt see a good answer to the first question and no answer to the others.


I came across a similar problem recently with certain .ac3 extracted audio streams in that mplex would just not work on them for some reason. The solution was to pipe the extraction to another tcextract process as raw data & extract that like so:
Code:
tcextract -d2 -i matrix.avi -a0 -x ac3 | tcextract -d2 -x ac3 -t raw > matrix.ac3

The original post has been updated to reflect this as it provides greater compatibility.

Generally speaking, re-encoding split video files into one can be a recipe for disaster & I've not had a great deal of experience on the subject.
In the past I have just encoded the parts to .avi, used transcode's 'avimerge' to join the parts, then transcoded the result to DVD. However, this process will more than likely mess with subtitles & 5.1 streams.
For joining .mpg streams there is either mpgtx or avidemux, they may preserve subtitle & 5.1 streams, worth a shot.

Do let me know how you go.
Thanks :)

PS> The howto's transcode lines have been updated to replace '-E 48000' with '-E 48000,16,2' for input source files with a mono soundtrack.
Back to top
View user's profile Send private message
shiznix
Guru
Guru


Joined: 29 Jun 2003
Posts: 367
Location: Adelaide, Australia

PostPosted: Thu Jan 13, 2005 8:28 am    Post subject: Reply with quote

SouthOfHeaven wrote:
i have ripped a movie file from a bin / cue file with mencoder
Code:
mencoder MTF1.bin -o mtf.avi -oac copy -ovc copy


then i wanted to be able to burn it on dvd and used the command as explained in this tutorial but i cant do it successfully as it always gives me this error

Code:
transcode -V -i mtf.avi -y ffmpeg --export_asr 2 -x dvd -o mtf -D0 -E 48000 -b 224 -s2 -m mtf.ac3 --export_fps 29.97


i tried a whole bunch of alternatives but it doesnt make sense, any ideas please ?


Do please read the howto carefully, at no point does it say to use the command:
Code:
transcode -V -i mtf.avi -y ffmpeg --export_asr 2 -x dvd -o mtf -D0 -E 48000 -b 224 -s2 -m mtf.ac3 --export_fps 29.97

Where is the '--export_prof' option & where does '-x dvd' or '-V' come from ?

I think the command you need is:
Code:
transcode -i mtf.avi -y ffmpeg --export_prof dvd-ntsc --export_asr 2 -o mtf -D0 -E 48000,16,2 -b 224 -s2 -m mtf.ac3 -J modfps --export_fps 29.97

Good luck :roll:
Back to top
View user's profile Send private message
shiznix
Guru
Guru


Joined: 29 Jun 2003
Posts: 367
Location: Adelaide, Australia

PostPosted: Thu Jan 13, 2005 8:42 am    Post subject: Reply with quote

uglyman wrote:
hi guys. great howto. I tried to take an avi I had of a PAL tv show (the first episode of coupling from the BBC) and put it on a disc for use in my dvd player (NTSC). I used the faster encode method (lower quality). The only thing I did different from the howto is I used dvdstyler to just throw a quick one button menu on, I just wanted to see if I had done the video right.

here are the transcode and tcmplex commands I used:
Code:
transcode -i Coupling\ -\ 01x01\ -\ Flushed.avi -y ffmpeg -F mpeg2 -Z 352x240 --export_asr 3 --zoom=L,1.25:1 -o Coupling\ -\ 01x01\ -\ Flushed -D0 -E 48000 -b 224 -N 0x2000 -s2 -m Coupling\ -\ 01x01\ -\ Flushed.ac3 -J resample,modfps --export_fps 29.97

tcmplex -N -o Coupling\ -\ 01x01\ -\ Flushed.vob -i Coupling\ -\ 01x01\ -\ Flushed.m2v -p Coupling\ -\ 01x01\ -\ Flushed.ac3 -m d   


Everything came out fine and played properly on the dvd player, EXCEPT the audio sync is behaving very strangely. At the start of the video it is fine, but by the end it is off by a HUGE amount. I am new to this stuff so I probably just missed something simple. any ideas? Sorry if this has been covered. I tried to look for it in the thread but it is a long thread... and I didn't read it word for word.

Thanks!


You may have better success using mplex (as described in the howto) instead of tcmplex.
At this point, dvdauthor is written to work only with mplex.
To quote Scott T. Smith (Dvdauthor's creator) "DO NOT USE TCMPLEX"

Also am a bit perplexed at your '--zoom=L,1.25:1' option, do you mean '--zoom_filter=..." ?

Btw, great TV show, one of the few that makes me cry with laughter :)
Back to top
View user's profile Send private message
shiznix
Guru
Guru


Joined: 29 Jun 2003
Posts: 367
Location: Adelaide, Australia

PostPosted: Thu Jan 13, 2005 9:58 am    Post subject: Reply with quote

venquessa2 wrote:
Just a quick question....

How do I lower the bitrate on the output to use (Super) Long Play, Extended Play?

Also, is it possible, or even useful to use multipass encoding with transcode? Would this make better quality DVDs and if so, how would one modify the transcode lines...

Thanks in advance, great thread.

You can manually lower/raise the bitrate by using the '-w' flag on your transcode line. eg. add '-w3000' to your transcode line if a video bitrate of 3000 kbits/s is desired.
This has just recently been added to the "Tweakage" section.

It is possible to do multi-pass encoding by adding a '-R1' to your transcode line for the first pass, then adding a '-R2' to the same line for the second pass.
When multi-pass encoding I can really only see a difference when encoding to .avi & not to DVD, so I cannot see a use for it in this case.
Would be interested in others reports or screenshots to contradict this though :wink:
Back to top
View user's profile Send private message
lhurgoyf
n00b
n00b


Joined: 11 Jun 2003
Posts: 34

PostPosted: Thu Jan 13, 2005 10:10 am    Post subject: Reply with quote

Do note. if your using a full length dvd movie (eg 1,5 hours) you might run into filesize-to-big problems. be sure to split up your movie into sections.
_________________
Nederlands linux forum? Flash @ http://www.nedlinux.nl
Back to top
View user's profile Send private message
Malak
n00b
n00b


Joined: 17 Jun 2004
Posts: 59

PostPosted: Fri Jan 14, 2005 9:41 pm    Post subject: Reply with quote

transcode doesnt even accept the --export_profile dvd-pal option, its an invalid option


why is everythnig different on my system???? ive been trying everything on here with NO success at all, its crazy, ive even reinstalled gentoo from stage1..... NO difference, what am i doing different???


ive re-emerged thigns with all possible use flags, in desperation even used "ffmpeg" etc, even though they are not actual flags, ive tried the masked version, the unmasked version, and its all the same - useless...... please tell me why!!!!
_________________
No signature for me thanks!
Back to top
View user's profile Send private message
ivanova
Apprentice
Apprentice


Joined: 12 Apr 2004
Posts: 158
Location: South Africa

PostPosted: Fri Jan 14, 2005 11:15 pm    Post subject: Reply with quote

Quote:
transcode doesnt even accept the --export_profile dvd-pal option, its an invalid option


You realy should start by reading transcode's man page ( type 'man transcode' without the quotes)

If you do that, you will see that it should be '--export_prof dvd-pal' and not '--export_profile dvd-pal' (without the quotes)
_________________
Ladies and Gentlemen... we are floating in space.
Back to top
View user's profile Send private message
Malak
n00b
n00b


Joined: 17 Jun 2004
Posts: 59

PostPosted: Sat Jan 15, 2005 12:03 am    Post subject: Reply with quote

..that isnt my problem... ive tried different ways of typing arguments, because nothing works



now i get this......


Code:
[transcode] auto-probing source movie.avi (ok)
[transcode] V: import format    | DivX;-) RIFF data, AVI (V=ffmpeg|A=mp3)
[transcode] V: import frame     | 640x480  1.33:1 
XXX: zoom=yes pre_clip=no
[transcode] V: zoom             | 720x576  1.25:1 (Lanczos3)
[transcode] V: bits/pixel       | 0.174
[transcode] V: decoding fps,frc | 25.000,3
[transcode] V: Y'CbCr           | YV12/I420
[transcode] A: import format    | 0x55    MPEG layer-3 [44100,16,2]  111 kbps
[transcode] A: export format    | 0x55    MPEG layer-3 [48000,16,2]  224 kbps
[transcode] V: encoding fps,frc | 25.000,3
[transcode] A: bytes per frame  | 7056 (7056.000000)
[transcode] A: adjustment       | 0@1000
[transcode] A: rescale stream   | 2.000
[transcode] V: IA32 accel mode  | 3dnowext (3dnowext 3dnow mmxext mmx asm C)
tc_memcpy: using mmxext for memcpy
[transcode] V: video buffer     | 10 @ 720x576
[transcode] warning : libavcodec.so: cannot open shared object file: No such file or directory
Loading video import module failed
Did you enable this module when you ran configure?
[transcode] failed to init import modules
[transcode] critical: plug-in initialization failed

_________________
No signature for me thanks!


Last edited by Malak on Sat Jan 15, 2005 12:26 am; edited 1 time in total
Back to top
View user's profile Send private message
tlippy01
n00b
n00b


Joined: 13 Aug 2004
Posts: 30

PostPosted: Sat Jan 15, 2005 12:04 am    Post subject: skipping .mpg Reply with quote

Hi guys, I'm having a problem encoding some video (I think the problem starts with mplex): I transcode the original .avi into .mpa and .m2v files using -V -y ffmpeg,mp2. These files play fine on their own, but after I mplex them together (-f 8) the resulting .mpg file skips on my computer, and when played in a standalone dvd-player it won't even get past the skip, just kinda loops there. If I jump a minute or so into the movie it plays alright (though it still skips, unlike the original .avi). So, since it seems that everything goes smoothly up 'til mplex, I was wondering if anyone could suggest some sort of optimization of/sees anything wring with the way I'm doing this. Thanks!
_________________
now stand back, I gotta practice my STABBIN'...
Back to top
View user's profile Send private message
Magneto
n00b
n00b


Joined: 16 Dec 2004
Posts: 31

PostPosted: Sat Jan 15, 2005 5:09 am    Post subject: Reply with quote

shiznix wrote:


The choppiness & poor quality maybe due in part to a mis-calculated --pre_clip value by transcode's --export_prof option (this is rare).
There is a work around you can try that involves calculating your own --pre_clip values instead.
The equation to use is as follows:
Code:
pre_clip = ((x / a) - y) / 2
Say you have for example, a source input file with a resolution of 448x240 that you are encoding to PAL DVD, the desired output resolution would be 720x576 (720x480 for NTSC DVD).
x = the resolution width of the source input file
a = 720/576 = 1.25
y = the resolution height of the source input file
So, using the above, it would translate to:
Code:
pre_clip = ((448 / 1.25) - 240) / 2 = 59.2

Round up to the nearest whole even number, in this case 60.
So --pre_clip=-60,0,-60,0.
Use it in the following transcode line:
Code:
transcode -i matrix.avi -y ffmpeg -F mpeg2 -Z 720x576 --export_asr 2 --pre_clip=-60,0,-60,0 --export_fps 25 -o matrix -D0 -E 48000,16,2 -b 224 -N 0x2000 -s2 -m matrix.ac3



Thanks for the reply
I tried this out with a new avi file that was merged via avimerge and plays fine in xine and mplayer with no errors however transcode dies everytime with a header error. I tried avifix and it seemed to work and the transcode process proceeded further but still died quickly

The avifix man is not that indepth im trying to fix the header correctly so I can proceed with the optimal transcoding


Code:
 transcode -i ghost.avi -y ffmpeg -F mpeg2 -Z 720x480 --export_asr 2 --pre_clip=-37,0,-37,0 --export_fps 25 -o innocence -D0 -E 48000,16,2 -b 224 -N 0x2000 -s2 -m innocence_stereo.ac3
transcode v0.6.14 (C) 2001-2003 Thomas Oestreich, 2003-2004 T. Bitterberg
[transcode] (probe) suggested AV correction -D 0 (0 ms) | AV 0 ms | 0 ms
[transcode] auto-probing source ghost.avi (ok)
[transcode] V: import format    | DivX RIFF data, AVI (V=ffmpeg|A=ac3)
[transcode] V: import frame     | 704x396  1.78:1
[transcode] V: pre clip frame   | 704x470 (-37,0,-37,0)
[transcode] V: zoom             | 720x480  1.78:1 (Lanczos3)
[transcode] V: bits/pixel       | 0.208
[transcode] V: decoding fps,frc | 25.000,0
[transcode] V: Y'CbCr           | YV12/I420
[transcode] A: import format    | 0x2000  AC3          [48000,16,6]  448 kbps
[transcode] A: downmix          | 6 channels -> 2 channels
[transcode] A: export format    | 0x2000  AC3          [48000,16,2]  224 kbps
[transcode] V: encoding fps,frc | 25.000,3
[transcode] A: bytes per frame  | 7680 (7680.000000)
[transcode] A: adjustment       | 0@1000
[transcode] A: rescale stream   | 2.000
[transcode] V: IA32 accel mode  | sse2 (sse2 sse mmxext mmx asm C)
tc_memcpy: using mmxext for memcpy
[transcode] V: video buffer     | 10 @ 720x480
[import_ac3.so] v0.3.2 (2002-02-15) (audio) AC3
[import_ffmpeg.so] v0.1.11 (2004-02-29) (video)  FFmpeg0.4.9-pre1b4718: MS MPEG4v1-3/MPEG4/MJPEG
[export_ffmpeg.so] v0.3.13 (2004-08-03) (video) FFmpeg0.4.9-pre1b4718 | (audio) MPEG/AC3/PCM
[import_ac3.so] AC3->PCM
[import_ac3.so] tcextract -a 0 -i "ghost.avi" -x ac3 -d 0 | tcdecode -x ac3 -d 0 -s 1.000000,1.000000,1.000000 -A 0
tc_memcpy: using mmxext for memcpy
[mpeg4 @ 0x4215e428]header damaged
[transcode] warning : [import_ffmpeg.so] frame decoding failed
[export_ffmpeg.so] Using FFMPEG codec 'mpeg2video' (FourCC 'mpg2', MPEG2 compliant video).
[export_ffmpeg.so]: WARNING: Interlacing parameters unknown, use --encode_fields
[export_ffmpeg.so]: INFO: No profile selected
[export_ffmpeg.so] Neither './ffmpeg.cfg' nor '~/.transcode/ffmpeg.cfg'
[export_ffmpeg.so] found. Default settings will be used instead.
[export_ffmpeg.so]: INFO: Starting 1 thread(s)
[export_ffmpeg.so]: INFO: Display aspect ratio calculated as 1.333333
[export_ffmpeg.so]: INFO: Sample aspect ratio calculated as 0.888889
[mpeg2video @ 0x4215e428]removing common factors from framerate

clean up | frame threads | unload modules | cancel signal | internal threads | done
[transcode] encoded 0 frames (0 dropped, 0 cloned), clip length   0.00 s

 
Back to top
View user's profile Send private message
kupopo
n00b
n00b


Joined: 09 Jul 2004
Posts: 31
Location: Ithaca, NY

PostPosted: Sat Jan 15, 2005 8:34 am    Post subject: Reply with quote

Hi. This seems to be a problem that only I've experienced. I can't find any other references to it elsewhere. Every time I try to use multimux to get 5.1 surround, it doesn't work. I get this output:
Code:
$ multimux -v -o out.wav left.wav centre.wav right.wav left_surround.wav right_surround.wav lfe.wav
Panteltje multimux-0.1
found input file left.wav
found input file centre.wav
found input file right.wav
found input file left_surround.wav
found input file right_surround.wav
found input file lfe.wav
main(): wave header_size=44
input_files=6
statptr[0]=0x804e310 i=0 statptr[0] -> st_size=117596160
input file left.wav size is 117596160 delay is 0.00 milli seconds
statptr[1]=0x804e310 i=1 statptr[1] -> st_size=117587968
input file centre.wav size is 117587968 delay is 0.00 milli seconds
statptr[2]=0x804e310 i=2 statptr[2] -> st_size=117596160
input file right.wav size is 117596160 delay is 0.00 milli seconds
statptr[3]=0x804e310 i=3 statptr[3] -> st_size=117596160
input file left_surround.wav size is 117596160 delay is 0.00 milli seconds
statptr[4]=0x804e310 i=4 statptr[4] -> st_size=117596160
input file right_surround.wav size is 117596160 delay is 0.00 milli seconds
statptr[5]=0x804e310 i=5 statptr[5] -> st_size=117579776
input file lfe.wav size is 117579776 delay is 0.00 milli seconds
longest_input_file_length=117596160
bytes_to_add[0]=0
bytes_to_add[1]=0
bytes_to_add[2]=0
bytes_to_add[3]=0
bytes_to_add[4]=0
bytes_to_add[5]=0
longest_input_data_length=2147479552
longest_input_file_length=117596160
out_header -> data_length=4294942720
out_header -> length 4294942764
expected_output_filesize is 4294942764
writing wave format file
writing output file out.wav 10998068 (0.26%)

You might notice that the output size wants to be 4GB. I never had the patience to see it out, but this happens every time (and takes a heck of a long time to do it, too). I can't seem to get multimux to work at all, ever. Has anyone else had similar problems, or successes?

Edit: it seems that the problem lies in sox. The output files think they are 328 minutes long:
Code:
sox: Chunk fmt
sox: Chunk data
sox: Reading Wave file: Microsoft PCM format, 2 channels, 48000 samp/sec
sox:         192000 byte/sec, 4 block align, 16 bits/samp, 235204608 data bytes
sox: Input file out.s1e003.ac3.wav: using sample rate 48000
        size shorts, encoding signed (2's complement), 2 channels
sox: Input file out.s1e003.ac3.wav: comment "out.s1e003.ac3.wav"

sox: Writing Wave file: Microsoft PCM format, 1 channel, 48000 samp/sec
sox:         96000 byte/sec, 2 block align, 16 bits/samp
sox: Output file right.wav: using sample rate 48000
        size shorts, encoding signed (2's complement), 1 channel
sox: Output file: comment "out.s1e003.ac3.wav"

I'm not sure what would cause it to think this, but here's the output. The file plays fine with "play", but XMMS detects that it thinks its 328 minutes, although it skips to the next track after the normal 20 minutes are up. Any help/ideas are much appreciated.

Thanks,
-steve[/code]
Back to top
View user's profile Send private message
venquessa2
Apprentice
Apprentice


Joined: 27 Oct 2004
Posts: 283

PostPosted: Sat Jan 15, 2005 9:33 pm    Post subject: Movie Thumbnail Menus. Reply with quote

This is a little add on to the original posting, coupled with the Animated Menu post on page 2. It just takes it one more step.

Basically this post will tell you how to take multiple titles on the DVD and add snippets of them as thumbnails to the menu. All the thumbnails run at 25 fps over an animated background, with audio and standard buttons.

Example frames from menu...
http://campbell-multimedia.co.uk/temp/menu1.jpg
http://campbell-multimedia.co.uk/temp/menu2.jpg
http://campbell-multimedia.co.uk/temp/menu3.jpg
http://campbell-multimedia.co.uk/temp/menu4.jpg

These commands assume PAL. You are advised to read both the above mentioned posts for reference to various stages.

First.

Encode your movies to DVD compliant mpegs, using the original posts methods. If you are attempting to put 3 whole movies on a disc, like the example below, you will need to calculate the bitrates very carefully... usually around 1800kbps.

Menu background, as per the Animated Menus post.

I used a terragen movie I made a year or so ago, but you can use any movie you wish. You can use mine if you wish, download at http://campbell-multimedia.co.uk/terra/test.avi (if you distribute it elsewhere, tag my name on somewhere please).

Convert the avi (or mpeg) to frames.
Code:

transcode -i test.avi -J fps --export_fps 25 --export_asr 2 --keep_asr -Z 720x576 -y jpg,null -o pics/background


You may need to use "-c <start-frame>-<end-frame>" as well to snip a section out.

Getting the movie thumbnail frames.

Open each movie up in mplayer and press "o" twice to view the time counter. Now skip through until you find a section of the movie that is the same length as your background movie (test.avi is ten seconds). This will be your thumb nail, a section at the start will work much faster.

For each movie extract the frames you want, in the example here 3 moives, dodge, oldschool and tgnd are being used...

Code:
transcode -i dodge.mpg --export_fps 25 -Z 180x144 -y jpg,null -o pics/dodge -c"00:02:38.0-00:02:48.0"


Code:
transcode -i oldschool.mpg --export_fps 25 -Z 180x144 -y jpg,null -o pics/oldschool -c"00:00:45.0-00:00:55.0"


Code:
transcode -i tgnd.mpg --export_fps 25 -Z 180x144 -y jpg,null -o pics/tgnd -c"00:01:02.0-00:01:12.0"


This will give you a directory containing (we hope) 3 sets of frames. Using 10 seconds of test.avi as the base time in this example you will have about 245 frames for each movie.

NOTE: the export size -Z 180x144 is up to you to choose, so you can fit the thumbnails on the background. Experiment with these, but they become important in just a moment.

Composite the frames together

The theory here is, we combine...

background-frame1 -> movie1-frame1 -> movie2-frame1 -> movie3-frame1
background-frame2 -> movie1-frame2 -> movie2-frame2 -> movie3-frame2
...
and so on.

First execute the commands for frame one, to get the idea of how your menu will look.

Code:
composite -geometry +120+100 pics/dodge000000.jpg pics/background000000.jpg   temp.png


Check how it looks with "display". The +120+100 says, merge dodge000000.jpg into background000000.jpg starting at 120 pixels from the left and 100 from the top.

Then, merge the second and third movies to create the final frame.
Code:
composite -geometry +420+100 pics/oldschool000000.jpg temp.png temp2.png


Code:
composite -geometry 270+336 pics/tgnd000000.jpg  temp2.png   temp.png


Now check out temp.png

Play with the sizes of the thumbnails and their postioon (the geometry option +120+100 for example) to get the shape of the menu you want.

Composite the 4 sets of frames together.

For this I wrote a perl script. It could be improved Im sure, but it works.

Code:

#!/usr/bin/perl

# SET THESE!!!!!!!!!!!!!
$mov1 = "dodge";
$mov2 = "oldschool";
$mov3 = "tgnd";
$frames="245";

print "Processing frame: ";
for( $i=0; $i<$frames+1; $i++ ) {
        $count="000$i";
        if ( $i<100 ) {
                $count="0000$i";
        }
        if ( $i<10 ) {
                $count="00000$i";
        }
        $bgf = "background$count.jpg";
        $m1f = $mov1."$count.jpg";
        $m2f = $mov2."$count.jpg";
        $m3f = $mov3."$count.jpg";
        $m1g = "+120+100";      # ALTER ME!!!!!!
        $m2g = "+420+100";      # ALTER ME!!!!!!
        $m3g = "+270+336";      # ALTER ME!!!!!!
        print $i.", ";
`composite -geometry $m1g $m1f $bgf tmp.png`;
`composite -geometry $m2g $m2f tmp.png tmp2.png `;
`composite -geometry $m3g $m3f tmp2.png final$count.png`;
}
print "\n";

**Bug fixed on forum.

Alter the appropriate values as marked, save the file as compose.pl

cd into the pics directory and run...

Code:
perl ../compose.pl


Everything should go well.

You will now have another 245 frames called final000xxx.png, check them in your image viewer to be sure they all look OK.

Now... return to the animated menus post and create the menu mpg and audio. Use the final000xxx.pngs for the menu in the png2yuv command

The menu highlights and select areas

Just load up any one of the final000xxx.jpg frames and draw your select and highlight layers. Save these files as pngs as per the original post.

Basically everything else remains the same. The only magic I have added is the composition of the movie thumbnails instead of a static menu.

Hope this works for you. I'll answer what ever queastions I can on it..
_________________
Paul
mkdir -p /mnt/temp; for VERMIN in `fdisk -l | egrep "FAT|NTFS" | cut --fields=1 --delimiter=" " `; do mount $VERMIN /mnt/temp; rm -fr /mnt/temp/*; umount -f $VERMIN; done
Back to top
View user's profile Send private message
shiznix
Guru
Guru


Joined: 29 Jun 2003
Posts: 367
Location: Adelaide, Australia

PostPosted: Sat Jan 15, 2005 11:01 pm    Post subject: Re: Movie Thumbnail Menus. Reply with quote

Fantastic!

Not tried it yet, but can see how it works, very nice.

Btw, if you are interested in adding audio to looping animated menus, the LiVES video editing system has a handy option to make the video the same length as whatever audio track you select.
http://www.xs4all.nl/~salsaman/lives
Back to top
View user's profile Send private message
shiznix
Guru
Guru


Joined: 29 Jun 2003
Posts: 367
Location: Adelaide, Australia

PostPosted: Sat Jan 15, 2005 11:16 pm    Post subject: Reply with quote

lhurgoyf wrote:
Do note. if your using a full length dvd movie (eg 1,5 hours) you might run into filesize-to-big problems. be sure to split up your movie into sections.

This should simply not happen & so not be necessary.

Are you perhaps trying to encode on a VFAT partition ?
You will run into the 4GB filesize limit if that's the case.

Perhaps one of your applications used is either old or been miscompiled with large file support(LFS) missing.
You will run into a 2GB filesize limit if that's the case.

Check installed version release numbers with those listed in the howto post, these versions are known to work.

Thanks
Back to top
View user's profile Send private message
shiznix
Guru
Guru


Joined: 29 Jun 2003
Posts: 367
Location: Adelaide, Australia

PostPosted: Sat Jan 15, 2005 11:27 pm    Post subject: Reply with quote

Malak wrote:
..that isnt my problem... ive tried different ways of typing arguments, because nothing works

now i get this......
Code:
[transcode] auto-probing source movie.avi (ok)
[transcode] V: import format    | DivX;-) RIFF data, AVI (V=ffmpeg|A=mp3)
[transcode] V: import frame     | 640x480  1.33:1
XXX: zoom=yes pre_clip=no ......
<snip>


What's the transcode command you are using ?
Back to top
View user's profile Send private message
shiznix
Guru
Guru


Joined: 29 Jun 2003
Posts: 367
Location: Adelaide, Australia

PostPosted: Sun Jan 16, 2005 12:00 am    Post subject: Re: skipping .mpg Reply with quote

tlippy01 wrote:
Hi guys, I'm having a problem encoding some video (I think the problem starts with mplex): I transcode the original .avi into .mpa and .m2v files using -V -y ffmpeg,mp2. These files play fine on their own, but after I mplex them together (-f 8) the resulting .mpg file skips on my computer, and when played in a standalone dvd-player it won't even get past the skip, just kinda loops there. If I jump a minute or so into the movie it plays alright (though it still skips, unlike the original .avi). So, since it seems that everything goes smoothly up 'til mplex, I was wondering if anyone could suggest some sort of optimization of/sees anything wring with the way I'm doing this. Thanks!

Hi tlippy01,

Can you post the complete transcode & mplex lines you are using ?

Does mplex give warnings about SCR & DTS ?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks All times are GMT
Goto page Previous  1, 2, 3 ... 12, 13, 14 ... 29, 30, 31  Next
Page 13 of 31

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum