Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Howto author AVI->DVD with menus using Linux only !
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3 ... 20, 21, 22 ... 29, 30, 31  Next  
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks
View previous topic :: View next topic  
Author Message
shiznix
Guru
Guru


Joined: 29 Jun 2003
Posts: 367
Location: Adelaide, Australia

PostPosted: Wed Jun 08, 2005 10:36 am    Post subject: Reply with quote

qwijibow wrote:
EDIT:

would you believe it.... i just copied and pasted the transcode line from the tweakage section, and the whole things encodes fine.

before i tried this, i used diferent profiles, like --export_prof vcd-pal but this suffered the same problem.
so it seems that the killing is caused by some kind of audo detection done by --export_prof.

im going to try and tweak the tweakage transcode line to get similar quality as --export_prof dvd-pal

the problem severity just got downgraded from critical, to minor inconvinience.

My DVD writer came with a great DVD authoring suit (for windows only) but didnt provide an mpeg2 codec.
Linux has an mpeg2 codec, but the tools to use it go way over my head.

After 20 pages and you are still answering questions on this guide, thanks, i truely apreciate it.

That's great news, happy to help!

Glad it finally works, but does using '--export_prof' also break for you in the same way on other .avi files ?

If so, you'd be doing a great service to bring this bug to the attention of the transcode-devel or transcode-user mailing list.
Back to top
View user's profile Send private message
qwijibow
n00b
n00b


Joined: 27 Dec 2004
Posts: 58

PostPosted: Wed Jun 08, 2005 12:12 pm    Post subject: Reply with quote

Quote:
Glad it finally works, but does using '--export_prof' also break for you in the same way on other .avi files ?

If so, you'd be doing a great service to bring this bug to the attention of the transcode-devel or transcode-user mailing list.


Yep, --export_prof killas of all attempts to transcode any of my avi files.

If i had more technical data like a usefull strace log, or just an error message, maybe they could do somthing.

Other than my hardware, make.conf gcc version etc, i wouldnt know what to submit in the report.

EDIT:
FIXED, but its pretty strange. Before i start trancoding, i passed the avi through mencoder.
after this, the transcode works fine, even with --export_prof dvd-pal.

what i dont understand is....
when i run mencoder...
Code:
Pos:5723.7s 171540f (99%) 106fps Trem:   0min 1159mb  A-V:0.065 [1462:224]
Skipping frame!
Pos:5723.9s 171546f (100%) 106fps Trem:   0min 1153mb  A-V:0.065 [1462:224]
Skipping frame!
Pos:5724.1s 171552f (100%) 106fps Trem:   0min 1153mb  A-V:0.065 [1462:224]
Skipping frame!
Pos:5724.2s 171556f (100%) 106fps Trem:   0min 1153mb  A-V:0.065 [1462:224]


mencoder apears to skip every frame. but the output is a working avi file.
i assume this is because im mencoding from AVI to AVI.

origonal file = RIFF (little-endian) data, AVI, 720 x 352, 29.97 fps, video: DivX 3 Fast-Motion, audio: MPEG-1 Layer 3 (stereo, 48000 Hz)
mencoded file = RIFF (little-endian) data, AVI, 720 x 352, 25.00 fps, video: DivX 3 Low-Motion, audio: MPEG-1 Layer 3 (stereo, 48000 Hz)

changed the frames per second, and changed from fast motion to low motion (i dont even know what this is, lol)
but toherwise, these files are the same ?

I thought that maybe mencoder was fixing bugs in the origonal AVI stream, but since transcode fails before it even starts encoding, this doesnt make sence.

ALSO, the mencoded file is taking twice as long to transcode (running at 25fps instead of 60 as before)

I am VERY confused !
Back to top
View user's profile Send private message
shiznix
Guru
Guru


Joined: 29 Jun 2003
Posts: 367
Location: Adelaide, Australia

PostPosted: Sat Jun 11, 2005 12:03 pm    Post subject: Reply with quote

qwijibow wrote:
Quote:
Glad it finally works, but does using '--export_prof' also break for you in the same way on other .avi files ?

If so, you'd be doing a great service to bring this bug to the attention of the transcode-devel or transcode-user mailing list.

Yep, --export_prof killas of all attempts to transcode any of my avi files.

If i had more technical data like a usefull strace log, or just an error message, maybe they could do somthing.

Other than my hardware, make.conf gcc version etc, i wouldnt know what to submit in the report.

EDIT:
FIXED, but its pretty strange. Before i start trancoding, i passed the avi through mencoder.
after this, the transcode works fine, even with --export_prof dvd-pal.

what i dont understand is....
when i run mencoder...
Code:
Pos:5723.7s 171540f (99%) 106fps Trem:   0min 1159mb  A-V:0.065 [1462:224]
Skipping frame!
Pos:5723.9s 171546f (100%) 106fps Trem:   0min 1153mb  A-V:0.065 [1462:224]
Skipping frame!
Pos:5724.1s 171552f (100%) 106fps Trem:   0min 1153mb  A-V:0.065 [1462:224]
Skipping frame!
Pos:5724.2s 171556f (100%) 106fps Trem:   0min 1153mb  A-V:0.065 [1462:224]

mencoder apears to skip every frame. but the output is a working avi file.
i assume this is because im mencoding from AVI to AVI.

original file = RIFF (little-endian) data, AVI, 720 x 352, 29.97 fps, video: DivX 3 Fast-Motion, audio: MPEG-1 Layer 3 (stereo, 48000 Hz)
mencoded file = RIFF (little-endian) data, AVI, 720 x 352, 25.00 fps, video: DivX 3 Low-Motion, audio: MPEG-1 Layer 3 (stereo, 48000 Hz)

changed the frames per second, and changed from fast motion to low motion (i dont even know what this is, lol)
but otherwise, these files are the same ?

I thought that maybe mencoder was fixing bugs in the original AVI stream, but since transcode fails before it even starts encoding, this doesnt make sense.
ALSO, the mencoded file is taking twice as long to transcode (running at 25fps instead of 60 as before)

Mencoder is skipping frames because you are encoding down from 29.97 to 25 fps, this is normal.

If the file works in transcode after being passed through mencoder, then it is unfortunately a transcode problem either auto-probing or decoding the original's video/audio codec(s).
Back to top
View user's profile Send private message
lokojones
Tux's lil' helper
Tux's lil' helper


Joined: 29 Feb 2004
Posts: 131
Location: Canary Islands, Spain.

PostPosted: Mon Jun 20, 2005 12:45 pm    Post subject: Reply with quote

I'm a bit lost.. I dont know where to start from, there are so many pages to search.. I'm a gentoo AMD64 user, and in ~amd64, the lastest transcode version is 0.6.14-r2..
I decided to try it anyway, but It fails in encoding the video, telling me that lame encoding is not available, but Its installed...

could someone make a quick summary of the status of this guide for amd64 people?

thx :)
_________________
Pure Gentoozo :)
Back to top
View user's profile Send private message
shiznix
Guru
Guru


Joined: 29 Jun 2003
Posts: 367
Location: Adelaide, Australia

PostPosted: Thu Jul 07, 2005 4:58 am    Post subject: Any2Vob-0.24 Reply with quote

Hi all,

Have just released a new version of any2vob (0.24) -> http://mightylegends.zapto.org/dvd/any2vob/

Many enhancements, check the Changelog.
Most funky is the new feature of being able to watch the movie as it's being encoded (--preview=yes).
In keeping with making this a CLI only tool, preview mode will work on the console without the need for X11 (as long as mplayer is compiled with +fbcon, or --enable-fbdev), uses mplayer's SDL video driver if running in X11.

Cheers,
Shiznix :wink:
Back to top
View user's profile Send private message
steelrose
Apprentice
Apprentice


Joined: 06 May 2002
Posts: 245
Location: Cyprus

PostPosted: Fri Jul 15, 2005 6:59 am    Post subject: Reply with quote

Hi Shizniz.Thanx for any2vob.Seems to work nice 4 me at the moment?May i ask if it can encode .ts (transport streams) files now and how ?
_________________
Hey.I am new to Linux and i will ask some stupid questions sometimes so please don't get angry with me and help
Back to top
View user's profile Send private message
shiznix
Guru
Guru


Joined: 29 Jun 2003
Posts: 367
Location: Adelaide, Australia

PostPosted: Fri Jul 15, 2005 3:46 pm    Post subject: Reply with quote

steelrose wrote:
Hi Shizniz.Thanx for any2vob.Seems to work nice 4 me at the moment?May i ask if it can encode .ts (transport streams) files now and how ?

Hi Steelrose,
Glad it's working well for you.
Yes, it can take a .ts file as input & encode to a vob.
Example:
Code:
any2vob -i your_file.ts

Many .ts transport streams have more than one video and/or audio track (PIDs) in them & these can be extracted & encoded also (by default any2vob only encodes the first or main PID).

To extract & encode all PIDs to seperate vobs, do:
Code:
any2vob --mpegts_allpids=yes -i your_file.ts

As far as the internal workings of it go, it uses the 'replex' tool to extract & convert PIDs to mpeg PS Program Streams, then 'ffmpeg' encodes to DVD.

* EDIT * - I've just fixed the toolcheck routines, seems the new bash arrays were causing some missing programs to go unchecked under certain circumstances (not sure if this affected anyone, but had the potential to).
A new release with this fix has been posted (0.26) :oops:
Back to top
View user's profile Send private message
Beetle B.
Guru
Guru


Joined: 01 Mar 2003
Posts: 517

PostPosted: Wed Jul 27, 2005 1:49 am    Post subject: Reply with quote

wrote:
Have just released a new version of any2vob (0.24)


Just tried this whole DVD authoring thing for the first time, and used your any2vob.

Unfortunately, I'm having the overscanning issue, and part of the picture is cut off. I know with transcode, I can add "'-j -18,-34,-22,-34'" to fix this. But how do I handle this problem with your any2vob. Any place in the script I can quickly edit?

Thanks.
_________________
Beetle B.

Please update the table of equivalents.
A Firefox guide.
Back to top
View user's profile Send private message
marcos
n00b
n00b


Joined: 28 Jul 2005
Posts: 5

PostPosted: Sat Aug 06, 2005 11:00 pm    Post subject: subtitle problem Reply with quote

Hi averybody!
I'm having a subtitle problem. I've tried everything posted in this thread, every script, every xml file, EVERYTHING, and the subtitles just keep on fu... me :'(. They just won't show up!
Please! HELP! Y don't know what else to do ....
THANKS!
_________________
aish aish, mal, muy mal.
Back to top
View user's profile Send private message
shiznix
Guru
Guru


Joined: 29 Jun 2003
Posts: 367
Location: Adelaide, Australia

PostPosted: Mon Aug 08, 2005 1:11 am    Post subject: Reply with quote

Beetle B. wrote:
wrote:
Have just released a new version of any2vob (0.24)


Just tried this whole DVD authoring thing for the first time, and used your any2vob.

Unfortunately, I'm having the overscanning issue, and part of the picture is cut off. I know with transcode, I can add "'-j -18,-34,-22,-34'" to fix this. But how do I handle this problem with your any2vob. Any place in the script I can quickly edit?

Thanks.
Hi Beetle,

In the latest any2vob (0.26), change the ffmpeg_crop() routine to the following:
Code:
ffmpeg_crop () {
        if [ ! -z "$SRC_ASPECT" ]; then
                T_REAL_WIDTH=`perl -le "print ( $HEIGHT / ( $ASPECT_E ))"`
                S_REAL_WIDTH=`perl -le "print ( $HEIGHT / $SRC_ASPECT )"`
                CLIP=`perl -le "print int(( $T_REAL_WIDTH - $S_REAL_WIDTH ) / 2 )"`
                # Even up $CLIP #
                CLIP=`perl -le "print int( $CLIP / 2 ) * 2"`
                OSCAN=([1]=18 [2]=34 [3]=22 [4]=34)
                if [ ! -z `echo $CLIP | grep "-"` ]; then
                        CROP_ARGS="-padtop ${OSCAN[1]} -padleft ${OSCAN[2]} -padbottom ${OSCAN[3]} -padright ${OSCAN[4]}"
                else
                        CROP_ARGS="-padtop $(( ${OSCAN[1]}+$CLIP )) -padleft ${OSCAN[2]} -padbottom $(( ${OSCAN[3]}+$CLIP )) -padright ${OSCAN[4]}"
                fi
        fi
}

I'll include this in the next version, so that it will be ON by default for NTSC encodings, but can be switched OFF with '--overscan=no'.
Back to top
View user's profile Send private message
shiznix
Guru
Guru


Joined: 29 Jun 2003
Posts: 367
Location: Adelaide, Australia

PostPosted: Mon Aug 08, 2005 1:30 am    Post subject: Re: subtitle problem Reply with quote

marcos wrote:
Hi averybody!
I'm having a subtitle problem. I've tried everything posted in this thread, every script, every xml file, EVERYTHING, and the subtitles just keep on fu... me :'(. They just won't show up!
Please! HELP! Y don't know what else to do ....
THANKS!

Hey Marcos,

Do you get a successful output when spumuxing the subtitles into the final VOB, something like this ?
Code:
INFO: Picture had 2 colors
INFO: Converting filenames to ANSI_X3.4-1968
INFO: Picture had 2 colors
INFO: Picture had 2 colors
INFO: Constructing blank img
INFO: Autodetect 0 = 0x0-720x576
INFO: Pickbuttongroups, success with 1 groups, useimg=1
INFO: Found EOF in .sub file.
INFO: Max_sub_size=4456 WARN: Read 0, expected 4
INFO: 1 subtitles added, 0 subtitles skipped, stream: 32, offset: 0.18

Do they show up in xine ?
If not, then you may need to turn them on (right-click on the video & choose 'Subtitle').
The subtitles can be forced ON by including the 'force' tag in your subtitle.xml file like so:
Code:
<subpictures>
  <stream>
    <spu start="00:00:00.0" end="00:00:00.0"
         highlight="matrix_menu_highlight.png"
         select="matrix_menu_select.png"
         autooutline="infer"
         autoorder="rows"
         force="yes"/>
  </stream>
</subpictures>

Are you using the 'dvdauthor-0.6.11_subtitle_colours.diff' patch ?
If so, then you will need to provide the palette file every time you use 'dvdauthor' & adjust your dvdauthor.xml accordingly, or the subtitles will come out black (black subtitles on a black background = "WTF are my subtitles?").
Back to top
View user's profile Send private message
marcos
n00b
n00b


Joined: 28 Jul 2005
Posts: 5

PostPosted: Mon Aug 08, 2005 4:59 pm    Post subject: cp subs to avi Reply with quote

shiznix
I,m not using the 'dvdauthor-0.6.11_subtitle_colours.diff' patch and all the output seens right.
For now I paste the subs in the avi file doing this:
mencoder -ovc lavc -lavcopts vcodec=mpeg4 -oac copy -sub matrix.srt matrix.avi -o matrix_sub.avi
and then do all the rest in the howto.
I now whant to know if there is a better way of doing this. The matrix_sub.avi file looks good but the video quality is a bit worse than the original matrix.avi file.
Is there any way to keep the quality of the original movie?.
Thanks!
_________________
aish aish, mal, muy mal.
Back to top
View user's profile Send private message
shiznix
Guru
Guru


Joined: 29 Jun 2003
Posts: 367
Location: Adelaide, Australia

PostPosted: Tue Aug 09, 2005 12:09 am    Post subject: Re: cp subs to avi Reply with quote

marcos wrote:
shiznix
I'm not using the 'dvdauthor-0.6.11_subtitle_colours.diff' patch and all the output seems right.
For now I paste the subs in the avi file doing this:
mencoder -ovc lavc -lavcopts vcodec=mpeg4 -oac copy -sub matrix.srt matrix.avi -o matrix_sub.avi
and then do all the rest in the howto.
I now want to know if there is a better way of doing this. The matrix_sub.avi file looks good but the video quality is a bit worse than the original matrix.avi file.
Is there any way to keep the quality of the original movie?.
Thanks!

As you probably know, what you are doing is known as hard subbing, and in (nearly?) all cases will not work for converting to DVD.
It's also not recommended as you limit DVD playback functionality, the user is locked into one subtitle without the ability to change to multiple subtitle streams, nor can the user switch the subtitles off.
For DVD, don't hard sub, remove '-sub matrix.srt' from your mencoder line.

Try passing matrix.avi through Transcode first, only then if it fails use the mencoder line shown in the howto to create a file that Transcode will be happy with.
Transcode will not work with mplayer's new mpeg4 codec, you must use 'vcodec=msmpeg4' (mplayer created their own fourcc (FMP4) for mpeg4).
At this point you'll also see that your mencoder line is missing video bitrate & high quality settings '-lavcopts vcodec=msmpeg4:vbitrate=5000:vhq' (this is why your video quality is suffering).

Don't use '-oac copy' as Transcode does not support some types of audio, always use '-oac lavc -lavcopts acodec=mp3 -srate 48000'.

Anyway, all the above is outlined in the howto.

Basic process goes like this:
* Pre-process with mencoder only if Transcode cannot correctly recognise the file
* transcode to file.m2v/file.ac3
* mplex file.m2v/file.ac3 to file.vob
* Mux file.srt subtitle(s) into file.vob using spumux

As a side note, it is possible to create DVD compliant mpeg2 video with mencoder in one pass, which at present seems to have scaling, framerate conversion & aspect issues.
Something to hope for in the future :wink:
Back to top
View user's profile Send private message
Beetle B.
Guru
Guru


Joined: 01 Mar 2003
Posts: 517

PostPosted: Tue Aug 09, 2005 10:03 pm    Post subject: Reply with quote

Hi Beetle,

In the latest any2vob (0.26), change the ffmpeg_crop() routine to the following:


Thanks!
_________________
Beetle B.

Please update the table of equivalents.
A Firefox guide.
Back to top
View user's profile Send private message
zaiyon
Apprentice
Apprentice


Joined: 19 May 2004
Posts: 219
Location: Germany

PostPosted: Mon Aug 15, 2005 8:59 am    Post subject: troubles with spumux Reply with quote

Hi, great howto, I used it several times now. But now I tried to add subtitles, and couldn't do it, this is my spumux file:
Code:

<subpictures>
  <stream>
    <textsub filename="trhps.ssa" characterset="ISO8859-1"
             fontsize="18.0" font="Vera.ttf" horizontal-alignment="center"
             vertical-alignment="bottom" left-margin="60"
             right-margin="60"
             top-margin="20" bottom-margin="30"
             subtitle-fps="25"
             movie-fps="25" movie-width="720"
             movie-height="574"/>
  </stream>
</subpictures>


and this is what happens:
Code:

$ spumux -s0 subtitle.xml < trhps.mpg > trhps-sub.mpg
DVDAuthor::spumux, version 0.6.11.
Build options: gnugetopt magick iconv freetype fribidi
Send bugs to <dvdauthor-users@lists.sourceforge.net>

INFO: Locale=en_US.utf8
INFO: Converting filenames to UTF-8
INFO: Detected subtitle file format: ssa
INFO: Opened iconv descriptor. *UTF-8* *ISO8859-1*
INFO: Read 1192 subtitles
INFO: Unicode font: 255 glyphs.
File size limit exceeded


Hint: I use an UTF-8 system.

The subtitle file is (as you can see) .saa format, and works just fine, testet with mplayer.

BTW, I currently plan to add the same movie twice to the same DVD, one with subtitles and one without, so that you can turn em off. (My menu has two buttons: "play with sub" and "play without sub")

Is there by any chance a more elegant way to make use of subtitles? Let the DVD player show em or whatever? When I buy commercial DVDs, I can usually turn subtitles on and of as I wish (even during playback)
_________________
What do you have when you have six lawyers buried up to their necks in sand? Not enough sand.
My Project - open Outcast
Back to top
View user's profile Send private message
shiznix
Guru
Guru


Joined: 29 Jun 2003
Posts: 367
Location: Adelaide, Australia

PostPosted: Mon Aug 15, 2005 10:39 pm    Post subject: Re: troubles with spumux Reply with quote

zaiyon wrote:
Hi, great howto, I used it several times now. But now I tried to add subtitles, and couldn't do it, this is my spumux file:

Code:

<subpictures>
  <stream>
    <textsub filename="trhps.ssa" characterset="ISO8859-1"
             fontsize="18.0" font="Vera.ttf" horizontal-alignment="center"
             vertical-alignment="bottom" left-margin="60"
             right-margin="60"
             top-margin="20" bottom-margin="30"
             subtitle-fps="25"
             movie-fps="25" movie-width="720"
             movie-height="574"/>
  </stream>
</subpictures>
and this is what happens:
Code:

$ spumux -s0 subtitle.xml < trhps.mpg > trhps-sub.mpg
DVDAuthor::spumux, version 0.6.11.
Build options: gnugetopt magick iconv freetype fribidi
Send bugs to <dvdauthor-users@lists.sourceforge.net>

INFO: Locale=en_US.utf8
INFO: Converting filenames to UTF-8
INFO: Detected subtitle file format: ssa
INFO: Opened iconv descriptor. *UTF-8* *ISO8859-1*
INFO: Read 1192 subtitles
INFO: Unicode font: 255 glyphs.
File size limit exceeded


This looks like a filesystem limitation, and not a message from dvdauthor or spumux itself.
Is the final file perhaps being written to a FAT/VFAT/FAT16/FAT32 filesystem ?

Quote:
Hint: I use an UTF-8 system.

The subtitle file is (as you can see) .ssa format, and works just fine, tested with mplayer.

BTW, I currently plan to add the same movie twice to the same DVD, one with subtitles and one without, so that you can turn em off. (My menu has two buttons: "play with sub" and "play without sub")

Is there by any chance a more elegant way to make use of subtitles? Let the DVD player show em or whatever? When I buy commercial DVDs, I can usually turn subtitles on and of as I wish (even during playback)

There is a better way.
There is no need to encode the movie twice, simply assign the relevant button to each subtitle stream in your dvdauthor.xml file like so:
Code:

  <titleset>

    <menus>
      <pgc>
        <button> subtitle = 64; jump title 1; </button>
        <button> subtitle = 65; jump title 1; </button>
        <vob file="matrix_menu_final.mpg"/>
        <post> jump cell 1; </post>
      </pgc>
    </menus>

    <titles>
      <pgc>
        <vob file="matrix_dvd.mpg" chapters="0,0:30,1:00,1:30,2:30,3:00,3:30,4:00"/>
          <post> call menu; </post>
      </pgc>
    </titles>

  </titleset>

Specifying subtitle values:
0-31 means the subtitle stream numbers 0-31 will be turned off.
64-95 means the subtitle stream numbers 0-31 will be turned on.

Specifying the tag 'force=yes' in your spumux.xml file for the subtitle stream will override the above values & force that subtitle stream to be displayed.
You can get a bit more of an idea of how the subtitling values work from 'man dvdauthor'.
Back to top
View user's profile Send private message
igds
n00b
n00b


Joined: 04 Aug 2004
Posts: 39

PostPosted: Tue Aug 23, 2005 8:28 am    Post subject: Reply with quote

The transcode option -J modfps=clonetype=3 caused a video problem for me, which was remedied by its omission (at least to my satisfaction, with the caveat that I was just looking for the easiest working solution).

Code:
transcode -i matrix.avi \
          -y ffmpeg \
         --export_prof dvd-ntsc --export_asr 3 --export_fps 29.97 \
          -J modfps=clonetype=3 \
          -D0 -s2 \
          -m matrix.ac3 \
          -o matrix

Taken from the How-To (2005-08-22) and edited for readability.

NCSALT-DVD.mpg is a self-made video that Pinnacle Studio (v9, I think, or else v7) claims is DVD-video compliant.
Code:
$ ls -hl NCSALT-DVD.mpg
[...] 3.0G [...] NCSALT-DVD.mpg

$ tcprobe -i NCSALT-DVD.mpg
[tcprobe] MPEG program stream (PS)
[tcprobe] summary for NCSALT-DVD.mpg, (*) = not default, 0 = not detected
import frame size: -g 720x480 [720x576] (*)
     aspect ratio: 4:3 (*)
       frame rate: -f 23.976 [25.000] frc=1 (*)
                   PTS=0.2315, frame_time=41 ms, bitrate=8000 kbps
      audio track: -a 0 [0] -e 48000,16,2 [48000,16,2] -n 0x50 [0x2000] (*)
                   PTS=0.1982, bitrate=224 kbps
                   -D 0 --av_fine_ms 33 (frames & ms) [0] [0]

Of course, dvdauthor choked when fed this file directly.

So I used the transcode command above with the appropriate changes.
Code:
transcode -i NCSALT-DVD.mpg \
          -y ffmpeg \
         --export_prof dvd-ntsc --export_asr 2 --export_fps 29.97 \
          -J modfps=clonetype=3 \
          -D0 -s2 \
          -m ncsalt_dvd.ac3 \
          -o ncsalt_dvd

After mplexing the resulting files, I noticed the audio was out of sync -- but it wasn't just that. The problem was actually with ncsalt_dvd.m2v and its speed. I'm afraid I didn't keep the bad file around to tcprobe it, but I will describe the problem thus.

The beginning of the video shows a series of still images, so I could easily (if not accurately) measure that the video was moving slower than proper. One image was shown for about 10 seconds, compared to the original 8; the others were shown for 5 seconds vis-a-vis 4. (Nothing was wrong with the audio, thankfully.)

Adding the --pulldown option did nothing (nor did removing -D0 nor -s2, just to be thorough). Removing the -J modfps=clonetype=3 option solved the problem, and I ended up with what I perceived to be a good and synced video and everything proceded smoothly from there on. (Looking at my bash history, it seems I also omitted -D0 in the final command, so I transcribe it thus even though I don't expect it had anything to do with anything.)
Code:
transcode -i NCSALT-DVD.mpg \
          -y ffmpeg \
         --export_prof dvd-ntsc --export_asr 2 --export_fps 29.97 \
          -s2 \
          -m ncsalt_dvd.ac3 \
          -o ncsalt_dvd

The resulting ncsalt_dvd.mpg after
Code:
$ mplex -f 8 -o ncsalt_dvd.mpg ncsalt_dvd.m2v ncsalt_dvd.ac3
is thus:
Code:
$ ls -hl ncsalt_dvd.mpg
[...] 2.2G [...] ncsalt_dvd.mpg

$ tcprobe -i ncsalt_dvd.mpg
[tcprobe] MPEG program stream (PS)
[tcprobe] summary for ncsalt_dvd.mpg, (*) = not default, 0 = not detected
import frame size: -g 720x480 [720x576] (*)
     aspect ratio: 4:3 (*)
       frame rate: -f 23.976 [25.000] frc=1 (*)
                   PTS=0.1780, frame_time=41 ms, bitrate=9000 kbps
      audio track: -a 0 [0] -e 48000,16,2 [48000,16,2] -n 0x2000 [0x2000]
                   PTS=0.1780, bitrate=224 kbps
                   -D 0 --av_fine_ms 0 (frames & ms) [0] [0]

The DVD I burned after authoring from ncsalt_dvd.mpg at least works in my standalone DVD player; that and my PC players are the extent of my testing capabilities, so I hope it doesn't choke on other players.

I realize that this may not the most optimal of solutions so, besides giving a heads up to anyone who might also be using Pinnacle Studio, I'm curious if anyone has any suggestions or comments; in particular, I'm a bit alarmed by the reduction of the video's filesize by 0.8 GB.

As a side note, I was accessing the files in question over Ethernet from a CIFS (see: SMB) mount, the files themselves residing on a Windows XP Pro machine. Also, the video itself is mostly just of people talking, sitting, and some dance performances.


By the way, thanks to every one for their efforts both past and present.
Back to top
View user's profile Send private message
Mythos
l33t
l33t


Joined: 02 May 2004
Posts: 953
Location: Portugal

PostPosted: Wed Aug 24, 2005 12:33 pm    Post subject: Reply with quote

Sorry but ...

Can i get a program like Nero Vision, simple as Nero Vision for linux ???

thanks [[]]
_________________
Best Regards,
Sérgio Henrique
Linux dune 3.0.6-gentoo #1 SMP Thu Oct 27 16:47:29 WEST 2011 x86_64 Intel(R) Core(TM)2 Duo CPU T7500 @ 2.20GHz GenuineIntel GNU/Linux
Back to top
View user's profile Send private message
majunbu
n00b
n00b


Joined: 02 Jul 2003
Posts: 13
Location: Ohio

PostPosted: Mon Aug 29, 2005 2:27 am    Post subject: Reply with quote

Question

I have just recently returned to Gentoo Linux from Windows and am familare with how and why things happen in that invironment concerning DVD creation from AVI's. I am working through trying to create a DVD following the instructions found in this thread. I have successfully created a DVD using the any2vob script file and following the menu and burning instructions with little problem. But I have a problem in the finished DVD as you get futher into the it I experiance an audio sycn problem and a video juerkyness issue especially with high motion scenes.

Right now I am sorta at a loss on how to address these issue's. So I am going back through and doing things manually not using the script. Here is the info on the avi I am trying to encode.

    624x352 mpeg4 Xvid
    44 Khz 128 audio
    23.976 fps

Here is the command I am currently using.
Code:

transcode -i bsg_2003_part1.avi -y ffmpeg --export_prof dvd-ntsc --export_asr 3 -o bsg2003p1 -D0 -s2 -m bsg2003p1.ac3 -J modfps=clonetype=4 --export_fps 29.970,4


Now my main question which could be the link to my problems is this. When the encoding starts on the status display it shows that it is encoding frames at a rate about 32fps and then steadly drops to about 21fps give or take. Is this normal? even though I had specified NTSC frame rates?

Any help is greatly appreciated. :D
Back to top
View user's profile Send private message
JerryWoody
n00b
n00b


Joined: 05 Sep 2005
Posts: 1

PostPosted: Mon Sep 05, 2005 7:04 am    Post subject: few quick notes Reply with quote

first off, I just want to join others in thanking you for offering such a great guide. I just got into using linux to create dvds after getting frustrated with nero, and after a lot of searching I can tell you that your post is far and away the best guide to the linux toolset... very straightforward and complete.

the only suggestion i'd like to make concerns your use of mencoder to turn random videos into avis before feeding to transcode. your method converts the audio to mp3 before converting again to ac3, which will result in some unnecessary quality loss. if you use "-oac pcm" instead of "-oac lavc -lavcopts acodec=mp3", you can avoid this quality loss. you will need more disk space using pcm as an intermediate format, but if you have enough for creating dvds, it shouldn't be an issue. On a similar note, using msmpeg4 for an intermediate video format is also causing quality loss. I tried using raw video, but transcode didn't like that, so I'd suggest using ffmpeg's mpeg4 format instead (just remove the -lavcopts line specifying the vcodec, as mpeg4 is the default). There will still be loss of quality, but less than msmpeg4. I saw that you noted that the new default fourcc for mpeg4 causes some problems, but you can work around that by specifying -ffourcc DX50.

in short, I suggest this command line to convert random videos to avi:
Code:
mencoder -o output_file.avi -ovc lavc -lavcopts vbitrate=5000:vhq -ffourcc DX50 -oac pcm -srate 48000 -ofps 29.97 your_movie.mov


on a different note, I needed to combine multiple videos into one title for my dvd. This is probably a common task, so i thought it might be useful for me to share what i learned. There are 2 different attacks to joining the videos: before transcode or after transcode. Before transcode is probably simplest: mencoder will accept multiple videos on the input line, so you can just do mencoder [various options .... ] part1.mov part2.mov ...
If your sources are already avis, you can just use avimerge. Not sure if that tool requires all avis to be in the same format.
The advantage to joining after transcode is that it makes defining chapter points easier, if each video already represents a chapter. Simply define multiple vobs within a pgc block:
Code:
<pgc>
    <vob file="part1.mpg" />
    <vob file="part2.mpg" />
</pgc>

Chapter 2 of the title will automatically go to the video in part2.mpg. Useful when you're piecing together a home movie from many clips of various lengths.

I hope I'm not repeating stuff others have already said... I didn't wade through all 20+ pages of this thread. Just thought some of this stuff might be useful enough to go in the main post.
Back to top
View user's profile Send private message
lodder_
Apprentice
Apprentice


Joined: 06 Nov 2004
Posts: 162
Location: Knokke-Heist, Belgium

PostPosted: Tue Sep 06, 2005 6:19 pm    Post subject: Reply with quote

I'm having problem with ffmpeg it suddenly stops recording working termanila is looked up and i have to kill it

if some one can help me solve this problem pls do
_________________
delodder.be
Back to top
View user's profile Send private message
shiznix
Guru
Guru


Joined: 29 Jun 2003
Posts: 367
Location: Adelaide, Australia

PostPosted: Thu Sep 15, 2005 1:53 pm    Post subject: Re: few quick notes Reply with quote

JerryWoody wrote:
first off, I just want to join others in thanking you for offering such a great guide. I just got into using linux to create dvds after getting frustrated with nero, and after a lot of searching I can tell you that your post is far and away the best guide to the linux toolset... very straightforward and complete.

Thanks for the compliment.

Quote:
The only suggestion i'd like to make concerns your use of mencoder to turn random videos into avis before feeding to transcode. your method converts the audio to mp3 before converting again to ac3, which will result in some unnecessary quality loss. if you use "-oac pcm" instead of "-oac lavc -lavcopts acodec=mp3", you can avoid this quality loss. you will need more disk space using pcm as an intermediate format, but if you have enough for creating dvds, it shouldn't be an issue. On a similar note, using msmpeg4 for an intermediate video format is also causing quality loss. I tried using raw video, but transcode didn't like that, so I'd suggest using ffmpeg's mpeg4 format instead (just remove the -lavcopts line specifying the vcodec, as mpeg4 is the default). There will still be loss of quality, but less than msmpeg4. I saw that you noted that the new default fourcc for mpeg4 causes some problems, but you can work around that by specifying -ffourcc DX50.

in short, I suggest this command line to convert random videos to avi:
Code:
mencoder -o output_file.avi -ovc lavc -lavcopts vbitrate=5000:vhq -ffourcc DX50 -oac pcm -srate 48000 -ofps 29.97 your_movie.mov

This looks good. I didn't know using mpeg4 & encoding with the -fourcc option would make transcode happy & the encoding to pcm instead of mp3 is also a nice touch. I'll test & update the guide.

Quote:
on a different note, I needed to combine multiple videos into one title for my dvd. This is probably a common task, so i thought it might be useful for me to share what i learned. There are 2 different attacks to joining the videos: before transcode or after transcode. Before transcode is probably simplest: mencoder will accept multiple videos on the input line, so you can just do mencoder [various options .... ] part1.mov part2.mov ...
If your sources are already avis, you can just use avimerge. Not sure if that tool requires all avis to be in the same format.

Only framerate & resolution need to be the same IIRC.

Quote:
The advantage to joining after transcode is that it makes defining chapter points easier, if each video already represents a chapter. Simply define multiple vobs within a pgc block:
Code:
<pgc>
    <vob file="part1.mpg" />
    <vob file="part2.mpg" />
</pgc>

Chapter 2 of the title will automatically go to the video in part2.mpg. Useful when you're piecing together a home movie from many clips of various lengths.

Also handy to know.

Quote:
I hope I'm not repeating stuff others have already said... I didn't wade through all 20+ pages of this thread. Just thought some of this stuff might be useful enough to go in the main post.

Not repeating at all, thanks for sharing the knowledge :)
Back to top
View user's profile Send private message
shiznix
Guru
Guru


Joined: 29 Jun 2003
Posts: 367
Location: Adelaide, Australia

PostPosted: Thu Sep 15, 2005 2:06 pm    Post subject: Reply with quote

majunbu wrote:
Question

I have just recently returned to Gentoo Linux from Windows and am familare with how and why things happen in that invironment concerning DVD creation from AVI's. I am working through trying to create a DVD following the instructions found in this thread. I have successfully created a DVD using the any2vob script file and following the menu and burning instructions with little problem. But I have a problem in the finished DVD as you get futher into the it I experiance an audio sycn problem and a video juerkyness issue especially with high motion scenes.

Right now I am sorta at a loss on how to address these issue's. So I am going back through and doing things manually not using the script. Here is the info on the avi I am trying to encode.

    624x352 mpeg4 Xvid
    44 Khz 128 audio
    23.976 fps

Here is the command I am currently using.
Code:

transcode -i bsg_2003_part1.avi -y ffmpeg --export_prof dvd-ntsc --export_asr 3 -o bsg2003p1 -D0 -s2 -m bsg2003p1.ac3 -J modfps=clonetype=4 --export_fps 29.970,4


Now my main question which could be the link to my problems is this. When the encoding starts on the status display it shows that it is encoding frames at a rate about 32fps and then steadly drops to about 21fps give or take. Is this normal? even though I had specified NTSC frame rates?

Any help is greatly appreciated. :D

The encoding framerate has nothing to do with the end result's playback framerate, this is just a live status report from transcode to say how fast the encoding is being done.

Regarding the jerkiness in high motion scenes, have you tried the suggestion mentioned in the howto under 'Jerky video & skipping audio' ?

My thought is that your DVD player is not coping too well with the encoded video bitrate & so needs to be re-encoded at a lower video bitrate value.
Back to top
View user's profile Send private message
DoctorWack
n00b
n00b


Joined: 26 Sep 2004
Posts: 14
Location: Whereabouts unknown, assumed armed and dangerous.

PostPosted: Fri Sep 16, 2005 4:49 am    Post subject: Reply with quote

I have a similar problem to kabutor's. I try to run spumux and get:
Code:
[razorblade root /home/doctorwack/FF7]# spumux -s0 sub.xml < FF7.mpg > FF7.mpg.temp
DVDAuthor::spumux, version 0.6.11.
Build options: gnugetopt magick iconv freetype fribidi
Send bugs to <dvdauthor-users@lists.sourceforge.net>

INFO: Locale=C
INFO: Converting filenames to ANSI_X3.4-1968
INFO: Detected subtitle file format: ssa
INFO: Opened iconv descriptor. *UTF-8* *ISO8859-1*
INFO: Read 600 subtitles
ERR: New_Face failed. Maybe the font path is wrong.
Please supply the text font file (luximb.ttf).
WARN: subtitle font: load_sub_face failed.
Segmentation fault

But I made sure to copy the Vera.ttf font from /usr/X11R6/lib/X11/fonts/TTF/ to ~/.spumux
I've tried it with several different fonts, with no success.
Here's my sub.xml :
Code:

<subpictures>
  <stream>
    <textsub filename="bien-xvid-ff7.ssa" characterset="ISO8859-1"
         fontsize="18.0" font="Vera.ttf" horizontal-alignment="center"
         vertical-alignment="bottom" left-margin="60" right-margin="60"
         top-margin="20" bottom-margin="30" subtitle-fps="23.976"
         movie-fps="29.97" movie-width="720" movie-height="574"/>
  </stream>
</subpictures>


If you could help me figure this out, I'd really appreciate it.
_________________
War is Peace
Freedom is Slavery
Ignorance is Strength
Two and Two Make Five.
Back to top
View user's profile Send private message
buckminster
Tux's lil' helper
Tux's lil' helper


Joined: 06 Oct 2004
Posts: 80
Location: Oberhausen, Germany

PostPosted: Fri Sep 16, 2005 7:44 am    Post subject: Reply with quote

Hi,

I know that its not the level you´re talking on, but I got a problem with dvdauthor and I think here´s somebody who could help me.

dvdauthor always breaks with an error message
Quote:
ERR SCR moves backwards remultiplex input
I get this with my own slideshow vobs, but also with vobs which I copied from a dvd.

In this thread I read the tip to use transcode and mplex to split and multiplex the vobs to keep or to get back the vobus. I tried that, but all I get is an error message of mplex that too many frames are dropped. What a pity.

Now my question: What else could be the trick to get dvdauthor to build my dvd without breaking with an error message, or what could be the reason for this errors.

Greetz

Frank
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks All times are GMT
Goto page Previous  1, 2, 3 ... 20, 21, 22 ... 29, 30, 31  Next
Page 21 of 31

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum