Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Failed to bring eth0 up
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Dutch
View previous topic :: View next topic  
Author Message
The_Loserkid
Tux's lil' helper
Tux's lil' helper


Joined: 16 Nov 2003
Posts: 101
Location: Merksem, Belgium

PostPosted: Mon Dec 29, 2003 7:55 pm    Post subject: Failed to bring eth0 up Reply with quote

hey, ik heb net men 2.4.20-gentoo-r8 kernel gerecompiled met ipmasq settings zodat ik ipmasquerading kan doen met men gentoo bak

in de pc zit een RTL8139 netwerkkaart
in de kernel waren er 2 device drivers voor RTL8139, ik heb ze beiden geselecteerd om in de kernel in te bouwen, dus niet als modules

als ik de pc echter opstart krijg ik volgend scherm te zien:
http://users.pandora.be/TLK/eth0.JPG

om een of andere reden kan hij de netwerkkaart dus niet initialiseren
ik denk niet dat het een driversprobleem is want als ik
Code:
# dmesg |grep eth0

doe, dan krijg ik volgend antwoord
Code:
eth0: Realtek RTL8139 Fast Ethernet at 0xd0a2a000, 00;50;fc;e4;e6;0d, IRQ 10
eth0: Identified 8139 chip type 'RTL-8139C'

dus hij vindt de kaart weldegelijk ....

als ik terug met mijn oude kernel boot is er niets aan de hand, die blijft de netwerkkaart perfect herkennen
spijtig genoeg heb ik geen backup van de .config file van deze kernel en weet ik ook niet meer welke settings ik daar nu juist heb gebruikt ...


heeft er iemand een idee waar het aan kan liggen dat hij de eth0 niet kan initialiseren ?
Back to top
View user's profile Send private message
rockfly
Apprentice
Apprentice


Joined: 27 Apr 2003
Posts: 179

PostPosted: Tue Dec 30, 2003 5:57 pm    Post subject: Reply with quote

je hebt 2 verschillende 8139 en 8139C , let goed op dat je de goede hebt, probeer anders die andere te compileren, ik heb zelf de 8139 versie (zonder C) bij mij werkt de c versie ook niet een geeft ie ook zoiets aan geloof ik.
Back to top
View user's profile Send private message
The_Loserkid
Tux's lil' helper
Tux's lil' helper


Joined: 16 Nov 2003
Posts: 101
Location: Merksem, Belgium

PostPosted: Tue Dec 30, 2003 8:34 pm    Post subject: Reply with quote

rockfly wrote:
je hebt 2 verschillende 8139 en 8139C , let goed op dat je de goede hebt, probeer anders die andere te compileren, ik heb zelf de 8139 versie (zonder C) bij mij werkt de c versie ook niet een geeft ie ook zoiets aan geloof ik.


zallik proberen, bedankt
Back to top
View user's profile Send private message
sfbtkm2
n00b
n00b


Joined: 21 Jun 2003
Posts: 2
Location: Belgium

PostPosted: Wed Jan 21, 2004 6:26 pm    Post subject: Reply with quote

Oftewel kan het zijn dat je een oud Realtek chipset hebt en dan moet je in de kernel de support for old Realtek chipsets aanvinken (en dan de kernel natuurlijk hercompileren).
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Dutch All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum