Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
alsa sound mixing aka dmix (not arts or esd needed)
View unanswered posts
View posts from last 24 hours

Goto page 1, 2, 3 ... 10, 11, 12  Next  
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks
View previous topic :: View next topic  
Author Message
Redeeman
l33t
l33t


Joined: 25 Sep 2003
Posts: 957
Location: Denmark

PostPosted: Wed Jan 07, 2004 11:10 pm    Post subject: alsa sound mixing aka dmix (not arts or esd needed) Reply with quote

note: i have only tested this on my cmedia 8738 and Analog Devices AD1980

first you need to make sure you have alsa working with your card.
then you will want to emerge the alsa-oss package that fits for your alsa version (you can eventually use dmesg to see the version) but your alsa-lib and alsa-utils (if using 2.4) alsa-driver package should be of same version, and then you can just do:

Code:
qpkg -I -v |redeeman@redeeman: ~$ qpkg -I -v | grep alsa
media-libs/alsa-lib-1.0.0_rc2 *
media-sound/alsa-utils-1.0.0_rc2 *

though, this requires you have gentoolkit installed.

so now i would want to do:

Code:
redeeman@redeeman: ~$ su
Password:

root@redeeman: /home/redeeman$ emerge /usr/portage/media-libs/alsa-oss/alsa-oss-1.0.0_rc2.ebuild


so it becomes:
Code:
redeeman@redeeman: ~$ qpkg -I -v | grep alsa
media-libs/alsa-oss-1.0.0-rc2 *
media-libs/alsa-lib-1.0.0_rc2 *
media-sound/alsa-utils-1.0.0_rc2 *


now you might want to know, what do the alsa-oss do?! simple, it tricks applications thats using oss to be using alsa, so out dmix is working ;) (though its recommended to use native alsa if possible)

now we are ready to create ~/.asoundrc, to enable the dmix plugin, and wrap dsp0 and default pcm interface over to our dmixer pcm device, my ~/.asoundrc looks like this:

Code:
pcm.dmixer {
    type dmix
    ipc_key 1024
    slave {
        pcm "hw:0,0"
        period_time 0
        period_size 1024
        buffer_size 8192
 rate 44100
    }

    bindings {
        0 0
        1 1
    }
}

pcm.dsp0 {
    type plug
    slave.pcm "dmixer"
}

pcm.!default {
        type plug
        slave.pcm "dmixer"
}

pcm.default {
 type plug
 slave.pcm "dmixer"
}

ctl.mixer0 {
    type hw
    card 0
}


i have seen this working taken directly in many cases, though it might not work on all cards.. :(

be sure to specify the device to default in the alsa applications.
to run your applications thats using oss, do like this:

aoss <applicationname>

and it should work.

Application specific stuff:

xmms:
you can emerge media-plugins/alsa-xmms to get native alsa support in xmms, and then you just adjust it to use default pcm device, and you are set!

mplayer:
if you enable alsa at compile time(done via USE variables) you can edit /etc/mplayer.conf in the line where you see ao=oss to:
Code:
ao=alsa9:default

or simply start mplayer like this:
Code:
mplayer -ao alsa9:default movie.avi


Test if it works
now start mplayer on a movie, and start xmms with a file, and try some application that uses oss. and see if it works! and then enjoy!

Questions
in mplayer, you use alsa9:default????
yes. i know it, but thats how it is!
_________________
Sandberg Enterprises


Last edited by Redeeman on Sun Sep 05, 2004 6:35 pm; edited 2 times in total
Back to top
View user's profile Send private message
hanzotutu
Apprentice
Apprentice


Joined: 10 Apr 2003
Posts: 170

PostPosted: Thu Jan 08, 2004 12:40 am    Post subject: Reply with quote

I follow the instruction. However, it still doesn't work.
my card is intel AC97.


    root@scimd movies # more /etc/mplayer.conf
    ##
    ## MPlayer config file
    ##
    ## This file can be copied to /usr/local/etc/mplayer.conf and/or ~/.mplayer/conf
    ig .
    ## If both exist, the ~/.mplayer/config's settings override the
    ## /usr/local/etc/mplayer.conf ones. And, of course command line overrides all.
    ## The options are the same as in the command line, but they can be specified
    ## more flexibly here. See below.
    ##

    # vo=xv # To specify default video driver (see -vo help for
    # list)

    ao=alsa9:default # To specify default audio driver (see -ao help for
    # list)

    ....



    hanzo@scimd movies $ mplayer movie.avi
    ...
    Checking audio filter chain for 48000Hz/2ch/16bit -> 48000Hz/2ch/16bit...
    AF_pre: af format: 2 bps, 2 ch, 48000 hz, little endian signed int
    AF_pre: 48000Hz 2ch Signed 16-bit (Little-Endian)
    alsa-init: requested format: 48000 Hz, 2 channels, Signed 16-bit (Little-Endian)
    alsa-init: soundcard set to default
    alsa-init: unable to set periodsize: Invalid argument
    Could not open/initialize audio device -> no sound.
    Audio: no sound
    Starting playback...
    ...




    root@scimd movies # qpkg -I -v | grep alsa
    media-libs/alsa-lib-1.0.0_rc2 *
    media-libs/alsa-oss-1.0.0_rc2 *
    media-sound/alsa-utils-1.0.0_rc2 *
    media-plugins/alsa-xmms-0.9.12 *
    root@scimd movies #
Back to top
View user's profile Send private message
Ian
l33t
l33t


Joined: 28 Oct 2002
Posts: 834
Location: Somerville, MA

PostPosted: Thu Jan 08, 2004 4:18 am    Post subject: Reply with quote

I followed everything, but I don't think it's working because I'm missing /etc/asound.state.

I'm not a big media buff (on linux at least), and I'm just using alsa-oss emulation through the 2.6 kernel, and it works. But I have the same sound card (CMedia 8738), so I figured why not try this.

Can you go through all the steps of actually setting up alsa, or point to a good place that has instructions, because I never found one that worked for me or I was able to understand :oops:.

Oh well, you learn something new everyday...
Back to top
View user's profile Send private message
Redeeman
l33t
l33t


Joined: 25 Sep 2003
Posts: 957
Location: Denmark

PostPosted: Thu Jan 08, 2004 1:40 pm    Post subject: Reply with quote

hanzotutu wrote:
I follow the instruction. However, it still doesn't work.
my card is intel AC97.


    root@scimd movies # more /etc/mplayer.conf
    ##
    ## MPlayer config file
    ##
    ## This file can be copied to /usr/local/etc/mplayer.conf and/or ~/.mplayer/conf
    ig .
    ## If both exist, the ~/.mplayer/config's settings override the
    ## /usr/local/etc/mplayer.conf ones. And, of course command line overrides all.
    ## The options are the same as in the command line, but they can be specified
    ## more flexibly here. See below.
    ##

    # vo=xv # To specify default video driver (see -vo help for
    # list)

    ao=alsa9:default # To specify default audio driver (see -ao help for
    # list)

    ....



    hanzo@scimd movies $ mplayer movie.avi
    ...
    Checking audio filter chain for 48000Hz/2ch/16bit -> 48000Hz/2ch/16bit...
    AF_pre: af format: 2 bps, 2 ch, 48000 hz, little endian signed int
    AF_pre: 48000Hz 2ch Signed 16-bit (Little-Endian)
    alsa-init: requested format: 48000 Hz, 2 channels, Signed 16-bit (Little-Endian)
    alsa-init: soundcard set to default
    alsa-init: unable to set periodsize: Invalid argument
    Could not open/initialize audio device -> no sound.
    Audio: no sound
    Starting playback...
    ...




    root@scimd movies # qpkg -I -v | grep alsa
    media-libs/alsa-lib-1.0.0_rc2 *
    media-libs/alsa-oss-1.0.0_rc2 *
    media-sound/alsa-utils-1.0.0_rc2 *
    media-plugins/alsa-xmms-0.9.12 *
    root@scimd movies #


try open xmms, and goto preferences, and then change output plugin to alsa, and try play something, if it works there its your mplayer that didnt get compiled with alsa support. let me know if it doesent work
_________________
Sandberg Enterprises
Back to top
View user's profile Send private message
Redeeman
l33t
l33t


Joined: 25 Sep 2003
Posts: 957
Location: Denmark

PostPosted: Thu Jan 08, 2004 2:15 pm    Post subject: Reply with quote

Setting up alsa.

first you need to make sure what kernel you have, just for good orders sake :D, do like this:

Code:
redeeman@redeeman: ~$ uname -r
2.6.1-rc1-love3


good, i have a 2.6 kernel, then alsa is included in the kernel (and i have the love-sources patch which includes newest snapshot)

we need to enable module loading to load the alsa modules. to do this we will cd into /usr/src/linux, as linux is a symlink to the current kernel, we will also check that its correct

(yes, i know my symlink points to 2.6.0 source, but i only have that)
Code:
redeeman@redeeman: ~$ su
Password:
root@redeeman: /home/redeeman$ cd /usr/src/
root@redeeman: /usr/src$ ls -l linux
lrwxr-xr-x    1 root     root           20 Jan  2 19:16 linux -> /usr/src/linux-2.6.0
root@redeeman: /usr/src$ cd linux
root@redeeman: /usr/src/linux$ make menuconfig

now see that linux points to the linux kernel dir, then its fine, if you by some reason dont have the link, do like this:
Code:
ln -s <kernel-source-dir> linux

and now we have got the link, and we are able to cd into it.

then you enable module loading, and then we need to enable only sound support, not any specific drivers.

when that is done you build the kernel and install.

then we need to install the alsa driver, which is alsa-driver in portage, just take the lastest stable release, i only have the unstable to test.
latest unmasked is right now 0.9.8, and i know that release works, as i have tested in that one, so now we will check which alsa packages we have got, and then uninstall, and install the ones we need again.

Code:
redeeman@redeeman: ~$ su
Password:
root@redeeman: /home/redeeman$ qpkg -I -v | grep alsa
media-libs/alsa-oss-1.0.0_rc2 *
media-libs/alsa-lib-1.0.0_rc2 *
media-sound/alsa-utils-1.0.0_rc2 *
media-plugins/alsa-xmms-0.9.12 *
root@redeeman: /home/redeeman$ emerge --unmerge alsa-oss alsa-lib alsa-utils alsa-xmms -p
 
>>> These are the packages that I would unmerge:
 
 media-sound/alsa-utils
    selected: 1.0.0_rc2
   protected: none
     omitted: none
 
 media-libs/alsa-oss
    selected: 0.9.8
   protected: none
     omitted: none
 
 media-plugins/alsa-xmms
    selected: 0.9.12
   protected: none
     omitted: none
 
 media-libs/alsa-lib
    selected: 1.0.0_rc2
   protected: none
     omitted: none
 
>>> 'Selected' packages are slated for removal.
>>> 'Protected' and 'omitted' packages will not be removed.
 
root@redeeman: /home/redeeman$ emerge alsa-lib alsa-driver alsa-oss alsa-utils -p
 
These are the packages that I would merge, in order:
 
Calculating dependencies ...done!
[ebuild   R   ] media-libs/alsa-lib-1.0.0_rc2
[ebuild N     ] media-sound/alsa-driver-1.0.0_rc2
[ebuild   R   ] media-libs/alsa-oss-1.0.0_rc2
[ebuild   R   ] media-sound/alsa-utils-1.0.0_rc2

root@redeeman: /home/redeeman$ etc-update
Scanning Configuration files...
Exiting: Nothing left to do; exiting. :)
root@redeeman: /home/redeeman$

yes, i know alsa-driver is now, but that is because i have drivers built in, and dont need it. we will come to that.
and no, i didnt have any config files to update, but you probably will, (i just did a -p because i already have installed).

now its time to edit /etc/modules.d/alsa, what we need to do, is uncomment some lines, and then change to our card!

Code:
# Alsa 0.9.X kernel modules' configuration file.
# $Header: /home/cvsroot/gentoo-x86/media-sound/alsa-utils/files/alsa-modules.conf-rc,v 1.1 2003/08/05 21:07:55 johnm Exp $

# ALSA portion
alias char-major-116 snd
# OSS/Free portion
alias char-major-14 soundcore

##
## IMPORTANT:
## You need to customise this section for your specific sound card(s)
## and then run `update-modules' command.
## Read alsa-driver's INSTALL file in /usr/share/doc for more info.
##
##  ALSA portion
alias snd-card-0 snd-cmipci
## alias snd-card-1 snd-ens1371
##  OSS/Free portion
alias sound-slot-0 snd-card-0
## alias sound-slot-1 snd-card-1
##

# OSS/Free portion - card #1
alias sound-service-0-0 snd-mixer-oss
alias sound-service-0-1 snd-seq-oss
alias sound-service-0-3 snd-pcm-oss
alias sound-service-0-8 snd-seq-oss
alias sound-service-0-12 snd-pcm-oss
##  OSS/Free portion - card #2
## alias sound-service-1-0 snd-mixer-oss
## alias sound-service-1-3 snd-pcm-oss
## alias sound-service-1-12 snd-pcm-oss

alias /dev/mixer snd-mixer-oss
alias /dev/dsp snd-pcm-oss
alias /dev/midi snd-seq-oss

# Set this to the correct number of cards.
options snd cards_limit=1

here i already have my stuff uncommented, so what you basically have to do, is uncomment following lines:
Code:
alias char-major-116 snd
alias char-major-14 soundcore

alias sound-slot-0 snd-card-0

alias sound-service-0-0 snd-mixer-oss
alias sound-service-0-1 snd-seq-oss
alias sound-service-0-3 snd-pcm-oss
alias sound-service-0-8 snd-seq-oss
alias sound-service-0-12 snd-pcm-oss

alias /dev/mixer snd-mixer-oss
alias /dev/dsp snd-pcm-oss
alias /dev/midi snd-seq-oss

options snd cards_limit=1


and then you need to edit this line:
Code:
alias snd-card-0 snd-cmipci

to:
Code:
snd-<whatever_your_card_driver_is>

my card is a cmedia 8738. and uses the driver snd-cmipci.

then we update modules, and stuff.
Code:
root@redeeman: /home/redeeman$ update-modules

and then we add alsasound to the default runlevel, and start it now
Code:
root@redeeman: /home/redeeman$ update-modules
root@redeeman: /home/redeeman$ /etc/init.d/alsasound start
 * ALSA Detected...
 * Restoring Mixer Levels                     [ ok ]

now we use the tool alsamixer to unmute our device, simply start alsamixer and unmute your master and/or pcm.
and now we are done, and are ready to follow my steps to get a working dmix plugin (software mixing)

Setting up for 2.6
if you are using 2.6.0, you probably have a little more experience.
then just enable alsa in kernel. with your needed drivers, and remember to install version 0.9.7 of the alsa tools, driver and lib. 2.6.0 includes that release :)

and then there shouldnt be anything more, just follow the other generic steps for 2.5.


FAQ
you made a spelling mistake???
probably thousands. pm me and i will correct![/code]
_________________
Sandberg Enterprises
Back to top
View user's profile Send private message
MooktaKiNG
Guru
Guru


Joined: 11 Nov 2002
Posts: 326
Location: London, UK

PostPosted: Fri Jan 09, 2004 2:29 am    Post subject: Reply with quote

Sorry but i don't really understand what this howto is about.

Is dmixer similar to artsd or esound?

Please explain.

I usually use artsd, but there are a lot of disadvantages with artsd.
_________________
http://www.mooktakim.com
Athlon XP 2001, Giga-Byte GA-7VRXP MB, 640Mb DDR RAM 333MHz, MSI Geforce 4800SE 128Mb DDR, 40x12x48 Liteon CDRW drive, Flower Cooler, ADSL Router
Back to top
View user's profile Send private message
Redeeman
l33t
l33t


Joined: 25 Sep 2003
Posts: 957
Location: Denmark

PostPosted: Fri Jan 09, 2004 4:05 pm    Post subject: Reply with quote

no, this is so you DONT need a sound server :D the sound system in the kernel with do the mixing, so you can use all applications without them having to have support for arts or esd :)
_________________
Sandberg Enterprises
Back to top
View user's profile Send private message
MooktaKiNG
Guru
Guru


Joined: 11 Nov 2002
Posts: 326
Location: London, UK

PostPosted: Fri Jan 09, 2004 11:37 pm    Post subject: Reply with quote

so i can use alsaplay soundfile.mp3
and it would play?

Then its fantastic.

Is there any performance gain from using artsd?

I'm sure there is, if its inside the kernel right?


How comes i haven't heard of this before?

is it a recent adition?
_________________
http://www.mooktakim.com
Athlon XP 2001, Giga-Byte GA-7VRXP MB, 640Mb DDR RAM 333MHz, MSI Geforce 4800SE 128Mb DDR, 40x12x48 Liteon CDRW drive, Flower Cooler, ADSL Router
Back to top
View user's profile Send private message
|darc|
n00b
n00b


Joined: 19 Jun 2003
Posts: 43
Location: New Orleans, LA

PostPosted: Sat Jan 10, 2004 3:44 am    Post subject: Reply with quote

Okay, I'm not sure if I entirely understand this correctly.

I'm using kernel 2.6.1-gentoo. My sound works fine individually for each app, but, of course, my problem is I can't play two sounds at once.

I have alsa-lib, alsa-util, alsamixergui, and alsa-xmms installed. I created the ~/.asoundrc file and pasted what you have in the Code box into the file, saved it, and tried to play two sounds at once. It did not work. I don't know if I had to restart stuff or anything, so I rebooted my computer and tried once again to play two things at once. However, it is still not working. I think I'm missing something (it seemed a bit easy to me :P ). I would appreciate it if you could walk me through this a bit.
Back to top
View user's profile Send private message
Redeeman
l33t
l33t


Joined: 25 Sep 2003
Posts: 957
Location: Denmark

PostPosted: Sat Jan 10, 2004 11:01 am    Post subject: Reply with quote

i dont think there is any direct performance gain, but ofcourse, you wont be running artsd or esd, BUT.
not all applications supports esd or arts, and then it wont work at all. with this dmix plugin from alsa, alsa itself will mix the sounds, and you can play as many as you want the same time.

|darc|:
now you need to emerge alsa-oss too, in the correct version number for the rest of alsa, and then you change output from oss driver to alsa driver in xmms. and type in to use default device.

then if the app more you will run uses oss, run it with aoos, like this:
Code:
aoss <someapp>

and it will work.

if it doesent, type here again, and i will try to help
_________________
Sandberg Enterprises
Back to top
View user's profile Send private message
|darc|
n00b
n00b


Joined: 19 Jun 2003
Posts: 43
Location: New Orleans, LA

PostPosted: Sat Jan 10, 2004 4:55 pm    Post subject: Reply with quote

The problem isn't with OSS, though, it's with the ALSA mixing itself. GAIM, with sounds set to "Command" and the command being "aplay -Dplug:dmix %s," XMMS using the ALSA output plugin, and totem ran with "aoss totem" still do not want to be mixed with each other. Totem, which outputs OSS, still worked without your above suggestion and without running it with "aoss" in front of it, but I still did what you suggested and, unfortunately, it's still not working. Each program still plays by itself perfectly.

EDIT: Nevermind, I got it working. I did not realize I had to specify "dmixer" in the XMMS ALSA configuration. GAIM is playing sound, totem is playing Half-Baked, and XMMS is playing Thurday - Jet Black New Year. Thanks for all your help, and this tutorial. :)
Back to top
View user's profile Send private message
Redeeman
l33t
l33t


Joined: 25 Sep 2003
Posts: 957
Location: Denmark

PostPosted: Sun Jan 11, 2004 12:10 am    Post subject: Reply with quote

actually, if you use my .asoundrc, it shouldnt be needed with dmixer, but default works too, so default configuration on alsa applications are working :)
but im glad it works for you! :)
_________________
Sandberg Enterprises
Back to top
View user's profile Send private message
enrique
Guru
Guru


Joined: 03 Sep 2002
Posts: 342
Location: Denmark

PostPosted: Sun Jan 11, 2004 12:18 am    Post subject: Reply with quote

Please note, that some programs have a faulty alsa implementation, so the do not work probaly with dmixer.

I can only say that Redeeman .asound works fine for me, with xmms, gaim, ogg123 and mplayer (mplayer sometimes hangs with dmix)

Att: Redeeman: hvor har du dog fået den dejlige .asound fra ;)
_________________
Kind regards, enrique
Workstation,HTPC,Powerbook
Back to top
View user's profile Send private message
Redeeman
l33t
l33t


Joined: 25 Sep 2003
Posts: 957
Location: Denmark

PostPosted: Sun Jan 11, 2004 11:57 am    Post subject: Reply with quote

enrique: :D hehe well, you didnt write a guide, so i had to take action! :)
_________________
Sandberg Enterprises
Back to top
View user's profile Send private message
dna42
n00b
n00b


Joined: 26 Feb 2003
Posts: 72

PostPosted: Sun Jan 11, 2004 1:47 pm    Post subject: Reply with quote

just in case anyone is interested...

in order to make this work with SDL apps (assuming you compiled your libsdl with alsa support) you just have to set two environment variables. i.e.
Code:
export SDL_AUDIODRIVER=alsa AUDIODEV=default
Back to top
View user's profile Send private message
pharaoh
Apprentice
Apprentice


Joined: 20 Nov 2003
Posts: 211
Location: Pennsylvania

PostPosted: Fri Jan 16, 2004 2:52 am    Post subject: Reply with quote

dna42: sorry I'm a newb...where do these variables get set at? Somewhere in the app/game that uses SDL or in the alsa file itself?
Back to top
View user's profile Send private message
discomfitor
l33t
l33t


Joined: 21 Feb 2003
Posts: 927
Location: None

PostPosted: Fri Jan 16, 2004 3:55 am    Post subject: Reply with quote

people with mplayer problems: https://forums.gentoo.org/viewtopic.php?t=124976

Ironically, I made that before I saw this. Been meaning to post it for a while.
_________________
There is no substitute for experience.
Imperfection indicates a lack of effort.
Back to top
View user's profile Send private message
arkanlor
n00b
n00b


Joined: 06 Jan 2004
Posts: 30

PostPosted: Fri Jan 16, 2004 12:35 pm    Post subject: Reply with quote

I'm a little bit confused now. =) after this howto =)

I have kernel 2.6.1 and I included all alsa stuff into my kernel including the drivers for my soundcards.
alsa is working, playing sound, but only one program a time.

because the howtos are so mixed up, maybe you could write one extra just for 2.6.x because I have no idea now how to continue. and I dont want to mess it up!
Back to top
View user's profile Send private message
pharaoh
Apprentice
Apprentice


Joined: 20 Nov 2003
Posts: 211
Location: Pennsylvania

PostPosted: Fri Jan 16, 2004 2:40 pm    Post subject: Reply with quote

I am in the same situation. Using kernel-2.6.1-rc1, only one sound at a time =\ Under Redhat this worked automagically, is maybe somewhere on that box I could search for clues?
Back to top
View user's profile Send private message
discomfitor
l33t
l33t


Joined: 21 Feb 2003
Posts: 927
Location: None

PostPosted: Fri Jan 16, 2004 3:02 pm    Post subject: Reply with quote

I use 2.6, and everything is the same, but you don't have to compile alsa-drivers since it's in the kernel.
_________________
There is no substitute for experience.
Imperfection indicates a lack of effort.
Back to top
View user's profile Send private message
Niek
Apprentice
Apprentice


Joined: 14 May 2002
Posts: 236
Location: Houten, The Netherlands

PostPosted: Fri Jan 16, 2004 4:06 pm    Post subject: Reply with quote

Thanks to this topic and https://forums.gentoo.org/viewtopic.php?t=124976 I finally got everything working.
It's possible to run MPlayer (-ao alsa9:default), XMMS (alsa-xmms plugin, audio device set to "default"), aplay (native alsa support) and HelixPlayer (OSS output, running with aoss ./hxplay) at the same time :)
Too bad the LD_PRELOAD trick of aoss is not working in all cases, e.g. I can't play Quake3 while another app is using the soundcard (other simple apps like wavplay also fails).
But in general, I'm very happy with this :) BTW, here is my stripped down /etc/asound.conf (better place it system-wide instead of per-user). I removed the needless settings the original post had:
Code:
pcm.mixer {
  type dmix
  ipc_key 1024
  slave {
    pcm "hw:0,0"
    period_time 0
    period_size 1024
    buffer_size 8192
    rate 44100
  }
}

pcm.!default {
  type plug
  slave.pcm "mixer"
}

_________________
Bezoek ook eens de Nederlandstalige Gentoo IRC channel op irc.freenode.net - #gentoo-nl
Back to top
View user's profile Send private message
SubAtomic
Apprentice
Apprentice


Joined: 20 Dec 2003
Posts: 255
Location: Hobart, TAS, Australia

PostPosted: Sat Jan 17, 2004 7:43 am    Post subject: Reply with quote

Ian wrote:
I followed everything, but I don't think it's working because I'm missing /etc/asound.state.
You don't necessarily need /etc/asound.state to enable dmix for alsa.

When you first execute /etc/init.d/alsasound restart your /etc/asound.state should be created automatically.


Last edited by SubAtomic on Sun Jan 18, 2004 8:57 am; edited 2 times in total
Back to top
View user's profile Send private message
dna42
n00b
n00b


Joined: 26 Feb 2003
Posts: 72

PostPosted: Sat Jan 17, 2004 10:50 pm    Post subject: Reply with quote

pharaoh wrote:
dna42: sorry I'm a newb...where do these variables get set at? Somewhere in the app/game that uses SDL or in the alsa file itself?


in neither of those locations.
these are environment variables, which are local to a shell, so, if you issue the above-mentioned command in a shell and start your sdl app from this very shell, it should inherit the variables and thus use alsa.
Back to top
View user's profile Send private message
DOG-mike
n00b
n00b


Joined: 22 Sep 2003
Posts: 15

PostPosted: Wed Jan 28, 2004 3:59 pm    Post subject: Reply with quote

Bumping this up to see if anyone could paste their /etc/asound.conf file. I'm having a hard time getting this to work (properly) with anything other than xmms and mplayer. Plus mplayer plays sound just a tick too fast.

nvidia soundstorm
Back to top
View user's profile Send private message
pharaoh
Apprentice
Apprentice


Joined: 20 Nov 2003
Posts: 211
Location: Pennsylvania

PostPosted: Wed Jan 28, 2004 4:58 pm    Post subject: Reply with quote

I haven't had any luck with this either. I don't even have an asound.conf...am I just supposed to make one?? My only goal is to get Teamspeak working while running Q3 or Neverwinter Nights.

Dell laptop with intel8x0
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks All times are GMT
Goto page 1, 2, 3 ... 10, 11, 12  Next
Page 1 of 12

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum