Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
X Window problem in iBook G4
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message
hcbin
n00b
n00b


Joined: 10 Jan 2004
Posts: 3

PostPosted: Sat Jan 10, 2004 11:59 am    Post subject: X Window problem in iBook G4 Reply with quote

Hi,

I got an iBook G4, I am managed to install Linux-benh 2.4 together with xfree and xfree-drm..

However startx or XFree86 --xf86config /etc/X11/XF86config-4 does not work.. I have use Xeasycof to work out the config file

I look at the forum, some posting say that we need the 2.5 (2.6) benh source for the latest graphic card, isn't that true?

By the way, i am able to startx if the color is only 8 bits... (safest).. but fail for any other largest number.

thank
Back to top
View user's profile Send private message
BaSS
Retired Dev
Retired Dev


Joined: 11 Jun 2002
Posts: 173
Location: Seville (Spain)

PostPosted: Sat Jan 10, 2004 6:04 pm    Post subject: Reply with quote

im have a iBook G4, and yes, you need kernel 2.6
I have a nice performance of the ati with this kernel using atifband fbdev in xconfig.

regards
_________________
JabberID: bass@im.gentoo.org
Back to top
View user's profile Send private message
Kirja
Tux's lil' helper
Tux's lil' helper


Joined: 23 Sep 2003
Posts: 116
Location: England

PostPosted: Sat Jan 10, 2004 6:19 pm    Post subject: Reply with quote

I am in the process of installing Gentoo on my iBook and will have to setup X soon. Im a complete noob though and have no idea what DRM / DRI are or the references you made to 'atifband' and 'fbdev'.

Are there any good resources around that could explain to me what these things are and do or can the people of the gentoo community give me some answers.

Either way I will be espically grateful.

Thanks
Back to top
View user's profile Send private message
hcbin
n00b
n00b


Joined: 10 Jan 2004
Posts: 3

PostPosted: Sun Jan 11, 2004 1:04 am    Post subject: Reply with quote

Is the development-sources 2.6.1 the latest ppc kernel source for gentoo?

Some porting mention using 2.6-benh source, but in the www.ppckernel.org, there is only 2.5 (developer release) for benh source.

Should I download the 2.5-benh from www.ppckernel.org or using the portage version of development-sources 2.6.1?

Is xfree-drm still necessary if we use 2.6 (or 2.5) source?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum