Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
X config for PWB G4 12"
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message
gentphil
n00b
n00b


Joined: 04 Dec 2003
Posts: 66
Location: France

PostPosted: Mon Jan 12, 2004 6:20 pm    Post subject: X config for PWB G4 12" Reply with quote

I could'nt run well X on my powerbook.

I have always the following :

EE FBDEV(0) :FBIOPAN_DISPLAY : invalid argument
EE FBDEV(0) :FBIOPAN_DISPLAY : invalid argument
EE FBDEV(0) :FBIOPAN_DISPLAY : invalid argument

If somebody could give to me an exemple of his X config...

Thanks

Phil
Back to top
View user's profile Send private message
ralph
Advocate
Advocate


Joined: 02 Mar 2003
Posts: 2001
Location: Hamburg

PostPosted: Mon Jan 12, 2004 9:19 pm    Post subject: Reply with quote

Hi,

you could take a look at the great PPC config file database.

http://ppcconfdb.sourceforge.net/

Hope this helps. :D
_________________
The computer can't tell you the emotional story. It can give you the exact mathematical design, but what's missing is the eyebrows.
- Frank Zappa
Back to top
View user's profile Send private message
eichi
n00b
n00b


Joined: 04 Sep 2002
Posts: 4
Location: Switzerland

PostPosted: Thu Jan 15, 2004 2:31 am    Post subject: Reply with quote

Install the newest xfree version (xfree-4.3.99.902.ebuild)

Edit /etc/yaboot.conf:
append="video=ofonly"

Edit /etc/X11/XF86Config-4:
Section "ServerLayout"
Identifier "XFree86 Configured"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
RgbPath "/usr/X11R6/lib/X11/rgb"
ModulePath "/usr/X11R6/lib/modules"
FontPath "/usr/X11R6/lib/X11/fonts/truetype"
FontPath "/usr/X11R6/lib/X11/fonts/misc/"
FontPath "/usr/X11R6/lib/X11/fonts/Speedo/"
FontPath "/usr/X11R6/lib/X11/fonts/Type1/"
FontPath "/usr/X11R6/lib/X11/fonts/CID/"
FontPath "/usr/X11R6/lib/X11/fonts/75dpi/"
FontPath "/usr/X11R6/lib/X11/fonts/100dpi/"
EndSection

Section "Module"
Load "extmod"
Load "dri"
Load "dbe"
Load "record"
Load "xtrap"
Load "glx"
Load "speedo"
Load "type1"
EndSection

Section "InputDevice"
Identifier "Keyboard0"
Driver "keyboard"
Option "CoreKeyboard"
Option "XkbRules" "xfree86"
Option "XkbModel" "macintosh"
Option "XkbLayout" "de_CH"
Option "XkbVariant" "nodeadkeys"
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "ZAxisMapping" "4 5"
Option "Device" "/dev/input/mice"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "Monitor Model"
UseModes "Modes0"
HorizSync 30-100
VertRefresh 50-160
EndSection

Section "Device"
### Available Driver options are:-
### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
### <string>: "String", <freq>: "<f> Hz/kHz/MHz"
### [arg]: arg optional
#Option "ShadowFB" # [<bool>]
#Option "VGAClocks" # [<bool>]
#Option "KGAUniversal" # [<bool>]
Identifier "Card0"
Driver "nv"
Option "FlatPanel"
VendorName "nVidia Corporation"
BoardName "Unknown Board"
BusID "PCI:0:16:0"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Card0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 1
Modes "1024x768"
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 4
Modes "1024x768"
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 8
Modes "1024x768"
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 15
Modes "1024x768"
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 16
Modes "1024x768"
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 24
Modes "1024x768"
EndSubSection
EndSection

Section "DRI"
Mode 0666
EndSection

Section "Modes"
Identifier "Modes0"
# mode generated by Xeasyconf
Modeline "1024x768" 85 1024 1032 1152 1360 768 784 787 823 -HSync -VSync
EndSection

I've got a Swiss Keyboard, so I guess you can leave some lines out ...

enjoy :-)
Back to top
View user's profile Send private message
gentphil
n00b
n00b


Joined: 04 Dec 2003
Posts: 66
Location: France

PostPosted: Thu Jan 15, 2004 7:06 am    Post subject: Reply with quote

Thanks for the help.

I've edit a XF86Config I find in /etc/X11 (and not the XF86Config-4) with a pre configuration and with bus ID 0-10-0 instead of 0-16-0, Save it in XF86Config-4 file, and thats work.
Further, I have to improve the config, but before, I will emerge the XFree-4.3.99.903.

Could you tell me why I need to put in the yaboot config "video=ofonly ?

Phil
Back to top
View user's profile Send private message
juju
n00b
n00b


Joined: 23 Dec 2003
Posts: 48
Location: Paris

PostPosted: Thu Jan 15, 2004 11:17 am    Post subject: Reply with quote

Salut Philippe,

Just a word about emerging XFree-4.3.99.902. To emerge such an ebuild you have to type something like:
emerge /usr/portage/x11-base/xfree/xfree-4.3.99.902.ebuild
but you have to known that it won't perform any dependency check so you have to fullfill those needs by yourself before emerging XFree. To do so, run something like emerge -p xfree and have a look to all dependencies needed by XFree-4.3. AFAIK XFree-4.3.99.902 uses the same dependencies, so emerge them and then emerge XFree.

If you already knew that, excuse-me, else i hope it will help you in your task

Good luck

Julien
_________________
open Signature (same as #include "signature.h" in OCaml)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum